⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC54722009-03-01

IP Flow Information Export (IPFIX) Applicability

IP Flow Information Export (IPFIX) Applicability

In this document, we describe the applicability of the IP Flow Information eXport (IPFIX) protocol for a variety of applications. We show how applications can use IPFIX, describe the relevant Information Elements (IEs) for those applications, and present opportunities and limitations of the protocol. Furthermore, we describe relations of the IPFIX framework to other architectures and frameworks. T…

RFC54712009-03-01

Guidelines for IP Flow Information Export (IPFIX) Testing

Guidelines for IP Flow Information Export (IPFIX) Testing

This document presents a list of tests for implementers of IP Flow Information eXport (IPFIX) compliant Exporting Processes and Collecting Processes. This document specifies guidelines for a series of tests that can be run on the IPFIX Exporting Process and Collecting Process in order to probe the conformity and robustness of the IPFIX protocol implementations. These tests cover all important func…

RFC54702009-03-01

Architecture for IP Flow Information Export

Architecture for IP Flow Information Export

This memo defines the IP Flow Information eXport (IPFIX) architecture for the selective monitoring of IP Flows, and for the export of measured IP Flow information from an IPFIX Device to a Collector. This memo provides information for the Internet community.

RFC54692009-02-01

DES and IDEA Cipher Suites for Transport Layer Security (TLS)

DES and IDEA Cipher Suites for Transport Layer Security (TLS)

Transport Layer Security (TLS) versions 1.0 (RFC 2246) and 1.1 (RFC 4346) include cipher suites based on DES (Data Encryption Standard) and IDEA (International Data Encryption Algorithm) algorithms. DES (when used in single-DES mode) and IDEA are no longer recommended for general use in TLS, and have been removed from TLS version 1.2 (RFC 5246). This document specifies these cipher suites for comp…

RFC54682009-04-01

Performance Analysis of Inter-Domain Path Computation Methodologies

Performance Analysis of Inter-Domain Path Computation Methodologies

This document presents a performance comparison between the per-domain path computation method and the Path Computation Element (PCE) Architecture-based Backward Recursive Path Computation (BRPC) procedure. Metrics to capture the significant performance aspects are identified, and detailed simulations are carried out on realistic scenarios. A performance analysis for each of the path computation m…

RFC54672009-03-01

GMPLS Asymmetric Bandwidth Bidirectional Label Switched Paths (LSPs)

GMPLS Asymmetric Bandwidth Bidirectional Label Switched Paths (LSPs)

This document defines a method for the support of GMPLS asymmetric bandwidth bidirectional Label Switched Paths (LSPs). The presented approach is applicable to any switching technology and builds on the original Resource Reservation Protocol (RSVP) model for the transport of traffic-related parameters. The procedures described in this document are experimental. This memo defines an Experimental Pr…

RFC54662009-02-01

IMAP4 Extension for Named Searches (Filters)

IMAP4 Extension for Named Searches (Filters)

The document defines a way to persistently store named IMAP (RFC 3501) searches on the server. Such named searches can be subsequently referenced in a SEARCH or any other command that accepts a search criterion as a parameter. [STANDARDS-TRACK]

RFC54652009-02-01

The IMAP NOTIFY Extension

The IMAP NOTIFY Extension

This document defines an IMAP extension that allows a client to request specific kinds of unsolicited notifications for specified mailboxes, such as messages being added to or deleted from such mailboxes. [STANDARDS-TRACK]

RFC54642009-02-01

The IMAP METADATA Extension

The IMAP METADATA Extension

The METADATA extension to the Internet Message Access Protocol permits clients and servers to maintain "annotations" or "metadata" on IMAP servers. It is possible to have annotations on a per-mailbox basis or on the server as a whole. For example, this would allow comments about the purpose of a particular mailbox to be "attached" to that mailbox, or a "message of the day" containing server status…

RFC54632009-03-01

Sieve Email Filtering: Ihave Extension

Sieve Email Filtering: Ihave Extension

This document describes the "ihave" extension to the Sieve email filtering language. The "ihave" extension provides a means to write scripts that can take advantage of optional Sieve features but can still run when those optional features are not available. The extension also defines a new error control command intended to be used to report situations where no combination of available extensions s…

RFC54622009-02-01

Multiprotocol Label Switching (MPLS) Label Stack Entry: "EXP" Field Renamed to "Traffic Class" Field

Multiprotocol Label Switching (MPLS) Label Stack Entry: "EXP" Field Renamed to "Traffic Class" Field

The early Multiprotocol Label Switching (MPLS) documents defined the form of the MPLS label stack entry. This includes a three-bit field called the "EXP field". The exact use of this field was not defined by these documents, except to state that it was to be "reserved for experimental use". Although the intended use of the EXP field was as a "Class of Service" (CoS) field, it was not named a CoS f…

RFC54612009-02-01

TCP's Reaction to Soft Errors

TCP's Reaction to Soft Errors

This document describes a non-standard, but widely implemented, modification to TCP's handling of ICMP soft error messages that rejects pending connection-requests when those error messages are received. This behavior reduces the likelihood of long delays between connection-establishment attempts that may arise in a number of scenarios, including one in which dual-stack nodes that have IPv6 enable…

RFC54602009-02-01

DHCPv6 Bulk Leasequery

DHCPv6 Bulk Leasequery

The Dynamic Host Configuration Protocol for IPv6 (DHCPv6) has been extended with a Leasequery capability that allows a client to request information about DHCPv6 bindings. That mechanism is limited to queries for individual bindings. In some situations individual binding queries may not be efficient, or even possible. This document expands on the Leasequery protocol, adding new query types and all…

RFC54592009-01-01

G.729.1 RTP Payload Format Update: Discontinuous Transmission (DTX) Support

G.729.1 RTP Payload Format Update: Discontinuous Transmission (DTX) Support

This document updates the Real-time Transport Protocol (RTP) payload format to be used for the International Telecommunication Union (ITU-T) Recommendation G.729.1 audio codec. It adds Discontinuous Transmission (DTX) support to the RFC 4749 specification, in a backward-compatible way. An updated media type registration is included for this payload format. [STANDARDS-TRACK]

RFC54582009-03-01

Security Requirements for the Unidirectional Lightweight Encapsulation (ULE) Protocol

Security Requirements for the Unidirectional Lightweight Encapsulation (ULE) Protocol

The MPEG-2 standard defined by ISO 13818-1 supports a range of transmission methods for a variety of services. This document provides a threat analysis and derives the security requirements when using the Transport Stream, TS, to support an Internet network-layer using Unidirectional Lightweight Encapsulation (ULE) defined in RFC 4326. The document also provides the motivation for link-layer secur…

RFC54572010-02-01

IANA Considerations for IAX: Inter-Asterisk eXchange Version 2

IANA Considerations for IAX: Inter-Asterisk eXchange Version 2

This document establishes the IANA registries for IAX, the Inter- Asterisk eXchange protocol, an application-layer control and media protocol for creating, modifying, and terminating multimedia sessions over Internet Protocol (IP) networks. IAX was developed by the open source community for the Asterisk PBX and is targeted primarily at Voice over Internet Protocol (VoIP) call control, but it can b…

RFC54562010-02-01

IAX: Inter-Asterisk eXchange Version 2

IAX: Inter-Asterisk eXchange Version 2

This document describes IAX, the Inter-Asterisk eXchange protocol, an application-layer control and media protocol for creating, modifying, and terminating multimedia sessions over Internet Protocol (IP) networks. IAX was developed by the open source community for the Asterisk Private Branch Exchange (PBX) and is targeted primarily at Voice over Internet Protocol (VoIP) call control, but it can be…

RFC54552009-03-01

Diffserv-Aware Class-Type Object for the Path Computation Element Communication Protocol

Diffserv-Aware Class-Type Object for the Path Computation Element Communication Protocol

This document specifies a CLASSTYPE object to support Diffserv-Aware Traffic Engineering (DS-TE) where path computation is performed with the aid of a Path Computation Element (PCE). [STANDARDS-TRACK]

RFC54542009-03-01

Dual-Stack Mobile IPv4

Dual-Stack Mobile IPv4

This specification provides IPv6 extensions to the Mobile IPv4 protocol. The extensions allow a dual-stack node to use IPv4 and IPv6 home addresses as well as to move between IPv4 and dual stack network infrastructures. [STANDARDS-TRACK]

RFC54532009-02-01

Reserved IPv6 Interface Identifiers

Reserved IPv6 Interface Identifiers

Interface identifiers in IPv6 unicast addresses are used to identify interfaces on a link. They are required to be unique within a subnet. Several RFCs have specified interface identifiers or identifier ranges that have a special meaning attached to them. An IPv6 node autoconfiguring an interface identifier in these ranges will encounter unexpected consequences. Since there is no centralized repos…

RFC54522009-01-01

Measures for Making DNS More Resilient against Forged Answers

Measures for Making DNS More Resilient against Forged Answers

The current Internet climate poses serious threats to the Domain Name System. In the interim period before the DNS protocol can be secured more fully, measures can already be taken to harden the DNS to make 'spoofing' a recursing nameserver many orders of magnitude harder. Even a cryptographically secured DNS benefits from having the ability to discard bogus responses quickly, as this potentially …

RFC54512009-04-01

Message Header Field for Indicating Message Authentication Status

Message Header Field for Indicating Message Authentication Status

This memo defines a new header field for use with electronic mail messages to indicate the results of message authentication efforts. Any receiver-side software, such as mail filters or Mail User Agents (MUAs), may use this message header field to relay that information in a convenient way to users or to make sorting and filtering decisions. [STANDARDS-TRACK]

RFC54502009-03-01

Transmission Time Offsets in RTP Streams

Transmission Time Offsets in RTP Streams

This document describes a method to inform Real-time Transport Protocol (RTP) clients when RTP packets are transmitted at a time other than their 'nominal' transmission time. It also provides a mechanism to provide improved inter-arrival jitter reports from the clients, that take into account the reported transmission times. [STANDARDS-TRACK]

RFC54492009-02-01

OSPF Multipoint Relay (MPR) Extension for Ad Hoc Networks

OSPF Multipoint Relay (MPR) Extension for Ad Hoc Networks

This document specifies an OSPFv3 interface type tailored for mobile ad hoc networks. This interface type is derived from the broadcast interface type, and is denoted the "OSPFv3 MANET interface type". This memo defines an Experimental Protocol for the Internet community.

RFC54482009-05-01

Improved Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA')

Improved Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA')

This specification defines a new EAP method, EAP-AKA', which is a small revision of the EAP-AKA (Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement) method. The change is a new key derivation function that binds the keys derived within the method to the name of the access network. The new key derivation mechanism has been defined in the 3rd Generation Par…

RFC54472009-02-01

Diameter Mobile IPv6: Support for Network Access Server to Diameter Server Interaction

Diameter Mobile IPv6: Support for Network Access Server to Diameter Server Interaction

A Mobile IPv6 node requires a home agent address, a home address, and a security association with its home agent before it can start utilizing Mobile IPv6. RFC 3775 requires that some or all of these parameters be statically configured. Mobile IPv6 bootstrapping work aims to make this information dynamically available to the mobile node. An important aspect of the Mobile IPv6 bootstrapping solutio…

RFC54462009-02-01

Service Selection for Mobile IPv4

Service Selection for Mobile IPv4

In some Mobile IPv4 deployments, identifying the mobile node or the mobility service subscriber is not enough to distinguish among the multiple services possibly provisioned to the mobile node. The capability to specify different services in addition to the mobile node's identity can be leveraged to provide flexibility for mobility service providers to provide multiple services within a single mob…

RFC54452009-03-01

Basic Forward Error Correction (FEC) Schemes

Basic Forward Error Correction (FEC) Schemes

This document provides Forward Error Correction (FEC) Scheme specifications according to the Reliable Multicast Transport (RMT) FEC building block for the Compact No-Code FEC Scheme, the Small Block, Large Block, and Expandable FEC Scheme, the Small Block Systematic FEC Scheme, and the Compact FEC Scheme. This document obsoletes RFC 3695 and assumes responsibility for the FEC Schemes defined in RF…

RFC54442009-02-01

Generalized Mobile Ad Hoc Network (MANET) Packet/Message Format

Generalized Mobile Ad Hoc Network (MANET) Packet/Message Format

This document specifies a packet format capable of carrying multiple messages that may be used by mobile ad hoc network routing protocols. [STANDARDS-TRACK]

RFC54432009-03-01

LDP IGP Synchronization

LDP IGP Synchronization

In certain networks, there is dependency on the edge-to-edge Label Switched Paths (LSPs) setup by the Label Distribution Protocol (LDP), e.g., networks that are used for Multiprotocol Label Switching (MPLS) Virtual Private Network (VPN) applications. For such applications, it is not possible to rely on Internet Protocol (IP) forwarding if the MPLS LSP is not operating appropriately. Blackholing of…