⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC100502026-09-01

Protocol-Specific Profiles for JSContact

Protocol-Specific Profiles for JSContact

This document defines the "JSContact Profiles" registry, an IANA registry for named subsets of JSContact elements. The document aims to facilitate using JSContact in the context of contact data exchange protocols or other use cases in which supporting all JSContact semantics might be inappropriate.

RFC100422026-08-01

Post-Quantum/Traditional Hybrid Key Exchange with the Module-Lattice-Based Key-Encapsulation Mechanism for Use in SSH

Post-Quantum/Traditional Hybrid Key Exchange with the Module-Lattice-Based Key-Encapsulation Mechanism for Use in SSH

This document defines Post-Quantum Traditional (PQ/T) Hybrid key exchange methods based on the quantum-resistant Module-Lattice-Based Key-Encapsulation Mechanism (ML-KEM) standard and traditional Elliptic-Curve Diffie-Hellman (ECDH) key exchange schemes. These methods are defined for use in the Secure Shell (SSH) transport layer protocol.

RFC100412026-09-01

Advertising Unreachable Links in OSPF

Advertising Unreachable Links in OSPF

OSPF Router Link State Advertisements (LSAs) use fixed-format encodings that always include advertised links in the default Shortest Path First (SPF) computation. For non-default SPF computations, e.g., Flexible Algorithms as described in RFC 9350, advertised OSPF links are used in the default SPF computation even if this is not intended. In order to advertise these links and not use them in the b…

RFC100402026-09-01

Locator/ID Separation Protocol (LISP) Geo-Coordinates

Locator/ID Separation Protocol (LISP) Geo-Coordinates

This document describes how Geo-Coordinates can be used in the Locator/ID Separation Protocol (LISP) and defines a new LISP Canonical Address Format (LCAF) encoding for such Geo-Coordinates. This document updates RFC 8060.

RFC100392026-09-01

Interconnecting EVPN and IPVPN Domains

Interconnecting EVPN and IPVPN Domains

Ethernet Virtual Private Network (EVPN) provides a unified BGP control plane for both intra- and inter-subnet forwarding within tenant networks. When a tenant network spans multiple domains, including any combination of EVPN and IPVPN domains, it becomes necessary to define the interworking mechanisms among these BGP domains (EVPN and IPVPN) to ensure seamless end-to-end tenant connectivity. This …

RFC100382026-08-01

Distributing the Segment Routing over IPv6 (SRv6) Locator Using DHCPv6

Distributing the Segment Routing over IPv6 (SRv6) Locator Using DHCPv6

In an SRv6 network, each SRv6 Segment Endpoint Node must be assigned an SRv6 Locator, and segment identifiers (SIDs) are generated within the address space of this SRv6 Locator. This document describes a method for assigning SRv6 Locators to SRv6 Segment Endpoint Nodes through the Dynamic Host Configuration Protocol for IPv6 (DHCPv6).

RFC100372026-08-01

Registration Data Access Protocol (RDAP) Extension for DNS Time-to-Live (TTL) Values

Registration Data Access Protocol (RDAP) Extension for DNS Time-to-Live (TTL) Values

This document specifies an extension to the Registration Data Access Protocol (RDAP), which allows the Time-to-Live (TTL) values for relevant DNS record types to be included in RDAP responses.

RFC100362026-08-01

Incremental Forwarding of HTTP Messages

Incremental Forwarding of HTTP Messages

This document specifies the "Incremental" HTTP header field, which instructs HTTP intermediaries to forward the HTTP message incrementally.

RFC100352026-08-01

YANG Library: Addition of the augmented-by List

YANG Library: Addition of the augmented-by List

"YANG Library" (RFC 8525) specifies the "ietf-yang-library" YANG module that provides information about the YANG modules, datastores, and datastore schemas used by a network management server. This document augments the "ietf-yang-library" module to provide the augmented-by list. It facilitates the process of obtaining all dependencies between YANG modules by querying the network management server…

RFC100342026-08-01

RTP Payload Format for Visual Volumetric Video-Based Coding (V3C)

RTP Payload Format for Visual Volumetric Video-Based Coding (V3C)

A visual volumetric video-based coding (V3C) ISO/IEC 23090-5 bitstream is composed of V3C units that contain V3C atlas sub-bitstreams, V3C video sub-bitstreams, and a V3C parameter set. This document describes an RTP payload format for V3C atlas sub-bitstreams. The RTP payload format for V3C video sub-bitstreams is defined by relevant IETF RFCs for the applicable video codec. The V3C RTP payload f…

RFC100332026-09-01

Hash-Based Signatures: State and Backup Management

Hash-Based Signatures: State and Backup Management

Stateful Hash-Based Signature Schemes (Stateful HBS) such as Leighton-Micali Signature (LMS), Hierarchical Signature System (HSS), eXtended Merkle Signature Scheme (XMSS), and XMSS^MT combine Merkle trees with One-Time Signatures (OTSs) to provide signatures that are resistant against attacks using large-scale quantum computers. Unlike conventional stateless digital signature schemes, Stateful HBS…

RFC100322026-09-01

The AEGIS Authenticated Encryption Algorithms

The AEGIS Authenticated Encryption Algorithms

This document describes the AEGIS-128L, AEGIS-256, AEGIS-128X, and AEGIS-256X AES-based authenticated encryption with associated data (AEAD) algorithms designed for high-performance applications. It also specifies their use as stream ciphers and message authentication codes (MACs). The document is a product of the Crypto Forum Research Group (CFRG).

RFC100312026-08-01

Media Access Control (MAC) Addresses in X.509 Certificates

Media Access Control (MAC) Addresses in X.509 Certificates

This document defines a new GeneralName.otherName for inclusion in the X.509 Subject Alternative Name (SAN) and Issuer Alternative Name (IAN) extensions to carry an IEEE Media Access Control (MAC) address. The new name form makes it possible to bind a Layer 2 interface identifier to a public key certificate. Additionally, this document defines how constraints on this name form can be encoded and p…

RFC100302026-08-01

Network Time Protocol (NTP) over the Precision Time Protocol (PTP)

Network Time Protocol (NTP) over the Precision Time Protocol (PTP)

This document specifies a transport for the client-server and symmetric modes of the Network Time Protocol (NTP) that encapsulates NTP messages in messages of the Precision Time Protocol (PTP). This transport enables hardware timestamping in network interface controllers (NICs) that can timestamp only PTP messages and delay corrections in PTP transparent clocks.

RFC100292026-07-01

DNS Multiple QTYPEs

DNS Multiple QTYPEs

This document specifies a method for a DNS client to request additional DNS record types to be delivered alongside the primary record type specified in the Question section of a DNS QUERY (OpCode=0).

RFC100282026-08-01

Updates to Dynamic IPv6 Multicast Address Group IDs

Updates to Dynamic IPv6 Multicast Address Group IDs

This document describes limitations of the existing range of dynamic IPv6 multicast addresses specified in "Allocation Guidelines for IPv6 Multicast Addresses" (RFC 3307). It updates RFC 3307 by replacing these allocations with a new IANA registry in the "IPv6 Multicast Address Space" registry group. The document also defines initial contents of the new registry: a reduced allocation for the Multi…

RFC100272026-08-01

Best Current Practice for Security of Cross-Device Flows

Best Current Practice for Security of Cross-Device Flows

This document describes threats against cross-device flows along with practical mitigations, protocol selection guidance, and a summary of formal analysis results identified as relevant to the security of cross-device flows. It serves as a security guide to system designers, architects, product managers, security specialists, fraud analysts, and engineers implementing cross-device flows.

RFC100262026-07-01

Operational Recommendations for DNSSEC Delegation Signer (DS) Automation

Operational Recommendations for DNSSEC Delegation Signer (DS) Automation

Enabling support for automatic acceptance of DNSSEC Delegation Signer (DS) parameters from the Child DNS operator (via RFCs 7344, 8078, and 9615) requires the Parental Agent, often a registry or registrar, to make a number of technical decisions around acceptance checks, error and success reporting, and multi-party issues such as concurrent updates. This document describes recommendations about ho…

RFC100242026-08-01

Post-Quantum Traditional (PQ/T) Hybrid Key Agreement Mechanisms for TLS 1.3

Post-Quantum Traditional (PQ/T) Hybrid Key Agreement Mechanisms for TLS 1.3

This document defines three hybrid key agreement mechanisms for TLS 1.3 -- X25519MLKEM768, SecP256r1MLKEM768, and SecP384r1MLKEM1024 -- that combine the post-quantum ML-KEM (Module-Lattice-Based Key Encapsulation Mechanism) with an ECDHE (Ephemeral Elliptic Curve Diffie-Hellman) exchange.

RFC100232026-07-01

The "_for-sale" Underscored and Globally Scoped DNS Node Name

The "_for-sale" Underscored and Globally Scoped DNS Node Name

This document defines an operational convention that uses the reserved underscored DNS leaf node name "_for-sale" to indicate the parent domain name is available for purchase. The convention can be deployed without disrupting existing operations, and it may be applied even when the domain name is still actively in use.

RFC100222026-07-01

IMAP UIDBATCHES Extension

IMAP UIDBATCHES Extension

The UIDBATCHES extension of the Internet Message Access Protocol (IMAP) allows clients to retrieve Unique Identifier (UID) ranges that partition a mailbox's messages into equally sized batches. This enables clients to perform operations such as FETCH, SEARCH, and STORE on specific message batches, providing better control over resource usage and response sizes. The extension is particularly useful…

RFC100192026-07-01

Zeroconf Multicast Address Allocation Problem Statement and Requirements

Zeroconf Multicast Address Allocation Problem Statement and Requirements

This document surveys current problems with existing protocols for automatically assigning multicast IP addresses in zero-configuration (zeroconf) networking environments. It addresses key challenges, such as link-layer address collisions, hardware limitations, multicast snooping inefficiencies, and the need to avoid manual configuration. Based on these challenges, it derives requirements for a li…

RFC100182026-08-01

Multicast and Ethernet VPN with Segment Routing Point-to-Multipoint (P2MP) and Ingress Replication

Multicast and Ethernet VPN with Segment Routing Point-to-Multipoint (P2MP) and Ingress Replication

A Point-to-Multipoint (P2MP) tree in a Segment Routing (SR) domain carries traffic from a Root to a set of Leaves. This document specifies extensions to BGP encodings and procedures for P2MP trees and Ingress Replication used in BGP/MPLS IP VPNs and Ethernet VPNs (EVPNs) in an SR domain. This document updates RFCs 6514 and 7988.

RFC100172026-08-01

OAuth 2.0 for Browser-Based Applications

OAuth 2.0 for Browser-Based Applications

This specification details the threats, attack consequences, security considerations, and best practices that must be taken into account when developing browser-based applications that use OAuth 2.0.

RFC100162026-09-01

System-Defined Configuration

System-Defined Configuration

The Network Management Datastore Architecture (NMDA) in RFC 8342 defines several configuration datastores holding configuration. The contents of these configuration datastores are controlled by clients. This document introduces the concept of a system configuration datastore holding configuration controlled by the system on which a server is running. The system configuration can be referenced (e.g…

RFC100152026-07-01

Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2

Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2

For (D)TLS 1.2, this document deprecates the use of two key exchanges, namely Diffie-Hellman (DH) over a finite field and RSA. It also discourages the use of static Elliptic Curve Diffie-Hellman (ECDH) cipher suites. These prescriptions apply only to (D)TLS 1.2, since (D)TLS 1.0 and TLS 1.1 are deprecated by RFC 8996 and (D)TLS 1.3 either does not use the affected algorithms or does not share the …

RFC100142026-06-01

Guidelines for Characterizing the Term "OAM"

Guidelines for Characterizing the Term "OAM"

As the IETF continues to produce and standardize different Operations, Administration, and Maintenance (OAM) protocols and technologies, various qualifiers and modifiers are prepended to the OAM abbreviation. While, at first glance, the most used qualifiers appear to be well understood, the same qualifier may be interpreted differently in different contexts. A case in point is the qualifiers "in-b…

RFC100132026-07-01

Entity Attestation Token (EAT) Measured Component

Entity Attestation Token (EAT) Measured Component

The term "measured component" refers to an object within the attester's target environment whose state can be sampled and typically digested using a cryptographic hash function. Examples of measured components include firmware stored in flash memory, software loaded into memory at start time, data stored in a file system, or values in a CPU register. This document provides the information model fo…

RFC100082026-06-01

The HTTP QUERY Method

The HTTP QUERY Method

This specification defines the QUERY method for HTTP. A QUERY requests that the request target process the enclosed content in a safe and idempotent manner and then respond with the result of that processing. This is similar to POST requests, but QUERY requests can be automatically repeated or restarted without concern for partial state changes.

RFC100072026-06-01

Clarification to Processing Key Usage Values During Certificate Revocation List (CRL) Validation

Clarification to Processing Key Usage Values During Certificate Revocation List (CRL) Validation

RFC 5280 defines the profile of X.509 certificates and Certificate Revocation Lists (CRLs) for use in the Internet. Section 4.2.1.3 of RFC 5280 requires CRL issuer certificates to contain the keyUsage extension with the cRLSign bit asserted. However, the CRL validation algorithm specified in Section 6.3 of RFC 5280 does not explicitly include a corresponding check for the presence of the keyUsage …