⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC100062026-08-01

Automatic SIP Trunking and Peering

Automatic SIP Trunking and Peering

This document specifies a framework that enables enterprise telephony Session Initiation Protocol (SIP) networks to solicit and obtain a capability set document from a SIP service provider. The capability set document encodes a set of characteristics that enable easy peering between enterprise and service provider SIP networks.

RFC100052026-06-01

BGP Link Bandwidth Extended Community

BGP Link Bandwidth Extended Community

This document defines a BGP extended community, the Link Bandwidth Extended Community, which carries bandwidth information to enable weighted load-balancing in multipath scenarios. It specifies the format and processing rules for this extended community type.

RFC100042026-07-01

Certificate Management over CMS (CMC): Compliance Requirements

Certificate Management over CMS (CMC): Compliance Requirements

This document provides a set of compliance statements about the Certificate Management over CMS (CMC) enrollment protocol. The ASN.1 structures and the transport mechanisms for the CMC enrollment protocol are covered in other documents (RFCs 10002 and 10003). This document provides the information needed to make a compliant version of CMC. This document obsoletes RFCs 5274 and 6402.

RFC100032026-07-01

Certificate Management over CMS (CMC): Transport Protocols

Certificate Management over CMS (CMC): Transport Protocols

This document defines a number of transport mechanisms that are used to move Certificate Management over CMS (CMC) messages. The transport mechanisms described in this document are HTTP, file, mail, and TCP. This document obsoletes RFCs 5273 and 6402.

RFC100022026-07-01

Certificate Management over CMS (CMC)

Certificate Management over CMS (CMC)

This document defines the base syntax for CMC, a Certificate Management protocol using the Cryptographic Message Syntax (CMS). This protocol addresses two immediate needs within the Internet Public Key Infrastructure (PKI) community: CMC also requires the use of the transport document (RFC 10003) and the requirements usage document (RFC 10004) along with this document for a full definition. This d…

RFC100012026-08-01

Operational Guidelines for DNS Transport in Mixed IPv4/IPv6 Environments

Operational Guidelines for DNS Transport in Mixed IPv4/IPv6 Environments

This document provides guidelines and documents best current practice for operating authoritative DNS servers, recursive resolvers, and stub resolvers in a mixed IPv4/IPv6 environment. This document recommends that both authoritative DNS servers and recursive resolvers support IPv4 and IPv6. It also provides guidance on how recursive DNS resolvers should select upstream DNS servers, including when…

RFC99992026-07-01

Remote ATtestation procedureS (RATS) Conceptual Message Wrapper (CMW)

Remote ATtestation procedureS (RATS) Conceptual Message Wrapper (CMW)

The conceptual messages introduced by the Remote ATtestation procedureS (RATS) architecture (RFC 9334) are protocol-agnostic data units that are conveyed between RATS roles during RATS interactions. Conceptual messages describe the meaning and function of such data units within RATS data flows without specifying a wire format, encoding, transport mechanism, or processing details. The initial set o…

RFC99982026-06-01

Report from the IAB/W3C Workshop on Age-Based Restrictions on Content Access

Report from the IAB/W3C Workshop on Age-Based Restrictions on Content Access

The Workshop on Age-Based Restrictions on Content Access was convened by the Internet Architecture Board (IAB) and World Wide Web Consortium (W3C) in October 2025. This report summarizes the significant points of discussion and identifies topics that may warrant further consideration and work. Note that this document is a report on the proceedings of the workshop. The views and positions documente…

RFC99972026-07-01

YANG-CBOR: Allocating SID Ranges for Private Enterprise Number (PEN) Holders

YANG-CBOR: Allocating SID Ranges for Private Enterprise Number (PEN) Holders

YANG-CBOR (RFC 9254, "Encoding of Data Modeled with YANG in the Concise Binary Object Representation (CBOR)") defines YANG Schema Item iDentifiers (YANG SIDs), globally unique 63-bit unsigned integers used to identify YANG items. RFC 9595 ("YANG Schema Item iDentifier (YANG SID)") defines ways to allocate these SIDs using IANA registries. The present specification employs these SID allocation mech…

RFC99962026-07-01

Media Types for Protocol Buffers

Media Types for Protocol Buffers

This document registers media types for Protocol Buffers, a common extensible mechanism for serializing structured data.

RFC99952026-07-01

CBOR Object Signing and Encryption (COSE) Hash Envelope

CBOR Object Signing and Encryption (COSE) Hash Envelope

This document defines new CBOR Object Signing and Encryption (COSE) header parameters for signaling a payload as an output of a hash function. This mechanism enables faster validation, as access to the original payload is not required for signature validation. Additionally, hints of the hashed payload's content format and availability are defined, providing references to optional discovery mechani…

RFC99942026-06-01

MPLS Network Action (MNA) Sub-Stack Specification Including In-Stack Network Actions and Data

MPLS Network Action (MNA) Sub-Stack Specification Including In-Stack Network Actions and Data

This document specifies the MPLS Network Action (MNA) Sub-Stack for carrying network actions and Ancillary Data (AD) in the MPLS label stack. MNA can be used to influence packet-forwarding decisions, carry additional Operations, Administration, and Maintenance (OAM) information in the MPLS packet, or perform user-defined operations. This document updates RFC 9789 to refine the list of pieces of in…

RFC99932026-05-01

RTP Payload Format for Haptics

RTP Payload Format for Haptics

This memo specifies an RTP payload format for MPEG-I haptic data. A haptic media stream is composed of MPEG-I Haptic Stream (MIHS) units including a MIHS unit header and zero or more MIHS packets. The RTP payload header format allows for packetization of a MIHS unit in an RTP packet payload as well as fragmentation of a MIHS unit into multiple RTP packets. The original subtype registration for 'ha…

RFC99922026-06-01

Routing in Fat Trees (RIFT) Key/Value Topology Information Elements Structure and Processing

Routing in Fat Trees (RIFT) Key/Value Topology Information Elements Structure and Processing

The Routing in Fat Trees (RIFT) protocol allows for key/value pairs to be advertised within Key-Value Topology Information Elements (KV TIEs). The data contained within these KV TIEs can be used for any imaginable purpose. This document specifies behavior for the various Key Types (i.e., Well-Known, Organizationally Unique Identifier (OUI), and Experimental) and a method to structure corresponding…

RFC99912026-05-01

Domain-Based Message Authentication, Reporting, and Conformance (DMARC) Failure Reporting

Domain-Based Message Authentication, Reporting, and Conformance (DMARC) Failure Reporting

Domain-based Message Authentication, Reporting, and Conformance (DMARC) is a mechanism by which a Domain Owner can request feedback about email messages using their domain in the From: address field. This document describes "failure reports", or "failed message reports", which provide details about individual messages that failed to authenticate according to the DMARC mechanism. This document upda…

RFC99902026-05-01

Domain-Based Message Authentication, Reporting, and Conformance (DMARC) Aggregate Reporting

Domain-Based Message Authentication, Reporting, and Conformance (DMARC) Aggregate Reporting

Domain-based Message Authentication, Reporting, and Conformance (DMARC) allows for Domain Owners to request aggregate reports from receivers. This report is an XML document and contains extensible elements that allow for other types of data to be specified later. The aggregate reports can be submitted by the receiver to the Domain Owner's specified destination as declared in the associated DNS rec…

RFC99892026-05-01

Domain-Based Message Authentication, Reporting, and Conformance (DMARC)

Domain-Based Message Authentication, Reporting, and Conformance (DMARC)

This document describes the Domain-based Message Authentication, Reporting, and Conformance (DMARC) protocol. DMARC permits the owner of an email's Author Domain to enable validation of the domain's use to indicate the Domain Owner's or Public Suffix Operator's message handling preference regarding failed validation and to request reports about the use of the domain name. Mail-receiving organizati…

RFC99872026-05-01

Secure Shell (SSH) Agent Protocol

Secure Shell (SSH) Agent Protocol

This document specifies a key agent protocol for use in the Secure Shell (SSH) protocol.

RFC99862026-06-01

Meticulous Keyed ISAAC for Bidirectional Forwarding Detection (BFD) Optimized Authentication

Meticulous Keyed ISAAC for Bidirectional Forwarding Detection (BFD) Optimized Authentication

This document describes a Bidirectional Forwarding Detection (BFD) Optimized Authentication Mode known as Meticulous Keyed ISAAC Authentication. This mode can be used to authenticate some BFD packets with less CPU time cost than using MD5 or SHA-1 with the trade-off of decreased security. This mechanism cannot be used to signal state changes, but it can be used to maintain a session in the Up stat…

RFC99852026-06-01

Optimizing Bidirectional Forwarding Detection (BFD) Authentication

Optimizing Bidirectional Forwarding Detection (BFD) Authentication

This document describes an experimental optimization to Bidirectional Forwarding Detection (BFD) Authentication. This optimization enables BFD to scale better when there is a desire to use authentication where applying the same authentication mechanism to every BFD Control Packet may adversely impact performance. This optimization partitions BFD Authentication into a more computationally intensive…

RFC99842026-06-01

YANG Groupings for UDP Clients and UDP Servers

YANG Groupings for UDP Clients and UDP Servers

This document presents two YANG 1.1 modules with reusable groupings for managing UDP clients and UDP servers.

RFC99832026-05-01

OSPFv2 Anycast Property Advertisement

OSPFv2 Anycast Property Advertisement

An IP prefix may be configured as anycast and, as such, the same value can be advertised by multiple routers. It is useful for other routers to know that the advertisement is for an anycast prefix. This document defines a new flag in the OSPFv2 Extended Prefix TLV Flags to advertise the anycast property. The document also specifies a companion YANG module for managing this function.

RFC99822026-05-01

JSContact Version 2.0: A JSON Representation of Contact Data

JSContact Version 2.0: A JSON Representation of Contact Data

This document defines version "2.0" of JSContact. It defines the uid property of a Card object to be optional, rather than mandatory, as defined previously in version "1.0". All other definitions of JSContact version "1.0" remain as defined in RFC 9553. This document updates RFC 9555 by redefining how to convert the now optional uid property from and to vCard. It also registers the vCard JSCOMPS p…

RFC99812026-05-01

Resource Public Key Infrastructure (RPKI) Manifest Number Handling

Resource Public Key Infrastructure (RPKI) Manifest Number Handling

The Resource Public Key Infrastructure (RPKI) makes use of signed objects called "manifests", each of which includes a "manifest number". This document updates RFC 9286 by specifying issuer and Relying Party (RP) behaviour when a manifest number reaches the largest possible value, a situation not considered in RFC 9286.

RFC99802026-06-01

Post-Quantum Cryptography in OpenPGP

Post-Quantum Cryptography in OpenPGP

This document defines a post-quantum public key algorithm extension for the OpenPGP protocol, extending RFC 9580. Given the generally assumed threat of a cryptographically relevant quantum computer, this extension provides a basis for long-term secure OpenPGP signatures and ciphertexts. Specifically, it defines composite public key encryption based on ML-KEM (formerly CRYSTALS-Kyber), composite pu…

RFC99792026-05-01

Registration of Further IMAP/JMAP Keywords and Mailbox Name Attributes

Registration of Further IMAP/JMAP Keywords and Mailbox Name Attributes

This document defines a number of keywords and mailbox name attributes that have been in use across different server and client implementations. It defines the intended use of these keywords and mailbox name attributes. This document registers all of these with IANA to avoid name collisions.

RFC99782026-06-01

Bidirectional Forwarding Detection (BFD) Stability

Bidirectional Forwarding Detection (BFD) Stability

This document describes extensions to the Bidirectional Forwarding Detection (BFD) protocol to measure BFD Stability. Specifically, it describes a mechanism for the detection of BFD packet loss.

RFC99772026-05-01

Publishing End-Site Prefix Lengths

Publishing End-Site Prefix Lengths

This document specifies how to augment the Routing Policy Specification Language (RPSL) inetnum: class to refer specifically to prefixlen files, which are Comma-Separated Values (CSV) files used to specify end-site prefix lengths. This document also describes an optional mechanism that uses the Resource Public Key Infrastructure (RPKI) to authenticate the prefixlen files.

RFC99752026-05-01

Clarifications on CDS/CDNSKEY and CSYNC Consistency

Clarifications on CDS/CDNSKEY and CSYNC Consistency

Maintenance of DNS delegations requires occasional changes of the DS and NS record sets on the parent side of the delegation. For the case of DS records, "Automating DNSSEC Delegation Trust Maintenance" (RFC 7344) provides automation by allowing the child to publish CDS and/or CDNSKEY records holding the prospective DS parameters that the parent can ingest. Similarly, "Child-to-Parent Synchronizat…

RFC99742026-06-01

Operations, Administration, and Maintenance (OAM) Requirements for the Bit Index Explicit Replication (BIER) Layer

Operations, Administration, and Maintenance (OAM) Requirements for the Bit Index Explicit Replication (BIER) Layer

This document specifies a list of functional requirements for Operations, Administration, and Maintenance mechanisms, protocols, and tools that support operations in the Bit Index Explicit Replication layer of a network.