⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC52232008-08-01

Discovering Location-to-Service Translation (LoST) Servers Using the Dynamic Host Configuration Protocol (DHCP)

Discovering Location-to-Service Translation (LoST) Servers Using the Dynamic Host Configuration Protocol (DHCP)

The Location-to-Service Translation (LoST) Protocol describes an XML- based protocol for mapping service identifiers and geospatial or civic location information to service contact Uniform Resource Locators (URLs). LoST servers can be located anywhere, but a placement closer to the end host, e.g., in the access network, is desirable. In disaster situations with intermittent network connectivity, s…

RFC52222008-08-01

LoST: A Location-to-Service Translation Protocol

LoST: A Location-to-Service Translation Protocol

This document describes an XML-based protocol for mapping service identifiers and geodetic or civic location information to service contact URIs. In particular, it can be used to determine the location-appropriate Public Safety Answering Point (PSAP) for emergency services. [STANDARDS-TRACK]

RFC52212008-07-01

Requirements for Address Selection Mechanisms

Requirements for Address Selection Mechanisms

There are some problematic cases when using the default address selection mechanism that RFC 3484 defines. This document describes additional requirements that operate with RFC 3484 to solve the problems. This memo provides information for the Internet community.

RFC52202008-07-01

Problem Statement for Default Address Selection in Multi-Prefix Environments: Operational Issues of RFC 3484 Default Rules

Problem Statement for Default Address Selection in Multi-Prefix Environments: Operational Issues of RFC 3484 Default Rules

A single physical link can have multiple prefixes assigned to it. In that environment, end hosts might have multiple IP addresses and be required to use them selectively. RFC 3484 defines default source and destination address selection rules and is implemented in a variety of OSs. But, it has been too difficult to use operationally for several reasons. In some environments where multiple prefixes…

RFC52192008-02-01

A More Loss-Tolerant RTP Payload Format for MP3 Audio

A More Loss-Tolerant RTP Payload Format for MP3 Audio

This document describes an RTP (Real-Time Protocol) payload format for transporting MPEG (Moving Picture Experts Group) 1 or 2, layer III audio (commonly known as "MP3"). This format is an alternative to that described in RFC 2250, and performs better if there is packet loss. This document obsoletes RFC 3119, correcting typographical errors in the "SDP usage" section and pseudo-code appendices. [S…

RFC52182008-07-01

What Makes for a Successful Protocol?

What Makes for a Successful Protocol?

The Internet community has specified a large number of protocols to date, and these protocols have achieved varying degrees of success. Based on case studies, this document attempts to ascertain factors that contribute to or hinder a protocol's success. It is hoped that these observations can serve as guidance for future protocol work. This memo provides information for the Internet community.

RFC52172008-07-01

Memorandum for Multi-Domain Public Key Infrastructure Interoperability

Memorandum for Multi-Domain Public Key Infrastructure Interoperability

The objective of this document is to establish a terminology framework and to suggest the operational requirements of Public Key Infrastructure (PKI) domain for interoperability of multi-domain Public Key Infrastructure, where each PKI domain is operated under a distinct policy. This document describes the relationships between Certification Authorities (CAs), provides the definition and requireme…

RFC52162008-03-01

The EAP-TLS Authentication Protocol

The EAP-TLS Authentication Protocol

The Extensible Authentication Protocol (EAP), defined in RFC 3748, provides support for multiple authentication methods. Transport Layer Security (TLS) provides for mutual authentication, integrity-protected ciphersuite negotiation, and key exchange between two endpoints. This document defines EAP-TLS, which includes support for certificate-based mutual authentication and key derivation. This docu…

RFC52152008-08-01

RTP Payload Format for Vorbis Encoded Audio

RTP Payload Format for Vorbis Encoded Audio

This document describes an RTP payload format for transporting Vorbis encoded audio. It details the RTP encapsulation mechanism for raw Vorbis data and the delivery mechanisms for the decoder probability model (referred to as a codebook), as well as other setup information. Also included within this memo are media type registrations and the details necessary for the use of Vorbis with the Session …

RFC52142008-03-01

Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)

Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)

The Intra-Site Automatic Tunnel Addressing Protocol (ISATAP) connects dual-stack (IPv6/IPv4) nodes over IPv4 networks. ISATAP views the IPv4 network as a link layer for IPv6 and supports an automatic tunneling abstraction similar to the Non-Broadcast Multiple Access (NBMA) model. This memo provides information for the Internet community.

RFC52132008-08-01

Proxy Mobile IPv6

Proxy Mobile IPv6

Network-based mobility management enables IP mobility for a host without requiring its participation in any mobility-related signaling. The network is responsible for managing IP mobility on behalf of the host. The mobility entities in the network are responsible for tracking the movements of the host and initiating the required mobility signaling on its behalf. This specification describes a netw…

RFC52122008-07-01

Requirements for GMPLS-Based Multi-Region and Multi-Layer Networks (MRN/MLN)

Requirements for GMPLS-Based Multi-Region and Multi-Layer Networks (MRN/MLN)

Most of the initial efforts to utilize Generalized MPLS (GMPLS) have been related to environments hosting devices with a single switching capability. The complexity raised by the control of such data planes is similar to that seen in classical IP/MPLS networks. By extending MPLS to support multiple switching technologies, GMPLS provides a comprehensive framework for the control of a multi-layered …

RFC52112008-07-01

An Internet Transition Plan

An Internet Transition Plan

This memo provides one possible plan for transitioning the Internet from a predominantly IPv4-based connectivity model to a predominantly IPv6-based connectivity model. This memo provides information for the Internet community.

RFC52102008-06-01

A Source Address Validation Architecture (SAVA) Testbed and Deployment Experience

A Source Address Validation Architecture (SAVA) Testbed and Deployment Experience

Because the Internet forwards packets according to the IP destination address, packet forwarding typically takes place without inspection of the source address and malicious attacks have been launched using spoofed source addresses. In an effort to enhance the Internet with IP source address validation, a prototype implementation of the IP Source Address Validation Architecture (SAVA) was created …

RFC52092008-06-01

Network Endpoint Assessment (NEA): Overview and Requirements

Network Endpoint Assessment (NEA): Overview and Requirements

This document defines the problem statement, scope, and protocol requirements between the components of the NEA (Network Endpoint Assessment) reference model. NEA provides owners of networks (e.g., an enterprise offering remote access) a mechanism to evaluate the posture of a system. This may take place during the request for network access and/or subsequently at any time while connected to the ne…

RFC52082008-05-01

Public-Key Cryptography Standards (PKCS) #8: Private-Key Information Syntax Specification Version 1.2

Public-Key Cryptography Standards (PKCS) #8: Private-Key Information Syntax Specification Version 1.2

This document represents a republication of PKCS #8 v1.2 from RSA Laboratories' Public Key Cryptography Standard (PKCS) series. Change control is transferred to the IETF. The body of this document, except for the security considerations section, is taken directly from the PKCS #8 v1.2 specification. This document describes a syntax for private-key information. This memo provides information for th…

RFC52072008-04-01

NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) Communication

NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) Communication

The Host Identity Protocol (HIP) changes the way in which two Internet hosts communicate. One key advantage over other schemes is that HIP does not require modifications to the traditional network- layer functionality of the Internet, i.e., its routers. In the current Internet, however, many devices other than routers modify the traditional network-layer behavior of the Internet. These "middleboxe…

RFC52062008-04-01

End-Host Mobility and Multihoming with the Host Identity Protocol

End-Host Mobility and Multihoming with the Host Identity Protocol

This document defines mobility and multihoming extensions to the Host Identity Protocol (HIP). Specifically, this document defines a general "LOCATOR" parameter for HIP messages that allows for a HIP host to notify peers about alternate addresses at which it may be reached. This document also defines elements of procedure for mobility of a HIP host -- the process by which a host dynamically change…

RFC52052008-04-01

Host Identity Protocol (HIP) Domain Name System (DNS) Extensions

Host Identity Protocol (HIP) Domain Name System (DNS) Extensions

This document specifies a new resource record (RR) for the Domain Name System (DNS), and how to use it with the Host Identity Protocol (HIP). This RR allows a HIP node to store in the DNS its Host Identity (HI, the public component of the node public-private key pair), Host Identity Tag (HIT, a truncated hash of its public key), and the Domain Names of its rendezvous servers (RVSs). This memo defi…

RFC52042008-04-01

Host Identity Protocol (HIP) Rendezvous Extension

Host Identity Protocol (HIP) Rendezvous Extension

This document defines a rendezvous extension for the Host Identity Protocol (HIP). The rendezvous extension extends HIP and the HIP registration extension for initiating communication between HIP nodes via HIP rendezvous servers. Rendezvous servers improve reachability and operation when HIP nodes are multi-homed or mobile. This memo defines an Experimental Protocol for the Internet community.

RFC52032008-04-01

Host Identity Protocol (HIP) Registration Extension

Host Identity Protocol (HIP) Registration Extension

This document specifies a registration mechanism for the Host Identity Protocol (HIP) that allows hosts to register with services, such as HIP rendezvous servers or middleboxes. This memo defines an Experimental Protocol for the Internet community.

RFC52022008-04-01

Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP)

Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP)

This memo specifies an Encapsulated Security Payload (ESP) based mechanism for transmission of user data packets, to be used with the Host Identity Protocol (HIP). This memo defines an Experimental Protocol for the Internet community.

RFC52012008-04-01

Host Identity Protocol

Host Identity Protocol

This memo specifies the details of the Host Identity Protocol (HIP). HIP allows consenting hosts to securely establish and maintain shared IP-layer state, allowing separation of the identifier and locator roles of IP addresses, thereby enabling continuity of communications across IP address changes. HIP is based on a Sigma-compliant Diffie- Hellman key exchange, using public key identifiers from a…

RFC51982008-03-01

Unicode Format for Network Interchange

Unicode Format for Network Interchange

The Internet today is in need of a standardized form for the transmission of internationalized "text" information, paralleling the specifications for the use of ASCII that date from the early days of the ARPANET. This document specifies that format, using UTF-8 with normalization and specific line-ending sequences. [STANDARDS-TRACK]

RFC51972008-06-01

On the Applicability of Various Multimedia Internet KEYing (MIKEY) Modes and Extensions

On the Applicability of Various Multimedia Internet KEYing (MIKEY) Modes and Extensions

Multimedia Internet Keying (MIKEY) is a key management protocol that can be used for \%real-time applications. In particular, it has been defined focusing on the support of the Secure \%Real-time Transport Protocol (SRTP). MIKEY itself is standardized within RFC 3830 and defines four key distribution methods. Moreover, it is defined to allow extensions of the protocol. As MIKEY becomes more and mo…

RFC51962008-09-01

Session Initiation Protocol (SIP) User Agent Capability Extension to Presence Information Data Format (PIDF)

Session Initiation Protocol (SIP) User Agent Capability Extension to Presence Information Data Format (PIDF)

Presence Information Data Format (PIDF) defines a common presence data format for Common Profile for Presence (CPP) compliant presence protocols. This memo defines a PIDF extension to represent SIP User Agent capabilities. [STANDARDS-TRACK]

RFC51952008-06-01

BGP-Based Auto-Discovery for Layer-1 VPNs

BGP-Based Auto-Discovery for Layer-1 VPNs

The purpose of this document is to define a BGP-based auto-discovery mechanism for Layer-1 VPNs (L1VPNs). The auto-discovery mechanism for L1VPNs allows the provider network devices to dynamically discover the set of Provider Edges (PEs) having ports attached to Customer Edge (CE) members of the same VPN. That information is necessary for completing the signaling phase of L1VPN connections. One ma…

RFC51942008-06-01

Framework for Real-Time Text over IP Using the Session Initiation Protocol (SIP)

Framework for Real-Time Text over IP Using the Session Initiation Protocol (SIP)

This document lists the essential requirements for real-time Text-over-IP (ToIP) and defines a framework for implementation of all required functions based on the Session Initiation Protocol (SIP) and the Real-Time Transport Protocol (RTP). This includes interworking between Text-over-IP and existing text telephony on the Public Switched Telephone Network (PSTN) and other networks. This memo provi…

RFC51932008-05-01

Protocol for Carrying Authentication for Network Access (PANA) Framework

Protocol for Carrying Authentication for Network Access (PANA) Framework

This document defines the general Protocol for Carrying Authentication for Network Access (PANA) framework functional elements, high-level call flow, and deployment environments. This memo provides information for the Internet community.

RFC51922008-05-01

DHCP Options for Protocol for Carrying Authentication for Network Access (PANA) Authentication Agents

DHCP Options for Protocol for Carrying Authentication for Network Access (PANA) Authentication Agents

This document defines new DHCPv4 and DHCPv6 options that contain a list of IP addresses to locate one or more PANA (Protocol for carrying Authentication for Network Access) Authentication Agents (PAAs). This is one of the methods that a PANA Client (PaC) can use to locate PAAs. [STANDARDS-TRACK]