⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC33162003-05-01

Internet Protocol Version 6 (IPv6) for Some Second and Third Generation Cellular Hosts

Internet Protocol Version 6 (IPv6) for Some Second and Third Generation Cellular Hosts

As the deployment of second and third generation cellular networks progresses, a large number of cellular hosts are being connected to the Internet. Standardization organizations are making IPv6 mandatory in their specifications. However, the concept of IPv6 covers many aspects and numerous specifications. In addition, the characteristics of cellular links in terms of bandwidth, cost and delay put…

RFC33152003-07-01

Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

The Dynamic Host Configuration Protocol for IPv6 (DHCP) enables DHCP servers to pass configuration parameters such as IPv6 network addresses to IPv6 nodes. It offers the capability of automatic allocation of reusable network addresses and additional configuration flexibility. This protocol is a stateful counterpart to 'IPv6 Stateless Address Autoconfiguration' (RFC2462), and can be used separately…

RFC33142002-09-01

Recommendations for IPv6 in Third Generation Partnership Project (3GPP) Standards

Recommendations for IPv6 in Third Generation Partnership Project (3GPP) Standards

This document contains recommendations from the Internet Engineering Task Force (IETF) IPv6 Working Group to the Third Generation Partnership Project (3GPP) community regarding the use of IPv6 in the 3GPP standards. Specifically, this document recommends that the 3GPP: 1. Specify that multiple prefixes may be assigned to each primary PDP context, 2. Require that a given prefix must not be assigned…

RFC33132003-01-01

Private Session Initiation Protocol (SIP) Extensions for Media Authorization

Private Session Initiation Protocol (SIP) Extensions for Media Authorization

This document describes the need for QoS and media authorization and defines a SIP extension that can be used to integrate QoS admission control with call signaling and help guard against denial of service attacks. The use of this extension is only applicable in administrative domains, or among federations of administrative domains with previously agreed-upon policies, where both the SIP proxy aut…

RFC33122002-10-01

Integration of Resource Management and Session Initiation Protocol (SIP)

Integration of Resource Management and Session Initiation Protocol (SIP)

This document defines a generic framework for preconditions which is extensible through IANA registration. This document also discusses how network quality of service can be made a precondition to establishment of sessions initiated by the Session Initiation Protocol (SIP). These preconditions require that the participant reserve network resources before continuing with the session. We do not defi…

RFC33112002-10-01

The Session Initiation Protocol (SIP) UPDATE Method

The Session Initiation Protocol (SIP) UPDATE Method

This specification defines the new UPDATE method for the Session Initiation Protocol (SIP). UPDATE allows a client to update parameters of a session (such as the set of media streams and their codecs) but has no impact on the state of a dialog. In that sense, it is like a re-INVITE, but can be sent before the initial INVITE has completed. This makes it very useful for updating session parameters w…

RFC33102002-09-01

Hypertext Transfer Protocol (HTTP) Digest Authentication Using Authentication and Key Agreement (AKA)

Hypertext Transfer Protocol (HTTP) Digest Authentication Using Authentication and Key Agreement (AKA)

The Hypertext Transfer Protocol (HTTP) Authentication Framework includes two authentication schemes: Basic and Digest. Both schemes employ a shared secret based mechanism for access authentication. The Authentication and Key Agreement (AKA) mechanism performs user authentication and session key distribution in Universal Mobile Telecommunications System (UMTS) networks. AKA is a challenge- response…

RFC33092002-09-01

Stream Control Transmission Protocol (SCTP) Checksum Change

Stream Control Transmission Protocol (SCTP) Checksum Change

Stream Control Transmission Protocol [RFC2960] (SCTP) currently uses an Adler-32 checksum. For small packets Adler-32 provides weak detection of errors. This document changes that checksum and updates SCTP to use a 32 bit CRC checksum.

RFC33082002-11-01

Layer Two Tunneling Protocol (L2TP) Differentiated Services Extension

Layer Two Tunneling Protocol (L2TP) Differentiated Services Extension

The Layer Two Tunneling Protocol (L2TP) provides a standard method for tunneling PPP packets. The current specification provides no provisions for supporting Differentiated Services (diffserv) over the L2TP control connection or subsequent data sessions. As a result, no standard mechanism currently exists within L2TP to provide L2TP protocol negotiations for service discrimination.

RFC33072002-09-01

Allocation Guidelines for IPv6 Multicast Addresses

Allocation Guidelines for IPv6 Multicast Addresses

This document specifies guidelines that must be implemented by any entity responsible for allocating IPv6 multicast addresses. This includes, but is not limited to, any documents or entities wishing to assign permanent IPv6 multicast addresses, allocate dynamic IPv6 multicast addresses, and define permanent IPv6 multicast group identifiers. The purpose of these guidelines is to reduce the probabil…

RFC33062002-09-01

Unicast-Prefix-based IPv6 Multicast Addresses

Unicast-Prefix-based IPv6 Multicast Addresses

This specification defines an extension to the multicast addressing architecture of the IP Version 6 protocol. The extension presented in this document allows for unicast-prefix-based allocation of multicast addresses. By delegating multicast addresses at the same time as unicast prefixes, network operators will be able to identify their multicast addresses without needing to run an inter-domain a…

RFC33052002-08-01

Report from the Joint W3C/IETF URI Planning Interest Group: Uniform Resource Identifiers (URIs), URLs, and Uniform Resource Names (URNs): Clarifications and Recommendations

Report from the Joint W3C/IETF URI Planning Interest Group: Uniform Resource Identifiers (URIs), URLs, and Uniform Resource Names (URNs): Clarifications and Recommendations

This paper is the product of the W3C URI Interest Group. It addresses and attempts to clarify two issues pertaining to URIs, and presents recommendations. Section 1 addresses how URI space is partitioned and the relationship between URIs, URLs, and URNs. Section 2 describes how URI schemes and URN namespace ids are registered. Section 3 mentions additional unresolved issues not considered by this …

RFC33042002-08-01

Middlebox Communications (midcom) Protocol Requirements

Middlebox Communications (midcom) Protocol Requirements

This document specifies the requirements that the Middlebox Commu- nication (midcom) protocol must satisfy in order to meet the needs of applications wishing to influence middlebox function. These requirements were developed with a specific focus on network address translation and firewall middleboxes.

RFC33032002-08-01

Middlebox communication architecture and framework

Middlebox communication architecture and framework

There are a variety of intermediate devices in the Internet today that require application intelligence for their operation. Datagrams pertaining to real-time streaming applications such as SIP and H.323 and peer-to-peer applications such as Napster and NetMeeting cannot be identified by merely examining packet headers.

RFC33022002-09-01

Tag Image File Format (TIFF) - image/tiff MIME Sub-type Registration

Tag Image File Format (TIFF) - image/tiff MIME Sub-type Registration

This document describes the registration of the MIME sub-type image/tiff. The baseline encoding of TIFF (Tag Image File Format) is defined by [TIFF]. This document refines an earlier sub-type registration in RFC 1528 [TPC.INT].

RFC33012002-06-01

Layer Two Tunnelling Protocol (L2TP): ATM access network extensions

Layer Two Tunnelling Protocol (L2TP): ATM access network extensions

L2TP [RFC2661] specifies a protocol for tunnelling PPP packets over packet based networks and over IP networks in particular. L2TP [RFC2661] supports remote access by ISDN and PSTN networks. This document augments the procedures described in [RFC2661] to further support ATM SVC or PVC based access networks. The extensions defined within this document allow for asymmetric bi-directional call establ…

RFC33002002-11-01

Internet Official Protocol Standards

Internet Official Protocol Standards

RFC32992003-12-01

Request for Comments Summary RFC Numbers 3200-3299

Request for Comments Summary RFC Numbers 3200-3299

RFC32982002-09-01

Service in the Public Switched Telephone Network/Intelligent Network (PSTN/IN) Requesting InTernet Service (SPIRITS) Protocol Requirements

Service in the Public Switched Telephone Network/Intelligent Network (PSTN/IN) Requesting InTernet Service (SPIRITS) Protocol Requirements

This document describes the SPIRITS protocol requirements, based on the architecture presented in RFC 3136. (SPIRITS stands for "Service in the PSTN/IN Requesting InTernet Service".) The purpose of the protocol is to support services that originate in the Public Switched Telephone Network (PSTN) and necessitate the interactions between the PSTN and the Internet. Similarly, such services are called…

RFC32972002-07-01

Content Negotiation for Messaging Services based on Email

Content Negotiation for Messaging Services based on Email

This memo describes a content negotiation mechanism for facsimile, voice and other messaging services that use Internet email. [STANDARDS-TRACK]

RFC32962002-07-01

Named Subordinate References in Lightweight Directory Access Protocol (LDAP) Directories

Named Subordinate References in Lightweight Directory Access Protocol (LDAP) Directories

This document details schema and protocol elements for representing and managing named subordinate references in Lightweight Directory Access Protocol (LDAP) Directories. [STANDARDS-TRACK]

RFC32952002-06-01

Definitions of Managed Objects for the General Switch Management Protocol (GSMP)

Definitions of Managed Objects for the General Switch Management Protocol (GSMP)

This memo defines a portion of the Management Information Base (MIB) for the use with the network management protocols in the Internet community. In particular, it describes managed objects for the General Switch Management Protocol (GSMP). [STANDARDS-TRACK]

RFC32942002-06-01

General Switch Management Protocol (GSMP) Applicability

General Switch Management Protocol (GSMP) Applicability

This memo provides an overview of the GSMP (General Switch Management Protocol) and includes information relating to its deployment in a IP network in an MPLS environment. It does not discuss deployment in an ATM (Asynchronous Transfer Mode) network or in a raw ethernet configuration. This memo provides information for the Internet community.

RFC32932002-06-01

General Switch Management Protocol (GSMP) Packet Encapsulations for Asynchronous Transfer Mode (ATM), Ethernet and Transmission Control Protocol (TCP)

General Switch Management Protocol (GSMP) Packet Encapsulations for Asynchronous Transfer Mode (ATM), Ethernet and Transmission Control Protocol (TCP)

This memo specifies the encapsulation of GSMP (General Switch Management Protocol) packets in ATM (Asynchronous Transfer Mode), Ethernet and TCP (Transmission Control Protocol). [STANDARDS-TRACK]

RFC32922002-06-01

General Switch Management Protocol (GSMP) V3

General Switch Management Protocol (GSMP) V3

This document describes the General Switch Management Protocol Version 3 (GSMPv3). The GSMPv3 is an asymmetric protocol that allows one or more external switch controllers to establish and maintain the state of a label switch such as, an ATM, frame relay or MPLS switch. The GSMPv3 allows control of both unicast and multicast switch connection state as well as control of switch system resources and…

RFC32912002-05-01

Textual Conventions for Internet Network Addresses

Textual Conventions for Internet Network Addresses

This MIB module defines textual conventions to represent commonly used Internet network layer addressing information. The intent is that these textual conventions (TCs) will be imported and used in MIB modules that would otherwise define their own representations. [STANDARDS-TRACK]

RFC32902002-06-01

An Informal Management Model for Diffserv Routers

An Informal Management Model for Diffserv Routers

This document proposes an informal management model of Differentiated Services (Diffserv) routers for use in their management and configuration. This model defines functional datapath elements (e.g., classifiers, meters, actions, marking, absolute dropping, counting, multiplexing), algorithmic droppers, queues and schedulers. It describes possible configuration parameters for these elements and ho…

RFC32892002-06-01

Management Information Base for the Differentiated Services Architecture

Management Information Base for the Differentiated Services Architecture

This memo describes an SMIv2 (Structure of Management Information version 2) MIB for a device implementing the Differentiated Services Architecture. It may be used both for monitoring and configuration of a router or switch capable of Differentiated Services functionality. [STANDARDS-TRACK]

RFC32882002-06-01

Using the Simple Object Access Protocol (SOAP) in Blocks Extensible Exchange Protocol (BEEP)

Using the Simple Object Access Protocol (SOAP) in Blocks Extensible Exchange Protocol (BEEP)

This memo specifies a Simple Object Access Protocol (SOAP) binding to the Blocks Extensible Exchange Protocol core (BEEP). A SOAP binding describes how SOAP messages are transmitted in the network. [STANDARDS-TRACK]

RFC32872002-07-01

Remote Monitoring MIB Extensions for Differentiated Services

Remote Monitoring MIB Extensions for Differentiated Services

This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in the Internet community. In particular, it describes managed objects used for monitoring Differentiated Services (DS) Codepoint usage in packets which contain a DS field, utilizing the monitoring framework defined in the RMON-2 (Remote Network Monitoring Management Version 2) MIB. [STAN…