⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC87672020-03-01

Serving Stale Data to Improve DNS Resiliency

Serving Stale Data to Improve DNS Resiliency

This document defines a method (serve-stale) for recursive resolvers to use stale DNS data to avoid outages when authoritative nameservers cannot be reached to refresh expired data. One of the motivations for serve-stale is to make the DNS more resilient to DoS attacks and thereby make them less attractive as an attack vector. This document updates the definitions of TTL from RFCs 1034 and 1035 so…

RFC87662020-06-01

Discovery Proxy for Multicast DNS-Based Service Discovery

Discovery Proxy for Multicast DNS-Based Service Discovery

This document specifies a network proxy that uses Multicast DNS to automatically populate the wide-area unicast Domain Name System namespace with records describing devices and services found on the local link.

RFC87652020-06-01

DNS Push Notifications

DNS Push Notifications

The Domain Name System (DNS) was designed to return matching records efficiently for queries for data that are relatively static. When those records change frequently, DNS is still efficient at returning the updated results when polled, as long as the polling rate is not too high. But, there exists no mechanism for a client to be asynchronously notified when these changes occur. This document defi…

RFC87642020-06-01

Apple's DNS Long-Lived Queries Protocol

Apple's DNS Long-Lived Queries Protocol

Apple's DNS Long-Lived Queries (LLQ) is a mechanism for extending the DNS protocol to support change notification, thus allowing clients to learn about changes to DNS data without polling the server. From 2005 onwards, LLQ was implemented in Apple products including Mac OS X, Bonjour for Windows, and AirPort wireless base stations. In 2020, the LLQ protocol was superseded by the IETF Standards Tra…

RFC87632020-04-01

Deployment Considerations for Information-Centric Networking (ICN)

Deployment Considerations for Information-Centric Networking (ICN)

Information-Centric Networking (ICN) is now reaching technological maturity after many years of fundamental research and experimentation. This document provides a number of deployment considerations in the interest of helping the ICN community move forward to the next step of live deployments. First, the major deployment configurations for ICN are described, including the key overlay and underlay …

RFC87622020-03-01

Simple Two-Way Active Measurement Protocol

Simple Two-Way Active Measurement Protocol

This document describes the Simple Two-way Active Measurement Protocol (STAMP), which enables the measurement of both one-way and round-trip performance metrics, like delay, delay variation, and packet loss.

RFC87612020-04-01

Video Codec Requirements and Evaluation Methodology

Video Codec Requirements and Evaluation Methodology

This document provides requirements for a video codec designed mainly for use over the Internet. In addition, this document describes an evaluation methodology for measuring the compression efficiency to determine whether or not the stated requirements have been fulfilled.

RFC87602020-03-01

The Session Initiation Protocol (SIP) Digest Access Authentication Scheme

The Session Initiation Protocol (SIP) Digest Access Authentication Scheme

This document updates RFC 3261 by modifying the Digest Access Authentication scheme used by the Session Initiation Protocol (SIP) to add support for more secure digest algorithms, e.g., SHA-256 and SHA-512/256, to replace the obsolete MD5 algorithm.

RFC87592020-03-01

RTP Payload for Timed Text Markup Language (TTML)

RTP Payload for Timed Text Markup Language (TTML)

This memo describes a Real-time Transport Protocol (RTP) payload format for Timed Text Markup Language (TTML), an XML-based timed text format from W3C. This payload format is specifically targeted at streaming workflows using TTML.

RFC87582020-04-01

Deprecating RC4 in Secure Shell (SSH)

Deprecating RC4 in Secure Shell (SSH)

This document deprecates RC4 in Secure Shell (SSH). Therefore, this document formally moves RFC 4345 to Historic status.

RFC87572020-03-01

Dynamic Link Exchange Protocol (DLEP) Latency Range Extension

Dynamic Link Exchange Protocol (DLEP) Latency Range Extension

This document defines an extension to the Dynamic Link Exchange Protocol (DLEP) to provide the range of latency that can be experienced on a link.

RFC87562020-03-01

Commercial National Security Algorithm (CNSA) Suite Profile of Certificate Management over CMS

Commercial National Security Algorithm (CNSA) Suite Profile of Certificate Management over CMS

This document specifies a profile of the Certificate Management over CMS (CMC) protocol for managing X.509 public key certificates in applications that use the Commercial National Security Algorithm (CNSA) Suite published by the United States Government. The profile applies to the capabilities, configuration, and operation of all components of US National Security Systems that manage X.509 public …

RFC87552020-03-01

Using Commercial National Security Algorithm Suite Algorithms in Secure/Multipurpose Internet Mail Extensions

Using Commercial National Security Algorithm Suite Algorithms in Secure/Multipurpose Internet Mail Extensions

The United States Government has published the National Security Agency (NSA) Commercial National Security Algorithm (CNSA) Suite, which defines cryptographic algorithm policy for national security applications. This document specifies the conventions for using the United States National Security Agency's CNSA Suite algorithms in Secure/Multipurpose Internet Mail Extensions (S/MIME) as specified i…

RFC87542020-03-01

IPv6 Segment Routing Header (SRH)

IPv6 Segment Routing Header (SRH)

Segment Routing can be applied to the IPv6 data plane using a new type of Routing Extension Header called the Segment Routing Header (SRH). This document describes the SRH and how it is used by nodes that are Segment Routing (SR) capable.

RFC87532020-04-01

Internationalized Domain Names for Applications (IDNA) Review for New Unicode Versions

Internationalized Domain Names for Applications (IDNA) Review for New Unicode Versions

The standards for Internationalized Domain Names in Applications (IDNA) require a review of each new version of Unicode to determine whether incompatibilities with prior versions or other issues exist and, where appropriate, to allow the IETF to decide on the trade-offs between compatibility with prior IDNA versions and compatibility with Unicode going forward. That requirement, and its relationsh…

RFC87522020-03-01

Report from the IAB Workshop on Exploring Synergy between Content Aggregation and the Publisher Ecosystem (ESCAPE)

Report from the IAB Workshop on Exploring Synergy between Content Aggregation and the Publisher Ecosystem (ESCAPE)

The Exploring Synergy between Content Aggregation and the Publisher Ecosystem (ESCAPE) Workshop was convened by the Internet Architecture Board (IAB) in July 2019. This report summarizes its significant points of discussion and identifies topics that may warrant further consideration. Note that this document is a report on the proceedings of the workshop. The views and positions documented in this…

RFC87512020-03-01

Hierarchical Stateful Path Computation Element (PCE)

Hierarchical Stateful Path Computation Element (PCE)

A stateful Path Computation Element (PCE) maintains information on the current network state received from the Path Computation Clients (PCCs), including computed Label Switched Paths (LSPs), reserved resources within the network, and pending path computation requests. This information may then be considered when computing the path for a new traffic-engineered LSP or for any associated/dependent L…

RFC87502020-03-01

Implicit Initialization Vector (IV) for Counter-Based Ciphers in Encapsulating Security Payload (ESP)

Implicit Initialization Vector (IV) for Counter-Based Ciphers in Encapsulating Security Payload (ESP)

Encapsulating Security Payload (ESP) sends an initialization vector (IV) in each packet. The size of the IV depends on the applied transform and is usually 8 or 16 octets for the transforms defined at the time this document was written. When used with IPsec, some algorithms, such as AES-GCM, AES-CCM, and ChaCha20-Poly1305, take the IV to generate a nonce that is used as an input parameter for encr…

RFC87492020-03-01

Moving DNSSEC Lookaside Validation (DLV) to Historic Status

Moving DNSSEC Lookaside Validation (DLV) to Historic Status

This document retires DNSSEC Lookaside Validation (DLV) and reclassifies RFCs 4431 and 5074 as Historic. Furthermore, this document updates RFC 6698 by excluding the DLV resource record from certificates and updates RFC 6840 by excluding the DLV registries from the trust anchor selection.

RFC87482020-03-01

Registry Fee Extension for the Extensible Provisioning Protocol (EPP)

Registry Fee Extension for the Extensible Provisioning Protocol (EPP)

Given the expansion of the DNS namespace and the proliferation of novel business models, it is desirable to provide a method for Extensible Provisioning Protocol (EPP) clients to query EPP servers for the fees and credits associated with various billable transactions and provide expected fees and credits for certain commands and objects. This document describes an EPP extension mapping for registr…

RFC87472020-03-01

Proof-of-Possession Key Semantics for CBOR Web Tokens (CWTs)

Proof-of-Possession Key Semantics for CBOR Web Tokens (CWTs)

This specification describes how to declare in a CBOR Web Token (CWT) (which is defined by RFC 8392) that the presenter of the CWT possesses a particular proof-of-possession key. Being able to prove possession of a key is also sometimes described as being the holder-of-key. This specification provides equivalent functionality to "Proof-of-Possession Key Semantics for JSON Web Tokens (JWTs)" (RFC 7…

RFC87462020-02-01

Concise Binary Object Representation (CBOR) Tags for Typed Arrays

Concise Binary Object Representation (CBOR) Tags for Typed Arrays

The Concise Binary Object Representation (CBOR), as defined in RFC 7049, is a data format whose design goals include the possibility of extremely small code size, fairly small message size, and extensibility without the need for version negotiation. This document makes use of this extensibility to define a number of CBOR tags for typed arrays of numeric data, as well as additional tags for multi-d…

RFC87452020-03-01

Path Computation Element Communication Protocol (PCEP) Extensions for Associating Working and Protection Label Switched Paths (LSPs) with Stateful PCE

Path Computation Element Communication Protocol (PCEP) Extensions for Associating Working and Protection Label Switched Paths (LSPs) with Stateful PCE

An active stateful Path Computation Element (PCE) is capable of computing as well as controlling via Path Computation Element Communication Protocol (PCEP) Multiprotocol Label Switching Traffic Engineering (MPLS-TE) Label Switched Paths (LSPs). Furthermore, it is also possible for an active stateful PCE to create, maintain, and delete LSPs. This document defines the PCEP extension to associate two…

RFC87442020-07-01

Issues and Requirements for Server Name Identification (SNI) Encryption in TLS

Issues and Requirements for Server Name Identification (SNI) Encryption in TLS

This document describes the general problem of encrypting the Server Name Identification (SNI) TLS parameter. The proposed solutions hide a hidden service behind a fronting service, only disclosing the SNI of the fronting service to external observers. This document lists known attacks against SNI encryption, discusses the current "HTTP co-tenancy" solution, and presents requirements for future TL…

RFC87432020-03-01

Multiple Access Management Services Multi-Access Management Services (MAMS)

Multiple Access Management Services Multi-Access Management Services (MAMS)

In multiconnectivity scenarios, the clients can simultaneously connect to multiple networks based on different access technologies and network architectures like Wi-Fi, LTE, and DSL. Both the quality of experience of the users and the overall network utilization and efficiency may be improved through the smart selection and combination of access and core network paths that can dynamically adapt to…

RFC87422020-02-01

Concise Binary Object Representation (CBOR) Sequences

Concise Binary Object Representation (CBOR) Sequences

This document describes the Concise Binary Object Representation (CBOR) Sequence format and associated media type "application/cbor-seq". A CBOR Sequence consists of any number of encoded CBOR data items, simply concatenated in sequence. Structured syntax suffixes for media types allow other media types to build on them and make it explicit that they are built on an existing media type as their fo…

RFC87412020-03-01

Ability for a Stateful Path Computation Element (PCE) to Request and Obtain Control of a Label Switched Path (LSP)

Ability for a Stateful Path Computation Element (PCE) to Request and Obtain Control of a Label Switched Path (LSP)

A stateful Path Computation Element (PCE) retains information about the placement of Multiprotocol Label Switching (MPLS) Traffic Engineering Label Switched Paths (TE LSPs). When a PCE has stateful control over LSPs, it may send indications to LSP head-ends to modify the attributes (especially the paths) of the LSPs. A Path Computation Client (PCC) that has set up LSPs under local configuration ma…

RFC87402020-02-01

Using TLS 1.3 with HTTP/2

Using TLS 1.3 with HTTP/2

This document updates RFC 7540 by forbidding TLS 1.3 post-handshake authentication, as an analog to the existing TLS 1.2 renegotiation restriction.

RFC87392020-03-01

Support for Short-Term, Automatically Renewed (STAR) Certificates in the Automated Certificate Management Environment (ACME)

Support for Short-Term, Automatically Renewed (STAR) Certificates in the Automated Certificate Management Environment (ACME)

Public key certificates need to be revoked when they are compromised, that is, when the associated private key is exposed to an unauthorized entity. However, the revocation process is often unreliable. An alternative to revocation is issuing a sequence of certificates, each with a short validity period, and terminating the sequence upon compromise. This memo proposes an Automated Certificate Manag…

RFC87382020-02-01

Automated Certificate Management Environment (ACME) IP Identifier Validation Extension

Automated Certificate Management Environment (ACME) IP Identifier Validation Extension

This document specifies identifiers and challenges required to enable the Automated Certificate Management Environment (ACME) to issue certificates for IP addresses.