⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC86432019-08-01

An Opportunistic Approach for Secure Real-time Transport Protocol (OSRTP)

An Opportunistic Approach for Secure Real-time Transport Protocol (OSRTP)

Opportunistic Secure Real-time Transport Protocol (OSRTP) is an implementation of the Opportunistic Security mechanism, as defined in RFC 7435, applied to the Real-time Transport Protocol (RTP). OSRTP allows encrypted media to be used in environments where support for encryption is not known in advance and is not required. OSRTP does not require Session Description Protocol (SDP) extensions or fea…

RFC86422019-08-01

Policy Behavior for Well-Known BGP Communities

Policy Behavior for Well-Known BGP Communities

Well-known BGP communities are manipulated differently across various current implementations, resulting in difficulties for operators. Network operators should deploy consistent community handling across their networks while taking the inconsistent behaviors from the various BGP implementations into consideration. This document recommends specific actions to limit future inconsistency: namely, BG…

RFC86412019-09-01

Subscription to YANG Notifications for Datastore Updates

Subscription to YANG Notifications for Datastore Updates

This document describes a mechanism that allows subscriber applications to request a continuous and customized stream of updates from a YANG datastore. Providing such visibility into updates enables new capabilities based on the remote mirroring and monitoring of configuration and operational state.

RFC86402019-09-01

Dynamic Subscription to YANG Events and Datastores over NETCONF

Dynamic Subscription to YANG Events and Datastores over NETCONF

This document provides a Network Configuration Protocol (NETCONF) binding to the dynamic subscription capability of both subscribed notifications and YANG-Push.

RFC86392019-09-01

Subscription to YANG Notifications

Subscription to YANG Notifications

This document defines a YANG data model and associated mechanisms enabling subscriber-specific subscriptions to a publisher's event streams. Applying these elements allows a subscriber to request and receive a continuous, customized feed of publisher-generated information.

RFC86382019-09-01

IPv4 Multicast over an IPv6 Multicast in Softwire Mesh Networks

IPv4 Multicast over an IPv6 Multicast in Softwire Mesh Networks

During the transition to IPv6, there are scenarios where a backbone network internally running one IP address family (referred to as the internal IP or I-IP family) connects client networks running another IP address family (referred to as the external IP or E-IP family). In such cases, the I-IP backbone needs to offer both unicast and multicast transit services to the client E-IP networks. This d…

RFC86372019-07-01

Applicability of the Path Computation Element (PCE) to the Abstraction and Control of TE Networks (ACTN)

Applicability of the Path Computation Element (PCE) to the Abstraction and Control of TE Networks (ACTN)

Abstraction and Control of TE Networks (ACTN) refers to the set of virtual network (VN) operations needed to orchestrate, control, and manage large-scale multidomain TE networks so as to facilitate network programmability, automation, efficient resource sharing, and end-to-end virtual service-aware connectivity and network function virtualization services. The Path Computation Element (PCE) is a c…

RFC86362019-07-01

Public Key Cryptography for Initial Authentication in Kerberos (PKINIT) Algorithm Agility

Public Key Cryptography for Initial Authentication in Kerberos (PKINIT) Algorithm Agility

This document updates the Public Key Cryptography for Initial Authentication in Kerberos (PKINIT) standard (RFC 4556) to remove protocol structures tied to specific cryptographic algorithms. The PKINIT key derivation function is made negotiable, and the digest algorithms for signing the pre-authentication data and the client's X.509 certificates are made discoverable. These changes provide preempt…

RFC86352019-08-01

Router Keying for BGPsec

Router Keying for BGPsec

BGPsec-speaking routers are provisioned with private keys in order to sign BGPsec announcements. The corresponding public keys are published in the Global Resource Public Key Infrastructure (RPKI), enabling verification of BGPsec messages. This document describes two methods of generating the public-private key pairs: router-driven and operator-driven.

RFC86342019-08-01

BGPsec Router Certificate Rollover

BGPsec Router Certificate Rollover

Certification Authorities (CAs) within the Resource Public Key Infrastructure (RPKI) manage BGPsec router certificates as well as RPKI certificates. The rollover of BGPsec router certificates must be carefully performed in order to synchronize the distribution of router public keys with BGPsec UPDATE messages verified with those router public keys. This document describes a safe rollover process, …

RFC86332019-07-01

Network Time Protocol Best Current Practices

Network Time Protocol Best Current Practices

The Network Time Protocol (NTP) is one of the oldest protocols on the Internet and has been widely used since its initial publication. This document is a collection of best practices for the general operation of NTP servers and clients on the Internet. It includes recommendations for the stable, accurate, and secure operation of NTP infrastructure. This document is targeted at NTP version 4 as des…

RFC86322019-09-01

A YANG Data Model for Alarm Management

A YANG Data Model for Alarm Management

This document defines a YANG module for alarm management. It includes functions for alarm-list management, alarm shelving, and notifications to inform management systems. There are also operations to manage the operator state of an alarm and administrative alarm procedures. The module carefully maps to relevant alarm standards.

RFC86312019-07-01

Link Relation Types for Web Services

Link Relation Types for Web Services

Many resources provided on the Web are part of sets of resources that are provided in a context that is managed by one particular service provider. Often, these sets of resources are referred to as "Web services" or "Web APIs". This specification defines link relations that represent relationships from Web services or APIs to resources that provide documentation, descriptions, metadata, or status …

RFC86302019-08-01

Resource Public Key Infrastructure (RPKI) Trust Anchor Locator

Resource Public Key Infrastructure (RPKI) Trust Anchor Locator

This document defines a Trust Anchor Locator (TAL) for the Resource Public Key Infrastructure (RPKI). The TAL allows Relying Parties in the RPKI to download the current Trust Anchor (TA) Certification Authority (CA) certificate from one or more locations and verify that the key of this self-signed certificate matches the key on the TAL. Thus, Relying Parties can be configured with TA keys but can …

RFC86292019-07-01

Dynamic Link Exchange Protocol (DLEP) Multi-Hop Forwarding Extension

Dynamic Link Exchange Protocol (DLEP) Multi-Hop Forwarding Extension

This document defines an extension to the Dynamic Link Exchange Protocol (DLEP) that enables the reporting and control of multi-hop forwarding by DLEP-capable modems.

RFC86282019-08-01

OAuth 2.0 Device Authorization Grant

OAuth 2.0 Device Authorization Grant

The OAuth 2.0 device authorization grant is designed for Internet- connected devices that either lack a browser to perform a user-agent- based authorization or are input constrained to the extent that requiring the user to input text in order to authenticate during the authorization flow is impractical. It enables OAuth clients on such devices (like smart TVs, media consoles, digital picture frame…

RFC86272019-07-01

RTP Payload Format for Flexible Forward Error Correction (FEC)

RTP Payload Format for Flexible Forward Error Correction (FEC)

This document defines new RTP payload formats for the Forward Error Correction (FEC) packets that are generated by the non-interleaved and interleaved parity codes from source media encapsulated in RTP. These parity codes are systematic codes (Flexible FEC, or "FLEX FEC"), where a number of FEC repair packets are generated from a set of source packets from one or more source RTP streams. These FEC…

RFC86252019-08-01

Ethernet Traffic Parameters with Availability Information

Ethernet Traffic Parameters with Availability Information

A packet-switching network may contain links with variable bandwidths (e.g., copper and radio). The bandwidth of such links is sensitive to the external environment (e.g., climate). Availability is typically used to describe these links when doing network planning. This document introduces an optional Bandwidth Availability TLV in RSVP-TE signaling. This extension can be used to set up a GMPLS Lab…

RFC86242019-06-01

Algorithm Implementation Requirements and Usage Guidance for DNSSEC

Algorithm Implementation Requirements and Usage Guidance for DNSSEC

The DNSSEC protocol makes use of various cryptographic algorithms in order to provide authentication of DNS data and proof of nonexistence. To ensure interoperability between DNS resolvers and DNS authoritative servers, it is necessary to specify a set of algorithm implementation requirements and usage guidelines to ensure that there is at least one algorithm that all implementations support. This…

RFC86232019-06-01

Stateful Path Computation Element (PCE) Protocol Extensions for Usage with Point-to-Multipoint TE Label Switched Paths (LSPs)

Stateful Path Computation Element (PCE) Protocol Extensions for Usage with Point-to-Multipoint TE Label Switched Paths (LSPs)

The Path Computation Element (PCE) has been identified as an appropriate technology for the determination of the paths of point- to-multipoint (P2MP) TE Label Switched Paths (LSPs). This document provides extensions required for the Path Computation Element Communication Protocol (PCEP) so as to enable the usage of a stateful PCE capability in supporting P2MP TE LSPs.

RFC86222019-06-01

A Lower-Effort Per-Hop Behavior (LE PHB) for Differentiated Services

A Lower-Effort Per-Hop Behavior (LE PHB) for Differentiated Services

This document specifies properties and characteristics of a Lower- Effort Per-Hop Behavior (LE PHB). The primary objective of this LE PHB is to protect Best-Effort (BE) traffic (packets forwarded with the default PHB) from LE traffic in congestion situations, i.e., when resources become scarce, BE traffic has precedence over LE traffic and may preempt it. Alternatively, packets forwarded by the LE…

RFC86212019-08-01

The JSON Meta Application Protocol (JMAP) for Mail

The JSON Meta Application Protocol (JMAP) for Mail

This document specifies a data model for synchronising email data with a server using the JSON Meta Application Protocol (JMAP). Clients can use this to efficiently search, access, organise, and send messages, and to get push notifications for fast resynchronisation when new messages are delivered or a change is made in another client.

RFC86202019-07-01

The JSON Meta Application Protocol (JMAP)

The JSON Meta Application Protocol (JMAP)

This document specifies a protocol for clients to efficiently query, fetch, and modify JSON-based data objects, with support for push notification of changes and fast resynchronisation and for out-of- band binary data upload/download.

RFC86192019-06-01

Algorithm Identifiers for the HMAC-based Extract-and-Expand Key Derivation Function (HKDF)

Algorithm Identifiers for the HMAC-based Extract-and-Expand Key Derivation Function (HKDF)

RFC 5869 specifies the HMAC-based Extract-and-Expand Key Derivation Function (HKDF) algorithm. This document assigns algorithm identifiers to the HKDF algorithm when used with three common one-way hash functions.

RFC86182019-09-01

Compacted-DNS (C-DNS): A Format for DNS Packet Capture

Compacted-DNS (C-DNS): A Format for DNS Packet Capture

This document describes a data representation for collections of DNS messages. The format is designed for efficient storage and transmission of large packet captures of DNS traffic; it attempts to minimize the size of such packet capture files but retain the full DNS message contents along with the most useful transport metadata. It is intended to assist with the development of DNS traffic- monito…

RFC86172019-07-01

The Authenticated Received Chain (ARC) Protocol

The Authenticated Received Chain (ARC) Protocol

The Authenticated Received Chain (ARC) protocol provides an authenticated "chain of custody" for a message, allowing each entity that handles the message to see what entities handled it before and what the message's authentication assessment was at each step in the handling. ARC allows Internet Mail Handlers to attach assertions of message authentication assessment to individual messages. As messa…

RFC86162019-06-01

Email Authentication for Internationalized Mail

Email Authentication for Internationalized Mail

Sender Policy Framework (SPF) (RFC 7208), DomainKeys Identified Mail (DKIM) (RFC 6376), and Domain-based Message Authentication, Reporting, and Conformance (DMARC) (RFC 7489) enable a domain owner to publish email authentication and policy information in the DNS. In internationalized email, domain names can occur both as U-labels and A-labels. This specification updates the SPF, DKIM, and DMARC sp…

RFC86152019-05-01

Well-Known Uniform Resource Identifiers (URIs)

Well-Known Uniform Resource Identifiers (URIs)

This memo defines a path prefix for "well-known locations", "/.well-known/", in selected Uniform Resource Identifier (URI) schemes. In doing so, it obsoletes RFC 5785 and updates the URI schemes defined in RFC 7230 to reserve that space. It also updates RFC 7595 to track URI schemes that support well-known URIs in their registry.

RFC86142019-06-01

Updated Processing of Control Flags for BGP Virtual Private LAN Service (VPLS)

Updated Processing of Control Flags for BGP Virtual Private LAN Service (VPLS)

This document updates the meaning of the Control Flags field in the "Layer2 Info Extended Community" used for BGP Virtual Private LAN Service (VPLS) Network Layer Reachability Information (NLRI) as defined in RFC 4761. This document updates RFC 4761.

RFC86132019-07-01

Object Security for Constrained RESTful Environments (OSCORE)

Object Security for Constrained RESTful Environments (OSCORE)

This document defines Object Security for Constrained RESTful Environments (OSCORE), a method for application-layer protection of the Constrained Application Protocol (CoAP), using CBOR Object Signing and Encryption (COSE). OSCORE provides end-to-end protection between endpoints communicating using CoAP or CoAP-mappable HTTP. OSCORE is designed for constrained nodes and networks supporting a range…