⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC81582017-12-01

IP Flow Information Export (IPFIX) Information Elements for Logging NAT Events

IP Flow Information Export (IPFIX) Information Elements for Logging NAT Events

Network operators require NAT devices to log events like creation and deletion of translations and information about the resources that the NAT device is managing. In many cases, the logs are essential to identify an attacker or a host that was used to launch malicious attacks and for various other purposes of accounting. Since there is no standard way of logging this information, different NAT de…

RFC81572017-05-01

Huawei's GRE Tunnel Bonding Protocol

Huawei's GRE Tunnel Bonding Protocol

There is an emerging demand for solutions that provide redundancy and load-sharing across wired and cellular links from a single Service Provider, so that a single subscriber is provided with bonded access to heterogeneous connections at the same time. In this document, GRE (Generic Routing Encapsulation) Tunnel Bonding is specified as an enabling approach for bonded access to a wired and a wirele…

RFC81562017-06-01

DHCPv6 Failover Protocol

DHCPv6 Failover Protocol

DHCPv6 as defined in "Dynamic Host Configuration Protocol for IPv6 (DHCPv6)" (RFC 3315) does not offer server redundancy. This document defines a protocol implementation to provide DHCPv6 failover, a mechanism for running two servers with the capability for either server to take over clients' leases in case of server failure or network partition. It meets the requirements for DHCPv6 failover detai…

RFC81552017-04-01

Traversal Using Relays around NAT (TURN) Server Auto Discovery

Traversal Using Relays around NAT (TURN) Server Auto Discovery

Current Traversal Using Relays around NAT (TURN) server discovery mechanisms are relatively static and limited to explicit configuration. These are usually under the administrative control of the application or TURN service provider, and not the enterprise, ISP, or the network in which the client is located. Enterprises and ISPs wishing to provide their own TURN servers need auto-discovery mechani…

RFC81542017-05-01

Parallel NFS (pNFS) Small Computer System Interface (SCSI) Layout

Parallel NFS (pNFS) Small Computer System Interface (SCSI) Layout

The Parallel Network File System (pNFS) allows a separation between the metadata (onto a metadata server) and data (onto a storage device) for a file. The Small Computer System Interface (SCSI) layout type is defined in this document as an extension to pNFS to allow the use of SCSI-based block storage devices.

RFC81532017-04-01

Digital Preservation Considerations for the RFC Series

Digital Preservation Considerations for the RFC Series

The RFC Editor is both the publisher and the archivist for the RFC Series. This document applies specifically to the archivist role of the RFC Editor. It provides guidance on when and how to preserve RFCs and describes the tools required to view or re-create RFCs as necessary. This document also highlights gaps in the current process and suggests compromises to balance cost with best practice.

RFC81522017-07-01

CBOR Object Signing and Encryption (COSE)

CBOR Object Signing and Encryption (COSE)

Concise Binary Object Representation (CBOR) is a data format designed for small code size and small message size. There is a need for the ability to have basic security services defined for this data format. This document defines the CBOR Object Signing and Encryption (COSE) protocol. This specification describes how to create and process signatures, message authentication codes, and encryption us…

RFC81512017-05-01

Use Cases for Data Center Network Virtualization Overlay Networks

Use Cases for Data Center Network Virtualization Overlay Networks

This document describes Network Virtualization over Layer 3 (NVO3) use cases that can be deployed in various data centers and serve different data-center applications.

RFC81502017-04-01

MPLS Transport Profile Linear Protection MIB

MPLS Transport Profile Linear Protection MIB

This memo defines a portion of the Management Information Base (MIB) for use with network management protocols. In particular, it defines objects for managing Multiprotocol Label Switching - Transport Profile (MPLS-TP) linear protection.

RFC81492017-04-01

RSVP Extensions for Reoptimization of Loosely Routed Point-to-Multipoint Traffic Engineering Label Switched Paths (LSPs)

RSVP Extensions for Reoptimization of Loosely Routed Point-to-Multipoint Traffic Engineering Label Switched Paths (LSPs)

The reoptimization of a Point-to-Multipoint (P2MP) Traffic Engineering (TE) Label Switched Path (LSP) may be triggered based on the need to reoptimize an individual source-to-leaf (S2L) sub-LSP or a set of S2L sub-LSPs, both using the Sub-Group-based reoptimization method, or the entire P2MP-TE LSP tree using the Make-Before-Break (MBB) method. This document discusses the application of the existi…

RFC81482017-05-01

Next-Generation Vehicle-Initiated Emergency Calls

Next-Generation Vehicle-Initiated Emergency Calls

This document describes how to use IP-based emergency services mechanisms to support the next generation of emergency calls placed by vehicles (automatically in the event of a crash or serious incident, or manually invoked by a vehicle occupant) and conveying vehicle, sensor, and location data related to the crash or incident. Such calls are often referred to as "Automatic Crash Notification" (ACN…

RFC81472017-05-01

Next-Generation Pan-European eCall

Next-Generation Pan-European eCall

This document describes how to use IP-based emergency services mechanisms to support the next generation of the Pan-European in-vehicle emergency call service defined under the eSafety initiative of the European Commission (generally referred to as "eCall"). eCall is a standardized and mandated system for a special form of emergency calls placed by vehicles, providing real-time communications and …

RFC81462017-04-01

Adding Support for Salted Password Databases to EAP-pwd

Adding Support for Salted Password Databases to EAP-pwd

EAP-pwd is an Extensible Authentication Protocol (EAP) method that utilizes a shared password for authentication using a technique that is resistant to dictionary attacks. It includes support for raw keys and double hashing of a password in the style of Microsoft Challenge Handshake Authentication Protocol version 2 (MSCHAPv2), but it does not include support for salted passwords. There are many e…

RFC81452017-04-01

Signaling Trust Anchor Knowledge in DNS Security Extensions (DNSSEC)

Signaling Trust Anchor Knowledge in DNS Security Extensions (DNSSEC)

The DNS Security Extensions (DNSSEC) were developed to provide origin authentication and integrity protection for DNS data by using digital signatures. These digital signatures can be verified by building a chain of trust starting from a trust anchor and proceeding down to a particular node in the DNS. This document specifies two different ways for validating resolvers to signal to a server which …

RFC81442017-04-01

Use of the Prefer Header Field in Web Distributed Authoring and Versioning (WebDAV)

Use of the Prefer Header Field in Web Distributed Authoring and Versioning (WebDAV)

This document defines how the Prefer header field (RFC 7240) can be used by a Web Distributed Authoring and Versioning (WebDAV) client to request that certain behaviors be employed by a server while constructing a response to a request. Furthermore, it defines the new "depth-noroot" preference.

RFC81432017-04-01

Using Transport Layer Security (TLS) with Network News Transfer Protocol (NNTP)

Using Transport Layer Security (TLS) with Network News Transfer Protocol (NNTP)

This document provides recommendations for improving the security of the Network News Transfer Protocol (NNTP) when using Transport Layer Security (TLS). It modernizes the NNTP usage of TLS to be consistent with TLS best current practices. This document updates RFC 4642.

RFC81422017-04-01

GeoJSON Text Sequences

GeoJSON Text Sequences

This document describes the GeoJSON text sequence format and "application/geo+json-seq" media type. This format is based on JavaScript Object Notation (JSON) text sequences and GeoJSON, and it makes arbitrarily large geographic datasets incrementally parseable without restricting the form of GeoJSON texts within a sequence.

RFC81412017-04-01

Uniform Resource Names (URNs)

Uniform Resource Names (URNs)

A Uniform Resource Name (URN) is a Uniform Resource Identifier (URI) that is assigned under the "urn" URI scheme and a particular URN namespace, with the intent that the URN will be a persistent, location-independent resource identifier. With regard to URN syntax, this document defines the canonical syntax for URNs (in a way that is consistent with URI syntax), specifies methods for determining UR…

RFC81402017-04-01

The Arte of ASCII: Or, An True and Accurate Representation of an Menagerie of Thynges Fabulous and Wonderful in Ye Forme of Character

The Arte of ASCII: Or, An True and Accurate Representation of an Menagerie of Thynges Fabulous and Wonderful in Ye Forme of Character

Ever since Gutenberg discovered and patented ASCII and the corresponding "Courier New" font with its now-famous "ten" point size, artisans and artificers have striven to represent their views of the world in print. Similarly, starting from Darwin's discovery of the hippogriff and his subsequent registration of the creature as an International Trade Mark, men (and some women) have struggled to cata…

RFC81392017-06-01

Transparent Interconnection of Lots of Links (TRILL): Appointed Forwarders

Transparent Interconnection of Lots of Links (TRILL): Appointed Forwarders

TRILL (Transparent Interconnection of Lots of Links) supports multi-access LAN (Local Area Network) links where a single link can have multiple end stations and TRILL switches attached. Where multiple TRILL switches are attached to a link, native traffic to and from end stations on that link is handled by a subset of those TRILL switches called "Appointed Forwarders" as originally specified in RFC…

RFC81382017-04-01

IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) Routing Header

IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) Routing Header

This specification introduces a new IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) dispatch type for use in 6LoWPAN route-over topologies, which initially covers the needs of Routing Protocol for Low-Power and Lossy Networks (RPL) data packet compression (RFC 6550). Using this dispatch type, this specification defines a method to compress the RPL Option (RFC 6553) information and Rou…

RFC81372017-05-01

IEEE 802.15.4 Information Element for the IETF

IEEE 802.15.4 Information Element for the IETF

IEEE Std 802.15.4 defines Information Elements (IEs) that can be used to extend 802.15.4 in an interoperable manner. The IEEE 802.15 Assigned Numbers Authority (ANA) manages the registry of the Information Elements. This document formulates a request for ANA to allocate a number from that registry for the IETF and describes how the IE is formatted to provide subtypes.

RFC81362017-04-01

Additional Transition Functionality for IPv6

Additional Transition Functionality for IPv6

This document proposes an additional mechanism intended to both facilitate transition from IPv4 to IPv6 and improve the latter's security and privacy.

RFC81352017-04-01

Complex Addressing in IPv6

Complex Addressing in IPv6

The 128-bit length of IPv6 addresses (RFC 4291) allows for new and innovative address schemes that can adapt to the challenges of today's complex network world. It also allows for new and improved security measures and supports advanced cloud computing challenges.

RFC81342017-05-01

Management Incident Lightweight Exchange (MILE) Implementation Report

Management Incident Lightweight Exchange (MILE) Implementation Report

This document is a collection of implementation reports from vendors, consortiums, and researchers who have implemented one or more of the standards published from the IETF INCident Handling (INCH) and Management Incident Lightweight Exchange (MILE) working groups.

RFC81332017-03-01

The Security Evaluated Standardized Password-Authenticated Key Exchange (SESPAKE) Protocol

The Security Evaluated Standardized Password-Authenticated Key Exchange (SESPAKE) Protocol

This document describes the Security Evaluated Standardized Password- Authenticated Key Exchange (SESPAKE) protocol. The SESPAKE protocol provides password-authenticated key exchange for usage in systems for protection of sensitive information. The security proofs of the protocol were made for situations involving an active adversary in the channel, including man-in-the-middle (MitM) attacks and a…

RFC81322017-04-01

PATCH and FETCH Methods for the Constrained Application Protocol (CoAP)

PATCH and FETCH Methods for the Constrained Application Protocol (CoAP)

The methods defined in RFC 7252 for the Constrained Application Protocol (CoAP) only allow access to a complete resource, not to parts of a resource. In case of resources with larger or complex data, or in situations where resource continuity is required, replacing or requesting the whole resource is undesirable. Several applications using CoAP need to access parts of the resources. This specifica…

RFC81312017-03-01

RSVP-TE Signaling Procedure for End-to-End GMPLS Restoration and Resource Sharing

RSVP-TE Signaling Procedure for End-to-End GMPLS Restoration and Resource Sharing

In non-packet transport networks, there are requirements where the Generalized Multiprotocol Label Switching (GMPLS) end-to-end recovery scheme needs to employ a restoration Label Switched Path (LSP) while keeping resources for the working and/or protecting LSPs reserved in the network after the failure occurs. This document reviews how the LSP association is to be provided using Resource Reservat…

RFC81302017-03-01

RTP Payload Format for the Mixed Excitation Linear Prediction Enhanced (MELPe) Codec

RTP Payload Format for the Mixed Excitation Linear Prediction Enhanced (MELPe) Codec

This document describes the RTP payload format for the Mixed Excitation Linear Prediction Enhanced (MELPe) speech coder. MELPe's three different speech encoding rates and sample frame sizes are supported. Comfort noise procedures and packet loss concealment are described in detail.

RFC81292017-03-01

Authentication Indicator in Kerberos Tickets

Authentication Indicator in Kerberos Tickets

This document updates RFC 4120, as it specifies an extension in the Kerberos protocol. It defines a new authorization data type, AD-AUTHENTICATION-INDICATOR. The purpose of introducing this data type is to include an indicator of the strength of a client's authentication in service tickets so that application services can use it as an input into policy decisions.