⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC98202025-09-01

Authentication Service Based on the Extensible Authentication Protocol (EAP) for Use with the Constrained Application Protocol (CoAP)

Authentication Service Based on the Extensible Authentication Protocol (EAP) for Use with the Constrained Application Protocol (CoAP)

This document specifies an authentication service that uses the Constrained Application Protocol (CoAP) as a transport method to carry the Extensible Authentication Protocol (EAP). As such, it defines an EAP lower layer based on CoAP called "CoAP-EAP". One of the main goals is to authenticate a CoAP-enabled Internet of Things (IoT) device (EAP peer) that intends to join a security domain managed b…

RFC98192025-07-01

Argument Signaling for BGP Services in Segment Routing over IPv6 (SRv6)

Argument Signaling for BGP Services in Segment Routing over IPv6 (SRv6)

RFC 9252 defines procedures and messages for BGP overlay services for Segment Routing over IPv6 (SRv6), including Layer 3 Virtual Private Network (L3VPN), Ethernet VPN (EVPN), and global Internet routing. This document updates RFC 9252 and provides more detailed specifications for the signaling and processing of SRv6 Segment Identifier advertisements for BGP overlay service routes associated with …

RFC98182025-07-01

DHCPv6 Prefix Delegation on IPv6 Customer Edge (CE) Routers in LANs

DHCPv6 Prefix Delegation on IPv6 Customer Edge (CE) Routers in LANs

This document defines requirements for IPv6 Customer Edge (CE) routers to support DHCPv6 Prefix Delegation for distributing available prefixes to LAN devices that were delegated to an IPv6 CE router. This document updates RFC 7084.

RFC98172025-08-01

Use Cases for In-Network Computing

Use Cases for In-Network Computing

Computing in the Network (COIN) comes with the prospect of deploying processing functionality on networking devices such as switches and network interface cards. While such functionality can be beneficial, it has to be carefully placed into the context of the general Internet communication, and it needs to be clearly identified where and how those benefits apply. This document presents some use ca…

RFC98162025-07-01

Usage and Applicability of BGP Link State (BGP-LS) Shortest Path First (SPF) Routing in Data Centers

Usage and Applicability of BGP Link State (BGP-LS) Shortest Path First (SPF) Routing in Data Centers

This document discusses the usage and applicability of BGP Link State (BGP-LS) Shortest Path First (SPF) extensions in data center networks utilizing Clos or Fat Tree topologies. The document is intended to provide simplified guidance for the deployment of BGP-LS SPF extensions.

RFC98152025-07-01

BGP Link State (BGP-LS) Shortest Path First (SPF) Routing

BGP Link State (BGP-LS) Shortest Path First (SPF) Routing

Many Massively Scaled Data Centers (MSDCs) have converged on simplified Layer 3 (L3) routing. Furthermore, requirements for operational simplicity have led many of these MSDCs to converge on BGP as their single routing protocol for both fabric routing and Data Center Interconnect (DCI) routing. This document describes extensions to BGP for use with BGP Link State (BGP-LS) distribution and the Shor…

RFC98142025-07-01

Use of the SLH-DSA Signature Algorithm in the Cryptographic Message Syntax (CMS)

Use of the SLH-DSA Signature Algorithm in the Cryptographic Message Syntax (CMS)

SLH-DSA is a stateless hash-based signature algorithm. This document specifies the conventions for using the SLH-DSA signature algorithm with the Cryptographic Message Syntax (CMS). In addition, the algorithm identifier and public key syntax are provided.

RFC98132025-07-01

Operational Considerations for Using TLS Pre-Shared Keys (TLS-PSKs) with RADIUS

Operational Considerations for Using TLS Pre-Shared Keys (TLS-PSKs) with RADIUS

This document provides implementation and operational considerations for using TLS Pre-Shared Keys (TLS-PSKs) with RADIUS/TLS (RFC 6614) and RADIUS/DTLS (RFC 7360). The purpose of the document is to help smooth the operational transition from the use of RADIUS/UDP to RADIUS/TLS.

RFC98122025-10-01

Clarification of IPv6 Address Allocation Policy

Clarification of IPv6 Address Allocation Policy

This document specifies the approval process for changes to the "IPv6 Address Space" registry. It also updates RFC 7249.

RFC98112025-07-01

Internet X.509 Public Key Infrastructure -- HTTP Transfer for the Certificate Management Protocol (CMP)

Internet X.509 Public Key Infrastructure -- HTTP Transfer for the Certificate Management Protocol (CMP)

This document describes how to layer the Certificate Management Protocol (CMP) over HTTP. It includes the updates to RFC 6712 specified in Section 3 of RFC 9480; these updates introduce CMP URIs using a well-known prefix. It obsoletes RFC 6712; and, together with RFC 9810, it also obsoletes RFC 9480.

RFC98102025-07-01

Internet X.509 Public Key Infrastructure -- Certificate Management Protocol (CMP)

Internet X.509 Public Key Infrastructure -- Certificate Management Protocol (CMP)

This document describes the Internet X.509 Public Key Infrastructure (PKI) Certificate Management Protocol (CMP). Protocol messages are defined for X.509v3 certificate creation and management. CMP provides interactions between client systems and PKI components such as a Registration Authority (RA) and a Certification Authority (CA). This document adds support for management of certificates contain…

RFC98092025-07-01

X.509 Certificate Extended Key Usage (EKU) for Configuration, Updates, and Safety-Critical Communication

X.509 Certificate Extended Key Usage (EKU) for Configuration, Updates, and Safety-Critical Communication

RFC 5280 defines the Extended Key Usage (EKU) extension and specifies several extended key purpose identifiers (KeyPurposeIds) for use with that extension in X.509 certificates. This document defines KeyPurposeIds for general-purpose and trust anchor configuration files, for software and firmware update packages, and for safety-critical communication to be included in the EKU extension of X.509 v3…

RFC98082025-07-01

Content Delivery Network Interconnection (CDNI) Capacity Capability Advertisement Extensions

Content Delivery Network Interconnection (CDNI) Capacity Capability Advertisement Extensions

This specification defines a set of additional Capability Objects that provide information about current downstream CDN (dCDN) utilization and specified usage limits to the delegating upstream CDN (uCDN) in order to inform traffic delegation decisions. This document supplements the CDNI Capability Objects, defined in RFC 8008 as part of the Footprint & Capabilities Advertisement Interface (FCI), w…

RFC98072025-07-01

The OPAQUE Augmented Password-Authenticated Key Exchange (aPAKE) Protocol

The OPAQUE Augmented Password-Authenticated Key Exchange (aPAKE) Protocol

This document describes the OPAQUE protocol, an Augmented (or Asymmetric) Password-Authenticated Key Exchange (aPAKE) protocol that supports mutual authentication in a client-server setting without reliance on PKI and with security against pre-computation attacks upon server compromise. In addition, the protocol provides forward secrecy and the ability to hide the password from the server, even du…

RFC98062025-06-01

Updates to SIP-Based Media Recording (SIPREC) to Correct Metadata Media Type

Updates to SIP-Based Media Recording (SIPREC) to Correct Metadata Media Type

The SIP-based Media Recording (SIPREC) protocol is defined by both "Session Initiation Protocol (SIP) Recording Metadata" (RFC 7865) and "Session Recording Protocol" (RFC 7866). Unfortunately, both RFCs contradict each other regarding how recording metadata is to be labeled. In addition, neither RFC registered the new media type. This document updates RFC 7866 to align with RFC 7865 when labeling …

RFC98052025-06-01

Deprecation of the IPv6 Router Alert Option for New Protocols

Deprecation of the IPv6 Router Alert Option for New Protocols

This document deprecates the IPv6 Router Alert option. Protocols that use the IPv6 Router Alert option may continue to do so, even in future versions. However, new protocols that are standardized in the future must not use the IPv6 Router Alert option. This document updates RFC 2711.

RFC98042025-06-01

Simple Public Key Infrastructure (SPKI) S-Expressions

Simple Public Key Infrastructure (SPKI) S-Expressions

This memo specifies the data structure representation that was devised to support Simple Public Key Infrastructure (SPKI) certificates, as detailed in RFC 2692, with the intent that it be more widely applicable. It has been and is being used elsewhere. There are multiple implementations in a variety of programming languages. Uses of this representation are referred to in this document as "S-expres…

RFC98032025-06-01

Extensible Provisioning Protocol (EPP) Mapping for DNS Time-to-Live (TTL) Values

Extensible Provisioning Protocol (EPP) Mapping for DNS Time-to-Live (TTL) Values

This document describes an extension to the Extensible Provisioning Protocol (EPP) that allows EPP clients to manage the Time-to-Live (TTL) value for domain name delegation records.

RFC98022025-06-01

Use of the HSS and XMSS Hash-Based Signature Algorithms in Internet X.509 Public Key Infrastructure

Use of the HSS and XMSS Hash-Based Signature Algorithms in Internet X.509 Public Key Infrastructure

This document specifies algorithm identifiers and ASN.1 encoding formats for the following stateful Hash-Based Signature (HBS) schemes: Hierarchical Signature System (HSS), eXtended Merkle Signature Scheme (XMSS), and XMSS^MT (a multi-tree variant of XMSS). This specification applies to the Internet X.509 Public Key Infrastructure (PKI) when digital signatures are used to sign certificates and cer…

RFC98012025-07-01

Private Line Emulation over Packet Switched Networks

Private Line Emulation over Packet Switched Networks

This document expands the applicability of Virtual Private Wire Service (VPWS) bit-stream payloads beyond Time Division Multiplexing (TDM) signals and provides pseudowire transport with complete signal transparency over Packet Switched Networks (PSNs).

RFC98002025-06-01

Compressed SRv6 Segment List Encoding

Compressed SRv6 Segment List Encoding

Segment Routing over IPv6 (SRv6) is the instantiation of Segment Routing (SR) on the IPv6 data plane. This document specifies new flavors for the SRv6 endpoint behaviors defined in RFC 8986, which enable the compression of an SRv6 segment list. Such compression significantly reduces the size of the SRv6 encapsulation needed to steer packets over long segment lists. This document updates RFC 8754 b…

RFC97992025-06-01

Automated Certificate Management Environment (ACME) Extensions for ".onion" Special-Use Domain Names

Automated Certificate Management Environment (ACME) Extensions for ".onion" Special-Use Domain Names

This document defines extensions to the Automated Certificate Management Environment (ACME) to allow for the automatic issuance of certificates to Tor Hidden Services (".onion" Special-Use Domain Names).

RFC97982025-06-01

PIM Join/Prune Attributes for Locator/ID Separation Protocol (LISP) Environments Using Underlay Multicast

PIM Join/Prune Attributes for Locator/ID Separation Protocol (LISP) Environments Using Underlay Multicast

This document specifies an update to the Receiver RLOC (Routing Locator) field of the PIM Join/Prune attribute that supports the construction of multicast distribution trees where the source and receivers are located in different Locator/ID Separation Protocol (LISP) sites and are connected using underlay IP multicast. This attribute allows the receiver site to signal the underlay multicast group …

RFC97972025-06-01

Randomized and Changing Media Access Control (MAC) Addresses: Context, Network Impacts, and Use Cases

Randomized and Changing Media Access Control (MAC) Addresses: Context, Network Impacts, and Use Cases

To limit the privacy issues created by the association between a device, its traffic, its location, and its user in IEEE 802 networks, client vendors and client OS vendors have started implementing Media Access Control (MAC) address randomization. This technology is particularly important in Wi-Fi networks (defined in IEEE 802.11) due to the over-the-air medium and device mobility. When such rando…

RFC97962025-07-01

SIP Call-Info Parameters for Rich Call Data

SIP Call-Info Parameters for Rich Call Data

This document specifies a usage of the SIP Call-Info header field that incorporates Rich Call Data (RCD) associated with the identity of the originating party in order to provide to the terminating party a description of the caller (including details about the reason for the session). RCD includes information about the caller beyond the telephone number (such as a calling name, logo, photo, or jCa…

RFC97952025-07-01

Personal Assertion Token (PASSporT) Extension for Rich Call Data

Personal Assertion Token (PASSporT) Extension for Rich Call Data

This document extends Personal Assertion Token (PASSporT), a token for conveying cryptographically signed call information about personal communications, to include rich metadata about a call and caller that can be signed and integrity protected, transmitted, and subsequently rendered to the called party. This framework is intended to include and extend caller- and call-specific information beyond…

RFC97942025-06-01

Terminology for Post-Quantum Traditional Hybrid Schemes

Terminology for Post-Quantum Traditional Hybrid Schemes

One aspect of the transition to post-quantum algorithms in cryptographic protocols is the development of hybrid schemes that incorporate both post-quantum and traditional asymmetric algorithms. This document defines terminology for such schemes. It is intended to be used as a reference and, hopefully, to ensure consistency and clarity across different protocols, standards, and organisations.

RFC97932025-06-01

BGP Extensions for Bit Index Explicit Replication (BIER)

BGP Extensions for Bit Index Explicit Replication (BIER)

Bit Index Explicit Replication (BIER) is a multicast forwarding architecture that doesn't require an explicit tree-building protocol and doesn't require intermediate routers to maintain per-tree multicast states. Some BIER-specific information and states, which are only in proportion to the number of BIER routers but not per-tree, do need to be advertised, calculated, and maintained. This document…

RFC97922025-06-01

Prefix Flag Extension for OSPFv2 and OSPFv3

Prefix Flag Extension for OSPFv2 and OSPFv3

Each OSPF prefix can be advertised with an 8-bit field to indicate specific properties of that prefix. However, all the OSPFv3 Prefix Options bits have already been assigned, and only a few bits remain unassigned in the Flags field of the OSPFv2 Extended Prefix TLV. This document solves this problem by defining a variable-length Prefix Extended Flags sub-TLV for OSPF. This sub-TLV is applicable to…

RFC97912025-07-01

Use Cases for MPLS Network Action Indicators and Ancillary Data

Use Cases for MPLS Network Action Indicators and Ancillary Data

This document presents use cases that have a common feature that may be addressed by encoding network action indicators and associated ancillary data within MPLS packets. There is community interest in extending the MPLS data plane to carry such indicators and ancillary data to address these use cases. The use cases described in this document are not an exhaustive set but rather the ones that have…