⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC76172015-09-01

The 'Basic' HTTP Authentication Scheme

The 'Basic' HTTP Authentication Scheme

This document defines the "Basic" Hypertext Transfer Protocol (HTTP) authentication scheme, which transmits credentials as user-id/ password pairs, encoded using Base64.

RFC76162015-09-01

HTTP Digest Access Authentication

HTTP Digest Access Authentication

The Hypertext Transfer Protocol (HTTP) provides a simple challenge- response authentication mechanism that may be used by a server to challenge a client request and by a client to provide authentication information. This document defines the HTTP Digest Authentication scheme that can be used with the HTTP authentication mechanism.

RFC76152015-09-01

HTTP Authentication-Info and Proxy-Authentication-Info Response Header Fields

HTTP Authentication-Info and Proxy-Authentication-Info Response Header Fields

This specification defines the "Authentication-Info" and "Proxy- Authentication-Info" response header fields for use in Hypertext Transfer Protocol (HTTP) authentication schemes that need to return information once the client's authentication credentials have been accepted.

RFC76142015-08-01

Explicit Subscriptions for the REFER Method

Explicit Subscriptions for the REFER Method

The Session Initiation Protocol (SIP) REFER request, as defined by RFC 3515, triggers an implicit SIP-Specific Event Notification framework subscription. Conflating the start of the subscription with handling the REFER request makes negotiating SUBSCRIBE extensions impossible and complicates avoiding SIP dialog sharing. This document defines extensions to REFER that remove the implicit subscriptio…

RFC76132015-08-01

Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and Passwords

Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and Passwords

This document describes updated methods for handling Unicode strings representing usernames and passwords. The previous approach was known as SASLprep (RFC 4013) and was based on stringprep (RFC 3454). The methods specified in this document provide a more sustainable approach to the handling of internationalized usernames and passwords. The preparation, enforcement, and comparison of international…

RFC76122015-06-01

Lightweight Directory Access Protocol (LDAP): Schema for Printer Services

Lightweight Directory Access Protocol (LDAP): Schema for Printer Services

This document defines a schema, object classes, and attributes, for Printers and print services, for use with directories that support the Lightweight Directory Access Protocol (RFC 4510). This document is based on the Printer attributes listed in Appendix E of "Internet Printing Protocol/1.1: Model and Semantics" (RFC 2911). Additional Printer attributes are based on definitions in "Printer MIB v…

RFC76112015-08-01

BGP ACCEPT_OWN Community Attribute

BGP ACCEPT_OWN Community Attribute

Under certain conditions, it is desirable for a Border Gateway Protocol (BGP) route reflector to be able to modify the Route Target (RT) list of a Virtual Private Network (VPN) route that the route reflector distributes, enabling the route reflector to control how a route originated within one VPN Routing and Forwarding table (VRF) is imported into other VRFs. This technique works effectively as l…

RFC76102015-08-01

DHCPv6-Shield: Protecting against Rogue DHCPv6 Servers

DHCPv6-Shield: Protecting against Rogue DHCPv6 Servers

This document specifies a mechanism for protecting hosts connected to a switched network against rogue DHCPv6 servers. It is based on DHCPv6 packet filtering at the layer 2 device at which the packets are received. A similar mechanism has been widely deployed in IPv4 networks ('DHCP snooping'); hence, it is desirable that similar functionality be provided for IPv6 networks. This document specifies…

RFC76092015-08-01

IBM's Shared Memory Communications over RDMA (SMC-R) Protocol

IBM's Shared Memory Communications over RDMA (SMC-R) Protocol

This document describes IBM's Shared Memory Communications over RDMA (SMC-R) protocol. This protocol provides Remote Direct Memory Access (RDMA) communications to TCP endpoints in a manner that is transparent to socket applications. It further provides for dynamic discovery of partner RDMA capabilities and dynamic setup of RDMA connections, as well as transparent high availability and load balanci…

RFC76082015-07-01

IPv6 Prefix Length Recommendation for Forwarding

IPv6 Prefix Length Recommendation for Forwarding

IPv6 prefix length, as in IPv4, is a parameter conveyed and used in IPv6 routing and forwarding processes in accordance with the Classless Inter-domain Routing (CIDR) architecture. The length of an IPv6 prefix may be any number from zero to 128, although subnets using stateless address autoconfiguration (SLAAC) for address allocation conventionally use a /64 prefix. Hardware and software implement…

RFC76072015-08-01

Codification of AS 0 Processing

Codification of AS 0 Processing

This document updates RFC 4271 and proscribes the use of Autonomous System (AS) 0 in the Border Gateway Protocol (BGP) OPEN, AS_PATH, AS4_PATH, AGGREGATOR, and AS4_AGGREGATOR attributes in the BGP UPDATE message.

RFC76062015-08-01

Revised Error Handling for BGP UPDATE Messages

Revised Error Handling for BGP UPDATE Messages

According to the base BGP specification, a BGP speaker that receives an UPDATE message containing a malformed attribute is required to reset the session over which the offending attribute was received. This behavior is undesirable because a session reset would impact not only routes with the offending attribute but also other valid routes exchanged over the session. This document partially revises…

RFC76052015-08-01

Recommendations on Using Assigned Transport Port Numbers

Recommendations on Using Assigned Transport Port Numbers

This document provides recommendations to designers of application and service protocols on how to use the transport protocol port number space and when to request a port assignment from IANA. It provides designer guidance to requesters or users of port numbers on how to interact with IANA using the processes defined in RFC 6335; thus, this document complements (but does not update) that document.

RFC76042015-09-01

Comparison of Different NAT Traversal Techniques for Media Controlled by the Real-Time Streaming Protocol (RTSP)

Comparison of Different NAT Traversal Techniques for Media Controlled by the Real-Time Streaming Protocol (RTSP)

This document describes several Network Address Translator (NAT) traversal techniques that were considered to be used for establishing the RTP media flows controlled by the Real-Time Streaming Protocol (RTSP). Each technique includes a description of how it would be used, the security implications of using it, and any other deployment considerations it has. There are also discussions on how NAT tr…

RFC76032015-08-01

Energy Management (EMAN) Applicability Statement

Energy Management (EMAN) Applicability Statement

The objective of Energy Management (EMAN) is to provide an energy management framework for networked devices. This document presents the applicability of the EMAN information model in a variety of scenarios with cases and target devices. These use cases are useful for identifying requirements for the framework and MIBs. Further, we describe the relationship of the EMAN framework to other relevant …

RFC76022015-07-01

IS-IS Extended Sequence Number TLV

IS-IS Extended Sequence Number TLV

This document defines the Extended Sequence Number TLV to protect Intermediate System to Intermediate System (IS-IS) PDUs from replay attacks.

RFC76012015-08-01

Message Header Field for Indicating Message Authentication Status

Message Header Field for Indicating Message Authentication Status

This document specifies a message header field called Authentication- Results for use with electronic mail messages to indicate the results of message authentication efforts. Any receiver-side software, such as mail filters or Mail User Agents (MUAs), can use this header field to relay that information in a convenient and meaningful way to users or to make sorting and filtering decisions.

RFC76002015-07-01

IPv4 Residual Deployment via IPv6 - A Stateless Solution (4rd)

IPv4 Residual Deployment via IPv6 - A Stateless Solution (4rd)

This document specifies a stateless solution for service providers to progressively deploy IPv6-only network domains while still offering IPv4 service to customers. The solution's distinctive properties are that TCP/UDP IPv4 packets are valid TCP/UDP IPv6 packets during domain traversal and that IPv4 fragmentation rules are fully preserved end to end. Each customer can be assigned one public IPv4 …

RFC75992015-07-01

Mapping of Address and Port using Translation (MAP-T)

Mapping of Address and Port using Translation (MAP-T)

This document specifies the solution architecture based on "Mapping of Address and Port" stateless IPv6-IPv4 Network Address Translation (NAT64) for providing shared or non-shared IPv4 address connectivity to and across an IPv6 network.

RFC75982015-07-01

DHCPv6 Options for Configuration of Softwire Address and Port-Mapped Clients

DHCPv6 Options for Configuration of Softwire Address and Port-Mapped Clients

This document specifies DHCPv6 options, termed Softwire46 options, for the provisioning of Softwire46 Customer Edge (CE) devices. Softwire46 is a collective term used to refer to architectures based on the notion of IPv4 Address plus Port (A+P) for providing IPv4 connectivity across an IPv6 network.

RFC75972015-07-01

Mapping of Address and Port with Encapsulation (MAP-E)

Mapping of Address and Port with Encapsulation (MAP-E)

This document describes a mechanism for transporting IPv4 packets across an IPv6 network using IP encapsulation. It also describes a generic mechanism for mapping between IPv6 addresses and IPv4 addresses as well as transport-layer ports.

RFC75962015-07-01

Lightweight 4over6: An Extension to the Dual-Stack Lite Architecture

Lightweight 4over6: An Extension to the Dual-Stack Lite Architecture

Dual-Stack Lite (DS-Lite) (RFC 6333) describes an architecture for transporting IPv4 packets over an IPv6 network. This document specifies an extension to DS-Lite called "Lightweight 4over6", which moves the Network Address and Port Translation (NAPT) function from the centralized DS-Lite tunnel concentrator to the tunnel client located in the Customer Premises Equipment (CPE). This removes the re…

RFC75952015-06-01

Guidelines and Registration Procedures for URI Schemes

Guidelines and Registration Procedures for URI Schemes

This document updates the guidelines and recommendations, as well as the IANA registration processes, for the definition of Uniform Resource Identifier (URI) schemes. It obsoletes RFC 4395.

RFC75942015-09-01

A Framework for Large-Scale Measurement of Broadband Performance (LMAP)

A Framework for Large-Scale Measurement of Broadband Performance (LMAP)

Measuring broadband service on a large scale requires a description of the logical architecture and standardisation of the key protocols that coordinate interactions between the components. This document presents an overall framework for large-scale measurements. It also defines terminology for LMAP (Large-Scale Measurement of Broadband Performance).

RFC75932015-09-01

The eduroam Architecture for Network Roaming

The eduroam Architecture for Network Roaming

This document describes the architecture of the eduroam service for federated (wireless) network access in academia. The combination of IEEE 802.1X, the Extensible Authentication Protocol (EAP), and RADIUS that is used in eduroam provides a secure, scalable, and deployable service for roaming network access. The successful deployment of eduroam over the last decade in the educational sector may se…

RFC75922015-07-01

OAuth 2.0 Dynamic Client Registration Management Protocol

OAuth 2.0 Dynamic Client Registration Management Protocol

This specification defines methods for management of OAuth 2.0 dynamic client registrations for use cases in which the properties of a registered client may need to be changed during the lifetime of the client. Not all authorization servers supporting dynamic client registration will support these management methods.

RFC75912015-07-01

OAuth 2.0 Dynamic Client Registration Protocol

OAuth 2.0 Dynamic Client Registration Protocol

This specification defines mechanisms for dynamically registering OAuth 2.0 clients with authorization servers. Registration requests send a set of desired client metadata values to the authorization server. The resulting registration responses return a client identifier to use at the authorization server and the client metadata values registered for the client. The client can then use this regist…

RFC75902015-06-01

Use of Transport Layer Security (TLS) in the Extensible Messaging and Presence Protocol (XMPP)

Use of Transport Layer Security (TLS) in the Extensible Messaging and Presence Protocol (XMPP)

This document provides recommendations for the use of Transport Layer Security (TLS) in the Extensible Messaging and Presence Protocol (XMPP). This document updates RFC 6120.

RFC75892015-06-01

Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 Authentication

Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 Authentication

The Network Configuration Protocol (NETCONF) provides mechanisms to install, manipulate, and delete the configuration of network devices. This document describes how to use the Transport Layer Security (TLS) protocol with mutual X.509 authentication to secure the exchange of NETCONF messages. This revision of RFC 5539 documents the new message framing used by NETCONF 1.1 and it obsoletes RFC 5539.

RFC75882015-07-01

A Widely Deployed Solution to the Generic Routing Encapsulation (GRE) Fragmentation Problem

A Widely Deployed Solution to the Generic Routing Encapsulation (GRE) Fragmentation Problem

This memo describes how many vendors have solved the Generic Routing Encapsulation (GRE) fragmentation problem. The solution described herein is configurable. It is widely deployed on the Internet in its default configuration.