⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC75572015-05-01

Extension Mechanism for the Babel Routing Protocol

Extension Mechanism for the Babel Routing Protocol

This document defines the encoding of extensions to the Babel routing protocol, as specified in RFC 6126.

RFC75562015-06-01

Multiple Provisioning Domain Architecture

Multiple Provisioning Domain Architecture

This document is a product of the work of the Multiple Interfaces Architecture Design team. It outlines a solution framework for some of the issues experienced by nodes that can be attached to multiple networks simultaneously. The framework defines the concept of a Provisioning Domain (PvD), which is a consistent set of network configuration information. PvD-aware nodes learn PvD-specific informat…

RFC75552015-06-01

Proxy MPLS Echo Request

Proxy MPLS Echo Request

This document defines a means of remotely initiating Multiprotocol Label Switched Protocol (MPLS) Pings on Label Switched Paths. An MPLS Proxy Ping Request is sent to any Label Switching Router along a Label Switched Path. The primary motivations for this facility are first to limit the number of messages and related processing when using LSP Ping in large Point-to-Multipoint LSPs, and second to e…

RFC75542015-05-01

Using IEEE 802.15.4e Time-Slotted Channel Hopping (TSCH) in the Internet of Things (IoT): Problem Statement

Using IEEE 802.15.4e Time-Slotted Channel Hopping (TSCH) in the Internet of Things (IoT): Problem Statement

This document describes the environment, problem statement, and goals for using the Time-Slotted Channel Hopping (TSCH) Medium Access Control (MAC) protocol of IEEE 802.14.4e in the context of Low-Power and Lossy Networks (LLNs). The set of goals enumerated in this document form an initial set only.

RFC75532015-06-01

The Uniform Resource Identifier (URI) DNS Resource Record

The Uniform Resource Identifier (URI) DNS Resource Record

This document describes the already registered DNS resource record (RR) type, called the Uniform Resource Identifier (URI) RR, that is used for publishing mappings from hostnames to URIs.

RFC75522015-06-01

Updates to LDP for IPv6

Updates to LDP for IPv6

The Label Distribution Protocol (LDP) specification defines procedures to exchange label bindings over either IPv4 or IPv6 networks, or both. This document corrects and clarifies the LDP behavior when an IPv6 network is used (with or without IPv4). This document updates RFCs 5036 and 6720.

RFC75512015-05-01

RSVP-TE Extensions for Associated Bidirectional Label Switched Paths (LSPs)

RSVP-TE Extensions for Associated Bidirectional Label Switched Paths (LSPs)

This document describes Resource Reservation Protocol (RSVP) extensions to bind two point-to-point unidirectional Label Switched Paths (LSPs) into an associated bidirectional LSP. The association is achieved by defining new Association Types for use in ASSOCIATION and in Extended ASSOCIATION Objects. One of these types enables independent provisioning of the associated bidirectional LSPs on both s…

RFC75502015-05-01

Issues and Recommendations with Multiple Stateful DHCPv6 Options

Issues and Recommendations with Multiple Stateful DHCPv6 Options

The Dynamic Host Configuration Protocol for IPv6 (DHCPv6) specification defined two stateful options, IA_NA and IA_TA, but did not anticipate the development of additional stateful options. DHCPv6 Prefix Delegation added the IA_PD option, which is stateful. Applications that use IA_NA and IA_PD together have revealed issues that need to be addressed. This document updates RFCs 3315 and 3633 to add…

RFC75492015-05-01

3GPP SIP URI Inter-Operator Traffic Leg Parameter

3GPP SIP URI Inter-Operator Traffic Leg Parameter

In 3GPP networks, the signaling path between a calling user and a called user can be partitioned into segments, referred to as traffic legs. Each traffic leg may span networks belonging to different operators and will have its own characteristics that can be different from other traffic legs in the same call. A traffic leg might be associated with multiple SIP dialogs, e.g., in case a Back-to-Back…

RFC75482015-05-01

Management of Networks with Constrained Devices: Use Cases

Management of Networks with Constrained Devices: Use Cases

This document discusses use cases concerning the management of networks in which constrained devices are involved. A problem statement, deployment options, and the requirements on the networks with constrained devices can be found in the companion document on "Management of Networks with Constrained Devices: Problem Statement and Requirements" (RFC 7547).

RFC75472015-05-01

Management of Networks with Constrained Devices: Problem Statement and Requirements

Management of Networks with Constrained Devices: Problem Statement and Requirements

This document provides a problem statement, deployment and management topology options, as well as requirements addressing the different use cases of the management of networks where constrained devices are involved.

RFC75462015-05-01

Structure of the Generic Security Service (GSS) Negotiation Loop

Structure of the Generic Security Service (GSS) Negotiation Loop

This document specifies the generic structure of the negotiation loop to establish a Generic Security Service (GSS) security context between initiator and acceptor. The control flow of the loop is indicated for both parties, including error conditions, and indications are given for where application-specific behavior must be specified.

RFC75452015-05-01

Protocol to Access White-Space (PAWS) Databases

Protocol to Access White-Space (PAWS) Databases

Portions of the radio spectrum that are allocated to licensees are available for non-interfering use. This available spectrum is called "white space". Allowing secondary users access to available spectrum "unlocks" existing spectrum to maximize its utilization and to provide opportunities for innovation, resulting in greater overall spectrum utilization. One approach to managing spectrum sharing u…

RFC75442015-08-01

Mapping and Interworking of Diversion Information between Diversion and History-Info Header Fields in the Session Initiation Protocol (SIP)

Mapping and Interworking of Diversion Information between Diversion and History-Info Header Fields in the Session Initiation Protocol (SIP)

Although the SIP History-Info header field described in RFC 7044 is the solution adopted in IETF, the non-standard Diversion header field described, as Historic, in RFC 5806 is nevertheless already implemented and used for conveying call-diversion-related information in Session Initiation Protocol (SIP) signaling. RFC 7044 obsoletes the original RFC 4244 and redefines the History-Info header field…

RFC75432015-05-01

Covering Prefixes Outbound Route Filter for BGP-4

Covering Prefixes Outbound Route Filter for BGP-4

This document defines a new Outbound Route Filter (ORF) type, called the Covering Prefixes ORF (CP-ORF). CP-ORF is applicable in Virtual Hub-and-Spoke VPNs. It also is applicable in BGP/MPLS Ethernet VPN (EVPN) networks.

RFC75422015-05-01

The Network Access Identifier

The Network Access Identifier

In order to provide inter-domain authentication services, it is necessary to have a standardized method that domains can use to identify each other's users. This document defines the syntax for the Network Access Identifier (NAI), the user identifier submitted by the client prior to accessing resources. This document is a revised version of RFC 4282. It addresses issues with international characte…

RFC75412015-05-01

HPACK: Header Compression for HTTP/2

HPACK: Header Compression for HTTP/2

This specification defines HPACK, a compression format for efficiently representing HTTP header fields, to be used in HTTP/2.

RFC75402015-05-01

Hypertext Transfer Protocol Version 2 (HTTP/2)

Hypertext Transfer Protocol Version 2 (HTTP/2)

This specification describes an optimized expression of the semantics of the Hypertext Transfer Protocol (HTTP), referred to as HTTP version 2 (HTTP/2). HTTP/2 enables a more efficient use of network resources and a reduced perception of latency by introducing header field compression and allowing multiple concurrent exchanges on the same connection. It also introduces unsolicited push of represen…

RFC75392015-05-01

ChaCha20 and Poly1305 for IETF Protocols

ChaCha20 and Poly1305 for IETF Protocols

This document defines the ChaCha20 stream cipher as well as the use of the Poly1305 authenticator, both as stand-alone algorithms and as a "combined mode", or Authenticated Encryption with Associated Data (AEAD) algorithm. This document does not introduce any new crypto, but is meant to serve as a stable reference and an implementation guide. It is a product of the Crypto Forum Research Group (CFR…

RFC75382015-04-01

The Hypertext Transfer Protocol Status Code 308 (Permanent Redirect)

The Hypertext Transfer Protocol Status Code 308 (Permanent Redirect)

This document specifies the additional Hypertext Transfer Protocol (HTTP) status code 308 (Permanent Redirect).

RFC75372015-05-01

IANA Registries for LSP Ping Code Points

IANA Registries for LSP Ping Code Points

RFCs 4379 and 6424 created name spaces for Multi-Protocol Label Switching (MPLS) Label Switched Path (LSP) Ping. However, those RFCs did not create the corresponding IANA registries for Downstream Mapping object Flags (DS Flags), Multipath Types, Pad TLVs, and Interface and Label Stack Address Types. There is now a need to make further code point allocations from these name spaces. This document u…

RFC75362015-05-01

Large-Scale Broadband Measurement Use Cases

Large-Scale Broadband Measurement Use Cases

Measuring broadband performance on a large scale is important for network diagnostics by providers and users, as well as for public policy. Understanding the various scenarios and users of measuring broadband performance is essential to development of the Large-scale Measurement of Broadband Performance (LMAP) framework, information model, and protocol. This document details two use cases that can…

RFC75352015-05-01

AS112 Redirection Using DNAME

AS112 Redirection Using DNAME

AS112 provides a mechanism for handling reverse lookups on IP addresses that are not unique (e.g., RFC 1918 addresses). This document describes modifications to the deployment and use of AS112 infrastructure that will allow zones to be added and dropped much more easily, using DNAME resource records. This approach makes it possible for any DNS zone administrator to sink traffic relating to parts o…

RFC75342015-05-01

AS112 Nameserver Operations

AS112 Nameserver Operations

Many sites connected to the Internet make use of IPv4 addresses that are not globally unique. Examples are the addresses designated in RFC 1918 for private use within individual sites. Devices in such environments may occasionally originate Domain Name System (DNS) queries (so-called "reverse lookups") corresponding to those private-use addresses. Since the addresses concerned have only local sign…

RFC75332015-03-01

Administration Protocol for Federated File Systems

Administration Protocol for Federated File Systems

This document describes the administration protocol for a federated file system (FedFS) that enables file access and namespace traversal across collections of independently administered fileservers. The protocol specifies a set of interfaces by which fileservers with different administrators can form a fileserver federation that provides a namespace composed of the file systems physically hosted o…

RFC75322015-03-01

Namespace Database (NSDB) Protocol for Federated File Systems

Namespace Database (NSDB) Protocol for Federated File Systems

This document describes a file system federation protocol that enables file access and namespace traversal across collections of independently administered fileservers. The protocol specifies a set of interfaces by which fileservers with different administrators can form a fileserver federation that provides a namespace composed of the file systems physically hosted on and exported by the constitu…

RFC75312015-03-01

Network File System (NFS) Version 4 External Data Representation Standard (XDR) Description

Network File System (NFS) Version 4 External Data Representation Standard (XDR) Description

The Network File System (NFS) version 4 protocol is a distributed file system protocol that owes its heritage to NFS protocol version 2 (RFC 1094) and version 3 (RFC 1813). Unlike earlier versions, the NFS version 4 protocol supports traditional file access while integrating support for file locking and the MOUNT protocol. In addition, support for strong security (and its negotiation), COMPOUND op…

RFC75302015-03-01

Network File System (NFS) Version 4 Protocol

Network File System (NFS) Version 4 Protocol

The Network File System (NFS) version 4 protocol is a distributed file system protocol that builds on the heritage of NFS protocol version 2 (RFC 1094) and version 3 (RFC 1813). Unlike earlier versions, the NFS version 4 protocol supports traditional file access while integrating support for file locking and the MOUNT protocol. In addition, support for strong security (and its negotiation), COMPOU…

RFC75292015-05-01

Non-Gregorian Recurrence Rules in the Internet Calendaring and Scheduling Core Object Specification (iCalendar)

Non-Gregorian Recurrence Rules in the Internet Calendaring and Scheduling Core Object Specification (iCalendar)

This document defines extensions to the Internet Calendaring and Scheduling Core Object Specification (iCalendar) (RFC 5545) to support use of non-Gregorian recurrence rules. It also defines how Calendaring Extensions to WebDAV (CalDAV) (RFC 4791) servers and clients can be extended to support these new recurrence rules.

RFC75282015-04-01

A Uniform Resource Name (URN) Namespace for the Hybrid Broadcast Broadband TV (HbbTV) Association

A Uniform Resource Name (URN) Namespace for the Hybrid Broadcast Broadband TV (HbbTV) Association

This document describes a Uniform Resource Name (URN) namespace for the Hybrid Broadcast Broadband TV (HbbTV) Association for naming persistent resources defined within HbbTV specifications. Example resources include technical documents and specifications, Extensible Markup Language (XML) Schemas, classification schemes, XML Document Type Definitions (DTDs), namespaces, style sheets, media assets,…