О документе
Network Working Group D. Meyer
Request for Comments: 2365 University of Oregon
BCP: 23 July 1998
Category: Best Current Practice
IP-многоадресная рассылка с административной областью действия
1. Аннотация
Этот документ определяет «пространство IPv4-адресов многоадресной рассылки с административной областью действия» как диапазон от 239.0.0.0 до 239.255.255.255. Кроме того, он описывает простой набор семантических правил для реализации IP-многоадресной рассылки с административной областью действия. Наконец, он задаёт соответствие между классами IPv6-адресов многоадресной рассылки [RFC1884] и классами IPv4-адресов многоадресной рассылки.
Этот меморандум является результатом работы MBONE Deployment Working Group (MBONED) в области эксплуатации и управления Internet Engineering Task Force. Направляйте комментарии по адресу <mboned@ns.uoregon.edu> или автору.
2. Благодарности
Значительная часть этого меморандума взята из «Administratively Scoped IP Multicast», Van Jacobson и Steve Deering, представленного на 30-й встрече IETF в Торонто, Канада, 25 июля 1994 года. Steve Casner, Mark Handley и Dave Thaler также предоставили проницательные комментарии к более ранним версиям этого документа.
3. Введение
Большинство современных реализаций IP-многоадресной рассылки достигают некоторого уровня ограничения области действия, используя поле TTL в IP-заголовке. Типичная практика MBONE (Multicast Backbone) состояла в проектировании порогов TTL, ограничивающих трафик некоторой административно определённой топологической областью. Базовое правило пересылки для интерфейсов с настроенными порогами TTL состоит в том, что пакет не пересылается через интерфейс, если его оставшийся TTL не превышает порог.
Ограничение области действия по TTL применялось для управления распространением трафика многоадресной рассылки с целью уменьшить нагрузку на дефицитные ресурсы (например, пропускную способность) либо добиться некоторого улучшения свойств приватности или масштабируемости. Кроме того, TTL также используется в своей традиционной роли для ограничения времени жизни дейтаграммы. С учётом этих часто конфликтующих ролей ограничение области действия по TTL оказалось трудно надёжно реализовать, а получающиеся схемы часто были сложными и трудными для понимания.
Более серьёзная архитектурная проблема касается взаимодействия ограничения области действия по TTL с протоколами широковещательной рассылки и отсечения (например, DVMRP [DVMRP]). Конкретная проблема состоит в том, что во многих распространённых случаях ограничение области действия по TTL может препятствовать эффективности отсечения. Рассмотрим случай, в котором TTL пакета либо истёк, либо не прошёл порог TTL. Маршрутизатор, отбрасывающий пакет, не сможет выполнить отсечение каких-либо источников выше по потоку и, следовательно, будет принимать весь трафик многоадресной рассылки (независимо от того, имеются ли получатели ниже по потоку). Заметим, что, хотя может показаться возможным посылать сообщения отсечения выше по потоку от точки, в которой пакет отбрасывается, эта стратегия может привести к отбрасыванию законного трафика, поскольку последующие пакеты могут пойти другим путём и прийти в ту же точку с большим TTL.
С другой стороны, IP-многоадресная рассылка с административной областью действия может предоставить ясную и простую семантику для IP-многоадресной рассылки с ограниченной областью действия. Ключевые свойства IP-многоадресной рассылки с административной областью действия состоят в том, что (i). пакеты, адресованные адресам многоадресной рассылки с административной областью действия, не пересекают настроенные административные границы, и (ii). адреса многоадресной рассылки с административной областью действия назначаются локально и поэтому не обязаны быть уникальными между административными границами.
4. Определение пространства IPv4-адресов многоадресной рассылки с административной областью действия
Пространство IPv4-адресов многоадресной рассылки с административной областью действия определяется как диапазон от 239.0.0.0 до 239.255.255.255.
5. Обсуждение
Для поддержки IP-многоадресной рассылки с административной областью действия маршрутизатору следует поддерживать настройку границ IP-многоадресной рассылки с ограниченной областью действия для каждого интерфейса. Такой маршрутизатор, называемый граничным маршрутизатором, не пересылает в обоих направлениях пакеты, соответствующие определению границы интерфейса (двунаправленная проверка предотвращает проблемы с сетями множественного доступа). Кроме того, граничный маршрутизатор всегда выполняет отсечение границы для групп плотного режима [PIMDM] и не принимает присоединения для групп разреженного режима [PIMSM] в диапазоне с административной областью действия.
6. Структура пространства многоадресной рассылки с административной областью действия
Структура пространства IP version 4 для многоадресной рассылки с административной областью действия в общих чертах основана на архитектуре адресации IP Version 6, описанной в RFC 1884 [RFC1884]. Этот документ определяет две важные области действия: IPv4 Local Scope и IPv4 Organization Local Scope. Эти области действия описаны ниже.
6.1. IPv4 Local Scope -- 239.255.0.0/16
239.255.0.0/16 определяется как IPv4 Local Scope. Local Scope является минимальной охватывающей областью действия и поэтому далее не делится. Хотя точный охват Local Scope зависит от площадки, локально ограниченные области должны соблюдать определённые топологические ограничения. В частности, Local Scope не должна пересекать какую-либо другую границу области действия. Кроме того, Local Scope должна полностью содержаться в любой большей области действия либо быть равной ей. Если области действия перекрываются по территории, область перекрытия должна находиться в собственной локальной области действия. Отсюда следует, что любая граница области действия также является границей для Local Scope. Более общие топологические требования к областям с административной областью действия обсуждаются ниже.
6.1.1. Расширение IPv4 Local Scope
Пространство IPv4 Local Scope растёт «вниз». Поэтому IPv4 Local Scope может расти вниз от 239.255.0.0/16 в зарезервированные диапазоны 239.254.0.0/16 и 239.253.0.0/16. Однако эти диапазоны не следует использовать, пока пространства 239.255.0.0/16 больше не достаточно.
6.2. IPv4 Organization Local Scope -- 239.192.0.0/14
239.192.0.0/14 определяется как IPv4 Organization Local Scope и является пространством, из которого организациям следует выделять поддиапазоны при определении областей действия для частного использования.
6.2.1. Расширение IPv4 Organization Local Scope
Диапазоны 239.0.0.0/10, 239.64.0.0/10 и 239.128.0.0/10 не назначены и доступны для расширения этого пространства. Эти диапазоны следует оставлять неназначенными, пока пространства 239.192.0.0/14 больше не достаточно. Это позволяет учесть возможность того, что будущие редакции этого документа могут определить дополнительные области действия большего, чем организации, масштаба.
6.3. Другие представляющие интерес области IPv4
Два других представляющих интерес класса областей действия — статически назначенная область действия, локальная для канала, и глобальная область действия — уже существуют в пространстве IPv4-многоадресной рассылки.
Статически назначенная область действия, локальная для канала, — 224.0.0.0/24. Существующие статические выделения глобальной области действия несколько более детализированы и включают
224.1.0.0-224.1.255.255 Группы многоадресной рассылки ST
224.2.0.0-224.2.127.253 Вызовы мультимедийных конференций
224.2.127.254 Объявления SAPv1
224.2.127.255 Объявления SAPv0 (устарело)
224.2.128.0-224.2.255.255 Динамические назначения SAP
224.252.0.0-224.255.255.255 Временные группы DIS
232.0.0.0-232.255.255.255 Временные группы VMTP
См. [RFC1700] для текущих назначений адресов многоадресной рассылки (этот список также можно найти, возможно в более актуальной форме, по адресу ftp://ftp.isi.edu/in-notes/iana/assignments/multicast-addresses).
7. Топологические требования к административным границам
Область IP-многоадресной рассылки с административной областью действия определяется как топологическая область, в которой имеется один или несколько граничных маршрутизаторов с общими определениями границы. О таком маршрутизаторе говорят, что он является границей для адресов с ограниченной областью действия в диапазоне, определённом его конфигурацией.
Администраторы сети могут настраивать область действия, когда требуется ограниченная область IP-многоадресной рассылки. Кроме того, администратор может при необходимости настраивать перекрывающиеся области действия (сети могут находиться в нескольких областях действия), с единственными ограничениями: область действия должна быть связной (между любыми двумя узлами в области действия должен существовать путь, не выходящий за её пределы) и выпуклой (то есть никакой путь между любыми двумя точками области не может пересекать границу области). Однако важно отметить, что, если области с административной областью действия топологически пересекаются, внешняя область действия должна состоять из её адресного пространства за вычетом адресных пространств всех пересекающихся областей действия. Это требование предотвращает проблему, которая возникла бы, когда путь между двумя точками в выпуклой области пересекает границу пересекающейся области. По этой причине рекомендуется, чтобы административные области действия, которые топологически пересекаются, не пересекались по диапазону адресов.
Наконец, отметим, что любая граница области действия является границей для Local Scope. Отсюда следует, что пакеты, отправленные группам, охватываемым 239.255.0.0/16, не должны пересылаться через какой-либо канал, для которого определена граница с ограниченной областью действия.
8. Разбиение пространства многоадресной рассылки с административной областью действия
Следующая таблица показывает разбиение пространства IPv4-многоадресной рассылки и задаёт соответствие между IPv4-префиксами многоадресной рассылки и значениями IPv6 SCOP:
IPv6 SCOP Описание RFC 1884 IPv4-префикс
===============================================================
0 зарезервировано
1 область действия, локальная для узла
2 область действия, локальная для канала 224.0.0.0/24
3 (не назначено) 239.255.0.0/16
4 (не назначено)
5 область действия, локальная для площадки
6 (не назначено)
7 (не назначено)
8 область действия, локальная для организации 239.192.0.0/14
A (не назначено)
B (не назначено)
C (не назначено)
D (не назначено)
E глобальная область действия 224.0.1.0-238.255.255.255
F зарезервировано
(не назначено) 239.0.0.0/10
(не назначено) 239.64.0.0/10
(не назначено) 239.128.0.0/10
9. Структура и использование области с ограниченной областью действия
Старший /24 в каждой области с ограниченной областью действия зарезервирован для относительных назначений. Относительное назначение представляет собой целочисленное смещение от наибольшего адреса в области действия и представляет 32-битный адрес (для IPv4). Например, в определённой выше Local Scope 239.255.255.0/24 зарезервирован для относительных выделений. Фактическое относительное назначение «0» (то есть 239.255.255.255 в Local Scope) в настоящее время существует для SAP [SAP]. Следующее относительное назначение, «1», соответствует адресу 239.255.255.254 в Local Scope. Остальная часть области с ограниченной областью действия ниже зарезервированного /24 доступна для динамического назначения (предположительно протоколом выделения адресов).
Важно отметить, что для практического использования областей действия, кроме Local Scope, потребуется разработать протокол обнаружения областей действия [MZAP]. Кроме того, поскольку любое использование любой области с административной областью действия, включая Local Scope, требует динамически назначаемой адресации, для того чтобы административное ограничение области действия стало в целом полезным, потребуется разработать Address Allocation Protocol (AAP).
9.1. Руководство по относительным назначениям
Запросы на относительные назначения следует направлять в IANA. При выполнении относительных назначений адресов IANA будет консультироваться с экспертом области. Эксперт области будет назначен соответствующим Area Director.
В общем случае относительные адреса будут использоваться только для начальной загрузки перехода к динамическим назначениям адресов изнутри области действия. Поэтому относительные назначения следует выполнять только для тех служб, которые не могут использовать протокол динамического назначения адресов для обнаружения адреса, используемого этой службой в желаемой области действия, например для самой службы динамического назначения адресов.
10. Соображения безопасности
Организациям, использующим IP-адреса многоадресной рассылки с административной областью действия, рекомендуется не полагаться на них для предотвращения передачи конфиденциальных данных за пределы организации. Если маршрутизатор многоадресной рассылки на административной границе будет неправильно настроен, будет содержать ошибку в коде административного ограничения области действия либо иметь иные проблемы, из-за которых этот маршрутизатор будет пересылать пакет IP-многоадресной рассылки с административной областью действия за пределы надлежащей области действия, данные организации покинут назначенную для их передачи область.
Организациям, использующим IP-многоадресную передачу с административной областью действия для передачи конфиденциальных данных, следует использовать какой-либо механизм обеспечения конфиденциальности (например, шифрование) для защиты этих данных. В случае многих существующих приложений для видеоконференций (например, vat) шифрование доступно как функция приложения и его лишь необходимо включить (а также надлежащим образом безопасно распространить криптографические ключи). Для многих других приложений использование IP Encapsulating Security Payload (ESP) [RFC-1825, RFC-1827] может обеспечивать конфиденциальность на IP-уровне посредством шифрования.
В контексте группы IP-многоадресной передачи с административной областью действия использование ручного распределения ключей вполне может быть осуществимым. Хотя динамическое управление ключами для IP Security на момент написания этой заметки является областью исследований, ожидается, что в будущем IETF расширит протокол управления ключами ISAKMP для поддержки масштабируемого распределения ключей многоадресной передачи.
Важно отметить, что описываемый в этой заметке «пограничный маршрутизатор» не обязательно предоставляет какие-либо возможности межсетевого экрана.
11. Ссылки
[ASMA] V. Jacobson, S. Deering, "Administratively Scoped IP
Multicast", представлено на 30-м IETF, Toronto, Canada, 25
July 1994.
[DVMRP] Pusateri, T., "Distance Vector Multicast Routing Protocol",
Work in Progress.
[MZAP] Handley, M., "Multicast-Scope Zone Announcement Protocol
(MZAP)", Work in Progress.
[PIMDM] Deering, S, et. al., "Protocol Independent Multicast
Version 2, Dense Mode Specification", Work in Progress.
[PIMSM] Estrin, D., Farinacci, D., Helmy, A., Thaler, D., Deering,
S., Handley, M., Jacobson, V., Liu, C., Sharma, P., and L.
Wei, "Protocol Independent Multicast Sparse Mode (PIM-SM):
Protocol Specification", RFC 2362, June 1998.
[RFC1700] Reynolds, J., and J. Postel, "Assigned Numbers", STD 2, RFC
1700, October 1994.
[RFC1884] Hinden. R., and S. Deering, "IP Version 6 Addressing
Architecture", RFC1884, December 1995.
[SAP] Handley, M., "SAP: Session Announcement Protocol", Work in
Progress.
12. Адрес автора
David Meyer
Cisco Systems
San Jose, CA
EMail: dmm@cisco.com
13. Полное заявление об авторском праве
Copyright (C) The Internet Society (1998). All Rights Reserved.
Этот документ и его переводы могут копироваться и предоставляться другим лицам, а производные работы, содержащие комментарии к нему, иным образом разъясняющие его или содействующие его реализации, могут подготавливаться, копироваться, публиковаться и распространяться, полностью или частично, без каких-либо ограничений при условии, что приведённое выше уведомление об авторском праве и этот абзац включены во все такие копии и производные работы. Однако сам этот документ не может быть каким-либо образом изменён, например путём удаления уведомления об авторском праве или ссылок на The Internet Society либо другие интернет-организации, за исключением случаев, когда это необходимо для разработки стандартов Интернета, в котором случае должны соблюдаться процедуры в отношении авторских прав, определённые процессом разработки стандартов Интернета, или когда это требуется для его перевода на языки, отличные от английского.
Предоставленные выше ограниченные разрешения являются бессрочными и не будут отозваны The Internet Society либо её правопреемниками или цессионариями.
Этот документ и содержащаяся в нём информация предоставляются на условиях «КАК ЕСТЬ», И THE INTERNET SOCIETY И INTERNET ENGINEERING TASK FORCE ОТКАЗЫВАЮТСЯ ОТ ВСЕХ ГАРАНТИЙ, ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ, ВКЛЮЧАЯ, ПОМИМО ПРОЧЕГО, ЛЮБУЮ ГАРАНТИЮ ТОГО, ЧТО ИСПОЛЬЗОВАНИЕ СОДЕРЖАЩЕЙСЯ ЗДЕСЬ ИНФОРМАЦИИ НЕ НАРУШИТ КАКИХ-ЛИБО ПРАВ, ИЛИ ЛЮБЫЕ ПОДРАЗУМЕВАЕМЫЕ ГАРАНТИИ ТОВАРНОЙ ПРИГОДНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ ОПРЕДЕЛЁННОЙ ЦЕЛИ.