⌕ Поиск по атласу

Полный русский перевод · RFC2644

RFC2644 · Изменение значения по умолчанию для направленных широковещательных рассылок в маршрутизаторах

Changing the Default for Directed Broadcasts in Routers

Карточка документа · Архив принятого перевода · Официальный источник

Содержание

О документе


Network Working Group                                           D. Senie
Request for Comments: 2644                        Amaranth Networks Inc.
Updates: 1812                                                August 1999
BCP: 34
Category: Best Current Practice

        Изменение значения по умолчанию для направленных широковещательных рассылок в маршрутизаторах

Статус настоящего меморандума

Этот документ определяет наилучшую текущую практику Интернета для
   интернет-сообщества и запрашивает обсуждение и предложения по
   улучшению. Распространение настоящего меморандума не ограничено.

Уведомление об авторском праве

Copyright (C) The Internet Society (1999). All Rights Reserved.

1. Введение

Router Requirements [1] устанавливает, что маршрутизаторы должны
   принимать и пересылать направленные широковещательные пакеты. В нём
   также установлено, что маршрутизаторы ДОЛЖНЫ (MUST) иметь возможность
   отключения этой функции и что по умолчанию эта возможность ДОЛЖНА
   (MUST) разрешать приём и пересылку направленных широковещательных
   пакетов. Хотя направленные широковещательные пакеты имеют применения,
   их использование в магистральной сети Интернета, по-видимому, целиком
   состоит из вредоносных атак на другие сети.

   Изменение требуемого значения по умолчанию для маршрутизаторов
   помогло бы обеспечить, чтобы новые маршрутизаторы, подключённые к
   Интернету, не усугубляли уже существующие проблемы.

   Ключевые слова "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
   "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY" и "OPTIONAL" в этом
   документе следует толковать так, как описано в RFC 2119.

2. Обсуждение

Наносящие ущерб атаки отказа в обслуживании привели к написанию [2]
   о фильтрации входящего трафика. Многие поставщики сетевых услуг и
   корпоративные сети одобрили применение этих методов, чтобы их сети не
   были источником таких атак.

   Недавняя тенденция в атаках Smurf [3] состоит в том, чтобы выбирать
   целями сети, допускающие направленные широковещательные пакеты извне
   своих сетей. Разрешая направленные широковещательные пакеты, эти
   системы становятся "Smurf Amplifiers".

   Хотя постоянное внедрение фильтров входящего трафика остаётся лучшим
   способом ограничить эти атаки, ограничению направленных
   широковещательных пакетов также следует уделить приоритетное внимание.

   Поставщикам сетевых услуг и операторам корпоративных сетей настоятельно
   рекомендуется обеспечить, чтобы их сети не были уязвимы для пакетов
   направленной широковещательной рассылки, поступающих извне их сетей.

   Mobile IP [4] содержал положения об использовании направленных
   широковещательных пакетов при использовании мобильным узлом
   динамического обнаружения агента. Хотя некоторые реализации
   поддерживают эту возможность, неясно, полезна ли она. Другие методы
   достижения того же результата документированы в [5]. По мере
   продвижения Mobile IP по пути стандартизации, возможно, стоило бы
   рассмотреть удаление формулировок об использовании направленных
   широковещательных пакетов.

3. Рекомендация

Router Requirements [1] обновляется следующим образом:

   Раздел 4.2.2.11 (d) заменяется следующим:

      (d) { <Network-prefix>, -1 }

      Направленная широковещательная рассылка — широковещательная рассылка,
      направленная указанному префиксу сети. Она НЕ ДОЛЖНА (MUST NOT)
      использоваться в качестве адреса источника. Маршрутизатор МОЖЕТ
      (MAY) формировать пакеты Network Directed Broadcast. Маршрутизатор
      МОЖЕТ (MAY) иметь параметр конфигурации, разрешающий ему принимать
      пакеты направленной широковещательной рассылки, однако этот параметр
      ДОЛЖЕН (MUST) быть отключён по умолчанию, и поэтому маршрутизатор
      НЕ ДОЛЖЕН (MUST NOT) принимать пакеты Network Directed Broadcast,
      если конечный пользователь явно не настроил его.

   Раздел 5.3.5.2, второй абзац заменяется следующим:

      Маршрутизатор МОЖЕТ (MAY) иметь возможность включить приём на
      интерфейсе широковещательных пакетов, направленных префиксу сети,
      и МОЖЕТ (MAY) иметь возможность включить пересылку
      широковещательных пакетов, направленных префиксу сети. По умолчанию
      эти возможности ДОЛЖНЫ (MUST) блокировать приём и блокировать
      пересылку широковещательных пакетов, направленных префиксу сети.

4. Соображения безопасности

Цель настоящего документа — снизить результативность некоторых типов
   атак отказа в обслуживании.

5. Ссылки

[1] Baker, F., "Requirements for IP Version 4 Routers", RFC 1812,
       June 1995.

   [2] Ferguson, P. and D. Senie, "Ingress Filtering", RFC 2267, January
       1998.

   [3] См. страницы Craig Huegen по адресу:
       http://www.quadrunner.com/~chuegen/smurf.txt, а также рекомендацию
       CERT по адресу: http://www.cert.org/advisories/CA-98.01.smurf.html

   [4] Perkins, C., "IP Mobility Support", RFC 2002, October 1996.

   [5] P. Calhoun, C. Perkins, "Mobile IP Dynamic Home Address
       Allocation Extensions", Work in Progress.

6. Благодарности

Автор хотел бы поблагодарить Brandon Ross из Mindspring и Gabriel
   Montenegro из Sun за их вклад.

7. Адрес автора

Daniel Senie
   Amaranth Networks Inc.
   324 Still River Road
   Bolton, MA 01740

   Phone: (978) 779-6813
   EMail: dts@senie.com

8. Полное заявление об авторском праве

Copyright (C) The Internet Society (1999). All Rights Reserved.

   Этот документ и его переводы могут копироваться и предоставляться
   другим лицам, а производные работы, которые комментируют или иным
   образом разъясняют его либо содействуют его реализации, могут
   подготавливаться, копироваться, публиковаться и распространяться,
   полностью или частично, без каких-либо ограничений при условии, что
   приведённое выше уведомление об авторском праве и этот абзац включены
   во все такие копии и производные работы. Однако сам этот документ не
   может быть каким-либо образом изменён, например путём удаления
   уведомления об авторском праве или ссылок на Internet Society либо
   другие интернет-организации, за исключением случаев, когда это
   необходимо для разработки интернет-стандартов, и в таком случае
   должны соблюдаться процедуры в отношении авторских прав, определённые
   процессом разработки интернет-стандартов, либо когда это требуется для
   перевода его на языки, отличные от английского.

   Предоставленные выше ограниченные разрешения являются бессрочными и не
   будут отозваны Internet Society или её правопреемниками либо цессионариями.

   Этот документ и содержащаяся в нём информация предоставляются на условиях
   "КАК ЕСТЬ", И THE INTERNET SOCIETY И THE INTERNET ENGINEERING TASK FORCE
   ОТКАЗЫВАЮТСЯ ОТ ВСЕХ ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ, ВКЛЮЧАЯ, ПОМИМО
   ПРОЧЕГО, ЛЮБУЮ ГАРАНТИЮ ТОГО, ЧТО ИСПОЛЬЗОВАНИЕ СОДЕРЖАЩЕЙСЯ ЗДЕСЬ
   ИНФОРМАЦИИ НЕ НАРУШИТ КАКИЕ-ЛИБО ПРАВА, А ТАКЖЕ ЛЮБЫЕ ПОДРАЗУМЕВАЕМЫЕ
   ГАРАНТИИ ТОВАРНОЙ ПРИГОДНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ ОПРЕДЕЛЁННОЙ ЦЕЛИ.

Благодарность

Финансирование функции RFC Editor в настоящее время обеспечивается
   Internet Society.