⌕ Поиск по атласу

Полный русский перевод · RFC2850

RFC2850 · Устав Совета по архитектуре Интернета (IAB)

Charter of the Internet Architecture Board (IAB)

Карточка документа · Архив принятого перевода · Официальный источник

Содержание

О документе


Network Working Group                        Internet Architecture Board
Запрос комментариев: 2850                          B. Carpenter, редактор
Заменяет: 1601                                                 Май 2000
BCP: 39
Категория: Лучшая современная практика

            Устав Совета по архитектуре Интернета (IAB)

Статус этого документа

Этот документ определяет одну из лучших современных практик Интернета для сообщества Интернета и запрашивает обсуждение и предложения по улучшениям. Распространение данного документа не ограничено.

Уведомление об авторских правах

Copyright (C) The Internet Society (2000). Все права защищены.

Аннотация

В этом документе описываются состав, порядок отбора, роли и организация Совета по архитектуре Интернета. Он заменяет RFC 1601.

Содержание:

   1. Членство в IAB...............................................2
   1.1  Отбор полноправных членов IAB..............................2
   1.2 Члены по должности и члены по связи.........................2
   2.  Роль IAB....................................................3
   2.1 Архитектурный надзор подробнее..............................4
   3. Организация IAB.............................................5
   3.1 Председатель IAB............................................5
   3.2 Исполнительный директор.....................................5
   3.3 Назначение председателя IRTF................................5
   3.4 Связи внутри IETF...........................................5
   3.5 Принятие решений............................................6
   3.6 Открытость и конфиденциальность.............................6
   Соображения безопасности........................................6
   Сводка изменений относительно RFC 1601..........................6
   Ссылки..........................................................7
   Адрес автора....................................................7
   Полное заявление об авторских правах............................8

1. Членство в IAB

Совет по архитектуре Интернета (IAB) должен (shall) состоять из тринадцати полноправных членов: председателя Internet Engineering Task Force (IETF) и двенадцати действующих членов. Председатель IETF, одновременно являющийся председателем Internet Engineering Steering Group (IESG), может участвовать во всех официальных действиях IAB, кроме утверждения членов IESG и рассмотрения апелляций на решения IESG. Члены IAB по должности и члены по связи также могут присутствовать на заседаниях IAB, но не должны (shall not) участвовать в определении официальных действий.

   Члены IAB должны (shall) исполнять свои обязанности как физические лица, а не как представители какой-либо компании, ведомства или иной организации. Члены IAB не должны (shall) иметь перед IAB, IETF, IRTF или IESG фидуциарной обязанности лояльности или заботы.

1.1 Отбор полноправных членов IAB

Полноправные члены IAB, включая председателя IETF, отбираются и назначаются согласно процедурам, определённым в [BCP 10]. Обычно ежегодно назначаются шесть действующих членов на двухлетний срок, а председатель IETF назначается раз в два года.

   Число сроков, которые член IAB может занимать, не ограничено при соблюдении процесса, определённого в [BCP 10].

   Вакансии, возникающие до окончания срока, заполняются согласно [BCP 10] и не влияют на полномочия IAB принимать решения.

1.2 Члены по должности и члены по связи

Члены IAB по должности и члены по связи не имеют права участвовать в решениях IAB, но, как ожидается, участвуют в обсуждениях IAB в соответствии со своими ролями. Однако должность члена по должности может занимать полноправный член, который вследствие этого не теряет своего права участвовать в решениях IAB.

   Председатель Internet Research Task Force (IRTF) является членом IAB по должности. У IAB есть исполнительный директор, являющийся членом IAB по должности.

   Internet Society, RFC Editor, IANA и IESG каждый назначают в IAB по одному члену по связи. Эти должности членов по связи не могут заниматься полноправным членом IAB.

   Вакансии на должностях членов по связи и членов по должности не влияют на полномочия IAB принимать решения.

2. Роль IAB

IAB учреждён и как комитет IETF, и как консультативный орган Internet Society. В его обязанности входит следующее:

   (a) Назначение IESG

   Номинационный комитет IETF, созданный согласно [BCP 10], ежегодно предоставляет список кандидатов на вакантные места в IESG, а при наличии вакансии — и на должность председателя IETF. IAB рассматривает кандидатов, давая согласие на назначение некоторых, всех либо ни одного из них.

   (b) Архитектурный надзор

   IAB осуществляет надзор за архитектурой протоколов и процедур, используемых Интернетом. Этот пункт подробнее раскрывается в разделе 2.1 ниже.

   (c) Надзор за процессом стандартизации и апелляции

   IAB осуществляет надзор за процессом, используемым для создания интернет-стандартов [BCP 9].

   IAB выступает апелляционным органом по жалобам на ненадлежащее исполнение процесса стандартизации, обладая полномочиями, определёнными в [BCP 9].

   (d) Серия RFC и IANA

   RFC Editor осуществляет редакционное управление и публикацию серии документов IETF «Request for Comment» (RFC), являющейся постоянным хранилищем документов IETF. Серия RFC образует архивный канал публикации интернет-стандартов и других материалов сообщества исследователей и инженеров Интернета. RFC доступны любому лицу бесплатно через Интернет. IAB должен утверждать назначение организации, действующей в качестве RFC Editor, а также общую политику, которой следует RFC Editor.

   Internet Assigned Numbers Authority (IANA) администрирует различные параметры протоколов, используемые протоколами IETF, делегируя это администрирование, когда это уместно. IAB должен утверждать назначение организации, действующей от имени IETF в качестве IANA. По техническим вопросам протоколов IETF IANA руководствуется указаниями IESG.

   (e) Связь с ISOC

   IAB выступает источником советов и рекомендаций для Совета попечителей и должностных лиц Internet Society по техническим, архитектурным, процедурным и, где это уместно, политическим вопросам, относящимся к Интернету и обеспечивающим его технологиям. При необходимости IAB может созывать группы компетентных лиц, проводить слушания и иным образом исследовать конкретные вопросы или темы, представленные ему Internet Society.

   (f) Внешние связи

   IAB представляет интересы IETF и Internet Society в отношениях технического взаимодействия с другими организациями, занимающимися стандартами, а также другими техническими и организационными вопросами, относящимися к всемирному Интернету. Такие связи поддерживаются в максимально неформальном виде и должны иметь доказуемую ценность для повышения качества спецификаций IETF. Отдельные члены IETF назначаются IAB или IESG, в зависимости от обстоятельств, представителями по связи с другими организациями.

2.1 Архитектурный надзор подробнее

Одна из основных ролей IAB состоит в долгосрочном планировании и координации между различными направлениями деятельности IETF. Ожидается, что IAB как коллегиально, так и отдельные его члены будут уделять внимание важным долгосрочным вопросам Интернета и обеспечивать доведение этих вопросов до сведения групп(ы), которые способны их рассмотреть. Также ожидается, что IAB будет играть роль в обеспечении осведомлённости лиц, ответственных за развитие Интернета и его технологий, о существенных элементах архитектуры Интернета.

   Члены IAB уделяют особое внимание возникающим видам деятельности в IETF и сессиям «Birds of a Feather» на заседаниях IETF. IAB помогает IESG оценивать такую деятельность и определять, является ли более подходящей группа IETF или IRTF. Когда предлагается новая рабочая группа IETF, IESG направляет в IAB предварительную версию устава для проверки архитектурной согласованности и целостности. IAB должен (shall) рассматривать эти предлагаемые уставы и предоставлять IESG обратную связь, когда это уместно.

   Во исполнение функции архитектурного надзора IAB поддерживает и организует Internet Research Task Force (IRTF) [BCP 8]. IAB рассматривает предложения о группах IRTF.

   IAB будет созывать семинары по приглашениям для проведения углублённого рассмотрения отдельных архитектурных вопросов. Такие рассмотрения могут включать изучение относящейся к делу деятельности IETF и IRTF, а также работы в других организациях; для этой цели семинар может приглашать квалифицированных участников представить сведения о целях и решениях проектирования, выборе технологий и других существенных аспектах этой деятельности. Результатом такого рассмотрения будет отчёт, который может содержать рекомендации сообществу IETF и IESG.

   IAB может организовывать специальные органы независимых технических экспертов для разрешения технических споров.

3. Организация IAB

3.1 Председатель IAB

Члены IAB должны (shall) выбрать одного из своих полноправных членов для исполнения обязанностей председателя IAB со всеми обязанностями и ответственностью, обычно связанными с такой должностью. Срок полномочий председателя IAB должен (shall) составлять один год без ограничения на повторное назначение. Председатель IAB может быть в любое время отстранён положительным голосованием двух третей членов IAB или вследствие его или её выхода из IAB.

   Председатель IAB должен (shall) обладать полномочиями управлять деятельностью и заседаниями IAB.

3.2 Исполнительный директор

Председатель IAB должен (shall) обладать полномочиями назначать почётного исполнительного директора (ExecD) на продлеваемый однолетний срок и отстранять его или её. ExecD должен (shall) администрировать внутреннюю деятельность IAB, например организацию заседаний и представление отчётов об их результатах.

   ExecD является членом по должности, как определено в разделе 1.2.

3.3 Назначение председателя IRTF

IAB должен (shall) обладать полномочиями назначать председателя Internet Research Task Force (IRTF) на продлеваемый двухлетний срок и отстранять его или её. Председатель IRTF должен (shall) отвечать за управление и организацию IRTF согласно [BCP 8].

   Председатель IRTF является членом по должности, как определено в разделе 1.2.

3.4 Связи внутри IETF

Председатель IAB и ещё один полноправный член IAB, не являющийся председателем IETF, который должен быть выбран IAB, должны (shall) выступать представителями по связи с IESG. Кроме того, IESG назначит одного из своих членов, не являющегося председателем IETF, представителем по связи с IAB. Представитель IESG по связи может присутствовать на заседаниях IAB.

   Вакансии на этих должностях представителей по связи не влияют на полномочия IAB или IESG принимать решения.

3.5 Принятие решений

IAB стремится принимать все решения единогласно. Если единогласия достичь невозможно, председатель может проводить неформальные опросы для определения консенсуса. IAB может принимать решения и предпринимать действия, если с ними согласны не менее семи полноправных членов и имеется не более двух несогласных.

   IAB может принимать решения на очном заседании, телеконференции, посредством связи через Интернет либо с использованием любого сочетания перечисленного.

3.6 Открытость и конфиденциальность

IAB публикует в Интернете протоколы всех своих заседаний и проводит открытое заседание на каждом заседании IETF. Он публикует все свои выводы как RFC, Internet Drafts или сообщения в списке рассылки IETF. Однако обсуждение кадровых вопросов, а возможно, также юридических и финансовых вопросов иногда может требоваться сохранять конфиденциальным; председатель с согласия полноправных членов может исключать членов по связи и членов по должности из таких обсуждений.

   В частности, IAB использует домен второго уровня iab.org и URL http://www.iab.org для публикации информации.

Соображения безопасности

Этот документ не создаёт каких-либо известных угроз безопасности.

Сводка изменений относительно RFC 1601

Этот документ заменяет [RFC 1601]. Основное изменение состоит в удалении материала, который теперь охватывается [BCP 8], [BCP 9] и [BCP 10], а также во многих обусловленных этим редакционных изменениях. Дополнительные изменения:

      - описание принятия решений, когда невозможно достичь единогласия
      - примечание об открытости и конфиденциальности
      - добавление должностей представителей по связи для Internet Society и IANA
      - пересмотренный текст, касающийся IANA и RFC Editor
      - уточнения по итогам юридической проверки

Ссылки

[RFC 1601]  Huitema, C., "Charter of the Internet Architecture Board
               (IAB)", RFC 1601, March 1994.

   [BCP 8]     Weinrib, A., and J. Postel, "IRTF Research Group
               Guidelines and Procedures", BCP 8, RFC 2014, October
               1996.

   [BCP 9]     Bradner, S., "The Internet Standards Process -- Revision
               3", BCP 9, RFC 2026, October 1996.

   [BCP 10]    Galvin, J., "IAB and IESG Selection, Confirmation, and
               Recall Process: Operation of the Nominating and Recall
               Committees", BCP 10, RFC 2282, February 1998.


Адрес автора

   Brian E. Carpenter
   IBM
   c/o iCAIR
   Suite 150
   1890 Maple Avenue
   Evanston IL 60201
   USA

   EMail: brian@icair.org

Полное заявление об авторском праве

Copyright (C) The Internet Society (2000). Все права защищены.

   Этот документ и его переводы могут копироваться и предоставляться
   другим лицам, а производные работы, которые комментируют или иным
   образом разъясняют его либо содействуют его реализации, могут
   подготавливаться, копироваться, публиковаться и распространяться
   полностью или частично без каких-либо ограничений при условии, что
   указанное выше уведомление об авторском праве и этот абзац включены
   во все такие копии и производные работы. Однако сам этот документ не
   может быть изменён каким-либо образом, например путём удаления
   уведомления об авторском праве или ссылок на Internet Society либо
   иные интернет-организации, за исключением случаев, когда это
   необходимо для разработки стандартов Интернета, в котором случае
   должны соблюдаться процедуры в отношении авторских прав, определённые
   процессом стандартов Интернета, либо когда это требуется для его
   перевода на языки, отличные от английского.

   Ограниченные разрешения, предоставленные выше, являются бессрочными
   и не будут отозваны Internet Society или её правопреемниками либо
   цессионариями.

   Этот документ и содержащаяся в нём информация предоставляются на
   условиях «КАК ЕСТЬ» ("AS IS"), И INTERNET SOCIETY И INTERNET
   ENGINEERING TASK FORCE ОТКАЗЫВАЮТСЯ ОТ ВСЕХ ГАРАНТИЙ, ЯВНЫХ ИЛИ
   ПОДРАЗУМЕВАЕМЫХ, ВКЛЮЧАЯ, ПОМИМО ПРОЧЕГО, ЛЮБУЮ ГАРАНТИЮ ТОГО, ЧТО
   ИСПОЛЬЗОВАНИЕ СОДЕРЖАЩЕЙСЯ ЗДЕСЬ ИНФОРМАЦИИ НЕ НАРУШИТ КАКИХ-ЛИБО
   ПРАВ, ИЛИ ЛЮБЫЕ ПОДРАЗУМЕВАЕМЫЕ ГАРАНТИИ ТОВАРНОЙ ПРИГОДНОСТИ ИЛИ
   ПРИГОДНОСТИ ДЛЯ ОПРЕДЕЛЁННОЙ ЦЕЛИ.

Благодарность

Финансирование функции RFC Editor в настоящее время предоставляется
   Internet Society.