⌕ Поиск по атласу

Полный русский перевод · RFC2939

RFC2939 · Процедуры и руководящие указания IANA по определению новых опций и типов сообщений DHCP

Procedures and IANA Guidelines for Definition of New DHCP Options and Message Types

Карточка документа · Архив принятого перевода · Официальный источник

Содержание

О документе


Network Working Group                                            R. Droms
Request for Comments: 2939                            Bucknell University
BCP: 43                                                    September 2000
Obsoletes: 2489
Category: Best Current Practice

            Процедуры и руководящие указания IANA по определению
                   новых опций и типов сообщений DHCP

Статус этого меморандума

Этот документ определяет лучшую современную практику Интернета для
   интернет-сообщества и запрашивает обсуждение и предложения по
   улучшению. Распространение этого меморандума не ограничено.

Уведомление об авторском праве

Copyright (C) The Internet Society (2000). All Rights Reserved.

Аннотация

Dynamic Host Configuration Protocol (DHCP) предоставляет механизм
   передачи конфигурационной информации хостам в сети Transmission
   Control Protocol/Internet Protocol (TCP/IP). Конфигурационные
   параметры и другая управляющая информация передаются в помеченных
   элементах данных, хранящихся в поле 'options' сообщения DHCP.
   Сами элементы данных также называются «опциями».

   Сообщения протокола DHCP идентифицируются опцией 'DHCP Message Type'
   (код опции 51). Каждый тип сообщения определяется значением данных,
   передаваемым в опции 'DHCP Message Type'.

   Новые опции и типы сообщений DHCP могут определяться после публикации
   спецификации DHCP для удовлетворения требований к передаче новых
   конфигурационных параметров либо для поддержки новой семантики
   протокола. Этот документ описывает процедуру определения новых опций
   и типов сообщений DHCP.

1. Введение

Dynamic Host Configuration Protocol (DHCP) [1] предоставляет механизм
   передачи конфигурационной информации хостам в сети TCP/IP.
   Конфигурационные параметры и другая управляющая информация передаются
   в помеченных элементах данных, хранящихся в поле 'options' сообщения
   DHCP. Сами элементы данных также называются «опциями» [2].

   Сообщения протокола DHCP идентифицируются опцией 'DHCP Message Type'
   (код опции 51). Каждый тип сообщения определяется значением данных,
   передаваемым в опции 'DHCP Message Type'.

   Этот документ описывает процедуру определения новых опций и типов
   сообщений DHCP. Эта процедура гарантирует, что:

   * выделение номеров новых опций и номеров типов сообщений
     координируется единым органом;
   * новые опции и типы сообщений проверяются на техническую корректность
     и уместность; и
   * документация для новых опций и типов сообщений является полной и
     опубликована.

   Как указано в «Guidelines for Writing an IANA Considerations Section
   in RFCs» (см. ссылки), IANA действует как центральный орган по
   назначению номеров, таких как коды опций DHCP и типов сообщений.
   Новая процедура, изложенная в этом документе, предоставит IANA
   указания по назначению кодов новых опций и типов сообщений.

   Этот документ обновляет и заменяет RFC 2489.

2. Обзор и предпосылки

Этот документ определяет процедуры для задания новых кодов опций и
   типов сообщений.

2.1 Новые коды опций DHCP

Описанная в этом документе процедура изменяет и уточняет процедуру
   определения новых опций в RFC 2131 [2]. Основное изменение касается
   момента, когда новой опции DHCP присваивается номер опции. В процедуре,
   описанной в этом документе, номер опции не присваивается, пока
   спецификация опции не будет готова к публикации в качестве RFC.

   После публикации RFC 2132 пространство номеров опций для публично
   определённых опций DHCP (1–127) почти исчерпано. За многими
   определёнными номерами опций не последовали Internet Drafts,
   представленные в DHC WG. Со стороны DHC WG отсутствовали конкретные
   указания IANA относительно назначения номеров опций DHCP.

   Процедура, определённая в RFC 2132, не устанавливает ясно, что новые
   опции должны по отдельности проверяться на техническую корректность,
   уместность и полноту документации. RFC 2132 также не требует, чтобы
   новые опции представлялись IESG для проверки, а автор спецификации
   опции отвечал за доведение новых опций до сведения IESG. Наконец,
   RFC 2132 не разъясняет, что вновь определённые опции не должны
   включаться в продукты, включаться в другие спецификации либо иным
   образом использоваться до публикации спецификации опции в качестве
   RFC.

   В дальнейшем новые коды опций DHCP будут назначаться по консенсусу
   IETF. Новые опции DHCP будут документироваться в RFC, одобренных IESG,
   а коды для этих опций будут назначаться в момент публикации
   соответствующих RFC. Как правило, IESG будет запрашивать мнение о
   предполагаемых назначениях у подходящих источников (например, у
   соответствующей рабочей группы, если она существует). Группы связанных
   опций могут объединяться в единую спецификацию и проверяться IESG как
   совокупность. До назначения кода опции неуместно включать новые опции
   в продукты, включать спецификацию в другие документы либо иным образом
   использовать новые опции.

   Пространство номеров опций DHCP (1–254) разделено на две части. Коды
   опций, специфичные для сайта [2] (128–254), определены как «Private
   Use» и не требуют проверки DHC WG. Коды опций, специфичные для сайта
   (128–254), НЕ ДОЛЖНЫ (MUST NOT) определяться для использования в
   каких-либо публично распространяемых реализациях сервера DHCP, клиента
   или ретрансляционного агента. Эти коды опций явно зарезервированы для
   частного определения и использования в пределах сайта или организации.

   Публичные коды опций (0–127, 255) определены как «Specification
   Required», и новые опции должны проверяться до назначения IANA номера
   опции. Подробности процесса проверки приведены в следующем разделе
   этого документа.

2.2 Новые типы сообщений DHCP

RFC 2131 не определяет какого-либо механизма для задания новых типов
   сообщений DHCP. В дальнейшем новые типы сообщений DHCP будут
   документироваться в RFC, одобренных IESG, а коды этих новых типов
   сообщений будут назначаться в момент публикации соответствующих RFC.

   Как правило, IESG будет запрашивать мнение о новых типах сообщений у
   подходящих источников (например, у соответствующей рабочей группы,
   если она существует). До назначения кода типа сообщения неуместно
   включать новые типы сообщений в продукты, включать спецификацию в
   другие документы либо иным образом использовать новые типы сообщений.

3. Процедура

Для получения одобрения опции и публикации спецификации опции в
   качестве RFC автор новой опции или типа сообщения DHCP выполнит
   следующие шаги:

   1. Автор разрабатывает новую опцию или тип сообщения.

   2. Автор документирует новую опцию или тип сообщения как Internet
      Draft, оставляя код опции или код типа сообщения как «To Be
      Determined» (TBD).

      Требование документировать новую опцию или тип сообщения как
      Internet Draft продиктовано практической целесообразностью.
      Теоретически новую опцию или тип сообщения можно было бы
      документировать на обороте конверта для представления; практически
      спецификация в конечном итоге станет Internet Draft в рамках
      процесса проверки.

   3. Автор представляет Internet Draft на проверку IESG.
      Предпочтительно, чтобы автор представил Internet Draft в DHC
      Working Group, но автор может предпочесть представить Internet
      Draft непосредственно IESG.

      Обратите внимание, что простая публикация новой опции или типа
      сообщения в качестве Internet Draft не доводит автоматически опцию
      до сведения IESG. Автор новой опции или типа сообщения должен явно
      направить запрос о рассмотрении новой опции в DHC WG или IESG.

   4. Спецификация новой опции или типа сообщения проверяется IESG.
      Спецификация проверяется DHC WG (если она существует) или IETF.
      Если опция или тип сообщения принимается для включения в
      спецификацию DHCP, спецификация опции или типа сообщения публикуется
      в качестве RFC. Она может быть опубликована как RFC из ветви
      стандартов либо как RFC вне ветви стандартов.

   5. В момент публикации в качестве RFC IANA назначает новой опции или
      типу сообщения код опции DHCP или код типа сообщения.

4. Ссылки

[1] Droms, R., "Dynamic Host Configuration Protocol", RFC 2131, March
       1997.

   [2] Alexander, S. and R. Droms, "DHCP Options and BOOTP Vendor
       Extensions", RFC 2132, March 1997.

   [3] Droms, R. and K. Fong, "NetWare/IP Domain Name and Information",
       RFC 2142, November 1997.

   [4] Narten, T. and H. Alvestrand, "Guidelines for Writing an IANA
       Considerations Section in RFCs", BCP 26, RFC 2434, October 1998.

   [5] Droms, R., "Procedure for Defining New DHCP Options", RFC 2489,
       January 1999.

5. Изменения по сравнению с RFC 2489

Этот документ расширяет процедуры определения новых опций DHCP,
   определённые в RFC 2489 [5], включая в них определение новых типов
   сообщений DHCP. Формулировка, резервирующая коды опций, специфичные для
   сайта, усилена, чтобы подчеркнуть требование: коды опций, специфичные
   для сайта, не должны кодироваться в публично распространяемых
   реализациях DHCP.

6. Вопросы безопасности

Информация, создающая или обновляющая назначение кода опции или кода
   типа сообщения, должна быть аутентифицирована.

   Анализ вопросов безопасности требуется для всех вновь определяемых
   опций DHCP или типов сообщений. Описание вопросов безопасности в
   спецификации новых опций или типов сообщений должно быть настолько
   точным, насколько это возможно. Спецификация новой опции или типа
   сообщения может ссылаться на раздел "Security Considerations" в
   спецификации DHCP [1]; например (из "NetWare/IP Domain Name and
   Information" [3]):

      DHCP в настоящее время не предоставляет механизмов аутентификации
      или безопасности. Возможные уязвимости для атак обсуждаются в
      разделе 7 спецификации протокола DHCP [RFC 2131].

7. Соображения IANA

RFC 2132 и RFC 2489 предоставляли IANA указания о процедуре, которой
   она должна следовать при назначении номеров опций для новых опций DHCP
   или типов сообщений. Этот документ обновляет и заменяет эти указания.
   В частности, IANA предлагается назначать коды опций DHCP или коды типов
   сообщений только для опций или типов сообщений, одобренных для
   публикации в качестве RFC; то есть документов, одобренных посредством
   «консенсуса IETF», как он определён в RFC 2434 [4].

8. Адрес автора

Ralph Droms
   Computer Science Department
   323 Dana Engineering
   Bucknell University
   Lewisburg, PA 17837

   Phone: (570) 524-1145
   EMail: droms@bucknell.edu

9. Полное заявление об авторском праве

Copyright (C) The Internet Society (2000). All Rights Reserved.

   Этот документ и его переводы могут копироваться и предоставляться
   другим лицам, а производные работы, комментирующие или иным образом
   объясняющие его либо содействующие его реализации, могут подготавливаться,
   копироваться, публиковаться и распространяться полностью или частично,
   без ограничений любого рода, при условии, что приведённое выше
   уведомление об авторском праве и этот абзац включены во все такие копии
   и производные работы. Однако сам этот документ не может изменяться
   каким-либо образом, например путём удаления уведомления об авторском
   праве или ссылок на Internet Society либо другие интернет-организации,
   за исключением случаев, когда это необходимо для разработки стандартов
   Интернета, в которых должны соблюдаться процедуры в отношении авторских
   прав, определённые процессом Internet Standards, либо когда это
   требуется для его перевода на языки, отличные от английского.

   Предоставленные выше ограниченные разрешения являются бессрочными и не
   будут отозваны Internet Society, её правопреемниками или цессионариями.

   Этот документ и содержащаяся в нём информация предоставляются по
   принципу «КАК ЕСТЬ», И INTERNET SOCIETY И INTERNET ENGINEERING TASK
   FORCE ОТКАЗЫВАЮТСЯ ОТ ВСЕХ ГАРАНТИЙ, ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ,
   ВКЛЮЧАЯ, ПОМИМО ПРОЧЕГО, ЛЮБУЮ ГАРАНТИЮ ТОГО, ЧТО ИСПОЛЬЗОВАНИЕ
   СОДЕРЖАЩЕЙСЯ ЗДЕСЬ ИНФОРМАЦИИ НЕ НАРУШИТ КАКИХ-ЛИБО ПРАВ, ЛИБО ЛЮБЫЕ
   ПОДРАЗУМЕВАЕМЫЕ ГАРАНТИИ КОММЕРЧЕСКОЙ ПРИГОДНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ
   ОПРЕДЕЛЁННОЙ ЦЕЛИ.

Благодарность

Финансирование функции RFC Editor в настоящее время предоставляется
   Internet Society.