О документе
Internet Engineering Task Force (IETF) M.B. Jones
Request for Comments: 9728 Self-Issued Consulting
Категория: стандартизация P. Hunt
ISSN: 2070-1721 Independent Identity, Inc.
A. Parecki
Okta
Апрель 2025
Метаданные защищённого ресурса OAuth 2.0
1. Введение
Эта спецификация определяет формат метаданных, позволяющий клиентам
OAuth 2.0 и серверам авторизации получать информацию, необходимую
для взаимодействия с защищённым ресурсом OAuth 2.0. Структура и содержание
этой спецификации намеренно сделаны максимально аналогичными
(1) «OAuth 2.0 Dynamic Client Registration Protocol» [RFC7591], который
позволяет клиенту предоставлять метаданные о себе серверу авторизации
OAuth 2.0, и (2) «OAuth 2.0 Authorization Server Metadata» [RFC8414],
который позволяет клиенту получать метаданные о сервере авторизации
OAuth 2.0.
Способы, которыми клиент получает сведения о местоположении защищённого
ресурса, выходят за рамки этого документа. В некоторых случаях
местоположение может быть задано в клиенте вручную; например, почтовый
клиент может предоставлять интерфейс, позволяющий пользователю ввести
URL своего сервера JSON Meta Application Protocol (JMAP) [RFC8620].
В других случаях оно может быть обнаружено динамически; например,
пользователь может ввести свой адрес электронной почты в почтовом клиенте,
клиент может выполнить обнаружение с помощью WebFinger [RFC7033]
(способом, связанным с описанием в разделе 2 [OpenID.Discovery]), чтобы
найти сервер ресурсов, а затем клиент может получить метаданные сервера
ресурсов, чтобы найти сервер авторизации, который следует использовать
для получения разрешения на доступ к электронной почте пользователя.
Метаданные защищённого ресурса извлекаются из общеизвестного
местоположения в виде документа JSON [RFC8259], который содержит
сведения о возможностях ресурса и, необязательно, о его связях с другими
службами. Этот процесс описан в разделе 3.
Эти метаданные могут передаваться либо как сведения, заявленные самим
ресурсом, либо как набор подписанных значений метаданных, представленных
в виде утверждений в JSON Web Token (JWT) [JWT]. В случае JWT издатель
ручается за достоверность данных о защищённом ресурсе. Это аналогично
роли, которую выполняет заявление о программном обеспечении (software
statement) в динамической регистрации клиентов OAuth [RFC7591].
Каждый защищённый ресурс, публикующий метаданные о себе, размещает
собственный документ метаданных в общеизвестном местоположении,
детерминированно выводимом из URL защищённого ресурса, даже если сервер
ресурсов реализует несколько защищённых ресурсов. Это не позволяет
злоумышленникам публиковать метаданные, которые якобы описывают
защищённый ресурс, но в действительности не являются авторитетными
для этого защищённого ресурса, как описано в разделе 7.3.
В разделе 2 определены параметры метаданных, которые может публиковать
защищённый ресурс; они включают, например, сведения о поддерживаемых
областях доступа, способах предъявления клиентом токена доступа и многое
другое. Эти значения, такие как jwks_uri (см. раздел 2), могут
использоваться с другими спецификациями; например, открытые ключи,
опубликованные по адресу jwks_uri, могут использоваться для проверки
подписанных ответов ресурса, как описано в [FAPI.MessageSigning].
В разделе 5 описано использование WWW-Authenticate защищёнными ресурсами
для динамического информирования клиентов об URL метаданных этих
защищённых ресурсов. Такое использование WWW-Authenticate может
указывать на то, что метаданные защищённого ресурса могли измениться.
1.1. Обозначения требований и соглашения
Ключевые слова «ДОЛЖЕН (MUST)», «НЕ ДОЛЖЕН (MUST NOT)», «ДОЛЖЕН
(REQUIRED)», «ДОЛЖЕН (SHALL)», «НЕ ДОЛЖЕН (SHALL NOT)», «СЛЕДУЕТ
(SHOULD)», «НЕ СЛЕДУЕТ (SHOULD NOT)», «СЛЕДУЕТ (RECOMMENDED)»,
«НЕ СЛЕДУЕТ (NOT RECOMMENDED)», «МОЖЕТ (MAY)» и «НЕОБЯЗАТЕЛЬНО
(OPTIONAL)» в этом документе следует трактовать так, как описано
в BCP 14 [RFC2119] [RFC8174], тогда и только тогда, когда они записаны
полностью прописными буквами, как показано здесь.
Во всех случаях применения структур данных JSON Web Signature (JWS)
[JWS] и структур данных JSON Web Encryption (JWE) [JWE], рассматриваемых
в этой спецификации, используется JWS Compact Serialization или JWE
Compact Serialization; JWS JSON Serialization и JWE JSON Serialization
не используются. Выбор единственного способа сериализации призван
облегчить обеспечение совместимости.
1.2. Терминология
Эта спецификация использует термины «токен доступа» (access token),
«код авторизации» (authorization code), «сервер авторизации»
(authorization server), «клиент» (client), «аутентификация клиента»
(client authentication), «идентификатор клиента» (client identifier),
«защищённый ресурс» (protected resource) и «сервер ресурсов»
(resource server), определённые в OAuth 2.0 [RFC6749], а также термины
«имя утверждения» (Claim Name) и «JSON Web Token (JWT)», определённые
в «JSON Web Token (JWT)» [JWT].
Эта спецификация определяет следующий термин:
Идентификатор ресурса (Resource Identifier):
Идентификатор защищённого ресурса, представляющий собой URL,
который использует схему https и не содержит компонента фрагмента.
Как указано в разделе 2 [RFC8707], ему также НЕ СЛЕДУЕТ (SHOULD NOT)
содержать компонент запроса, однако признаётся, что существуют случаи,
в которых компонент запроса является полезной и необходимой частью
идентификатора ресурса. Метаданные защищённого ресурса публикуются
в местоположении .well-known [RFC8615], выводимом из этого
идентификатора ресурса, как описано в разделе 3.
2. Метаданные защищённого ресурса
Защищённые ресурсы могут иметь метаданные, описывающие их конфигурацию.
Следующие параметры метаданных защищённого ресурса используются в этой
спецификации и зарегистрированы в реестре «OAuth Protected Resource
Metadata», учреждённом в разделе 8.1:
resource
ДОЛЖЕН (REQUIRED) присутствовать. Идентификатор защищённого ресурса,
определённый в разделе 1.2.
authorization_servers
НЕОБЯЗАТЕЛЬНО (OPTIONAL). Массив JSON, содержащий список
идентификаторов издателей серверов авторизации OAuth, определённых
в [RFC8414], для серверов авторизации, которые можно использовать
с этим защищённым ресурсом. Защищённые ресурсы МОГУТ (MAY) не объявлять
некоторые поддерживаемые серверы авторизации даже при использовании
этого параметра. В некоторых сценариях использования множество
серверов авторизации невозможно перечислить; в таком случае этот
параметр метаданных не используется.
jwks_uri
НЕОБЯЗАТЕЛЬНО (OPTIONAL). URL документа JSON Web Key (JWK) Set [JWK]
защищённого ресурса. Этот документ содержит открытые ключи,
принадлежащие защищённому ресурсу, например ключ или ключи подписи,
которые сервер ресурсов использует для подписания ответов ресурса.
Этот URL ДОЛЖЕН (MUST) использовать схему https. Когда предоставляются
как ключи подписи, так и ключи шифрования, для всех ключей в наборе
JWK Set, на который указывает URL, ДОЛЖНО (REQUIRED) быть задано
значение параметра use (назначение открытого ключа), указывающее
предполагаемое применение каждого ключа.
scopes_supported
СЛЕДУЕТ (RECOMMENDED) включать. Массив JSON, содержащий список значений
областей доступа, определённых в OAuth 2.0 [RFC6749], которые
используются в запросах авторизации для запроса доступа к этому
защищённому ресурсу. Защищённые ресурсы МОГУТ (MAY) не объявлять
некоторые поддерживаемые значения областей доступа даже при
использовании этого параметра.
bearer_methods_supported
НЕОБЯЗАТЕЛЬНО (OPTIONAL). Массив JSON, содержащий список поддерживаемых
методов отправки токена на предъявителя OAuth 2.0 [RFC6750]
защищённому ресурсу. Определены значения ["header", "body", "query"],
соответствующие разделам 2.1, 2.2 и 2.3 [RFC6750]. Пустой массив []
можно использовать, чтобы указать, что ни один метод передачи токена
на предъявителя не поддерживается. Если эта запись опущена, никакие
поддерживаемые по умолчанию методы передачи токена на предъявителя
не подразумеваются; её отсутствие также не означает, что они
не поддерживаются.
resource_signing_alg_values_supported
НЕОБЯЗАТЕЛЬНО (OPTIONAL). Массив JSON, содержащий список алгоритмов
подписи JWS [JWS] (значений alg) [JWA], поддерживаемых защищённым
ресурсом для подписания ответов ресурса, например так, как описано
в [FAPI.MessageSigning]. Если эта запись опущена, никакие алгоритмы
по умолчанию не подразумеваются. Значение none НЕ ДОЛЖНО (MUST NOT)
использоваться.
resource_name
Имя защищённого ресурса, предназначенное для отображения конечному
пользователю и восприятия человеком. В метаданные защищённого ресурса
СЛЕДУЕТ (RECOMMENDED) включать это поле. Значение этого поля МОЖЕТ
(MAY) быть интернационализировано, как описано в разделе 2.1.
resource_documentation
НЕОБЯЗАТЕЛЬНО (OPTIONAL). URL страницы, содержащей информацию
для восприятия человеком, которую разработчики могут захотеть узнать
или в которой могут нуждаться при использовании защищённого ресурса.
Значение этого поля МОЖЕТ (MAY) быть интернационализировано,
как описано в разделе 2.1.
resource_policy_uri
НЕОБЯЗАТЕЛЬНО (OPTIONAL). URL страницы, содержащей информацию
для восприятия человеком о требованиях защищённого ресурса к тому,
как клиент может использовать данные, предоставленные защищённым
ресурсом. Значение этого поля МОЖЕТ (MAY) быть интернационализировано,
как описано в разделе 2.1.
resource_tos_uri
НЕОБЯЗАТЕЛЬНО (OPTIONAL). URL страницы, содержащей информацию
для восприятия человеком об условиях использования защищённого
ресурса. Значение этого поля МОЖЕТ (MAY) быть интернационализировано,
как описано в разделе 2.1.
tls_client_certificate_bound_access_tokens
НЕОБЯЗАТЕЛЬНО (OPTIONAL). Логическое значение, указывающее, поддерживает
ли защищённый ресурс токены доступа, привязанные к сертификату клиента
при взаимной аутентификации TLS [RFC8705]. Если параметр опущен,
значение по умолчанию — false.
authorization_details_types_supported
НЕОБЯЗАТЕЛЬНО (OPTIONAL). Массив JSON, содержащий список значений типов
подробных сведений об авторизации, поддерживаемых сервером ресурсов
при использовании параметра запроса authorization_details [RFC9396].
dpop_signing_alg_values_supported
НЕОБЯЗАТЕЛЬНО (OPTIONAL). Массив JSON, содержащий список значений alg
JWS (из реестра «JSON Web Signature and Encryption Algorithms»
[IANA.JOSE]), поддерживаемых сервером ресурсов для проверки JWT
с доказательствами Demonstrating Proof of Possession (DPoP) [RFC9449].
dpop_bound_access_tokens_required
НЕОБЯЗАТЕЛЬНО (OPTIONAL). Логическое значение, указывающее, всегда ли
защищённый ресурс требует использования токенов доступа, привязанных
к DPoP [RFC9449]. Если параметр опущен, значение по умолчанию — false.
Также МОГУТ (MAY) использоваться дополнительные параметры метаданных
защищённого ресурса.
2.1. Метаданные ресурса для восприятия человеком
Значения метаданных ресурса, предназначенные для восприятия человеком,
и значения метаданных ресурса, ссылающиеся на содержимое для восприятия
человеком, МОГУТ (MAY) быть представлены на нескольких языках
и с использованием нескольких систем письменности. Например, поля
resource_name, resource_documentation, resource_tos_uri
и resource_policy_uri могут иметь несколько значений метаданных
для разных локалей, чтобы облегчить использование в разных местах.
Для указания языков и систем письма к именам параметров метаданных ресурса добавляются языковые теги [BCP47], отделённые символом #. Поскольку имена членов, рассматриваемые в JSON [RFC8259], чувствительны к регистру, СЛЕДУЕТ (RECOMMENDED) записывать значения языковых тегов, используемых в именах утверждений (Claim Names), в том регистре символов, в котором они зарегистрированы в "Language Subtag Registry" [IANA.Language]. В частности, обычно названия языков записываются строчными буквами, названия регионов — прописными буквами, а языки — буквами в смешанном регистре. Однако, поскольку согласно [BCP47] значения языковых тегов нечувствительны к регистру, реализациям СЛЕДУЕТ (SHOULD) интерпретировать предоставленные значения языковых тегов без учёта регистра. Согласно рекомендациям [BCP47], значения языковых тегов, используемых в именах параметров метаданных, следует конкретизировать лишь настолько, насколько это необходимо. Например, во многих контекстах может быть достаточно fr вместо fr-CA или fr-FR.
Например, ресурс может представить своё имя на английском языке как "resource_name#en": "My Resource", а своё имя на итальянском языке как "resource_name#it": "La mia bella risorsa" в своих метаданных. Любое из этих имён или все они МОГУТ (MAY) отображаться конечному пользователю; выбор отображаемых имён определяется конфигурацией системы, предпочтениями пользователя или другими факторами.
Если какое-либо человекочитаемое поле передаётся без языкового тега, использующие его стороны НЕ ДОЛЖНЫ (MUST NOT) делать какие-либо предположения о языке, наборе символов или системе письма строкового значения, и строковое значение ДОЛЖНО (MUST) использоваться как есть везде, где оно представляется в пользовательском интерфейсе. Для содействия совместимости СЛЕДУЕТ (RECOMMENDED) для каждого вида предоставляемых человекочитаемых метаданных включать экземпляр соответствующего параметра метаданных без языковых тегов в дополнение к любым параметрам для конкретных языков; также СЛЕДУЕТ (RECOMMENDED), чтобы любые человекочитаемые поля, передаваемые без языковых тегов, содержали значения, пригодные для отображения в самых разных системах.
2.2. Подписанные метаданные защищённого ресурса
Помимо элементов JSON, значения метаданных также МОГУТ (MAY) предоставляться в виде значения signed_metadata, представляющего собой JSON Web Token (JWT) [JWT], который содержит совокупность утверждений о значениях метаданных защищённого ресурса. Набор параметров метаданных, которые могут использоваться в подписанных метаданных в качестве утверждений, определён в разделе 2. Подписанные метаданные ДОЛЖНЫ (MUST) быть подписаны цифровой подписью или защищены кодом аутентификации сообщения (Message Authentication Code, MAC) с использованием JSON Web Signature (JWS) [JWS] и ДОЛЖНЫ (MUST) содержать утверждение iss (issuer), обозначающее сторону, удостоверяющую утверждения в подписанных метаданных. Потребители метаданных МОГУТ (MAY) игнорировать подписанные метаданные, если они не поддерживают эту возможность. Если потребитель метаданных поддерживает подписанные метаданные, значения метаданных, передаваемые в подписанных метаданных, ДОЛЖНЫ (MUST) иметь приоритет над соответствующими значениями, передаваемыми с помощью обычных элементов JSON.
Подписанные метаданные включаются в JSON-объект метаданных защищённого ресурса с помощью следующего НЕОБЯЗАТЕЛЬНОГО (OPTIONAL) параметра метаданных:
signed_metadata
JWT, содержащий параметры метаданных защищённого ресурса в качестве утверждений. Это строковое значение, состоящее из всего подписанного JWT. Параметру signed_metadata НЕ СЛЕДУЕТ (SHOULD NOT) присутствовать в JWT в качестве утверждения; СЛЕДУЕТ (RECOMMENDED) отклонять любые метаданные, в которых это происходит.
3. Получение метаданных защищённого ресурса
Защищённые ресурсы, поддерживающие метаданные, ДОЛЖНЫ (MUST) обеспечивать доступность JSON-документа, содержащего метаданные согласно разделу 2, по URL, образованному вставкой строки общеизвестного URI в идентификатор защищённого ресурса между компонентом хоста и компонентами пути и/или запроса, если они имеются. По умолчанию используется строка общеизвестного URI /.well-known/oauth-protected-resource. Синтаксис и семантика .well-known определены в [RFC8615]. Используемый суффикс пути общеизвестного URI ДОЛЖЕН (MUST) быть зарегистрирован в реестре "Well-Known URIs" [IANA.well-known]. Примеры такого построения приведены в разделе 3.1.
Термин «приложение», используемый ниже (и в [RFC8414]), охватывает все компоненты, используемые для выполнения задачи в рамках варианта использования. К ним могут относиться клиенты OAuth, серверы авторизации, защищённые ресурсы и компоненты, не относящиеся к OAuth, включая код, выполняемый в каждом из них. Приложения создаются для решения конкретных задач и могут использовать множество компонентов и служб.
Различные приложения, использующие защищённые ресурсы OAuth специфичными для этих приложений способами, МОГУТ (MAY) определять и регистрировать разные суффиксы пути общеизвестного URI для публикации метаданных защищённых ресурсов, используемых этими приложениями. Например, если приложение Example использует защищённый ресурс OAuth специфичным для Example способом и ему необходимо публиковать специфичные для Example значения метаданных, оно может зарегистрировать и использовать суффикс пути URI example-protected-resource и публиковать документ метаданных по URL, образованному вставкой /.well-known/example-protected-resource между компонентом хоста и компонентами пути и/или запроса в идентификаторе защищённого ресурса. В качестве альтернативы многие такие приложения будут использовать строку общеизвестного URI по умолчанию /.well-known/oauth-protected-resource, которая является подходящим выбором для защищённых ресурсов OAuth общего назначения, и не будут регистрировать строку, специфичную для приложения.
Приложение OAuth 2.0, использующее эту спецификацию, ДОЛЖНО (MUST) указывать, какой суффикс общеизвестного URI оно будет использовать для этой цели. Один и тот же защищённый ресурс МОЖЕТ (MAY) публиковать свои метаданные по нескольким общеизвестным адресам, полученным из его идентификатора ресурса, — например, публиковать метаданные как по /.well-known/example-protected-resource, так и по /.well-known/oauth-protected-resource.
3.1. Запрос метаданных защищённого ресурса
Документ метаданных защищённого ресурса ДОЛЖЕН (MUST) запрашиваться с помощью HTTP-запроса GET по ранее указанному URL.
Если идентификатор ресурса — https://resource.example.com, а суффикс пути общеизвестного URI — oauth-protected-resource, потребитель метаданных для их получения выполнит следующий запрос, поскольку идентификатор ресурса не содержит компонента пути:
GET /.well-known/oauth-protected-resource HTTP/1.1
Host: resource.example.com
Если значение идентификатора ресурса содержит компонент пути или запроса, любой завершающий символ косой черты (/) после компонента хоста ДОЛЖЕН (MUST) быть удалён перед вставкой /.well-known/ и суффикса пути общеизвестного URI между компонентом хоста и компонентами пути и/или запроса. Если идентификатор ресурса — https://resource.example.com/resource1, а суффикс пути общеизвестного URI — oauth-protected-resource, потребитель метаданных для их получения выполнит следующий запрос, поскольку идентификатор ресурса содержит компонент пути:
GET /.well-known/oauth-protected-resource/resource1 HTTP/1.1
Host: resource.example.com
Использование компонентов пути позволяет поддерживать несколько ресурсов на одном хосте. Это требуется в некоторых конфигурациях хостинга с несколькими арендаторами. Такое использование .well-known предназначено для поддержки нескольких ресурсов на одном хосте; в отличие от его использования в [RFC8615], оно не предоставляет общую информацию о хосте.
3.2. Ответ с метаданными защищённого ресурса
Ответ представляет собой набор параметров метаданных о конфигурации защищённого ресурса. Успешный ответ ДОЛЖЕН (MUST) использовать код состояния HTTP 200 OK и возвращать JSON-объект с типом содержимого application/json, членами которого является набор параметров метаданных, представляющий собой подмножество параметров метаданных, определённых в разделе 2. Дополнительные параметры метаданных МОГУТ (MAY) определяться и использоваться; любые непонятные параметры метаданных ДОЛЖНЫ (MUST) игнорироваться.
Параметры с несколькими значениями представляются в виде массивов JSON. Параметры, не имеющие значений, ДОЛЖНЫ (MUST) отсутствовать в ответе.
В ответе с ошибкой используется соответствующее значение кода состояния HTTP.
Ниже приведён ненормативный пример ответа:
HTTP/1.1 200 OK
Content-Type: application/json
{
"resource":
"https://resource.example.com",
"authorization_servers":
["https://as1.example.com",
"https://as2.example.net"],
"bearer_methods_supported":
["header", "body"],
"scopes_supported":
["profile", "email", "phone"],
"resource_documentation":
"https://resource.example.com/resource_documentation.html"
}
3.3. Проверка метаданных защищённого ресурса
Возвращённое значение resource ДОЛЖНО (MUST) быть идентично значению идентификатора защищённого ресурса, в который был вставлен суффикс пути общеизвестного URI для создания URL, используемого для получения метаданных. Если эти значения не идентичны, данные, содержащиеся в ответе, НЕ ДОЛЖНЫ (MUST NOT) использоваться.
Если метаданные защищённого ресурса были получены по URL, возвращённому защищённым ресурсом через параметр resource_metadata поля WWW-Authenticate, то возвращённое значение resource ДОЛЖНО (MUST) быть идентично URL, который клиент использовал для выполнения запроса к серверу ресурсов. Если эти значения не идентичны, данные, содержащиеся в ответе, НЕ ДОЛЖНЫ (MUST NOT) использоваться.
Эти действия по проверке могут предотвратить атаки с выдачей себя за другую сторону, как описано в разделе 7.3.
Получатель ДОЛЖЕН (MUST) проверить, что любые подписанные метаданные были подписаны ключом, принадлежащим издателю, и что подпись действительна. Если подпись не проходит проверку или издатель не является доверенным, получателю СЛЕДУЕТ (SHOULD) рассматривать это как состояние ошибки.
4. Метаданные сервера авторизации
Для поддержки вариантов использования, в которых можно перечислить множество допустимых защищённых ресурсов для использования с сервером авторизации, эта спецификация определяет параметр метаданных сервера авторизации protected_resources, позволяющий серверу авторизации явно перечислить защищённые ресурсы. Обратите внимание: если множество допустимых серверов авторизации для использования с защищённым ресурсом также можно перечислить, списки в метаданных сервера авторизации и метаданных защищённого ресурса следует взаимно проверять на согласованность, когда эти списки используются профилем приложения.
Следующий параметр метаданных сервера авторизации определён этой спецификацией и зарегистрирован в реестре "OAuth Authorization Server Metadata", учреждённом в "OAuth 2.0 Authorization Server Metadata" [RFC8414].
protected_resources
НЕОБЯЗАТЕЛЬНО (OPTIONAL). Массив JSON, содержащий список идентификаторов защищённых ресурсов OAuth, которые могут использоваться с этим сервером авторизации. Серверы авторизации МОГУТ (MAY) не объявлять некоторые поддерживаемые защищённые ресурсы, даже когда этот параметр используется. В некоторых вариантах использования множество защищённых ресурсов невозможно перечислить; в таком случае этот параметр метаданных будет отсутствовать.
5. Использование WWW-Authenticate для метаданных защищённого ресурса
Защищённый ресурс МОЖЕТ (MAY) использовать поле заголовка HTTP-ответа WWW-Authenticate, рассматриваемое в [RFC9110], чтобы вернуть клиенту URL своих метаданных защищённого ресурса. Затем клиент может получить метаданные защищённого ресурса, как описано в разделе 3. После этого клиент может, например, определить, какой сервер авторизации использовать для ресурса, на основании полученных метаданных защищённого ресурса.
Типичный сквозной процесс, в котором это выполняется, выглядит следующим образом. Обратите внимание: хотя в этом примере используется процесс OAuth 2.0 с кодом авторизации, аналогичная последовательность также может быть реализована с любым другим процессом OAuth.
+------------+ +------------+ +------------------+
| Клиент | | Сервер | | Сервер |
| | | ресурсов | | авторизации |
+-----+------+ +-----+------+ +--------+---------+
| | |
| 1. Запрос ресурса | |
| ---------------------------> | |
| Без токена доступа | |
| | |
| | |
| 2. WWW-Authenticate | |
| <--------------------------- | |
| | |
| | |
| 3. Получение метаданных RS | |
| ---------------------------> | |
| | |
| | |
| 4. Ответ с метаданными RS | |
| <--------------------------- | |
| | |
+----------+---------------------+ | |
| 5. Проверка метаданных RS | | |
| Построение URL метаданных AS | | |
+----------+---------------------+ | |
| | |
| 6. Получение метаданных AS | |
| -----------------------------+------------------> |
| | |
| | |
| 7. Ответ с метаданными AS | |
| <----------------------------+------------------- |
| | |
+-+------------------------------+--------------------+-+
| 8–9. Процесс авторизации OAuth с кодом авторизации |
| Клиент получает токен доступа |
+-+------------------------------+--------------------+-+
| | |
| 10. Запрос ресурса | |
| ---------------------------> | |
| С токеном доступа | |
| | |
| | |
| 11. Ответ с ресурсом | |
| <--------------------------- | |
| | |
+-----+------+ +-----+------+ +--------+---------+
| Клиент | | Сервер | | Сервер |
| | | ресурсов | | авторизации |
+------------+ +------------+ +------------------+
Рисунок 1: Диаграмма последовательности
1. Клиент отправляет запрос к защищённому ресурсу, не предъявляя токен доступа.
2. Сервер ресурсов отвечает заголовком WWW-Authenticate, включающим URL метаданных защищённого ресурса.
3. Клиент получает метаданные защищённого ресурса по этому URL.
4. Сервер ресурсов отвечает метаданными защищённого ресурса в соответствии с разделом 3.2.
5. Клиент проверяет метаданные защищённого ресурса, как описано в разделе 3.3, и строит URL метаданных сервера авторизации на основе идентификатора издателя из метаданных ресурса в соответствии с [RFC8414].
6. Клиент отправляет запрос для получения метаданных сервера авторизации.
7. Сервер авторизации отвечает документом метаданных сервера авторизации в соответствии с [RFC8414].
8. Клиент направляет пользовательский агент на сервер авторизации для начала процесса авторизации.
9. Обмен в рамках авторизации завершается, и сервер авторизации возвращает клиенту токен доступа.
10. Клиент повторяет запрос ресурса из шага 1, предъявляя вновь полученный токен доступа.
11. Сервер ресурсов возвращает запрошенный защищённый ресурс.
5.1. Ответ WWW-Authenticate
Эта спецификация вводит новый параметр поля заголовка HTTP-ответа WWW-Authenticate для указания URL метаданных защищённого ресурса:
resource_metadata:
URL метаданных защищённого ресурса.
Приведённый ниже ответ представляет собой пример заголовка WWW-Authenticate, включающего идентификатор ресурса.
HTTP/1.1 401 Unauthorized
WWW-Authenticate: Bearer resource_metadata=
"https://resource.example.com/.well-known/oauth-protected-resource"
Код состояния HTTP в приведённом выше примере ответа определён в [RFC6750].
Этот параметр также МОЖЕТ (MAY) использоваться в ответах WWW-Authenticate со схемами авторизации, отличными от "Bearer" [RFC6750], например со схемой DPoP, определённой в [RFC9449].
Параметр resource_metadata МОЖЕТ (MAY) сочетаться с другими параметрами, определёнными в других расширениях, например с параметром max_age, определённым в [RFC9470].
5.2. Изменения метаданных ресурса
В любой момент и по любой причине, определяемой сервером ресурсов, защищённый ресурс МОЖЕТ (MAY) ответить новым запросом аутентификации WWW-Authenticate, включающим значение URL метаданных защищённого ресурса, чтобы указать, что его метаданные могли измениться. Если клиент получает такой ответ WWW-Authenticate, ему СЛЕДУЕТ (SHOULD) получить обновлённые метаданные защищённого ресурса и использовать полученные новые значения метаданных после их проверки, как описано в разделе 3.3. Помимо прочего, это позволяет серверу ресурсов менять используемые им серверы авторизации без какого-либо иного согласования с клиентами.
5.3. Идентификатор клиента и аутентификация клиента
Способ установления идентификатора клиента на сервере авторизации выходит за рамки этой спецификации.
Эта спецификация предназначена для развёртывания в сценариях, в которых клиент не располагает предварительными сведениями о сервере ресурсов, а сервер ресурсов может как располагать, так и не располагать предварительными сведениями о клиенте.
Существуют некоторые методы, с помощью которых нераспознанный клиент может воспользоваться сервером авторизации, например применение Dynamic Client Registration [RFC7591] для регистрации клиента до начала процесса авторизации. Будущие расширения OAuth могут определить альтернативы, например использование URL для идентификации клиентов.
5.4. Совместимость с другими методами аутентификации
Серверы ресурсов МОГУТ (MAY) возвращать другие заголовки WWW-Authenticate, указывающие различные схемы аутентификации. Это позволяет серверу ресурсов поддерживать клиентов, которые могут как реализовывать, так и не реализовывать эту спецификацию, а клиентам — выбирать предпочтительную схему аутентификации.
6. Операции со строками
Обработка некоторых сообщений OAuth 2.0 требует сравнения значений в сообщениях с известными значениями. Например, имена членов в ответе с метаданными могут сравниваться с конкретными именами членов, такими как resource. Однако сравнение строк Unicode [UNICODE] имеет существенные последствия для безопасности.
Поэтому сравнения строк JSON с другими строками Unicode ДОЛЖНЫ (MUST) выполняться следующим образом:
1. Удалить всё экранирование, применённое в JSON, чтобы получить массив кодовых точек Unicode.
2. Нормализация Unicode [USA15] НЕ ДОЛЖНА (MUST NOT) применяться ни на каком этапе ни к строке JSON, ни к строке, с которой она сравнивается.
3. Сравнение двух строк ДОЛЖНО (MUST) выполняться путём проверки равенства соответствующих кодовых точек Unicode.
Обратите внимание, что это та же процедура сравнения на равенство, которая описана в разделе 8.3 [RFC8259].
7. Соображения безопасности
7.1. Требования к TLS
Реализации ДОЛЖНЫ (MUST) поддерживать TLS. Они ДОЛЖНЫ (MUST) следовать указаниям [BCP195], в котором приведены рекомендации и требования по повышению безопасности развёрнутых служб, использующих TLS.
Использование TLS при обращении к URL метаданных защищённого ресурса защищает от раскрытия информации и её подмены.
7.2. Области доступа
Параметр scopes_supported представляет собой список областей доступа, о поддержке которых сервер ресурсов готов сообщить. Он не предназначен для указания на то, что клиенту OAuth следует запрашивать все области доступа из списка. Клиенту по-прежнему СЛЕДУЕТ (SHOULD) придерживаться передовых практик OAuth и запрашивать токены с как можно более ограниченной областью доступа для данной операции, как описано в разделе 2.3 документа "Best Current Practice for OAuth 2.0 Security" [RFC9700].
7.3. Атаки с выдачей себя за другой субъект
При выполнении запроса метаданных защищённого ресурса клиент ДОЛЖЕН (MUST) проверять сертификат TLS, как описано в [RFC9525]. Проверка того, что сертификат сервера действителен для URL идентификатора ресурса, предотвращает атаки с посредником и атаки на основе DNS. Эти атаки могут обманным путём заставить клиента использовать сервер ресурсов злоумышленника, что позволит выдать его за подлинный защищённый ресурс. Если злоумышленнику удастся это осуществить, он сможет получить доступ к ресурсам, к которым имеет доступ затронутый клиент, используя защищённый ресурс, за который он себя выдаёт.
Злоумышленник также может попытаться выдать себя за защищённый ресурс, опубликовав документ метаданных, который содержит параметр метаданных resource со значением URL идентификатора защищённого ресурса, за который он себя выдаёт, но при этом содержит информацию, выбранную злоумышленником. Если клиент примет такой документ, это позволит злоумышленнику выдать себя за этот защищённый ресурс. Чтобы предотвратить это, клиент ДОЛЖЕН (MUST) убедиться, что URL идентификатора ресурса, используемый им в качестве префикса запроса метаданных, в точности совпадает со значением параметра метаданных resource в полученном клиентом документе метаданных защищённого ресурса, как описано в разделе 3.3.
7.4. Токены доступа с ограничением по аудитории
Если клиент предполагает взаимодействовать с несколькими серверами ресурсов, ему СЛЕДУЕТ (SHOULD) запрашивать токены доступа с ограничением по аудитории, используя [RFC8707], а серверу авторизации СЛЕДУЕТ (SHOULD) поддерживать токены доступа с ограничением по аудитории.
Без токенов доступа с ограничением по аудитории вредоносный сервер ресурсов (RS1) может с помощью заголовка WWW-Authenticate заставить клиента запросить токен доступа с областью доступа, используемой подлинным сервером ресурсов (RS2), а после отправки клиентом запроса к RS1 этот сервер RS1 сможет повторно использовать токен доступа на RS2.
Хотя эта атака не становится возможной непосредственно благодаря этой спецификации и возможна при обычном развёртывании OAuth 2.0, использование динамически конфигурируемых клиентов несколько повышает её вероятность. Поэтому при использовании возможностей этой спецификации СЛЕДУЕТ (RECOMMENDED) использовать токены доступа с ограничением по аудитории и Resource Indicators [RFC8707].
7.5. Публикация метаданных в стандартном формате
Публикация информации о защищённом ресурсе в стандартном формате облегчает использование защищённого ресурса как легитимным клиентам, так и злоумышленникам. Независимо от того, публикует ли защищённый ресурс свои метаданные произвольным способом или в стандартном формате, определённом этой спецификацией, следует применять одни и те же меры защиты от атак, которые могут быть осуществлены с использованием этой информации.
7.6. Серверы авторизации
Для поддержки сценариев использования, в которых можно перечислить множество легитимных серверов авторизации, используемых с защищённым ресурсом, эта спецификация определяет параметр метаданных authorization_servers, позволяющий явно перечислить их. Обратите внимание: если множество легитимных защищённых ресурсов, используемых с сервером авторизации, также можно перечислить, то при использовании этих списков профилем приложения списки в метаданных защищённого ресурса и метаданных сервера авторизации следует перекрёстно проверять на согласованность.
Безопасное определение подходящих серверов авторизации для использования с защищённым ресурсом во всех сценариях использования выходит за рамки этой спецификации. Эта спецификация предполагает, что клиент располагает способом определения подходящих серверов авторизации для использования с защищённым ресурсом и что клиент использует правильные метаданные для каждого защищённого ресурса. Разработчикам реализаций необходимо учитывать, что, если клиент использует неподходящий сервер авторизации, злоумышленник может получить возможность действовать в качестве посреднического прокси между клиентом и действительным сервером авторизации, оставаясь при этом незамеченным сервером авторизации или клиентом.
Способы определения подходящих серверов авторизации для использования с защищённым ресурсом в общем случае зависят от приложения. Например, некоторые защищённые ресурсы используются с фиксированным сервером авторизации или набором серверов авторизации, местоположения которых могут быть известны благодаря внеполосным механизмам. Другой вариант, описанный в этой спецификации, — публикация защищённым ресурсом местоположений серверов авторизации в качестве значений метаданных. В других случаях множество серверов авторизации, которые можно использовать с защищённым ресурсом, может динамически изменяться в результате административных действий или изменений множества серверов авторизации, соблюдающих правила системы доверия. Возможны и многие другие способы определения подходящих связей между защищёнными ресурсами и серверами авторизации.
7.7. Подделка запросов на стороне сервера (SSRF)
Ожидается, что клиент OAuth получит метаданные сервера авторизации на основе значения издателя в метаданных сервера ресурсов. Поскольку эта спецификация позволяет клиентам взаимодействовать с серверами ресурсов (RS) и серверами авторизации (AS), о которых у них нет предварительных сведений, это создаёт риск атак с подделкой запросов на стороне сервера (Server-Side Request Forgery, SSRF) со стороны злоумышленников или вредоносных серверов ресурсов. Клиентам СЛЕДУЕТ (SHOULD) принимать надлежащие меры предосторожности против атак SSRF, например блокировать запросы к внутренним диапазонам IP-адресов. Дополнительные рекомендации приведены в памятке «SSRF Prevention Cheat Sheet» Open Worldwide Application Security Project (OWASP) [OWASP.SSRF].
7.8. Фишинг
Эта спецификация может применяться в сценарии, в котором нужный HTTP-ресурс определяется URL, выбранным пользователем. Если этот ресурс вредоносный или скомпрометирован, он может ввести пользователя в заблуждение, побудив его раскрыть учётные данные своей учётной записи или разрешить нежелательный доступ к возможностям, контролируемым OAuth. Этот риск уменьшается, но не устраняется при соблюдении передовых практик построения пользовательских интерфейсов OAuth, таких как предоставление пользователю понятного уведомления, отображение доменного имени сервера авторизации, поддержка устойчивых к фишингу аутентификаторов, привязанных к источнику (origin), поддержка использования менеджеров паролей и применение эвристических проверок, например проверки репутации домена.
7.9. Различия между неподписанными и подписанными метаданными
Целостность неподписанных метаданных защищается посредством использования TLS на сайте, где они размещены. Это означает, что их безопасность зависит от инфраструктуры открытых ключей Интернета с использованием X.509 (PKIX), как описано в [RFC9525]. Целостность подписанных метаданных дополнительно защищается подписью JWS, создаваемой издателем, которая не зависит от инфраструктуры открытых ключей Интернета.
При использовании неподписанных метаданных стороной, выпускающей метаданные, является сам защищённый ресурс, представленный значением resource в метаданных, тогда как при использовании подписанных метаданных сторона, выпускающая метаданные, представлена утверждением iss (issuer) в подписанных метаданных. При использовании подписанных метаданных приложения могут принимать решения о доверии на основе сведений об издателе, выполнившем подписание, — эти сведения недоступны при использовании неподписанных метаданных. Способ принятия таких решений о доверии выходит за рамки этой спецификации.
7.10. Кэширование метаданных
Метаданные защищённого ресурса получают с помощью HTTP-запроса GET, как указано в разделе 3.1. Применяются обычные правила кэширования HTTP, а это означает, что запрос GET может получить кэшированную копию содержимого вместо самой последней копии. Реализациям следует использовать директивы кэширования HTTP, такие как Cache-Control с max-age, определённые в [RFC9111], чтобы обеспечить кэширование полученных метаданных в течение подходящих периодов времени.
8. Вопросы IANA
Значения регистрируются в соответствии с процедурой Specification Required [RFC8126]. Запросы на регистрацию следует направлять по адресу <oauth-ext-review@ietf.org>, чтобы начать двухнедельный период рассмотрения. Однако для выделения значений до публикации окончательной версии спецификации назначенные эксперты могут одобрить регистрацию, как только убедятся, что спецификация будет завершена и опубликована. Однако если спецификация не будет завершена и опубликована своевременно, по оценке назначенных экспертов, назначенные эксперты могут запросить у IANA отзыв регистрации.
В запросах на регистрацию, направляемых в список рассылки для рассмотрения, следует использовать подходящую тему (например, "Request to register OAuth Protected Resource Metadata: example").
В течение периода рассмотрения назначенные эксперты одобряют или отклоняют запрос на регистрацию, сообщая об этом решении в список рассылки для рассмотрения и в IANA. Отказы следует сопровождать объяснением и, если применимо, рекомендациями о том, как добиться одобрения запроса. Если назначенные эксперты не отвечают, заявителям следует обратиться в IANA для передачи вопроса на более высокий уровень рассмотрения.
При рассмотрении предлагаемых регистраций назначенным экспертам следует применять следующие критерии: они должны быть уникальными, то есть им не следует дублировать существующую функциональность; они, вероятно, имеют общую применимость, а не предназначены для использования в одном приложении; они понятны и соответствуют назначению реестра.
IANA должна принимать обновления реестра только от назначенных экспертов, и ей следует направлять все запросы на регистрацию в список рассылки для рассмотрения.
Чтобы обеспечить рассмотрение решений о регистрации с учётом широкого круга сведений, следует назначить нескольких экспертов, представляющих точки зрения различных приложений, использующих эту спецификацию. В случаях, когда регистрация может восприниматься как конфликт интересов для конкретного эксперта, этому эксперту следует положиться на суждение других экспертов.
Список рассылки используется для публичного рассмотрения запросов на регистрацию, что позволяет как назначенным экспертам, так и другим заинтересованным сторонам высказывать замечания по предлагаемым регистрациям. Назначенные эксперты могут выделять значения до публикации окончательной спецификации. Это позволяет авторам заблаговременно получать рекомендации назначенных экспертов, чтобы любые выявленные проблемы можно было устранить до публикации окончательной спецификации.
8.1. Реестр OAuth Protected Resource Metadata
Эта спецификация учреждает реестр "OAuth Protected Resource Metadata" для имён метаданных защищённых ресурсов OAuth 2.0. В реестре указываются параметр метаданных защищённого ресурса и ссылка на спецификацию, которая его определяет.
8.1.1. Шаблон регистрации
Имя метаданных:
Запрашиваемое имя (например, "resource"). Это имя чувствительно к регистру. Имена не могут совпадать с другими зарегистрированными именами при сравнении без учёта регистра, если только назначенные эксперты не укажут вескую причину для такого исключения.
Описание метаданных:
Краткое описание метаданных (например, «URL идентификатора ресурса»).
Ответственный за изменения:
Для RFC потока IETF укажите "IETF". Для остальных укажите имя ответственной стороны. Можно также включить другие сведения (например, почтовый адрес, адрес электронной почты, URI домашней страницы).
Документ(ы) спецификации:
Ссылка на документ или документы, определяющие параметр, желательно с URI, по которым можно получить копии документов. Можно также указать соответствующие разделы, но это не обязательно.
8.1.2. Начальное содержимое реестра
Имя метаданных: resource
Описание метаданных: URL идентификатора защищённого ресурса
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: authorization_servers
Описание метаданных: Массив JSON, содержащий список идентификаторов издателей серверов авторизации OAuth
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: jwks_uri
Описание метаданных: URL документа JWK Set защищённого ресурса
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: scopes_supported
Описание метаданных: Массив JSON, содержащий список значений области доступа OAuth 2.0, которые используются в запросах авторизации для запроса доступа к этому защищённому ресурсу
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: bearer_methods_supported
Описание метаданных: Массив JSON, содержащий список методов предъявления токенов на предъявителя OAuth 2.0, которые поддерживает этот защищённый ресурс
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: resource_signing_alg_values_supported
Описание метаданных: Массив JSON, содержащий список алгоритмов подписи JWS (значений alg), поддерживаемых защищённым ресурсом для подписанного содержимого
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: resource_name
Описание метаданных: Человекочитаемое имя защищённого ресурса
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: resource_documentation
Описание метаданных: URL страницы, содержащей человекочитаемую информацию, которую разработчики могут захотеть узнать или которая может понадобиться им при использовании защищённого ресурса
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: resource_policy_uri
Описание метаданных: URL страницы, содержащей человекочитаемую информацию о требованиях защищённого ресурса к тому, как клиент может использовать данные, предоставляемые защищённым ресурсом
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: resource_tos_uri
Описание метаданных: URL страницы, содержащей человекочитаемую информацию об условиях обслуживания защищённого ресурса
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: tls_client_certificate_bound_access_tokens
Описание метаданных: Логическое значение, указывающее на поддержку защищённым ресурсом токенов доступа, привязанных к клиентскому сертификату взаимной TLS-аутентификации
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: authorization_details_types_supported
Описание метаданных: Массив JSON, содержащий список значений типа подробных сведений об авторизации, поддерживаемых сервером ресурсов при использовании параметра запроса authorization_details
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: dpop_signing_alg_values_supported
Описание метаданных: Массив JSON, содержащий список значений alg JWS, поддерживаемых сервером ресурсов для проверки JWT доказательства DPoP
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: dpop_bound_access_tokens_required
Описание метаданных: Логическое значение, определяющее, всегда ли защищённый ресурс требует использования токенов доступа, привязанных к DPoP
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2 RFC 9728
Имя метаданных: signed_metadata
Описание метаданных: Подписанный JWT, содержащий параметры метаданных о защищённом ресурсе в виде утверждений
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 2.2 RFC 9728
8.2. Реестр OAuth Authorization Server Metadata
IANA зарегистрировала следующий параметр метаданных сервера авторизации в реестре "OAuth Authorization Server Metadata", учреждённом в "OAuth 2.0 Authorization Server Metadata" [RFC8414].
8.2.1. Содержимое реестра
Имя метаданных: protected_resources
Описание метаданных: Массив JSON, содержащий список идентификаторов ресурсов для защищённых ресурсов OAuth
Ответственный за изменения: IETF
Документ(ы) спецификации: Раздел 4 RFC 9728
8.3. Реестр Well-Known URIs
Эта спецификация регистрирует общеизвестный URI, определённый в разделе 3, в реестре "Well-Known URIs" [IANA.well-known].
8.3.1. Содержимое реестра
Суффикс URI: oauth-protected-resource
Ссылка: Раздел 3 RFC 9728
Статус: permanent
Ответственный за изменения: IETF
Связанная информация: (none)
9.1. Нормативные ссылки
[BCP195] Best Current Practice 195,
<https://www.rfc-editor.org/info/bcp195>.
На момент написания этот BCP включает следующие документы:
Moriarty, K. and S. Farrell, "Deprecating TLS 1.0 and TLS
1.1", BCP 195, RFC 8996, DOI 10.17487/RFC8996, March 2021,
<https://www.rfc-editor.org/info/rfc8996>.
Sheffer, Y., Saint-Andre, P., and T. Fossati,
"Recommendations for Secure Use of Transport Layer
Security (TLS) and Datagram Transport Layer Security
(DTLS)", BCP 195, RFC 9325, DOI 10.17487/RFC9325, November
2022, <https://www.rfc-editor.org/info/rfc9325>.
[BCP47] Best Current Practice 47,
<https://www.rfc-editor.org/info/bcp47>.
На момент написания этот BCP включает следующие документы:
Phillips, A., Ed. and M. Davis, Ed., "Matching of Language
Tags", BCP 47, RFC 4647, DOI 10.17487/RFC4647, September
2006, <https://www.rfc-editor.org/info/rfc4647>.
Phillips, A., Ed. and M. Davis, Ed., "Tags for Identifying
Languages", BCP 47, RFC 5646, DOI 10.17487/RFC5646,
September 2009, <https://www.rfc-editor.org/info/rfc5646>.
[IANA.Language]
IANA, "Language Subtag Registry",
<https://www.iana.org/assignments/language-subtag-registry>.
[JWA] Jones, M., "JSON Web Algorithms (JWA)", RFC 7518,
DOI 10.17487/RFC7518, May 2015,
<https://www.rfc-editor.org/info/rfc7518>.
[JWE] Jones, M. and J. Hildebrand, "JSON Web Encryption (JWE)",
RFC 7516, DOI 10.17487/RFC7516, May 2015,
<https://www.rfc-editor.org/info/rfc7516>.
[JWK] Jones, M., "JSON Web Key (JWK)", RFC 7517,
DOI 10.17487/RFC7517, May 2015,
<https://www.rfc-editor.org/info/rfc7517>.
[JWS] Jones, M., Bradley, J., and N. Sakimura, "JSON Web
Signature (JWS)", RFC 7515, DOI 10.17487/RFC7515, May
2015, <https://www.rfc-editor.org/info/rfc7515>.
[JWT] Jones, M., Bradley, J., and N. Sakimura, "JSON Web Token
(JWT)", RFC 7519, DOI 10.17487/RFC7519, May 2015,
<https://www.rfc-editor.org/info/rfc7519>.
[RFC2119] Bradner, S., "Key words for use in RFCs to Indicate
Requirement Levels", BCP 14, RFC 2119,
DOI 10.17487/RFC2119, March 1997,
<https://www.rfc-editor.org/info/rfc2119>.
[RFC6749] Hardt, D., Ed., "The OAuth 2.0 Authorization Framework",
RFC 6749, DOI 10.17487/RFC6749, October 2012,
<https://www.rfc-editor.org/info/rfc6749>.
[RFC6750] Jones, M. and D. Hardt, "The OAuth 2.0 Authorization
Framework: Bearer Token Usage", RFC 6750,
DOI 10.17487/RFC6750, October 2012,
<https://www.rfc-editor.org/info/rfc6750>.
[RFC7591] Richer, J., Ed., Jones, M., Bradley, J., Machulak, M., and
P. Hunt, "OAuth 2.0 Dynamic Client Registration Protocol",
RFC 7591, DOI 10.17487/RFC7591, July 2015,
<https://www.rfc-editor.org/info/rfc7591>.
[RFC8126] Cotton, M., Leiba, B., and T. Narten, "Guidelines for
Writing an IANA Considerations Section in RFCs", BCP 26,
RFC 8126, DOI 10.17487/RFC8126, June 2017,
<https://www.rfc-editor.org/info/rfc8126>.
[RFC8174] Leiba, B., "Ambiguity of Uppercase vs Lowercase in RFC
2119 Key Words", BCP 14, RFC 8174, DOI 10.17487/RFC8174,
May 2017, <https://www.rfc-editor.org/info/rfc8174>.
[RFC8259] Bray, T., Ed., "The JavaScript Object Notation (JSON) Data
Interchange Format", STD 90, RFC 8259,
DOI 10.17487/RFC8259, December 2017,
<https://www.rfc-editor.org/info/rfc8259>.
[RFC8414] Jones, M., Sakimura, N., and J. Bradley, "OAuth 2.0
Authorization Server Metadata", RFC 8414,
DOI 10.17487/RFC8414, June 2018,
<https://www.rfc-editor.org/info/rfc8414>.
[RFC8615] Nottingham, M., "Well-Known Uniform Resource Identifiers
(URIs)", RFC 8615, DOI 10.17487/RFC8615, May 2019,
<https://www.rfc-editor.org/info/rfc8615>.
[RFC8705] Campbell, B., Bradley, J., Sakimura, N., and T.
Lodderstedt, "OAuth 2.0 Mutual-TLS Client Authentication
and Certificate-Bound Access Tokens", RFC 8705,
DOI 10.17487/RFC8705, February 2020,
<https://www.rfc-editor.org/info/rfc8705>.
[RFC8707] Campbell, B., Bradley, J., and H. Tschofenig, "Resource
Indicators for OAuth 2.0", RFC 8707, DOI 10.17487/RFC8707,
February 2020, <https://www.rfc-editor.org/info/rfc8707>.
[RFC9110] Fielding, R., Ed., Nottingham, M., Ed., and J. Reschke,
Ed., "HTTP Semantics", STD 97, RFC 9110,
DOI 10.17487/RFC9110, June 2022,
<https://www.rfc-editor.org/info/rfc9110>.
[RFC9111] Fielding, R., Ed., Nottingham, M., Ed., and J. Reschke,
Ed., "HTTP Caching", STD 98, RFC 9111,
DOI 10.17487/RFC9111, June 2022,
<https://www.rfc-editor.org/info/rfc9111>.
[RFC9396] Lodderstedt, T., Richer, J., and B. Campbell, "OAuth 2.0
Rich Authorization Requests", RFC 9396,
DOI 10.17487/RFC9396, May 2023,
<https://www.rfc-editor.org/info/rfc9396>.
[RFC9449] Fett, D., Campbell, B., Bradley, J., Lodderstedt, T.,
Jones, M., and D. Waite, "OAuth 2.0 Demonstrating Proof of
Possession (DPoP)", RFC 9449, DOI 10.17487/RFC9449,
September 2023, <https://www.rfc-editor.org/info/rfc9449>.
[RFC9525] Saint-Andre, P. and R. Salz, "Service Identity in TLS",
RFC 9525, DOI 10.17487/RFC9525, November 2023,
<https://www.rfc-editor.org/info/rfc9525>.
[UNICODE] The Unicode Consortium, "The Unicode Standard",
<https://www.unicode.org/versions/latest/>.
[USA15] Whistler, K., Ed., "Unicode Normalization Forms", Unicode
Standard Annex #15, 14 August 2024,
<https://www.unicode.org/reports/tr15/>.
9.2. Информационные ссылки
[FAPI.MessageSigning]
Tonge, D. and D. Fett, "FAPI 2.0 Message Signing (Draft)",
24 March 2023,
<https://openid.net/specs/fapi-2_0-message-signing.html>.
[IANA.JOSE]
IANA, "JSON Web Signature and Encryption Algorithms",
<https://www.iana.org/assignments/jose>.
[IANA.well-known]
IANA, "Well-Known URIs",
<https://www.iana.org/assignments/well-known-uris>.
[OpenID.Discovery]
Sakimura, N., Bradley, J., Jones, M., and E. Jay, "OpenID
Connect Discovery 1.0 incorporating errata set 2", 15
December 2023, <https://openid.net/specs/openid-connect-discovery-1_0.html>.
[OWASP.SSRF]
OWASP Foundation, "OWASP Server-Side Request Forgery
Prevention Cheat Sheet",
<https://cheatsheetseries.owasp.org/cheatsheets/Server_Side_Request_Forgery_Prevention_Cheat_Sheet.html>.
[RFC7033] Jones, P., Salgueiro, G., Jones, M., and J. Smarr,
"WebFinger", RFC 7033, DOI 10.17487/RFC7033, September
2013, <https://www.rfc-editor.org/info/rfc7033>.
[RFC8620] Jenkins, N. and C. Newman, "The JSON Meta Application
Protocol (JMAP)", RFC 8620, DOI 10.17487/RFC8620, July
2019, <https://www.rfc-editor.org/info/rfc8620>.
[RFC9470] Bertocci, V. and B. Campbell, "OAuth 2.0 Step Up
Authentication Challenge Protocol", RFC 9470,
DOI 10.17487/RFC9470, September 2023,
<https://www.rfc-editor.org/info/rfc9470>.
[RFC9700] Lodderstedt, T., Bradley, J., Labunets, A., and D. Fett,
"Best Current Practice for OAuth 2.0 Security", BCP 240,
RFC 9700, DOI 10.17487/RFC9700, January 2025,
<https://www.rfc-editor.org/info/rfc9700>.