⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC70152013-09-01

Flow Aggregation for the IP Flow Information Export (IPFIX) Protocol

Flow Aggregation for the IP Flow Information Export (IPFIX) Protocol

This document provides a common implementation-independent basis for the interoperable application of the IP Flow Information Export (IPFIX) protocol to the handling of Aggregated Flows, which are IPFIX Flows representing packets from multiple Original Flows sharing some set of common properties. It does this through a detailed terminology and a descriptive Intermediate Aggregation Process archite…

RFC70142013-09-01

Flow Selection Techniques

Flow Selection Techniques

The Intermediate Flow Selection Process is the process of selecting a subset of Flows from all observed Flows. The Intermediate Flow Selection Process may be located at an IP Flow Information Export (IPFIX) Exporter or Collector, or within an IPFIX Mediator. It reduces the effort of post-processing Flow data and transferring Flow Records. This document describes motivations for using the Intermedi…

RFC70132013-09-01

Guidelines for Authors and Reviewers of IP Flow Information Export (IPFIX) Information Elements

Guidelines for Authors and Reviewers of IP Flow Information Export (IPFIX) Information Elements

This document provides guidelines for how to write definitions of new Information Elements for the IP Flow Information Export (IPFIX) protocol. It provides instructions on using the proper conventions for Information Elements to be registered in the IANA IPFIX Information Element registry, and provides guidelines for expert reviewers to evaluate new registrations.

RFC70122013-09-01

Information Model for IP Flow Information Export (IPFIX)

Information Model for IP Flow Information Export (IPFIX)

This document defines the data types and management policy for the information model for the IP Flow Information Export (IPFIX) protocol. This information model is maintained as the IANA "IPFIX Information Elements" registry, the initial contents of which were defined by RFC 5102. This information model is used by the IPFIX protocol for encoding measured traffic information and information related…

RFC70112013-09-01

Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of Flow Information

Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of Flow Information

This document specifies the IP Flow Information Export (IPFIX) protocol, which serves as a means for transmitting Traffic Flow information over the network. In order to transmit Traffic Flow information from an Exporting Process to a Collecting Process, a common representation of flow data and a standard means of communicating them are required. This document describes how the IPFIX Data and Templ…

RFC70102013-09-01

IPv6 Site Renumbering Gap Analysis

IPv6 Site Renumbering Gap Analysis

This document briefly introduces the existing mechanisms that could be utilized for IPv6 site renumbering and tries to cover most of the explicit issues and requirements associated with IPv6 renumbering. The content is mainly a gap analysis that provides a basis for future works to identify and develop solutions or to stimulate such development as appropriate. The gap analysis is organized by the …

RFC70092013-08-01

OAuth 2.0 Token Revocation

OAuth 2.0 Token Revocation

This document proposes an additional endpoint for OAuth authorization servers, which allows clients to notify the authorization server that a previously obtained refresh or access token is no longer needed. This allows the authorization server to clean up security credentials. A revocation request will invalidate the actual token and, if applicable, other tokens based on the same authorization gra…

RFC70082013-08-01

A Description of the KCipher-2 Encryption Algorithm

A Description of the KCipher-2 Encryption Algorithm

This document describes the KCipher-2 encryption algorithm. KCipher-2 is a stream cipher with a 128-bit key and a 128-bit initialization vector. Since the algorithm for KCipher-2 was published in 2007, security and efficiency have been rigorously evaluated through academic and industrial studies. As of the publication of this document, no security vulnerabilities have been found. KCipher-2 offers …

RFC70072013-08-01

Update to Remove DVI4 from the Recommended Codecs for the RTP Profile for Audio and Video Conferences with Minimal Control (RTP/AVP)

Update to Remove DVI4 from the Recommended Codecs for the RTP Profile for Audio and Video Conferences with Minimal Control (RTP/AVP)

The RTP Profile for Audio and Video Conferences with Minimal Control (RTP/AVP) is the basis for many other profiles, such as the Secure Real-time Transport Protocol (RTP/SAVP), the Extended RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/AVPF), and the Extended Secure RTP Profile for RTCP-Based Feedback (RTP/SAVPF). This document updates RFC 3551, the RTP/AVP profil…

RFC70062013-09-01

Miscellaneous Capabilities Negotiation in the Session Description Protocol (SDP)

Miscellaneous Capabilities Negotiation in the Session Description Protocol (SDP)

The Session Description Protocol (SDP) has been extended with a capability negotiation mechanism framework that allows the endpoints to negotiate transport protocols and attributes. This framework has been extended with a media capabilities negotiation mechanism that allows endpoints to negotiate additional media-related capabilities. This negotiation is embedded into the widely used SDP offer/ans…

RFC70052013-09-01

RTP Control Protocol (RTCP) Extended Report (XR) Block for De-Jitter Buffer Metric Reporting

RTP Control Protocol (RTCP) Extended Report (XR) Block for De-Jitter Buffer Metric Reporting

This document defines an RTP Control Protocol (RTCP) Extended Report (XR) block that allows the reporting of de-jitter buffer metrics for a range of RTP applications.

RFC70042013-09-01

RTP Control Protocol (RTCP) Extended Report (XR) Blocks for Summary Statistics Metrics Reporting

RTP Control Protocol (RTCP) Extended Report (XR) Blocks for Summary Statistics Metrics Reporting

This document defines three RTP Control Protocol (RTCP) Extended Report (XR) blocks that allow the reporting of loss, duplication, and discard summary statistics metrics in a range of RTP applications.

RFC70032013-09-01

RTP Control Protocol (RTCP) Extended Report (XR) Block for Burst/Gap Discard Metric Reporting

RTP Control Protocol (RTCP) Extended Report (XR) Block for Burst/Gap Discard Metric Reporting

This document defines an RTP Control Protocol (RTCP) Extended Report (XR) block that allows the reporting of burst and gap discard metrics for use in a range of RTP applications.

RFC70022013-09-01

RTP Control Protocol (RTCP) Extended Report (XR) Block for Discard Count Metric Reporting

RTP Control Protocol (RTCP) Extended Report (XR) Block for Discard Count Metric Reporting

This document defines an RTP Control Protocol (RTCP) Extended Report (XR) block that allows the reporting of a simple discard count metric for use in a range of RTP applications.

RFC70012013-09-01

Message Header Field for Indicating Message Authentication Status

Message Header Field for Indicating Message Authentication Status

This document specifies a message header field called Authentication- Results for use with electronic mail messages to indicate the results of message authentication efforts. Any receiver-side software, such as mail filters or Mail User Agents (MUAs), can use this header field to relay that information in a convenient and meaningful way to users or to make sorting and filtering decisions.

RFC69982013-08-01

A Mechanism to Measure the Routing Metrics along a Point-to-Point Route in a Low-Power and Lossy Network

A Mechanism to Measure the Routing Metrics along a Point-to-Point Route in a Low-Power and Lossy Network

This document specifies a mechanism that enables a Routing Protocol for Low-power and Lossy Networks (RPL) router to measure the aggregated values of given routing metrics along an existing route towards another RPL router, thereby allowing the router to decide if it wants to initiate the discovery of a better route.

RFC69972013-08-01

Reactive Discovery of Point-to-Point Routes in Low-Power and Lossy Networks

Reactive Discovery of Point-to-Point Routes in Low-Power and Lossy Networks

This document specifies a point-to-point route discovery mechanism, complementary to the Routing Protocol for Low-power and Lossy Networks (RPL) core functionality. This mechanism allows an IPv6 router to discover "on demand" routes to one or more IPv6 routers in a Low-power and Lossy Network (LLN) such that the discovered routes meet specified metrics constraints.

RFC69962013-07-01

Autonomous System (AS) Reservation for Private Use

Autonomous System (AS) Reservation for Private Use

This document describes the reservation of Autonomous System Numbers (ASNs) that are for Private Use only, known as Private Use ASNs, and provides operational guidance on their use. This document enlarges the total space available for Private Use ASNs by documenting the reservation of a second, larger range and updates RFC 1930 by replacing Section 10 of that document.

RFC69942013-08-01

Shared Use of Experimental TCP Options

Shared Use of Experimental TCP Options

This document describes how the experimental TCP option codepoints can concurrently support multiple TCP extensions, even within the same connection, using a new IANA TCP experiment identifier. This approach is robust to experiments that are not registered and to those that do not use this sharing mechanism. It is recommended for all new TCP options that use these codepoints.

RFC69932013-07-01

Instant Messaging and Presence Purpose for the Call-Info Header Field in the Session Initiation Protocol (SIP)

Instant Messaging and Presence Purpose for the Call-Info Header Field in the Session Initiation Protocol (SIP)

This document defines and registers a value of "impp" ("instant messaging and presence protocol") for the "purpose" header field parameter of the Call-Info header field in the Session Initiation Protocol (SIP).

RFC69922013-07-01

Routing for IPv4-Embedded IPv6 Packets

Routing for IPv4-Embedded IPv6 Packets

This document describes a routing scenario where IPv4 packets are transported over an IPv6 network, based on the methods described in RFCs 6145 and 6052, along with a separate OSPFv3 routing table for IPv4-embedded IPv6 routes in the IPv6 network.

RFC69912013-07-01

Common YANG Data Types

Common YANG Data Types

This document introduces a collection of common data types to be used with the YANG data modeling language. This document obsoletes RFC 6021.

RFC69902013-08-01

RTP Control Protocol (RTCP) Extended Report (XR) Block for MPEG-2 Transport Stream (TS) Program Specific Information (PSI) Independent Decodability Statistics Metrics Reporting

RTP Control Protocol (RTCP) Extended Report (XR) Block for MPEG-2 Transport Stream (TS) Program Specific Information (PSI) Independent Decodability Statistics Metrics Reporting

An MPEG-2 Transport Stream (TS) is a standard container format used in the transmission and storage of multimedia data. Unicast/ multicast MPEG-2 TS over RTP is widely deployed in IPTV systems. This document defines an RTP Control Protocol (RTCP) Extended Report (XR) block that allows the reporting of MPEG-2 TS decodability statistics metrics related to transmissions of MPEG-2 TS over RTP. The met…

RFC69892013-07-01

Additional Diffie-Hellman Tests for the Internet Key Exchange Protocol Version 2 (IKEv2)

Additional Diffie-Hellman Tests for the Internet Key Exchange Protocol Version 2 (IKEv2)

This document adds a small number of mandatory tests required for the secure operation of the Internet Key Exchange Protocol version 2 (IKEv2) with elliptic curve groups. No change is required to IKE implementations that use modular exponential groups, other than a few rarely used so-called Digital Signature Algorithm (DSA) groups. This document updates the IKEv2 protocol, RFC 5996.

RFC69882013-09-01

Requirements for Energy Management

Requirements for Energy Management

This document defines requirements for standards specifications for Energy Management. The requirements defined in this document are concerned with monitoring functions as well as control functions. Monitoring functions include identifying energy-managed devices and their components, as well as monitoring their Power States, Power Inlets, Power Outlets, actual power, Power Attributes, received ene…

RFC69872013-09-01

OSPF Stub Router Advertisement

OSPF Stub Router Advertisement

This document describes a backward-compatible technique that may be used by OSPF (Open Shortest Path First) implementations to advertise a router's unavailability to forward transit traffic or to lower the preference level for the paths through such a router. This document obsoletes RFC 3137.

RFC69862013-08-01

GOST R 34.11-2012: Hash Function

GOST R 34.11-2012: Hash Function

This document is intended to be a source of information about the Russian Federal standard hash function (GOST R 34.11-2012), which is one of the Russian cryptographic standard algorithms (called GOST algorithms). This document updates RFC 5831.

RFC69852013-07-01

IMIX Genome: Specification of Variable Packet Sizes for Additional Testing

IMIX Genome: Specification of Variable Packet Sizes for Additional Testing

Benchmarking methodologies have always relied on test conditions with constant packet sizes, with the goal of understanding what network device capability has been tested. Tests with a constant packet size reveal device capabilities but differ significantly from the conditions encountered in operational deployment, so additional tests are sometimes conducted with a mixture of packet sizes, or "IMI…

RFC69842013-08-01

Interoperability Report for Forwarding and Control Element Separation (ForCES)

Interoperability Report for Forwarding and Control Element Separation (ForCES)

This document captures the results of the second Forwarding and Control Element Separation (ForCES) interoperability test that took place on February 24-25, 2011, in the Internet Technology Lab (ITL) at Zhejiang Gongshang University, China. The results of the first ForCES interoperability test were reported in RFC 6053, and this document updates RFC 6053 by providing further interoperability resul…

RFC69832013-07-01

Models for HTTP-Adaptive-Streaming-Aware Content Distribution Network Interconnection (CDNI)

Models for HTTP-Adaptive-Streaming-Aware Content Distribution Network Interconnection (CDNI)

This document presents thoughts on the potential impact of supporting HTTP Adaptive Streaming (HAS) technologies in Content Distribution Network Interconnection (CDNI) scenarios. The intent is to present the authors' analysis of the CDNI-HAS problem space and discuss different options put forward by the authors (and by others during informal discussions) on how to deal with HAS in the context of C…