⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC69212013-04-01

Design Considerations for Faster-Than-Light (FTL) Communication

Design Considerations for Faster-Than-Light (FTL) Communication

We are approaching the time when we will be able to communicate faster than the speed of light. It is well known that as we approach the speed of light, time slows down. Logically, it is reasonable to assume that as we go faster than the speed of light, time will reverse. The major consequence of this for Internet protocols is that packets will arrive before they are sent. This will have a major i…

RFC69202013-04-01

Naming Things with Hashes

Naming Things with Hashes

This document defines a set of ways to identify a thing (a digital object in this case) using the output from a hash function. It specifies a new URI scheme for this purpose, a way to map these to HTTP URLs, and binary and human-speakable formats for these names. The various formats are designed to support, but not require, a strong link to the referenced object, such that the referenced object ma…

RFC69192013-04-01

Further Key Words for Use in RFCs to Indicate Requirement Levels

Further Key Words for Use in RFCs to Indicate Requirement Levels

RFC 2119 defines a standard set of key words for describing requirements of a specification. Many IETF documents have found that these words cannot accurately capture the nuanced requirements of their specification. This document defines additional key words that can be used to address alternative requirements scenarios. Authors who follow these guidelines should incorporate this phrase near the b…

RFC69182013-04-01

Formally Deprecating Some ICMPv4 Message Types

Formally Deprecating Some ICMPv4 Message Types

A number of ICMPv4 message types have become obsolete in practice, but have never been formally deprecated. This document deprecates such ICMPv4 message types, thus cleaning up the corresponding IANA registry. Additionally, it updates RFC 792 and RFC 950, obsoletes RFC 1788, and requests the RFC Editor to change the status of RFC 1788 to Historic.

RFC69172013-04-01

Media Resource Brokering

Media Resource Brokering

The MediaCtrl working group in the IETF has proposed an architecture for controlling media services. The Session Initiation Protocol (SIP) is used as the signaling protocol that provides many inherent capabilities for message routing. In addition to such signaling properties, a need exists for intelligent, application-level media service selection based on non-static signaling properties. This is …

RFC69162013-04-01

Algorithm Agility Procedure for the Resource Public Key Infrastructure (RPKI)

Algorithm Agility Procedure for the Resource Public Key Infrastructure (RPKI)

This document specifies the process that Certification Authorities (CAs) and Relying Parties (RPs) participating in the Resource Public Key Infrastructure (RPKI) will need to follow to transition to a new (and probably cryptographically stronger) algorithm set. The process is expected to be completed over a timescale of several years. Consequently, no emergency transition is specified. The transit…

RFC69152013-04-01

Flow Identity Extension for HTTP-Enabled Location Delivery (HELD)

Flow Identity Extension for HTTP-Enabled Location Delivery (HELD)

RFC 6155 specifies an extension for the HTTP-Enabled Location Delivery (HELD) protocol, allowing the use of an IP address and port number to request a Device location based on an individual packet flow. However, certain kinds of NAT require that identifiers for both ends of the packet flow must be specified in order to unambiguously satisfy the location request. This document specifies an XML Sche…

RFC69142013-04-01

SIMPLE Made Simple: An Overview of the IETF Specifications for Instant Messaging and Presence Using the Session Initiation Protocol (SIP)

SIMPLE Made Simple: An Overview of the IETF Specifications for Instant Messaging and Presence Using the Session Initiation Protocol (SIP)

The IETF has produced many specifications related to Presence and Instant Messaging with the Session Initiation Protocol (SIP). Collectively, these specifications are known as SIP for Instant Messaging and Presence Leveraging Extensions (SIMPLE). This document serves as a guide to the SIMPLE suite of specifications. It categorizes the specifications, explains what each is for, and how they relate …

RFC69132013-03-01

Indicating Fax over IP Capability in the Session Initiation Protocol (SIP)

Indicating Fax over IP Capability in the Session Initiation Protocol (SIP)

This document defines and registers with IANA the new "fax" media feature tag for use with the Session Initiation Protocol (SIP). Currently, fax calls are indistinguishable from voice calls at call initiation. Consequently, fax calls can be routed to SIP user agents that are not fax capable. A "fax" media feature tag implemented in conjunction with caller preferences allows for more accurate fax c…

RFC69122013-04-01

Principles for Unicode Code Point Inclusion in Labels in the DNS

Principles for Unicode Code Point Inclusion in Labels in the DNS

Internationalized Domain Names in Applications (IDNA) makes available to DNS zone administrators a very wide range of Unicode code points. Most operators of zones should probably not permit registration of U-labels using the entire range. This is especially true of zones that accept registrations across organizational boundaries, such as top-level domains and, most importantly, the root. It is unf…

RFC69112013-04-01

RADIUS Attributes for IPv6 Access Networks

RADIUS Attributes for IPv6 Access Networks

This document specifies additional IPv6 RADIUS Attributes useful in residential broadband network deployments. The Attributes, which are used for authorization and accounting, enable assignment of a host IPv6 address and an IPv6 DNS server address via DHCPv6, assignment of an IPv6 route announced via router advertisement, assignment of a named IPv6 delegated prefix pool, and assignment of a named …

RFC69102013-04-01

Completion of Calls for the Session Initiation Protocol (SIP)

Completion of Calls for the Session Initiation Protocol (SIP)

The "completion of calls" feature defined in this specification allows the caller of a failed call to be notified when the callee becomes available to receive a call. For the realization of a basic solution without queuing, this document references the usage of the dialog event package (RFC 4235) that is described as 'Automatic Redial' in "Session Initiation Protocol Service Examples" (RFC 5359). …

RFC69092013-04-01

IPv4 Traffic Offload Selector Option for Proxy Mobile IPv6

IPv4 Traffic Offload Selector Option for Proxy Mobile IPv6

This specification defines a new mobility option, the IPv4 Traffic Offload Selector option, for Proxy Mobile IPv6. This option can be used by the local mobility anchor and the mobile access gateway for negotiating IPv4 traffic offload policy for a mobility session. Based on the negotiated IPv4 traffic offload policy, a mobile access gateway can selectively offload some of the IPv4 traffic flows in…

RFC69082013-03-01

Deployment Considerations for Dual-Stack Lite

Deployment Considerations for Dual-Stack Lite

This document discusses the deployment issues of and the requirements for the deployment and operation of Dual-Stack Lite (DS-Lite). This document describes the various deployment considerations and applicability of the DS-Lite architecture.

RFC69072013-03-01

Use Cases and Interpretations of Resource Public Key Infrastructure (RPKI) Objects for Issuers and Relying Parties

Use Cases and Interpretations of Resource Public Key Infrastructure (RPKI) Objects for Issuers and Relying Parties

This document describes a number of use cases together with directions and interpretations for organizations and relying parties when creating or encountering Resource Public Key Infrastructure (RPKI) object scenarios in the public RPKI. All of these items are discussed here in relation to the Internet routing system.

RFC69062013-03-01

The 'profile' Link Relation Type

The 'profile' Link Relation Type

This specification defines the 'profile' link relation type that allows resource representations to indicate that they are following one or more profiles. A profile is defined not to alter the semantics of the resource representation itself, but to allow clients to learn about additional semantics (constraints, conventions, extensions) that are associated with the resource representation, in addit…

RFC69052013-03-01

Requirements for Operations, Administration, and Maintenance (OAM) in Transparent Interconnection of Lots of Links (TRILL)

Requirements for Operations, Administration, and Maintenance (OAM) in Transparent Interconnection of Lots of Links (TRILL)

Operations, Administration, and Maintenance (OAM) is a general term used to identify functions and toolsets to troubleshoot and monitor networks. This document presents OAM requirements applicable to the Transparent Interconnection of Lots of Links (TRILL).

RFC69042013-04-01

Encryption of Header Extensions in the Secure Real-time Transport Protocol (SRTP)

Encryption of Header Extensions in the Secure Real-time Transport Protocol (SRTP)

The Secure Real-time Transport Protocol (SRTP) provides authentication, but not encryption, of the headers of Real-time Transport Protocol (RTP) packets. However, RTP header extensions may carry sensitive information for which participants in multimedia sessions want confidentiality. This document provides a mechanism, extending the mechanisms of SRTP, to selectively encrypt RTP header extensions …

RFC69032013-03-01

Additional Link Relation Types

Additional Link Relation Types

This specification defines a number of additional link relation types that can used for a range of purposes in a variety of applications types.

RFC69022013-04-01

JavaScript Object Notation (JSON) Patch

JavaScript Object Notation (JSON) Patch

JSON Patch defines a JSON document structure for expressing a sequence of operations to apply to a JavaScript Object Notation (JSON) document; it is suitable for use with the HTTP PATCH method. The "application/json-patch+json" media type is used to identify such patch documents.

RFC69012013-04-01

JavaScript Object Notation (JSON) Pointer

JavaScript Object Notation (JSON) Pointer

JSON Pointer defines a string syntax for identifying a specific value within a JavaScript Object Notation (JSON) document.

RFC68982013-03-01

Link Management Protocol Behavior Negotiation and Configuration Modifications

Link Management Protocol Behavior Negotiation and Configuration Modifications

The Link Management Protocol (LMP) is used to coordinate the properties, use, and faults of data links in networks controlled by Generalized Multiprotocol Label Switching (GMPLS). This document defines an extension to LMP to negotiate capabilities and indicate support for LMP extensions. The defined extension is compatible with non-supporting implementations. This document updates RFC 4204, RFC 42…

RFC68972013-03-01

Multipath TCP (MPTCP) Application Interface Considerations

Multipath TCP (MPTCP) Application Interface Considerations

Multipath TCP (MPTCP) adds the capability of using multiple paths to a regular TCP session. Even though it is designed to be totally backward compatible to applications, the data transport differs compared to regular TCP, and there are several additional degrees of freedom that applications may wish to exploit. This document summarizes the impact that MPTCP may have on applications, such as change…

RFC68962013-03-01

SCS: KoanLogic's Secure Cookie Sessions for HTTP

SCS: KoanLogic's Secure Cookie Sessions for HTTP

This memo defines a generic URI and HTTP-header-friendly envelope for carrying symmetrically encrypted, authenticated, and origin-timestamped tokens. It also describes one possible usage of such tokens via a simple protocol based on HTTP cookies. Secure Cookie Session (SCS) use cases cover a wide spectrum of applications, ranging from distribution of authorized content via HTTP (e.g., with out-of-…

RFC68952013-04-01

Domain Name System (DNS) IANA Considerations

Domain Name System (DNS) IANA Considerations

This document specifies Internet Assigned Numbers Authority (IANA) parameter assignment considerations for the allocation of Domain Name System (DNS) resource record types, CLASSes, operation codes, error codes, DNS protocol message header bits, and AFSDB resource record subtypes. It obsoletes RFC 6195 and updates RFCs 1183, 2845, 2930, and 3597.

RFC68942013-03-01

Methodology for Benchmarking MPLS Traffic Engineered (MPLS-TE) Fast Reroute Protection

Methodology for Benchmarking MPLS Traffic Engineered (MPLS-TE) Fast Reroute Protection

This document describes the methodology for benchmarking MPLS Fast Reroute (FRR) protection mechanisms for link and node protection. This document provides test methodologies and testbed setup for measuring failover times of Fast Reroute techniques while considering factors (such as underlying links) that might impact recovery times for real-time applications bound to MPLS Traffic Engineered (MPLS…

RFC68932013-03-01

A Uniform Resource Name (URN) Namespace for the Open IPTV Forum (OIPF)

A Uniform Resource Name (URN) Namespace for the Open IPTV Forum (OIPF)

This document describes a Uniform Resource Name (URN) namespace for the Open IPTV Forum (OIPF) for naming persistent resources defined within OIPF specifications. Example resources include technical documents and specifications, eXtensible Markup Language (XML) schemas, classification schemes, XML Document Type Definitions (DTDs), namespaces, style sheets, media assets, and other types of resource…

RFC68922013-03-01

The 'describes' Link Relation Type

The 'describes' Link Relation Type

This specification defines the 'describes' link relation type that allows resource representations to indicate that they are describing another resource. In contexts where applications want to associate described resources and description resources, and want to build services based on these associations, the 'describes' link relation type provides the opposite direction of the 'describedby' link r…

RFC68912013-04-01

Extension Mechanisms for DNS (EDNS(0))

Extension Mechanisms for DNS (EDNS(0))

The Domain Name System's wire protocol includes a number of fixed fields whose range has been or soon will be exhausted and does not allow requestors to advertise their capabilities to responders. This document describes backward-compatible mechanisms for allowing the protocol to grow. This document updates the Extension Mechanisms for DNS (EDNS(0)) specification (and obsoletes RFC 2671) based on …

RFC68902013-04-01

Special-Purpose IP Address Registries

Special-Purpose IP Address Registries

This memo reiterates the assignment of an IPv4 address block (192.0.0.0/24) to IANA. It also instructs IANA to restructure its IPv4 and IPv6 Special-Purpose Address Registries. Upon restructuring, the aforementioned registries will record all special-purpose address blocks, maintaining a common set of information regarding each address block.