⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC95202023-12-01

Negative Caching of DNS Resolution Failures

Negative Caching of DNS Resolution Failures

In the DNS, resolvers employ caching to reduce both latency for end users and load on authoritative name servers. The process of resolution may result in one of three types of responses: (1) a response containing the requested data, (2) a response indicating the requested data does not exist, or (3) a non-response due to a resolution failure in which the resolver does not receive any useful inform…

RFC95192024-01-01

Update to the IANA SSH Protocol Parameters Registry Requirements

Update to the IANA SSH Protocol Parameters Registry Requirements

This specification updates the registration policies for adding new entries to registries within the IANA "Secure Shell (SSH) Protocol Parameters" group of registries. Previously, the registration policy was generally IETF Review, as defined in RFC 8126, although a few registries require Standards Action. This specification changes it from IETF Review to Expert Review. This document updates RFCs 4…

RFC95182023-12-01

Centralization, Decentralization, and Internet Standards

Centralization, Decentralization, and Internet Standards

This document discusses aspects of centralization that relate to Internet standards efforts. It argues that, while standards bodies have a limited ability to prevent many forms of centralization, they can still make contributions that assist in the decentralization of the Internet.

RFC95172024-01-01

A URN Namespace for the Data Documentation Initiative (DDI)

A URN Namespace for the Data Documentation Initiative (DDI)

This document describes the Namespace Identifier (NID) "ddi" for Uniform Resource Names (URNs) used to identify resources that conform to the standards published by the Data Documentation Initiative (DDI) Alliance. The DDI Alliance is not affiliated with the Internet Engineering Task Force (IETF) or Internet Society (ISOC). This Independent Submission is not a standard nor does it have IETF commun…

RFC95162023-11-01

Active Operations, Administration, and Maintenance (OAM) for Service Function Chaining (SFC)

Active Operations, Administration, and Maintenance (OAM) for Service Function Chaining (SFC)

A set of requirements for active Operations, Administration, and Maintenance (OAM) for Service Function Chaining (SFC) in a network is presented in this document. Based on these requirements, an encapsulation of active OAM messages in SFC and a mechanism to detect and localize defects are described.

RFC95152023-12-01

Revision to Registration Procedures for Multiple BMP Registries

Revision to Registration Procedures for Multiple BMP Registries

This document updates RFC 7854, "BGP Monitoring Protocol (BMP)", by changing the registration procedures for several registries. Specifically, any BMP registry with a range of 32768-65530 designated "Specification Required" has that range redesignated as "First Come First Served".

RFC95142023-12-01

Border Gateway Protocol - Link State (BGP-LS) Extensions for Segment Routing over IPv6 (SRv6)

Border Gateway Protocol - Link State (BGP-LS) Extensions for Segment Routing over IPv6 (SRv6)

Segment Routing over IPv6 (SRv6) allows for a flexible definition of end-to-end paths within various topologies by encoding paths as sequences of topological or functional sub-paths called "segments". These segments are advertised by various protocols such as BGP, IS-IS, and OSPFv3. This document defines extensions to BGP - Link State (BGP-LS) to advertise SRv6 segments along with their behaviors …

RFC95132023-12-01

OSPFv3 Extensions for Segment Routing over IPv6 (SRv6)

OSPFv3 Extensions for Segment Routing over IPv6 (SRv6)

The Segment Routing (SR) architecture allows a flexible definition of the end-to-end path by encoding it as a sequence of topological elements called segments. It can be implemented over an MPLS or IPv6 data plane. This document describes the OSPFv3 extensions required to support SR over the IPv6 data plane.

RFC95122024-02-01

YAML Media Type

YAML Media Type

This document registers the application/yaml media type and the +yaml structured syntax suffix with IANA. Both identify document components that are serialized according to the YAML specification.

RFC95112023-11-01

Attribution of Internet Probes

Attribution of Internet Probes

Active measurements over the public Internet can target either collaborating parties or non-collaborating ones. Sometimes these measurements, also called "probes", are viewed as unwelcome or aggressive. This document suggests some simple techniques for a source to identify its probes. This allows any party or organization to understand what an unsolicited probe packet is, what its purpose is, and,…

RFC95102024-02-01

Alternative Delta Time Encoding for Content-Centric Networking (CCNx) Using Compact Floating-Point Arithmetic

Alternative Delta Time Encoding for Content-Centric Networking (CCNx) Using Compact Floating-Point Arithmetic

Content-Centric Networking (CCNx) utilizes delta time for a number of functions. When using CCNx in environments with constrained nodes or bandwidth constrained networks, it is valuable to have a compressed representation of delta time. In order to do so, either accuracy or dynamic range has to be sacrificed. Since the current uses of delta time do not require both simultaneously, one can consider…

RFC95092024-03-01

X.509 Certificate Extended Key Usage (EKU) for 5G Network Functions

X.509 Certificate Extended Key Usage (EKU) for 5G Network Functions

RFC 5280 specifies several extended key purpose identifiers (KeyPurposeIds) for X.509 certificates. This document defines encrypting JSON objects in HTTP messages, using JSON Web Tokens (JWTs), and signing the OAuth 2.0 access tokens KeyPurposeIds for inclusion in the Extended Key Usage (EKU) extension of X.509 v3 public key certificates used by Network Functions (NFs) for the 5G System.

RFC95082024-03-01

Information-Centric Networking (ICN) Ping Protocol Specification

Information-Centric Networking (ICN) Ping Protocol Specification

This document presents the design of an Information-Centric Networking (ICN) Ping protocol. It includes the operations of both the client and the forwarder. This document is a product of the Information-Centric Networking Research Group (ICNRG) of the IRTF.

RFC95072024-03-01

Information-Centric Networking (ICN) Traceroute Protocol Specification

Information-Centric Networking (ICN) Traceroute Protocol Specification

This document presents the design of an Information-Centric Networking (ICN) Traceroute protocol. This includes the operation of both the client and the forwarder. This document is a product of the Information-Centric Networking Research Group (ICNRG) of the IRTF.

RFC95062023-10-01

Explicit Host-to-Network Flow Measurements Techniques

Explicit Host-to-Network Flow Measurements Techniques

This document describes protocol-independent methods called Explicit Host-to-Network Flow Measurement Techniques that can be applicable to transport-layer protocols between the client and server. These methods employ just a few marking bits inside the header of each packet for performance measurements and require the client and server to collaborate. Both endpoints cooperate by marking packets and…

RFC95052023-11-01

A Survey of Worldwide Censorship Techniques

A Survey of Worldwide Censorship Techniques

This document describes technical mechanisms employed in network censorship that regimes around the world use for blocking or impairing Internet traffic. It aims to make designers, implementers, and users of Internet protocols aware of the properties exploited and mechanisms used for censoring end-user access to information. This document makes no suggestions on individual protocol considerations,…

RFC95042023-12-01

Path Computation Element Communication Protocol (PCEP) Extensions for Stateful PCE Usage in GMPLS-Controlled Networks

Path Computation Element Communication Protocol (PCEP) Extensions for Stateful PCE Usage in GMPLS-Controlled Networks

The Path Computation Element Communication Protocol (PCEP) has been extended to support stateful PCE functions where the stateful PCE maintains information about paths and resource usage within a network; however, these extensions do not cover all requirements for GMPLS networks. This document provides the extensions required for PCEP so as to enable the usage of a stateful PCE capability in GMPLS…

RFC95032023-10-01

Simple Two-Way Active Measurement Protocol (STAMP) Extensions for Segment Routing Networks

Simple Two-Way Active Measurement Protocol (STAMP) Extensions for Segment Routing Networks

Segment Routing (SR) leverages the source routing paradigm. SR is applicable to both Multiprotocol Label Switching (SR-MPLS) and IPv6 (SRv6) forwarding planes. This document specifies Simple Two-Way Active Measurement Protocol (STAMP) extensions (as described in RFC 8762) for SR networks, for both the SR-MPLS and SRv6 forwarding planes, by augmenting the optional extensions defined in RFC 8972.

RFC95022023-11-01

IGP Flexible Algorithm in IP Networks

IGP Flexible Algorithm in IP Networks

This document extends IGP Flexible Algorithm so that it can be used with regular IPv4 and IPv6 forwarding.

RFC95012023-12-01

Open Participation Principle regarding Remote Registration Fee

Open Participation Principle regarding Remote Registration Fee

This document outlines a principle for open participation that extends the open process principle defined in RFC 3935 by stating that there must be a free option for online participation to IETF meetings and, if possible, related IETF-hosted events.

RFC95002023-12-01

Standard Public Key Cryptography (PKC) Test Keys

Standard Public Key Cryptography (PKC) Test Keys

This document provides a set of standard Public Key Cryptography (PKC) test keys that may be used wherever pre-generated keys and associated operations like digital signatures are required. Like the European Institute for Computer Antivirus Research (EICAR) virus test and the Generic Test for Unsolicited Bulk Email (GTUBE) spam test files, these publicly known test keys can be detected and recogni…

RFC94992024-03-01

DNS Terminology

DNS Terminology

The Domain Name System (DNS) is defined in literally dozens of different RFCs. The terminology used by implementers and developers of DNS protocols, and by operators of DNS systems, has changed in the decades since the DNS was first defined. This document gives current definitions for many of the terms used in the DNS in a single document. This document updates RFC 2308 by clarifying the definitio…

RFC94982023-11-01

The GNU Name System

The GNU Name System

This document provides the GNU Name System (GNS) technical specification. GNS is a decentralized and censorship-resistant domain name resolution protocol that provides a privacy-enhancing alternative to the Domain Name System (DNS) protocols. This document defines the normative wire format of resource records, resolution processes, cryptographic routines, and security and privacy considerations fo…

RFC94972023-12-01

Oblivious Pseudorandom Functions (OPRFs) Using Prime-Order Groups

Oblivious Pseudorandom Functions (OPRFs) Using Prime-Order Groups

An Oblivious Pseudorandom Function (OPRF) is a two-party protocol between a client and a server for computing the output of a Pseudorandom Function (PRF). The server provides the PRF private key, and the client provides the PRF input. At the end of the protocol, the client learns the PRF output without learning anything about the PRF private key, and the server learns neither the PRF input nor out…

RFC94962023-12-01

The ristretto255 and decaf448 Groups

The ristretto255 and decaf448 Groups

This memo specifies two prime-order groups, ristretto255 and decaf448, suitable for safely implementing higher-level and complex cryptographic protocols. The ristretto255 group can be implemented using Curve25519, allowing existing Curve25519 implementations to be reused and extended to provide a prime-order group. Likewise, the decaf448 group can be implemented using edwards448. This document is …

RFC94952023-10-01

Certification Authority Authorization (CAA) Processing for Email Addresses

Certification Authority Authorization (CAA) Processing for Email Addresses

The Certification Authority Authorization (CAA) DNS resource record (RR) provides a mechanism for domains to express the allowed set of Certification Authorities that are authorized to issue certificates for the domain. RFC 8659 contains the core CAA specification, where Property Tags that restrict the issuance of certificates that certify domain names are defined. This specification defines a Pro…

RFC94942023-11-01

Long-Lived Graceful Restart for BGP

Long-Lived Graceful Restart for BGP

This document introduces a BGP capability called the "Long-Lived Graceful Restart Capability" (or "LLGR Capability"). The benefit of this capability is that stale routes can be retained for a longer time upon session failure than is provided for by BGP Graceful Restart (as described in RFC 4724). A well-known BGP community called "LLGR_STALE" is introduced for marking stale routes retained for a l…

RFC94932023-12-01

Subject Identifiers for Security Event Tokens

Subject Identifiers for Security Event Tokens

Security events communicated within Security Event Tokens may support a variety of identifiers to identify subjects related to the event. This specification formalizes the notion of Subject Identifiers as structured information that describes a subject and named formats that define the syntax and semantics for encoding Subject Identifiers as JSON objects. It also establishes a registry for definin…

RFC94922023-10-01

OSPF Application-Specific Link Attributes

OSPF Application-Specific Link Attributes

Existing traffic-engineering-related link attribute advertisements have been defined and are used in RSVP-TE deployments. Since the original RSVP-TE use case was defined, additional applications such as Segment Routing (SR) Policy and Loop-Free Alternates (LFAs) that also make use of the link attribute advertisements have been defined. In cases where multiple applications wish to make use of these…

RFC94912023-11-01

Integration of the Network Service Header (NSH) and Segment Routing for Service Function Chaining (SFC)

Integration of the Network Service Header (NSH) and Segment Routing for Service Function Chaining (SFC)

This document describes the integration of the Network Service Header (NSH) and Segment Routing (SR), as well as encapsulation details, to efficiently support Service Function Chaining (SFC) while maintaining separation of the service and transport planes as originally intended by the SFC architecture. Combining these technologies allows SR to be used for steering packets between Service Function …