⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC95502024-03-01

Deterministic Networking (DetNet): Packet Ordering Function

Deterministic Networking (DetNet): Packet Ordering Function

The replication and elimination functions of the Deterministic Networking (DetNet) architecture can result in out-of-order packets, which is not acceptable for some time-sensitive applications. The Packet Ordering Function (POF) algorithms described in this document enable restoration of the correct packet order when the replication and elimination functions are used in DetNet networks. The POF on…

RFC95492024-03-01

Internationalization Updates to RFC 5280

Internationalization Updates to RFC 5280

The updates to RFC 5280 described in this document provide alignment with the 2008 specification for Internationalized Domain Names (IDNs) and includes support for internationalized email addresses in X.509 certificates. The updates ensure that name constraints for email addresses that contain only ASCII characters and internationalized email addresses are handled in the same manner. This document…

RFC95482024-05-01

Generating Transport Key Containers (PFX) Using the GOST Algorithms

Generating Transport Key Containers (PFX) Using the GOST Algorithms

This document specifies how to use "PKCS #12: Personal Information Exchange Syntax v1.1" (RFC 7292) to transport key containers (PFX) for storing keys and certificates in conjunction with the Russian national standard GOST algorithms. This specification has been developed outside the IETF. The purpose of publication is to facilitate interoperable implementations that wish to support the GOST algor…

RFC95472024-02-01

Report from the IAB Workshop on Environmental Impact of Internet Applications and Systems, 2022

Report from the IAB Workshop on Environmental Impact of Internet Applications and Systems, 2022

Internet communications and applications have both environmental costs and benefits. The IAB ran an online workshop in December 2022 to explore and understand these impacts. The role of the workshop was to discuss the impacts and the evolving industry needs, and to identify areas for improvements and future work. A key goal of the workshop was to call further attention to the topic and bring toget…

RFC95462024-02-01

Operations, Administration, and Maintenance (OAM) for Deterministic Networking (DetNet) with the MPLS Data Plane

Operations, Administration, and Maintenance (OAM) for Deterministic Networking (DetNet) with the MPLS Data Plane

This document defines format and usage principles of the Deterministic Networking (DetNet) service Associated Channel over a DetNet network with the MPLS data plane. The DetNet service Associated Channel can be used to carry test packets of active Operations, Administration, and Maintenance (OAM) protocols that are used to detect DetNet failures and measure performance metrics.

RFC95452024-02-01

Path Segment Identifier in MPLS-Based Segment Routing Networks

Path Segment Identifier in MPLS-Based Segment Routing Networks

A Segment Routing (SR) path is identified by an SR segment list. A subset of segments from the segment list cannot be leveraged to distinguish one SR path from another as they may be partially congruent. SR path identification is a prerequisite for various use cases such as performance measurement and end-to-end 1+1 path protection. In an SR over MPLS (SR-MPLS) data plane, an egress node cannot de…

RFC95442024-03-01

Precision Availability Metrics (PAMs) for Services Governed by Service Level Objectives (SLOs)

Precision Availability Metrics (PAMs) for Services Governed by Service Level Objectives (SLOs)

This document defines a set of metrics for networking services with performance requirements expressed as Service Level Objectives (SLOs). These metrics, referred to as "Precision Availability Metrics (PAMs)", are useful for defining and monitoring SLOs. For example, PAMs can be used by providers and/or customers of an RFC 9543 Network Slice Service to assess whether the service is provided in com…

RFC95432024-03-01

A Framework for Network Slices in Networks Built from IETF Technologies

A Framework for Network Slices in Networks Built from IETF Technologies

This document describes network slicing in the context of networks built from IETF technologies. It defines the term "IETF Network Slice" to describe this type of network slice and establishes the general principles of network slicing in the IETF context. The document discusses the general framework for requesting and operating IETF Network Slices, the characteristics of an IETF Network Slice, the…

RFC95422024-04-01

IANA Considerations and IETF Protocol and Documentation Usage for IEEE 802 Parameters

IANA Considerations and IETF Protocol and Documentation Usage for IEEE 802 Parameters

Some IETF protocols make use of Ethernet frame formats and IEEE 802 parameters. This document discusses several aspects of such parameters and their use in IETF protocols, specifies IANA considerations for assignment of points under the IANA Organizationally Unique Identifier (OUI), and provides some values for use in documentation. This document obsoletes RFC 7042.

RFC95412024-03-01

Flush Mechanism for Customer MAC Addresses Based on Service Instance Identifier (I-SID) in Provider Backbone Bridging EVPN (PBB-EVPN)

Flush Mechanism for Customer MAC Addresses Based on Service Instance Identifier (I-SID) in Provider Backbone Bridging EVPN (PBB-EVPN)

Provider Backbone Bridging (PBB) can be combined with Ethernet Virtual Private Networks (EVPNs) to deploy Ethernet Local Area Network (E-LAN) services in large Multiprotocol Label Switching (MPLS) networks. That combination is what we refer to as "PBB-EVPN." Single-Active multihoming and per Service Instance Identifier (I-SID) load-balancing can be provided to access devices and aggregation networ…

RFC95402024-02-01

Discovery of Oblivious Services via Service Binding Records

Discovery of Oblivious Services via Service Binding Records

This document defines a parameter that can be included in Service Binding (SVCB) and HTTPS DNS resource records to denote that a service is accessible using Oblivious HTTP, by offering an Oblivious Gateway Resource through which to access the target. This document also defines a mechanism for learning the key configuration of the discovered Oblivious Gateway Resource.

RFC95392024-02-01

Unilateral Opportunistic Deployment of Encrypted Recursive-to-Authoritative DNS

Unilateral Opportunistic Deployment of Encrypted Recursive-to-Authoritative DNS

This document sets out steps that DNS servers (recursive resolvers and authoritative servers) can take unilaterally (without any coordination with other peers) to defend DNS query privacy against a passive network monitor. The protections provided by the guidance in this document can be defeated by an active attacker, but they should be simpler and less risky to deploy than more powerful defenses.…

RFC95382024-02-01

Content Delivery Network Interconnection (CDNI) Delegation Using the Automated Certificate Management Environment

Content Delivery Network Interconnection (CDNI) Delegation Using the Automated Certificate Management Environment

This document defines metadata to support delegating the delivery of HTTPS content between two or more interconnected Content Delivery Networks (CDNs). Specifically, this document defines a Content Delivery Network Interconnection (CDNI) Metadata interface object to enable delegation of X.509 certificates leveraging delegation schemes defined in RFC 9115. Per RFC 9115, delegating entities can rema…

RFC95372024-03-01

Redacted Fields in the Registration Data Access Protocol (RDAP) Response

Redacted Fields in the Registration Data Access Protocol (RDAP) Response

This document describes a Registration Data Access Protocol (RDAP) extension for specifying methods of redaction of RDAP responses and explicitly identifying redacted RDAP response fields, using JSONPath as the default expression language.

RFC95362024-04-01

Registration Data Access Protocol (RDAP) Reverse Search

Registration Data Access Protocol (RDAP) Reverse Search

The Registration Data Access Protocol (RDAP) does not include query capabilities for finding the list of domains related to a set of entities matching a given search pattern. Considering that an RDAP entity can be associated with any defined object class and other relationships between RDAP object classes exist, a reverse search can be applied to other use cases besides the classic domain-entity s…

RFC95352024-02-01

JSONPath: Query Expressions for JSON

JSONPath: Query Expressions for JSON

JSONPath defines a string syntax for selecting and extracting JSON (RFC 8259) values from within a given JSON value.

RFC95342024-01-01

Simple Two-Way Active Measurement Protocol Extensions for Performance Measurement on a Link Aggregation Group

Simple Two-Way Active Measurement Protocol Extensions for Performance Measurement on a Link Aggregation Group

This document extends Simple Two-way Active Measurement Protocol (STAMP) to implement performance measurement on every member link of a Link Aggregation Group (LAG). Knowing the measured metrics of each member link of a LAG enables operators to enforce a performance-based traffic steering policy across the member links.

RFC95332024-01-01

One-Way and Two-Way Active Measurement Protocol Extensions for Performance Measurement on a Link Aggregation Group

One-Way and Two-Way Active Measurement Protocol Extensions for Performance Measurement on a Link Aggregation Group

This document defines extensions to the One-Way Active Measurement Protocol (OWAMP) and the Two-Way Active Measurement Protocol (TWAMP) to implement performance measurement on every member link of a Link Aggregation Group (LAG). Knowing the measured metrics of each member link of a LAG enables operators to enforce the performance-based traffic steering policy across the member links.

RFC95322024-01-01

HTTP Proxy-Status Parameter for Next-Hop Aliases

HTTP Proxy-Status Parameter for Next-Hop Aliases

This document defines the next-hop-aliases HTTP Proxy-Status Parameter. This parameter carries the list of aliases and canonical names an intermediary received during DNS resolution as part of establishing a connection to the next hop.

RFC95312024-03-01

Path Steering in Content-Centric Networking (CCNx) and Named Data Networking (NDN)

Path Steering in Content-Centric Networking (CCNx) and Named Data Networking (NDN)

Path steering is a mechanism to discover paths to the producers of Information-Centric Networking (ICN) Content Objects and steer subsequent Interest messages along a previously discovered path. It has various uses, including the operation of state-of-the-art multi-path congestion control algorithms and for network measurement and management. This specification derives directly from the design pub…

RFC95302024-02-01

Digest Fields

Digest Fields

This document defines HTTP fields that support integrity digests. The Content-Digest field can be used for the integrity of HTTP message content. The Repr-Digest field can be used for the integrity of HTTP representations. Want-Content-Digest and Want-Repr-Digest can be used to indicate a sender's interest and preferences for receiving the respective Integrity fields. This document obsoletes RFC 3…

RFC95292024-03-01

Traces of Ephemeral Diffie-Hellman Over COSE (EDHOC)

Traces of Ephemeral Diffie-Hellman Over COSE (EDHOC)

This document contains example traces of Ephemeral Diffie-Hellman Over COSE (EDHOC).

RFC95282024-03-01

Ephemeral Diffie-Hellman Over COSE (EDHOC)

Ephemeral Diffie-Hellman Over COSE (EDHOC)

This document specifies Ephemeral Diffie-Hellman Over COSE (EDHOC), a very compact and lightweight authenticated Diffie-Hellman key exchange with ephemeral keys. EDHOC provides mutual authentication, forward secrecy, and identity protection. EDHOC is intended for usage in constrained scenarios, and a main use case is to establish an Object Security for Constrained RESTful Environments (OSCORE) sec…

RFC95272024-01-01

DHCPv6 Options for the Homenet Naming Authority

DHCPv6 Options for the Homenet Naming Authority

This document defines DHCPv6 options so that a Homenet Naming Authority (HNA) can automatically set the appropriate configuration and outsource the authoritative naming service for the home network. In most cases, the outsourcing mechanism is transparent for the end user.

RFC95262024-01-01

Simple Provisioning of Public Names for Residential Networks

Simple Provisioning of Public Names for Residential Networks

Home network owners may have devices or services hosted on their home network that they wish to access from the Internet (i.e., from a network outside of the home network). Home networks are increasingly numbered using IPv6 addresses, which in principle makes this access simpler, but accessing home networks from the Internet requires the names and IP addresses of these devices and services to be m…

RFC95252023-11-01

Service Identity in TLS

Service Identity in TLS

Many application technologies enable secure communication between two entities by means of Transport Layer Security (TLS) with Internet Public Key Infrastructure using X.509 (PKIX) certificates. This document specifies procedures for representing and verifying the identity of application services in such interactions. This document obsoletes RFC 6125.

RFC95242024-02-01

Segment Routing Replication for Multipoint Service Delivery

Segment Routing Replication for Multipoint Service Delivery

This document describes the Segment Routing Replication segment for multipoint service delivery. A Replication segment allows a packet to be replicated from a replication node to downstream nodes.

RFC95232024-02-01

A Secure Selection and Filtering Mechanism for the Network Time Protocol with Khronos

A Secure Selection and Filtering Mechanism for the Network Time Protocol with Khronos

The Network Time Protocol version 4 (NTPv4), as defined in RFC 5905, is the mechanism used by NTP clients to synchronize with NTP servers across the Internet. This document describes a companion application to the NTPv4 client, named "Khronos", that is used as a "watchdog" alongside NTPv4 and that provides improved security against time-shifting attacks. Khronos involves changes to the NTP client'…

RFC95222024-01-01

Overview and Principles of Internet Traffic Engineering

Overview and Principles of Internet Traffic Engineering

This document describes the principles of traffic engineering (TE) in the Internet. The document is intended to promote better understanding of the issues surrounding traffic engineering in IP networks and the networks that support IP networking and to provide a common basis for the development of traffic-engineering capabilities for the Internet. The principles, architectures, and methodologies f…

RFC95212024-01-01

Bidirectional Forwarding Detection (BFD) for Generic Network Virtualization Encapsulation (Geneve)

Bidirectional Forwarding Detection (BFD) for Generic Network Virtualization Encapsulation (Geneve)

This document describes the use of the Bidirectional Forwarding Detection (BFD) protocol in point-to-point Generic Network Virtualization Encapsulation (Geneve) unicast tunnels used to make up an overlay network.