⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC95802024-07-01

OpenPGP

OpenPGP

This document specifies the message formats used in OpenPGP. OpenPGP provides encryption with public key or symmetric cryptographic algorithms, digital signatures, compression, and key management. This document is maintained in order to publish all necessary information needed to develop interoperable applications based on the OpenPGP format. It is not a step-by-step cookbook for writing an applic…

RFC95792024-05-01

Use of Password-Based Message Authentication Code 1 (PBMAC1) in PKCS #12 Syntax

Use of Password-Based Message Authentication Code 1 (PBMAC1) in PKCS #12 Syntax

This document specifies additions and amendments to RFCs 7292 and 8018. It defines a way to use the Password-Based Message Authentication Code 1 (PBMAC1), defined in RFC 8018, inside the PKCS #12 syntax. The purpose of this specification is to permit the use of more modern Password-Based Key Derivation Functions (PBKDFs) and allow for regulatory compliance.

RFC95782024-06-01

Privacy Pass Issuance Protocols

Privacy Pass Issuance Protocols

This document specifies two variants of the two-message issuance protocol for Privacy Pass tokens: one that produces tokens that are privately verifiable using the Issuer Private Key and one that produces tokens that are publicly verifiable using the Issuer Public Key. Instances of "issuance protocol" and "issuance protocols" in the text of this document are used interchangeably to refer to the tw…

RFC95772024-06-01

The Privacy Pass HTTP Authentication Scheme

The Privacy Pass HTTP Authentication Scheme

This document defines an HTTP authentication scheme for Privacy Pass, a privacy-preserving authentication mechanism used for authorization. The authentication scheme specified in this document can be used by Clients to redeem Privacy Pass tokens with an Origin. It can also be used by Origins to challenge Clients to present Privacy Pass tokens.

RFC95762024-06-01

The Privacy Pass Architecture

The Privacy Pass Architecture

This document specifies the Privacy Pass architecture and requirements for its constituent protocols used for authorization based on privacy-preserving authentication mechanisms. It describes the conceptual model of Privacy Pass and its protocols, its security and privacy goals, practical deployment models, and recommendations for each deployment model, to help ensure that the desired security and…

RFC95752024-06-01

DRIP Entity Tag (DET) Authentication Formats and Protocols for Broadcast Remote Identification (RID)

DRIP Entity Tag (DET) Authentication Formats and Protocols for Broadcast Remote Identification (RID)

The Drone Remote Identification Protocol (DRIP), plus trust policies and periodic access to registries, augments Unmanned Aircraft System (UAS) Remote Identification (RID), enabling local real-time assessment of trustworthiness of received RID messages and observed UAS, even by Observers lacking Internet access. This document defines DRIP message types and formats to be sent in Broadcast RID Authe…

RFC95742024-05-01

Optimized Ingress Replication Solution for Ethernet VPNs (EVPNs)

Optimized Ingress Replication Solution for Ethernet VPNs (EVPNs)

Network Virtualization Overlay (NVO) networks using Ethernet VPNs (EVPNs) as their control plane may use trees based on ingress replication or Protocol Independent Multicast (PIM) to convey the overlay Broadcast, Unknown Unicast, or Multicast (BUM) traffic. PIM provides an efficient solution that prevents sending multiple copies of the same packet over the same physical link; however, it may not a…

RFC95732024-05-01

MVPN/EVPN Tunnel Aggregation with Common Labels

MVPN/EVPN Tunnel Aggregation with Common Labels

The Multicast VPN (MVPN) specifications allow a single Point-to-Multipoint (P2MP) tunnel to carry traffic of multiple IP VPNs (referred to as VPNs in this document). The EVPN specifications allow a single P2MP tunnel to carry traffic of multiple Broadcast Domains (BDs). These features require the ingress router of the P2MP tunnel to allocate an upstream-assigned MPLS label for each VPN or for each…

RFC95722024-05-01

Updates to EVPN Broadcast, Unknown Unicast, or Multicast (BUM) Procedures

Updates to EVPN Broadcast, Unknown Unicast, or Multicast (BUM) Procedures

This document specifies updated procedures for handling Broadcast, Unknown Unicast, or Multicast (BUM) traffic in Ethernet VPNs (EVPNs), including selective multicast and segmentation of provider tunnels. This document updates RFC 7432.

RFC95712024-05-01

Extension of RFC 6374-Based Performance Measurement Using Synonymous Flow Labels

Extension of RFC 6374-Based Performance Measurement Using Synonymous Flow Labels

RFC 6374 describes methods of making loss and delay measurements on Label Switched Paths (LSPs) primarily as they are used in MPLS Transport Profile (MPLS-TP) networks. This document describes a method of extending the performance measurements (specified in RFC 6374) from flows carried over MPLS-TP to flows carried over generic MPLS LSPs. In particular, it extends the technique to allow loss and d…

RFC95702024-05-01

Deprecating the Use of Router Alert in LSP Ping

Deprecating the Use of Router Alert in LSP Ping

The MPLS echo request and MPLS echo response messages, defined in RFC 8029, "Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures" (usually referred to as LSP ping), are encapsulated in IP packets with headers that include a Router Alert Option (RAO). In actual deployments, the RAO was neither required nor used. Furthermore, RFC 6398 identifies security vulnerabilities associated with…

RFC95692024-09-01

The Application-Layer Traffic Optimization (ALTO) Transport Information Publication Service (TIPS)

The Application-Layer Traffic Optimization (ALTO) Transport Information Publication Service (TIPS)

"Application-Layer Traffic Optimization (ALTO) Protocol" (RFC 7285) leverages HTTP/1.1 and is designed for the simple, sequential request-reply use case, in which an ALTO client requests a sequence of information resources and the server responds with the complete content of each resource, one at a time. RFC 8895, which describes ALTO incremental updates using Server-Sent Events (SSE), defines a m…

RFC95682024-04-01

Virtual Router Redundancy Protocol (VRRP) Version 3 for IPv4 and IPv6

Virtual Router Redundancy Protocol (VRRP) Version 3 for IPv4 and IPv6

This document defines version 3 of the Virtual Router Redundancy Protocol (VRRP) for IPv4 and IPv6. It obsoletes RFC 5798, which previously specified VRRP (version 3). RFC 5798 obsoleted RFC 3768, which specified VRRP (version 2) for IPv4. VRRP specifies an election protocol that dynamically assigns responsibility for a Virtual Router to one of the VRRP Routers on a LAN. The VRRP Router controllin…

RFC95672024-04-01

DNS Error Reporting

DNS Error Reporting

DNS error reporting is a lightweight reporting mechanism that provides the operator of an authoritative server with reports on DNS resource records that fail to resolve or validate. A domain owner or DNS hosting organization can use these reports to improve domain hosting. The reports are based on extended DNS errors as described in RFC 8914. When a domain name fails to resolve or validate due to …

RFC95662024-04-01

Deterministic Networking (DetNet) Packet Replication, Elimination, and Ordering Functions (PREOF) via MPLS over UDP/IP

Deterministic Networking (DetNet) Packet Replication, Elimination, and Ordering Functions (PREOF) via MPLS over UDP/IP

This document describes how the DetNet IP data plane can support the Packet Replication, Elimination, and Ordering Functions (PREOF) built on the existing MPLS PREOF solution defined for the DetNet MPLS data plane and the mechanisms defined by MPLS-over-UDP technology.

RFC95652024-03-01

An Update to the tcpControlBits IP Flow Information Export (IPFIX) Information Element

An Update to the tcpControlBits IP Flow Information Export (IPFIX) Information Element

RFC 7125 revised the tcpControlBits IP Flow Information Export (IPFIX) Information Element that was originally defined in RFC 5102 to reflect changes to the TCP header control bits since RFC 793. However, that update is still problematic for interoperability because some flag values have subsequently been deprecated. This document removes stale information from the IANA "IPFIX Information Elements…

RFC95642024-04-01

Faster Than Light Speed Protocol (FLIP)

Faster Than Light Speed Protocol (FLIP)

The recent advances in artificial intelligence (AI) such as large language models enable the design of the Faster than LIght speed Protocol (FLIP) for Internet. FLIP provides a way to avoid congestion, enhance security, and deliver faster packets on the Internet by using AI to predict future packets at the receiving peer before they arrive. This document describes the protocol, its various encapsu…

RFC95632024-12-01

SM2 Digital Signature Algorithm for DNSSEC

SM2 Digital Signature Algorithm for DNSSEC

This document specifies the use of the SM2 digital signature algorithm and SM3 hash algorithm for DNS Security (DNSSEC). This document is an Independent Submission to the RFC series and does not have consensus of the IETF community.

RFC95622024-05-01

Universally Unique IDentifiers (UUIDs)

Universally Unique IDentifiers (UUIDs)

This specification defines UUIDs (Universally Unique IDentifiers) -- also known as GUIDs (Globally Unique IDentifiers) -- and a Uniform Resource Name namespace for UUIDs. A UUID is 128 bits long and is intended to guarantee uniqueness across space and time. UUIDs were originally used in the Apollo Network Computing System (NCS), later in the Open Software Foundation's (OSF's) Distributed Computing…

RFC95612024-04-01

Using the Parallel NFS (pNFS) SCSI Layout to Access Non-Volatile Memory Express (NVMe) Storage Devices

Using the Parallel NFS (pNFS) SCSI Layout to Access Non-Volatile Memory Express (NVMe) Storage Devices

This document specifies how to use the Parallel Network File System (pNFS) Small Computer System Interface (SCSI) Layout Type to access storage devices using the Non-Volatile Memory Express (NVMe) protocol family.

RFC95602024-04-01

Federated Authentication for the Registration Data Access Protocol (RDAP) Using OpenID Connect

Federated Authentication for the Registration Data Access Protocol (RDAP) Using OpenID Connect

The Registration Data Access Protocol (RDAP) provides Representational State Transfer (RESTful) web services to retrieve registration metadata from domain name and regional internet registries. RDAP allows a server to make access control decisions based on client identity, and as such, it includes support for client identification features provided by the Hypertext Transfer Protocol (HTTP). Identi…

RFC95592024-10-01

Matroska Media Container Format Specification

Matroska Media Container Format Specification

This document defines the Matroska audiovisual data container structure, including definitions of its structural elements, terminology, vocabulary, and application. This document updates RFC 8794 to permit the use of a previously reserved Extensible Binary Meta Language (EBML) Element ID.

RFC95582024-04-01

Use of GOST 2012 Signature Algorithms in DNSKEY and RRSIG Resource Records for DNSSEC

Use of GOST 2012 Signature Algorithms in DNSKEY and RRSIG Resource Records for DNSSEC

This document describes how to produce digital signatures and hash functions using the GOST R 34.10-2012 and GOST R 34.11-2012 algorithms for DNSKEY, RRSIG, and DS resource records, for use in the Domain Name System Security Extensions (DNSSEC).

RFC95572024-04-01

Date and Time on the Internet: Timestamps with Additional Information

Date and Time on the Internet: Timestamps with Additional Information

This document defines an extension to the timestamp format defined in RFC 3339 for representing additional information, including a time zone. It updates RFC 3339 in the specific interpretation of the local offset Z, which is no longer understood to "imply that UTC is the preferred reference point for the specified time".

RFC95562024-04-01

Internet of Things (IoT) Edge Challenges and Functions

Internet of Things (IoT) Edge Challenges and Functions

Many Internet of Things (IoT) applications have requirements that cannot be satisfied by centralized cloud-based systems (i.e., cloud computing). These include time sensitivity, data volume, connectivity cost, operation in the face of intermittent services, privacy, and security. As a result, IoT is driving the Internet toward edge computing. This document outlines the requirements of the emerging…

RFC95552024-05-01

JSContact: Converting from and to vCard

JSContact: Converting from and to vCard

This document defines how to convert contact information between the JSContact and vCard data formats. It defines conversion rules for every JSContact and vCard element registered at IANA at the time of publication. It also defines new JSContact properties as well as vCard properties and parameters, to support converting arbitrary or unknown JSContact and vCard elements.

RFC95542024-05-01

vCard Format Extensions for JSContact

vCard Format Extensions for JSContact

This document defines a set of new properties for vCard and extends the use of existing ones. Their primary purpose is to align the same set of features between the JSContact and vCard formats, but the new definitions also aim to be useful within just the vCard format. This document updates RFC 6350 ("vCard Format Specification").

RFC95532024-05-01

JSContact: A JSON Representation of Contact Data

JSContact: A JSON Representation of Contact Data

This specification defines a data model and JavaScript Object Notation (JSON) representation of contact card information that can be used for data storage and exchange in address book or directory applications. It aims to be an alternative to the vCard data format and to be unambiguous, extendable, and simple to process. In contrast to the JSON-based jCard format, it is not a direct mapping from t…

RFC95522023-12-01

Distribution of Link-State and Traffic Engineering Information Using BGP

Distribution of Link-State and Traffic Engineering Information Using BGP

In many environments, a component external to a network is called upon to perform computations based on the network topology and the current state of the connections within the network, including Traffic Engineering (TE) information. This is information typically distributed by IGP routing protocols within the network. This document describes a mechanism by which link-state and TE information can …

RFC95512024-03-01

Framework of Operations, Administration, and Maintenance (OAM) for Deterministic Networking (DetNet)

Framework of Operations, Administration, and Maintenance (OAM) for Deterministic Networking (DetNet)

Deterministic Networking (DetNet), as defined in RFC 8655, aims to provide bounded end-to-end latency on top of the network infrastructure, comprising both Layer 2 bridged and Layer 3 routed segments. This document's primary purpose is to detail the specific requirements of the Operations, Administration, and Maintenance (OAM) recommended to maintain a deterministic network. The document will be u…