⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC96102024-12-01

JSON Meta Application Protocol (JMAP) for Contacts

JSON Meta Application Protocol (JMAP) for Contacts

This document specifies a data model for synchronising contact data with a server using the JSON Meta Application Protocol (JMAP).

RFC96092025-02-01

Initializing a DNS Resolver with Priming Queries

Initializing a DNS Resolver with Priming Queries

This document describes the queries that a DNS resolver should emit to initialize its cache. The result is that the resolver gets both a current NS resource record set (RRset) for the root zone and the necessary address information for reaching the root servers. This document obsoletes RFC 8109.

RFC96082024-06-01

No Revocation Available for X.509 Public Key Certificates

No Revocation Available for X.509 Public Key Certificates

X.509v3 public key certificates are profiled in RFC 5280. Short-lived certificates are seeing greater use in the Internet. The Certification Authority (CA) that issues these short-lived certificates do not publish revocation information because the certificate lifespan that is shorter than the time needed to detect, report, and distribute revocation information. Some long-lived X.509v3 public key …

RFC96072024-07-01

RTP Payload Format for the Secure Communication Interoperability Protocol (SCIP) Codec

RTP Payload Format for the Secure Communication Interoperability Protocol (SCIP) Codec

This document describes the RTP payload format of the Secure Communication Interoperability Protocol (SCIP). SCIP is an application-layer protocol that provides end-to-end session establishment, payload encryption, packetization and de-packetization of media, and reliable transport. This document provides a globally available reference that can be used for the development of network equipment and …

RFC96062024-06-01

DNS Resolver Information

DNS Resolver Information

This document specifies a method for DNS resolvers to publish information about themselves. DNS clients can use the resolver information to identify the capabilities of DNS resolvers. How DNS clients use such information is beyond the scope of this document.

RFC96052024-08-01

Secure Frame (SFrame): Lightweight Authenticated Encryption for Real-Time Media

Secure Frame (SFrame): Lightweight Authenticated Encryption for Real-Time Media

This document describes the Secure Frame (SFrame) end-to-end encryption and authentication mechanism for media frames in a multiparty conference call, in which central media servers (Selective Forwarding Units or SFUs) can access the media metadata needed to make forwarding decisions without having access to the actual media. This mechanism differs from the Secure Real-Time Protocol (SRTP) in that…

RFC96042024-08-01

Carrying Binding Label/SID in PCE-Based Networks

Carrying Binding Label/SID in PCE-Based Networks

In order to provide greater scalability, network confidentiality, and service independence, Segment Routing (SR) utilizes a Binding Segment Identifier (BSID), as described in RFC 8402. It is possible to associate a BSID to an RSVP-TE-signaled Traffic Engineering (TE) Label Switched Path (LSP) or an SR TE path. The BSID can be used by an upstream node for steering traffic into the appropriate TE pa…

RFC96032024-07-01

Path Computation Element Communication Protocol (PCEP) Extensions for IPv6 Segment Routing

Path Computation Element Communication Protocol (PCEP) Extensions for IPv6 Segment Routing

Segment Routing (SR) can be used to steer packets through a network using the IPv6 or MPLS data plane, employing the source routing paradigm. An SR Path can be derived from a variety of mechanisms, including an IGP Shortest Path Tree (SPT), explicit configuration, or a Path Computation Element (PCE). Since SR can be applied to both MPLS and IPv6 data planes, a PCE should be able to compute an SR P…

RFC96022024-10-01

Segment Routing over IPv6 (SRv6) Segment Identifiers in the IPv6 Addressing Architecture

Segment Routing over IPv6 (SRv6) Segment Identifiers in the IPv6 Addressing Architecture

Segment Routing over IPv6 (SRv6) uses IPv6 as the underlying data plane. Thus, Segment Identifiers (SIDs) used by SRv6 can resemble IPv6 addresses and behave like them while exhibiting slightly different behaviors in some situations. This document explores the characteristics of SRv6 SIDs and focuses on the relationship of SRv6 SIDs to the IPv6 Addressing Architecture. This document allocates and …

RFC96012024-08-01

Propagating Explicit Congestion Notification across IP Tunnel Headers Separated by a Shim

Propagating Explicit Congestion Notification across IP Tunnel Headers Separated by a Shim

RFC 6040 on "Tunnelling of Explicit Congestion Notification" made the rules for propagation of Explicit Congestion Notification (ECN) consistent for all forms of IP-in-IP tunnel. This specification updates RFC 6040 to clarify that its scope includes tunnels where two IP headers are separated by at least one shim header that is not sufficient on its own for wide-area packet forwarding. It surveys w…

RFC96002024-08-01

TRansparent Interconnection of Lots of Links (TRILL): Explicit Congestion Notification (ECN) Support

TRansparent Interconnection of Lots of Links (TRILL): Explicit Congestion Notification (ECN) Support

Explicit Congestion Notification (ECN) allows a forwarding element to notify downstream devices, including the destination, of the onset of congestion without having to drop packets. This can improve network efficiency through better congestion control without packet drops. This document extends ECN to TRansparent Interconnection of Lots of Links (TRILL) switches, including integration with IP ECN…

RFC95992024-08-01

Guidelines for Adding Congestion Notification to Protocols that Encapsulate IP

Guidelines for Adding Congestion Notification to Protocols that Encapsulate IP

The purpose of this document is to guide the design of congestion notification in any lower-layer or tunnelling protocol that encapsulates IP. The aim is for explicit congestion signals to propagate consistently from lower-layer protocols into IP. Then, the IP internetwork layer can act as a portability layer to carry congestion notification from non-IP-aware congested nodes up to the transport la…

RFC95982024-05-01

Internationalized Email Addresses in X.509 Certificates

Internationalized Email Addresses in X.509 Certificates

This document defines a new name form for inclusion in the otherName field of an X.509 Subject Alternative Name and Issuer Alternative Name extension that allows a certificate subject to be associated with an internationalized email address. This document updates RFC 5280 and obsoletes RFC 8398.

RFC95972024-06-01

CBOR Web Token (CWT) Claims in COSE Headers

CBOR Web Token (CWT) Claims in COSE Headers

This document describes how to include CBOR Web Token (CWT) claims in the header parameters of any CBOR Object Signing and Encryption (COSE) structure. This functionality helps to facilitate applications that wish to make use of CWT claims in encrypted COSE structures and/or COSE structures featuring detached signatures, while having some of those claims be available before decryption and/or witho…

RFC95962024-06-01

CBOR Object Signing and Encryption (COSE) "typ" (type) Header Parameter

CBOR Object Signing and Encryption (COSE) "typ" (type) Header Parameter

This specification adds the equivalent of the JSON Object Signing and Encryption (JOSE) "typ" (type) header parameter to CBOR Object Signing and Encryption (COSE). This enables the benefits of explicit typing (as defined in RFC 8725, "JSON Web Token Best Current Practices") to be brought to COSE objects. The syntax of the COSE type header parameter value is the same as the existing COSE content ty…

RFC95952024-07-01

YANG Schema Item iDentifier (YANG SID)

YANG Schema Item iDentifier (YANG SID)

YANG Schema Item iDentifiers (YANG SIDs) are globally unique 63-bit unsigned integers used to identify YANG items. SIDs provide a more compact method for identifying those YANG items that can be used efficiently, notably in constrained environments (RFC 7228). This document defines the semantics, registration processes, and assignment processes for YANG SIDs for IETF-managed YANG modules. To enabl…

RFC95942024-09-01

Key Provisioning for Group Communication Using Authentication and Authorization for Constrained Environments (ACE)

Key Provisioning for Group Communication Using Authentication and Authorization for Constrained Environments (ACE)

This document defines how to use the Authentication and Authorization for Constrained Environments (ACE) framework to distribute keying material and configuration parameters for secure group communication. Candidate group members that act as Clients and are authorized to join a group can do so by interacting with a Key Distribution Center (KDC) acting as the Resource Server, from which they obtain…

RFC95932024-07-01

Announcing Supported Authentication Methods in the Internet Key Exchange Protocol Version 2 (IKEv2)

Announcing Supported Authentication Methods in the Internet Key Exchange Protocol Version 2 (IKEv2)

This specification defines a mechanism that allows implementations of the Internet Key Exchange Protocol Version 2 (IKEv2) to indicate the list of supported authentication methods to their peers while establishing IKEv2 Security Associations (SAs). This mechanism improves interoperability when IKEv2 partners are configured with multiple credentials of different types for authenticating each other.

RFC95922024-06-01

Retiring the Tao of the IETF

Retiring the Tao of the IETF

This document retires and obsoletes the Tao of the IETF as an IETF-maintained document. This document also obsoletes RFC 6722, which describes the publication process of the Tao. Furthermore, this document describes the rationale for the retirement of the Tao. For archival purposes, the last version of the Tao is included in the appendix. Information that new participants need to engage in the wor…

RFC95912024-06-01

The Flexible Round-Optimized Schnorr Threshold (FROST) Protocol for Two-Round Schnorr Signatures

The Flexible Round-Optimized Schnorr Threshold (FROST) Protocol for Two-Round Schnorr Signatures

This document specifies the Flexible Round-Optimized Schnorr Threshold (FROST) signing protocol. FROST signatures can be issued after a threshold number of entities cooperate to compute a signature, allowing for improved distribution of trust and redundancy with respect to a secret key. FROST depends only on a prime-order group and cryptographic hash function. This document specifies a number of c…

RFC95902024-05-01

IMAP Extension for Returning Mailbox METADATA in Extended LIS

IMAP Extension for Returning Mailbox METADATA in Extended LIS

This document defines an extension to the Internet Message Access Protocol (IMAP) LIST command that allows the client to request mailbox annotations (metadata), along with other information typically returned by the LIST command.

RFC95892024-05-01

On the Use of the Cryptographic Message Syntax (CMS) Signing-Time Attribute in Resource Public Key Infrastructure (RPKI) Signed Objects

On the Use of the Cryptographic Message Syntax (CMS) Signing-Time Attribute in Resource Public Key Infrastructure (RPKI) Signed Objects

In the Resource Public Key Infrastructure (RPKI), Signed Objects are defined as Cryptographic Message Syntax (CMS) protected content types. A Signed Object contains a signing-time attribute, representing the purported time at which the object was signed by its issuer. RPKI repositories are accessible using the rsync and RPKI Repository Delta protocols, allowing Relying Parties (RPs) to synchronize…

RFC95882024-08-01

Kerberos Simple Password-Authenticated Key Exchange (SPAKE) Pre-authentication

Kerberos Simple Password-Authenticated Key Exchange (SPAKE) Pre-authentication

This document defines a new pre-authentication mechanism for the Kerberos protocol. The mechanism uses a password-authenticated key exchange (PAKE) to prevent brute-force password attacks, and it may incorporate a second factor.

RFC95872024-06-01

YANG Data Model for OSPFv3 Extended Link State Advertisements (LSAs)

YANG Data Model for OSPFv3 Extended Link State Advertisements (LSAs)

This document defines a YANG data model augmenting the IETF OSPF YANG data model (RFC 9129) to provide support for OSPFv3 Link State Advertisement (LSA) Extensibility as defined in RFC 8362. OSPFv3 Extended LSAs provide extensible TLV-based LSAs for the base LSA types defined in RFC 5340.

RFC95862024-05-01

IMAP Extension for Using and Returning Unique Identifiers (UIDs) Only

IMAP Extension for Using and Returning Unique Identifiers (UIDs) Only

The UIDONLY extension to the Internet Message Access Protocol (RFCs 3501 and 9051) allows clients to enable a mode in which information about mailbox changes is returned using only Unique Identifiers (UIDs). Message numbers are not returned in responses and cannot be used in requests once this extension is enabled. This helps both clients and servers to reduce resource usage required to maintain a…

RFC95852024-05-01

IMAP Response Code for Command Progress Notifications

IMAP Response Code for Command Progress Notifications

This document defines a new IMAP untagged response code, "INPROGRESS", that provides progress notifications regarding the status of long-running commands.

RFC95842024-06-01

RTP Payload Format for Essential Video Coding (EVC)

RTP Payload Format for Essential Video Coding (EVC)

This document describes an RTP payload format for the Essential Video Coding (EVC) standard, published as ISO/IEC International Standard 23094-1. EVC was developed by the MPEG. The RTP payload format allows for the packetization of one or more Network Abstraction Layer (NAL) units in each RTP packet payload and the fragmentation of a NAL unit into multiple RTP packets. The payload format has broad…

RFC95832024-06-01

Application Scenarios for the Quantum Internet

Application Scenarios for the Quantum Internet

The Quantum Internet has the potential to improve application functionality by incorporating quantum information technology into the infrastructure of the overall Internet. This document provides an overview of some applications expected to be used on the Quantum Internet and categorizes them. Some general requirements for the Quantum Internet are also discussed. The intent of this document is to …

RFC95822024-05-01

A Profile for Route Origin Authorizations (ROAs)

A Profile for Route Origin Authorizations (ROAs)

This document defines a standard profile for Route Origin Authorizations (ROAs). A ROA is a digitally signed object that provides a means of verifying that an IP address block holder has authorized an Autonomous System (AS) to originate routes to one or more prefixes within the address block. This document obsoletes RFC 6482.

RFC95812024-08-01

Concise Binary Object Representation (CBOR) Tags for Time, Duration, and Period

Concise Binary Object Representation (CBOR) Tags for Time, Duration, and Period

The Concise Binary Object Representation (CBOR, RFC 8949) is a data format whose design goals include the possibility of extremely small code size, fairly small message size, and extensibility without the need for version negotiation. In CBOR, one point of extensibility is the definition of CBOR tags. RFC 8949 defines two tags for time: CBOR tag 0 (RFC 3339 time as a string) and tag 1 (POSIX time …