⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC36822004-02-01

The Generalized TTL Security Mechanism (GTSM)

The Generalized TTL Security Mechanism (GTSM)

The use of a packet's Time to Live (TTL) (IPv4) or Hop Limit (IPv6) to protect a protocol stack from CPU-utilization based attacks has been proposed in many settings (see for example, RFC 2461). This document generalizes these techniques for use by other protocols such as BGP (RFC 1771), Multicast Source Discovery Protocol (MSDP), Bidirectional Forwarding Detection, and Label Distribution Protocol…

RFC36812004-01-01

Delegation of E.F.F.3.IP6.ARPA

Delegation of E.F.F.3.IP6.ARPA

This document discusses the need for delegation of the E.F.F.3.IP6.ARPA DNS zone in order to enable reverse lookups for 6bone addresses, and makes specific recommendations for the process needed to accomplish this.

RFC36802004-03-01

A Session Initiation Protocol (SIP) Event Package for Registrations

A Session Initiation Protocol (SIP) Event Package for Registrations

This document defines a Session Initiation Protocol (SIP) event package for registrations. Through its REGISTER method, SIP allows a user agent to create, modify, and delete registrations. Registrations can also be altered by administrators in order to enforce policy. As a result, these registrations represent a piece of state in the network that can change dynamically. There are many cases where …

RFC36792004-01-01

Unused Dynamic Host Configuration Protocol (DHCP) Option Codes

Unused Dynamic Host Configuration Protocol (DHCP) Option Codes

Prior to the publication of RFC 2489 (which was updated by RFC 2939), several option codes were assigned to proposed Dynamic Host Configuration Protocol (DHCP) options that were subsequently never used. This document lists those unused option codes and directs IANA to make these option codes available for assignment to other DHCP options in the future. The document also lists several option codes …

RFC36782004-01-01

Socket Interface Extensions for Multicast Source Filters

Socket Interface Extensions for Multicast Source Filters

The Internet Group Management Protocol (IGMPv3) for IPv4 and the Multicast Listener Discovery (MLDv2) for IPv6 add the capability for applications to express source filters on multicast group memberships, which allows receiver applications to determine the set of senders (sources) from which to accept multicast traffic. This capability also simplifies support of one-to-many type multicast applicat…

RFC36772003-12-01

Процедуры назначения IETF члена Совета попечителей ISOC

IETF ISOC Board of Trustee Appointment Procedures

RFC 3677 описывает процедуру, по которой IETF ежегодно выбирает кандидата для назначения в Совет попечителей Internet Society (ISOC), а IESG подтверждает этот выбор. Документ устанавливает публичный сбор кандидатур, их рассмотрение IAB, подтверждение IESG и ориентировочные сроки этапов по 4–6 недель. Кандидату следует быть активно вовлечённым в IETF, с особым акцентом на активное участие в рабочих…

Читать русский перевод →
RFC36762004-02-01

The Text/Plain Format and DelSp Parameters

The Text/Plain Format and DelSp Parameters

This specification establishes two parameters (Format and DelSP) to be used with the Text/Plain media type. In the presence of these parameters, trailing whitespace is used to indicate flowed lines and a canonical quote indicator is used to indicate quoted lines. This results in an encoding which appears as normal Text/Plain in older implementations, since it is in fact normal Text/Plain, yet prov…

RFC36752004-02-01

.sex Considered Dangerous

.sex Considered Dangerous

Periodically there are proposals to mandate the use of a special top level name or an IP address bit to flag "adult" or "unsafe" material or the like. This document explains why this is an ill considered idea from the legal, philosophical, and particularly, the technical points of view.

RFC36742003-12-01

Feature Discovery in Lightweight Directory Access Protocol (LDAP)

Feature Discovery in Lightweight Directory Access Protocol (LDAP)

The Lightweight Directory Access Protocol (LDAP) is an extensible protocol with numerous elective features. This document introduces a general mechanism for discovery of elective features and extensions which cannot be discovered using existing mechanisms.

RFC36732003-12-01

Lightweight Directory Access Protocol version 3 (LDAPv3): All Operational Attributes

Lightweight Directory Access Protocol version 3 (LDAPv3): All Operational Attributes

The Lightweight Directory Access Protocol (LDAP) supports a mechanism for requesting the return of all user attributes but not all operational attributes. This document describes an LDAP extension which clients may use to request the return of all operational attributes.

RFC36722003-12-01

Subentries in the Lightweight Directory Access Protocol (LDAP)

Subentries in the Lightweight Directory Access Protocol (LDAP)

In X.500 directories, subentries are special entries used to hold information associated with a subtree or subtree refinement. This document adapts X.500 subentries mechanisms for use with the Lightweight Directory Access Protocol (LDAP).

RFC36712003-12-01

Collective Attributes in the Lightweight Directory Access Protocol (LDAP)

Collective Attributes in the Lightweight Directory Access Protocol (LDAP)

X.500 collective attributes allow common characteristics to be shared between collections of entries. This document summarizes the X.500 information model for collective attributes and describes use of collective attributes in LDAP (Lightweight Directory Access Protocol). This document provides schema definitions for collective attributes for use in LDAP.

RFC36702004-01-01

Information Model for Describing Network Device QoS Datapath Mechanisms

Information Model for Describing Network Device QoS Datapath Mechanisms

The purpose of this document is to define an information model to describe the quality of service (QoS) mechanisms inherent in different network devices, including hosts. Broadly speaking, these mechanisms describe the properties common to selecting and conditioning traffic through the forwarding path (datapath) of a network device. This selection and conditioning of traffic in the datapath spans …

RFC36692004-02-01

Guidelines for Working Groups on Intellectual Property Issues

Guidelines for Working Groups on Intellectual Property Issues

This memo lays out a conceptual framework and rules of thumb useful for working groups dealing with Intellectual Property Rights (IPR) issues. It documents specific examples of how IPR issues have been dealt with in the IETF. This memo provides information for the Internet community.

RFC36682004-02-01

Intellectual Property Rights in IETF Technology

Intellectual Property Rights in IETF Technology

The IETF policies about Intellectual Property Rights (IPR), such as patent rights, relative to technologies developed in the IETF are designed to ensure that IETF working groups and participants have as much information about any IPR constraints on a technical proposal as possible. The policies are also intended to benefit the Internet community and the public at large, while respecting the legiti…

RFC36672004-02-01

IETF Rights in Contributions

IETF Rights in Contributions

The IETF policies about rights in Contributions to the IETF are designed to ensure that such Contributions can be made available to the IETF and Internet communities while permitting the authors to retain as many rights as possible. This memo details the IETF policies on rights in Contributions to the IETF. It also describes the objectives that the policies are designed to meet. This memo updates …

RFC36662004-01-01

Session Initiation Protocol (SIP) Public Switched Telephone Network (PSTN) Call Flows

Session Initiation Protocol (SIP) Public Switched Telephone Network (PSTN) Call Flows

This document contains best current practice examples of Session Initiation Protocol (SIP) call flows showing interworking with the Public Switched Telephone Network (PSTN). Elements in these call flows include SIP User Agents, SIP Proxy Servers, and PSTN Gateways. Scenarios include SIP to PSTN, PSTN to SIP, and PSTN to PSTN via SIP. PSTN telephony protocols are illustrated using ISDN (Integrated …

RFC36652004-01-01

Примеры базовых потоков вызовов протокола инициации сеансов (SIP)

Session Initiation Protocol (SIP) Basic Call Flow Examples

RFC 3665 содержит проверенные рабочей группой примеры базовых потоков сигнализации SIP, основанные на SIP версии 2.0 из RFC 3261 и использовании SDP по RFC 3264. Он охватывает регистрацию SIP, установление и завершение сеансов напрямую и через прокси-серверы, множественную аутентификацию прокси, отказ прокси, SIP ALG, перенаправление, re-INVITE при смене IP-адреса и несколько неуспешных сценариев.…

Читать русский перевод →
RFC36642004-01-01

The AES-XCBC-PRF-128 Algorithm for the Internet Key Exchange Protocol (IKE)

The AES-XCBC-PRF-128 Algorithm for the Internet Key Exchange Protocol (IKE)

Some implementations of IP Security (IPsec) may want to use a pseudo-random function derived from the Advanced Encryption Standard (AES). This document describes such an algorithm, called AES-XCBC-PRF-128.

RFC36632003-12-01

Domain Administrative Data in Lightweight Directory Access Protocol (LDAP)

Domain Administrative Data in Lightweight Directory Access Protocol (LDAP)

Domain registration data has typically been exposed to the general public via Nicname/Whois for administrative purposes. This document describes the Referral Lightweight Directory Access Protocol (LDAP) Service, an experimental service using LDAP and well-known LDAP types to make domain administrative data available.

RFC36622003-12-01

A Lower Effort Per-Domain Behavior (PDB) for Differentiated Services

A Lower Effort Per-Domain Behavior (PDB) for Differentiated Services

This document proposes a differentiated services per-domain behavior (PDB) whose traffic may be "starved" (although starvation is not strictly required) in a properly functioning network. This is in contrast to the Internet's "best-effort" or "normal Internet traffic" model, where prolonged starvation indicates network problems. In this sense, the proposed PDB's traffic is forwarded with a "lower"…

RFC36612003-12-01

Media Gateway Control Protocol (MGCP) Return Code Usage

Media Gateway Control Protocol (MGCP) Return Code Usage

This document provides implementation guidelines for the use of return codes in RFC 3435, Media Gateway Control Protocol (MGCP) Version 1.0. Return codes in RFC 3435 do not cover all possible specific situations that may ever occur in a gateway. That is not possible and not necessary. What is important is to ensure that the Call Agent that receives a return code behaves appropriately and consisten…

RFC36602003-12-01

Basic Media Gateway Control Protocol (MGCP) Packages

Basic Media Gateway Control Protocol (MGCP) Packages

This document provides a basic set of Media Gateway Control Protocol (MGCP) packages. The generic, line, trunk, handset, RTP, DTMF (Dual Tone Multifrequency), announcement server and script packages are updates of packages from RFC 2705 with additional explanation and in some cases new versions of these packages. In addition to these, five new packages are defined here. These are the signal list, …

RFC36592007-03-01

Extensions to FTP

Extensions to FTP

This document specifies new FTP commands to obtain listings of remote directories in a defined format, and to permit restarts of interrupted data transfers in STREAM mode. It allows character sets other than US-ASCII, and also defines an optional virtual file storage structure. [STANDARDS-TRACK]

RFC36582003-12-01

Delegation Signer (DS) Resource Record (RR)

Delegation Signer (DS) Resource Record (RR)

The delegation signer (DS) resource record (RR) is inserted at a zone cut (i.e., a delegation point) to indicate that the delegated zone is digitally signed and that the delegated zone recognizes the indicated key as a valid zone key for the delegated zone. The DS RR is a modification to the DNS Security Extensions definition, motivated by operational considerations. The intent is to use this reso…

RFC36572004-01-01

Use of the Camellia Encryption Algorithm in Cryptographic Message Syntax (CMS)

Use of the Camellia Encryption Algorithm in Cryptographic Message Syntax (CMS)

This document specifies the conventions for using the Camellia encryption algorithm for encryption with the Cryptographic Message Syntax (CMS).

RFC36562003-12-01

The Mailbox Update (MUPDATE) Distributed Mailbox Database Protocol

The Mailbox Update (MUPDATE) Distributed Mailbox Database Protocol

As the demand for high-performance mail delivery agents increases, it becomes apparent that single-machine solutions are inadequate to the task, both because of capacity limits and that the failure of the single machine means a loss of mail delivery for all users. It is preferable to allow many machines to share the responsibility of mail delivery. The Mailbox Update (MUPDATE) protocol allows a gr…

RFC36552003-11-01

Redefinition of DNS Authenticated Data (AD) bit

Redefinition of DNS Authenticated Data (AD) bit

This document alters the specification defined in RFC 2535. Based on implementation experience, the Authenticated Data (AD) bit in the DNS header is not useful. This document redefines the AD bit such that it is only set if all answers or records proving that no answers exist in the response has been cryptographically verified or otherwise meets the server's local security policy.

RFC36542003-12-01

Requirements for Separation of IP Control and Forwarding

Requirements for Separation of IP Control and Forwarding

This document introduces the Forwarding and Control Element Separation (ForCES) architecture and defines a set of associated terminology. This document also defines a set of architectural, modeling, and protocol requirements to logically separate the control and data forwarding planes of an IP (IPv4, IPv6, etc.) networking device.

RFC36532003-12-01

XML-Signature XPath Filter 2.0

XML-Signature XPath Filter 2.0

XML Signature recommends a standard means for specifying information content to be digitally signed and for representing the resulting digital signatures in XML. Some applications require the ability to specify a subset of a given XML document as the information content to be signed. The XML Signature specification meets this requirement with the XPath transform. However, this transform can be dif…