⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC34112002-12-01

An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks

An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks

This document describes an architecture for describing Simple Network Management Protocol (SNMP) Management Frameworks. The architecture is designed to be modular to allow the evolution of the SNMP protocol standards over time. The major portions of the architecture are an SNMP engine containing a Message Processing Subsystem, a Security Subsystem and an Access Control Subsystem, and possibly mult…

RFC34102002-12-01

Introduction and Applicability Statements for Internet-Standard Management Framework

Introduction and Applicability Statements for Internet-Standard Management Framework

The purpose of this document is to provide an overview of the third version of the Internet-Standard Management Framework, termed the SNMP version 3 Framework (SNMPv3). This Framework is derived from and builds upon both the original Internet-Standard Management Framework (SNMPv1) and the second Internet-Standard Management Framework (SNMPv2). The architecture is designed to be modular to allow th…

RFC34092002-12-01

Lower Layer Guidelines for Robust RTP/UDP/IP Header Compression

Lower Layer Guidelines for Robust RTP/UDP/IP Header Compression

This document describes lower layer guidelines for robust header compression (ROHC) and the requirements ROHC puts on lower layers. The purpose of this document is to support the incorporation of robust header compression algorithms, as specified in the ROHC working group, into different systems such as those specified by Third Generation Partnership Project (3GPP), 3GPP Project 2 (3GPP2), Europea…

RFC34082002-12-01

Zero-byte Support for Bidirectional Reliable Mode (R-mode) in Extended Link-Layer Assisted RObust Header Compression (ROHC) Profile

Zero-byte Support for Bidirectional Reliable Mode (R-mode) in Extended Link-Layer Assisted RObust Header Compression (ROHC) Profile

This document defines an additional mode of the link-layer assisted RObust Header Compression (ROHC) profile, also known as the zero-byte profile, beyond the two defined in RFC 3242. Zero-byte header compression exists in order to prevent the single-octet ROHC header from pushing a packet voice stream into the next higher fixed packet size for the radio. It is usable in certain widely deployed old…

RFC34072002-10-01

Session Description Protocol (SDP) Simple Capability Declaration

Session Description Protocol (SDP) Simple Capability Declaration

This document defines a set of Session Description Protocol (SDP) attributes that enables SDP to provide a minimal and backwards compatible capability declaration mechanism. Such capability declarations can be used as input to a subsequent session negotiation, which is done by means outside the scope of this document. This provides a simple and limited solution to the general capability negotiatio…

RFC34062002-10-01

Uniform Resource Names (URN) Namespace Definition Mechanisms

Uniform Resource Names (URN) Namespace Definition Mechanisms

This document lays out general definitions of and mechanisms for establishing Uniform Resource Names (URN) "namespaces". The URN WG has defined a syntax for URNs in RFC 2141, as well as some proposed mechanisms for their resolution and use in Internet applications in RFC 3401 and RFC 3405. The whole rests on the concept of individual "namespaces" within the URN structure. Apart from proof-of-conce…

RFC34052002-10-01

Система обнаружения динамического делегирования (DDDS), часть пятая: процедуры назначения URI.ARPA

Dynamic Delegation Discovery System (DDDS) Part Five: URI.ARPA Assignment Procedures

RFC 3405 устанавливает политики и процедуры внесения записей Naming Authority Pointer (NAPTR) в DNS-зоны URI.ARPA и URN.ARPA для разрешения URI и URN в рамках DDDS. Регистрация для URI.ARPA допускается только для схем URI из дерева IETF и не может предшествовать корректной регистрации схемы и публикации стабильной спецификации; аналогично, регистрация для URN.ARPA не может предшествовать корректно…

Читать русский перевод →
RFC34042002-10-01

Dynamic Delegation Discovery System (DDDS) Part Four: The Uniform Resource Identifiers (URI)

Dynamic Delegation Discovery System (DDDS) Part Four: The Uniform Resource Identifiers (URI)

This document describes a specification for taking Uniform Resource Identifiers (URI) and locating an authoritative server for information about that URI. The method used to locate that authoritative server is the Dynamic Delegation Discovery System. This document is part of a series that is specified in "Dynamic Delegation Discovery System (DDDS) Part One: The Comprehensive DDDS" (RFC 3401). It i…

RFC34032002-10-01

Dynamic Delegation Discovery System (DDDS) Part Three: The Domain Name System (DNS) Database

Dynamic Delegation Discovery System (DDDS) Part Three: The Domain Name System (DNS) Database

This document describes a Dynamic Delegation Discovery System (DDDS) Database using the Domain Name System (DNS) as a distributed database of Rules. The Keys are domain-names and the Rules are encoded using the Naming Authority Pointer (NAPTR) Resource Record (RR). Since this document obsoletes RFC 2915, it is the official specification for the NAPTR DNS Resource Record. It is also part of a serie…

RFC34022002-10-01

Dynamic Delegation Discovery System (DDDS) Part Two: The Algorithm

Dynamic Delegation Discovery System (DDDS) Part Two: The Algorithm

This document describes the Dynamic Delegation Discovery System (DDDS) algorithm for applying dynamically retrieved string transformation rules to an application-unique string. Well-formed transformation rules will reflect the delegation of management of information associated with the string. This document is also part of a series that is completely specified in "Dynamic Delegation Discovery Syst…

RFC34012002-10-01

Dynamic Delegation Discovery System (DDDS) Part One: The Comprehensive DDDS

Dynamic Delegation Discovery System (DDDS) Part One: The Comprehensive DDDS

This document specifies the exact documents that make up the complete Dynamic Delegation Discovery System (DDDS). DDDS is an abstract algorithm for applying dynamically retrieved string transformation rules to an application-unique string. This document along with RFC 3402, RFC 3403 and RFC 3404 obsolete RFC 2168 and RFC 2915, as well as updates RFC 2276. This memo provides information for the Int…

RFC33982002-12-01

Integrated Services Digital Network (ISDN) User Part (ISUP) to Session Initiation Protocol (SIP) Mapping

Integrated Services Digital Network (ISDN) User Part (ISUP) to Session Initiation Protocol (SIP) Mapping

This document describes a way to perform the mapping between two signaling protocols: the Session Initiation Protocol (SIP) and the ISDN User Part (ISUP) of SS7. This mechanism might be implemented when using SIP in an environment where part of the call involves interworking with the Public Switched Telephone Network (PSTN).

RFC33972002-11-01

Dynamic Host Configuration Protocol (DHCP) Domain Search Option

Dynamic Host Configuration Protocol (DHCP) Domain Search Option

This document defines a new DHCP option which is passed from the DHCP Server to the DHCP Client to specify the domain search list used when resolving hostnames using DNS.

RFC33962002-11-01

Encoding Long Options in the Dynamic Host Configuration Protocol (DHCPv4)

Encoding Long Options in the Dynamic Host Configuration Protocol (DHCPv4)

This document specifies the processing rules for DHCPv4 options that appear multiple times in the same message. Multiple instances of the same option are generated when an option exceeds 255 octets in size (the maximum size of a single option) or when an option needs to be split apart in order to take advantage of DHCP option overloading. When multiple instances of the same option appear in the op…

RFC33952002-09-01

Remote Network Monitoring MIB Protocol Identifier Reference Extensions

Remote Network Monitoring MIB Protocol Identifier Reference Extensions

This memo defines extensions to the Protocol Identifier Reference document for the identification of application verb information. It does not obsolete any portion of the Protocol Identifier Reference document. In particular, it describes the algorithms required to identify protocol operations (verbs) within the protocol encapsulations managed with the Remote Network Monitoring MIB Version 2, RFC …

RFC33942002-10-01

Advanced Encryption Standard (AES) Key Wrap Algorithm

Advanced Encryption Standard (AES) Key Wrap Algorithm

The purpose of this document is to make the AES Key Wrap algorithm conveniently available to the Internet community. The United States of America has adopted AES as the new encryption standard. The AES Key Wrap algorithm will probably be adopted by the USA for encryption of AES keys. The authors took most of the text in this document from the draft AES Key Wrap posted by NIST.

RFC33932002-11-01

IP Packet Delay Variation Metric for IP Performance Metrics (IPPM)

IP Packet Delay Variation Metric for IP Performance Metrics (IPPM)

This memo refers to a metric for variation in delay of packets across Internet paths. The metric is based on the difference in the One-Way- Delay of selected packets. This difference in delay is called 'IP Packet Delay variation.' The metric is valid for measurements between two hosts both in the case that they have synchronized clocks and in the case that they are not synchronized. We discuss bot…

RFC33922002-11-01

Capabilities Advertisement with BGP-4

Capabilities Advertisement with BGP-4

Currently BGP-4 requires that when a BGP speaker receives an OPEN message with one or more unrecognized Optional Parameters, the speaker must terminate BGP peering. This complicates introduction of new capabilities in BGP. This document defines new Optional Parameter, called Capabilities, that is expected to facilitate introduction of new capabilities in BGP by providing graceful capability advert…

RFC33912002-12-01

The MIME Application/Vnd.pwg-multiplexed Content-Type

The MIME Application/Vnd.pwg-multiplexed Content-Type

The Application/Vnd.pwg-multiplexed content-type, like the Multipart/Related content-type, provides a mechanism for representing objects that consist of multiple components. An Application/Vnd.pwg- multiplexed entity contains a sequence of chunks. Each chunk contains a MIME message or a part of a MIME message. Each MIME message represents a component of the compound object, just as a body part of …

RFC33902002-11-01

Increasing TCP's Initial Window

Increasing TCP's Initial Window

This document specifies an optional standard for TCP to increase the permitted initial window from one segment to roughly 4K bytes, replacing RFC 2414. This document discusses the advantages and disadvantages of the higher initial window. The document includes discussion of experiments and simulations showing that the higher initial window does not lead to congestion collapse. Finally, the documen…

RFC33892002-10-01

Real-time Transport Protocol (RTP) Payload for Comfort Noise (CN)

Real-time Transport Protocol (RTP) Payload for Comfort Noise (CN)

This document describes an RTP [2] payload format for transporting comfort noise (CN). The CN payload type is primarily for use with audio codecs that do not support comfort noise as part of the codec itself such as ITU-T Recommendations G.711 [3], G.726 [4], G.727 [5], G.728 [6], and G.722 [7].

RFC33882002-12-01

Grouping of Media Lines in the Session Description Protocol (SDP)

Grouping of Media Lines in the Session Description Protocol (SDP)

This document defines two SDP attributes: 'groupe' and 'mid'. They allow to group together several 'm' lines for two different purposes: for lip synchronization and for receiving media from a single flow (several media streams), encoded in different formats during a particular session, in different ports and host interfaces.

RFC33872002-10-01

Considerations from the Service Management Research Group (SMRG) on Quality of Service (QoS) in the IP Network

Considerations from the Service Management Research Group (SMRG) on Quality of Service (QoS) in the IP Network

The guiding principles in the design of IP network management were simplicity and no centralized control. The best effort service paradigm was a result of the original management principles and the other way around. New methods to distinguish the service given to one set of packets or flows relative to another are well underway. However, as IP networks evolve the management approach of the past ma…

RFC33862002-11-01

Network Hierarchy and Multilayer Survivability

Network Hierarchy and Multilayer Survivability

This document is the deliverable out of the Network Hierarchy and Survivability Techniques Design Team established within the Traffic Engineering Working Group. This team collected and documented current and near term requirements for survivability and hierarchy in service provider environments. For clarity, an expanded set of definitions is included. The team determined that there appears to be a…

RFC33852002-09-01

Internet Protocol Small Computer System Interface (iSCSI) Cyclic Redundancy Check (CRC)/Checksum Considerations

Internet Protocol Small Computer System Interface (iSCSI) Cyclic Redundancy Check (CRC)/Checksum Considerations

Cyclic redundancy check (CRC) codes [Peterson] are shortened cyclic codes used for error detection. A number of CRC codes have been adopted in standards: ATM, IEC, IEEE, CCITT, IBM-SDLC, and more [Baicheva]. The most important expectation from this kind of code is a very low probability for undetected errors. The probability of undetected errors in such codes has been, and still is, subject to ext…

RFC33842002-10-01

Lightweight Directory Access Protocol (version 3) Replication Requirements

Lightweight Directory Access Protocol (version 3) Replication Requirements

This document discusses the fundamental requirements for replication of data accessible via the Lightweight Directory Access Protocol (version 3) [RFC2251]. It is intended to be a gathering place for general replication requirements needed to provide interoperability between informational directories.

RFC33832002-09-01

Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

This document provides procedures for registering extensible elements of LDAP (Lightweight Directory Access Protocol). The document also provides guidelines to IANA (Internet Assigned Numbers Authority) describing conditions under which new values can be assigned

RFC33822002-10-01

Internet Printing Protocol (IPP): The 'collection' attribute syntax

Internet Printing Protocol (IPP): The 'collection' attribute syntax

This document specifies an OPTIONAL attribute syntax called 'collection' for use with the Internet Printing Protocol/1.0 (IPP) [RFC2565, RFC2566], IPP/1.1 [RFC2911, RFC2910]. A 'collection' is a container holding one or more named values, which are called 'member' attributes.

RFC33812002-10-01

Internet Printing Protocol (IPP): Job Progress Attributes

Internet Printing Protocol (IPP): Job Progress Attributes

This document defines four new Job Description attributes for monitoring job progress to be registered as OPTIONAL extensions to IPP/1.0 [RFC2566] and IPP/1.1 [RFC2911].

RFC33802002-10-01

Internet Printing Protocol (IPP): Job and Printer Set Operations

Internet Printing Protocol (IPP): Job and Printer Set Operations

This document specifies 3 additional OPTIONAL operations for use with the Internet Printing Protocol/1.0 (IPP) [RFC2565, RFC2566], and IPP/1.1 [RFC2911, RFC2910]. The end user, operator, and administrator Set-Job-Attributes and Set-Printer-Attributes operations are used to modify IPP Job objects and Printer objects, respectively. The third administrator Get-Printer-Supported-Values operation retur…