⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC85822019-08-01

Diameter Overload Rate Control

Diameter Overload Rate Control

This specification documents an extension to the Diameter Overload Indication Conveyance (DOIC) base solution, which is defined in RFC 7683. This extension adds a new overload-control abatement algorithm. This abatement algorithm allows for a DOIC reporting node to specify a maximum rate at which a DOIC reacting node sends Diameter requests to the DOIC reporting node.

RFC85812019-08-01

Diameter Agent Overload and the Peer Overload Report

Diameter Agent Overload and the Peer Overload Report

This specification documents an extension to the Diameter Overload Indication Conveyance (DOIC), a base solution for Diameter overload defined in RFC 7683. The extension defines the Peer Overload report type. The initial use case for the peer report is the handling of occurrences of overload of a Diameter Agent.

RFC85802019-05-01

Sieve Extension: File Carbon Copy (FCC)

Sieve Extension: File Carbon Copy (FCC)

The Sieve email filtering language provides a number of action commands, some of which can generate additional messages on behalf of the user. This document defines an extension to such commands to allow a copy of any generated message to be filed into a target mailbox. This document updates RFCs 5230 and 5435 by adding a new tagged argument to the Vacation and Notify actions, respectively.

RFC85792019-05-01

Sieve Email Filtering: Delivering to Special-Use Mailboxes

Sieve Email Filtering: Delivering to Special-Use Mailboxes

The SPECIAL-USE capability of the IMAP protocol (RFC 6154) allows clients to identify special-use mailboxes, e.g., where draft or sent messages should be put. This simplifies client configuration. In contrast, the Sieve mail filtering language (RFC 5228) currently has no such capability. This memo defines a Sieve extension that fills this gap: it adds a test for checking whether a special-use attr…

RFC85782019-05-01

Deterministic Networking Use Cases

Deterministic Networking Use Cases

This document presents use cases for diverse industries that have in common a need for "deterministic flows". "Deterministic" in this context means that such flows provide guaranteed bandwidth, bounded latency, and other properties germane to the transport of time-sensitive data. These use cases differ notably in their network topologies and specific desired behavior, providing as a group broad in…

RFC85772019-04-01

Signaling RSVP-TE Tunnels on a Shared MPLS Forwarding Plane

Signaling RSVP-TE Tunnels on a Shared MPLS Forwarding Plane

As the scale of MPLS RSVP-TE networks has grown, the number of Label Switched Paths (LSPs) supported by individual network elements has increased. Various implementation recommendations have been proposed to manage the resulting increase in the amount of control-plane state information. However, those changes have had no effect on the number of labels that a transit Label Switching Router (LSR) ha…

RFC85762019-04-01

Internet of Things (IoT) Security: State of the Art and Challenges

Internet of Things (IoT) Security: State of the Art and Challenges

The Internet of Things (IoT) concept refers to the usage of standard Internet protocols to allow for human-to-thing and thing-to-thing communication. The security needs for IoT systems are well recognized, and many standardization steps to provide security have been taken -- for example, the specification of the Constrained Application Protocol (CoAP) secured with Datagram Transport Layer Security…

RFC85752019-05-01

YANG Data Model for the Precision Time Protocol (PTP)

YANG Data Model for the Precision Time Protocol (PTP)

This document defines a YANG data model for the configuration of devices and clocks using the Precision Time Protocol (PTP) as specified in IEEE Std 1588-2008. It also defines the retrieval of the configuration information, the data sets and the running states of PTP clocks. The YANG module in this document conforms to the Network Management Datastore Architecture (NMDA).

RFC85742019-04-01

cite-as: A Link Relation to Convey a Preferred URI for Referencing

cite-as: A Link Relation to Convey a Preferred URI for Referencing

A web resource is routinely referenced by means of the URI with which it is directly accessed. But cases exist where referencing a resource by means of a different URI is preferred. This specification defines a link relation type that can be used to convey such a preference.

RFC85732019-06-01

Message Authentication Code for the Network Time Protocol

Message Authentication Code for the Network Time Protocol

The Network Time Protocol (NTP), as described in RFC 5905, states that NTP packets should be authenticated by appending NTP data to a 128-bit key and hashing the result with MD5 to obtain a 128-bit tag. This document deprecates MD5-based authentication, which is considered too weak, and recommends the use of AES-CMAC as described in RFC 4493 as a replacement.

RFC85722019-04-01

Secure Zero Touch Provisioning (SZTP)

Secure Zero Touch Provisioning (SZTP)

This document presents a technique to securely provision a networking device when it is booting in a factory-default state. Variations in the solution enable it to be used on both public and private networks. The provisioning steps are able to update the boot image, commit an initial configuration, and execute arbitrary scripts to address auxiliary needs. The updated device is subsequently able to…

RFC85712019-03-01

BGP - Link State (BGP-LS) Advertisement of IGP Traffic Engineering Performance Metric Extensions

BGP - Link State (BGP-LS) Advertisement of IGP Traffic Engineering Performance Metric Extensions

This document defines new BGP - Link State (BGP-LS) TLVs in order to carry the IGP Traffic Engineering Metric Extensions defined in the IS-IS and OSPF protocols.

RFC85702019-03-01

IS-IS Traffic Engineering (TE) Metric Extensions

IS-IS Traffic Engineering (TE) Metric Extensions

In certain networks, such as, but not limited to, financial information networks (e.g., stock market data providers), network-performance criteria (e.g., latency) are becoming as critical to data-path selection as other metrics. This document describes extensions to IS-IS Traffic Engineering Extensions (RFC 5305). These extensions provide a way to distribute and collect network-performance informa…

RFC85692019-07-01

Content-Centric Networking (CCNx) Semantics

Content-Centric Networking (CCNx) Semantics

This document describes the core concepts of the Content-Centric Networking (CCNx) architecture and presents a network protocol based on two messages: Interests and Content Objects. It specifies the set of mandatory and optional fields within those messages and describes their behavior and interpretation. This architecture and protocol specification is independent of a specific wire encoding. The …

RFC85682019-04-01

Network Virtualization Research Challenges

Network Virtualization Research Challenges

This document describes open research challenges for network virtualization. Network virtualization is following a similar path as previously taken by cloud computing. Specifically, cloud computing popularized migration of computing functions (e.g., applications) and storage from local, dedicated, physical resources to remote virtual functions accessible through the Internet. In a similar manner, …

RFC85672019-04-01

Customer Management DNS Resource Records

Customer Management DNS Resource Records

Maintaining high Quality of Experience (QoE) increasingly requires end-to-end, holistic network management, including managed Customer Premises Equipment (CPE). Because customer management is a shared global responsibility, the Domain Name System (DNS) provides an ideal existing infrastructure for maintaining authoritative customer information that must be readily, reliably, and publicly accessibl…

RFC85652019-04-01

Hypertext Jeopardy Protocol (HTJP/1.0)

Hypertext Jeopardy Protocol (HTJP/1.0)

The Hypertext Jeopardy Protocol (HTJP) inverts the request/response semantics of the Hypertext Transfer Protocol (HTTP). Using conventional HTTP, one connects to a server, asks a question, and expects a correct answer. Using HTJP, one connects to a server, sends an answer, and expects a correct question. This document specifies the semantics of HTJP.

RFC85642019-04-01

Support of Point-to-Multipoint Bidirectional Forwarding Detection (BFD) in Transparent Interconnection of Lots of Links (TRILL)

Support of Point-to-Multipoint Bidirectional Forwarding Detection (BFD) in Transparent Interconnection of Lots of Links (TRILL)

Point-to-multipoint (P2MP) Bidirectional Forwarding Detection (BFD) is designed to verify multipoint connectivity. This document specifies the support of P2MP BFD in Transparent Interconnection of Lots of Links (TRILL). Similar to TRILL point-to-point BFD, BFD Control packets in TRILL P2MP BFD are transmitted using RBridge Channel messages. This document updates RFCs 7175 and 7177.

RFC85632019-04-01

Bidirectional Forwarding Detection (BFD) Multipoint Active Tails

Bidirectional Forwarding Detection (BFD) Multipoint Active Tails

This document describes active tail extensions to the Bidirectional Forwarding Detection (BFD) protocol for multipoint networks.

RFC85622019-04-01

Bidirectional Forwarding Detection (BFD) for Multipoint Networks

Bidirectional Forwarding Detection (BFD) for Multipoint Networks

This document describes extensions to the Bidirectional Forwarding Detection (BFD) protocol for its use in multipoint and multicast networks. This document updates RFC 5880.

RFC85612019-06-01

A YANG Data Model for Microwave Radio Link

A YANG Data Model for Microwave Radio Link

This document defines a YANG data model for control and management of radio link interfaces and their connectivity to packet (typically Ethernet) interfaces in a microwave/millimeter wave node. The data nodes for management of the interface protection functionality is broken out into a separate and generic YANG data model in order to make it available for other interface types as well.

RFC85602019-05-01

Seamless Integration of Ethernet VPN (EVPN) with Virtual Private LAN Service (VPLS) and Their Provider Backbone Bridge (PBB) Equivalents

Seamless Integration of Ethernet VPN (EVPN) with Virtual Private LAN Service (VPLS) and Their Provider Backbone Bridge (PBB) Equivalents

This document specifies mechanisms for backward compatibility of Ethernet VPN (EVPN) and Provider Backbone Bridge Ethernet VPN (PBB-EVPN) solutions with Virtual Private LAN Service (VPLS) and Provider Backbone Bridge VPLS (PBB-VPLS) solutions. It also provides mechanisms for the seamless integration of these two technologies in the same MPLS/IP network on a per-VPN-instance basis. Implementation o…

RFC85592019-04-01

Dynamic Authorization Proxying in the Remote Authentication Dial-In User Service (RADIUS) Protocol

Dynamic Authorization Proxying in the Remote Authentication Dial-In User Service (RADIUS) Protocol

RFC 5176 defines Change-of-Authorization (CoA) and Disconnect Message (DM) behavior for RADIUS. RFC 5176 also suggests that proxying these messages is possible, but it does not provide guidance as to how that is done. This specification updates RFC 5176 to correct that omission for scenarios where networks use realm-based proxying as defined in RFC 7542. This specification also updates RFC 5580 to…

RFC85582019-04-01

Transport Protocol Path Signals

Transport Protocol Path Signals

This document discusses the nature of signals seen by on-path elements examining transport protocols, contrasting implicit and explicit signals. For example, TCP's state machine uses a series of well-known messages that are exchanged in the clear. Because these are visible to network elements on the path between the two nodes setting up the transport connection, they are often used as signals by t…

RFC85572019-05-01

Deterministic Networking Problem Statement

Deterministic Networking Problem Statement

This paper documents the needs in various industries to establish multi-hop paths for characterized flows with deterministic properties.

RFC85562019-04-01

Multicast VPN Using Bit Index Explicit Replication (BIER)

Multicast VPN Using Bit Index Explicit Replication (BIER)

The Multicast Virtual Private Network (MVPN) specifications require the use of multicast tunnels ("P-tunnels") that traverse a service provider's backbone network. The P-tunnels are used for carrying multicast traffic across the backbone. A variety of P-tunnel types are supported. Bit Index Explicit Replication (BIER) is a new architecture that provides optimal multicast forwarding through a "mult…

RFC85552019-03-01

Automatic Certificate Management Environment (ACME)

Automatic Certificate Management Environment (ACME)

Public Key Infrastructure using X.509 (PKIX) certificates are used for a number of purposes, the most significant of which is the authentication of domain names. Thus, certification authorities (CAs) in the Web PKI are trusted to verify that an applicant for a certificate legitimately represents the domain name(s) in the certificate. As of this writing, this verification is done through a collecti…

RFC85542019-04-01

Leighton-Micali Hash-Based Signatures

Leighton-Micali Hash-Based Signatures

This note describes a digital-signature system based on cryptographic hash functions, following the seminal work in this area of Lamport, Diffie, Winternitz, and Merkle, as adapted by Leighton and Micali in 1995. It specifies a one-time signature scheme and a general signature scheme. These systems provide asymmetric authentication without using large integer mathematics and can achieve a high sec…

RFC85532019-03-01

DNS Attrleaf Changes: Fixing Specifications That Use Underscored Node Names

DNS Attrleaf Changes: Fixing Specifications That Use Underscored Node Names

Using an underscore for a prefix creates a space for constrained interoperation of resource records. Original uses of an underscore character as a domain node name prefix were specified without the benefit of an IANA registry. This produced an entirely uncoordinated set of name-creation activities, all drawing from the same namespace. A registry for these names has now been defined by RFC 8552. Ho…

RFC85522019-03-01

Scoped Interpretation of DNS Resource Records through "Underscored" Naming of Attribute Leaves

Scoped Interpretation of DNS Resource Records through "Underscored" Naming of Attribute Leaves

Formally, any DNS Resource Record (RR) may occur under any domain name. However, some services use an operational convention for defining specific interpretations of an RRset by locating the records in a DNS branch under the parent domain to which the RRset actually applies. The top of this subordinate branch is defined by a naming convention that uses a reserved node name, which begins with the u…