⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC79182016-08-01

Transport Layer Security (TLS) False Start

Transport Layer Security (TLS) False Start

This document specifies an optional behavior of Transport Layer Security (TLS) client implementations, dubbed "False Start". It affects only protocol timing, not on-the-wire protocol data, and can be implemented unilaterally. A TLS False Start reduces handshake latency to one round trip.

RFC79172016-07-01

Advertising Node Administrative Tags in IS-IS

Advertising Node Administrative Tags in IS-IS

This document describes an extension to the IS-IS routing protocol to advertise node administrative tags. This optional capability allows tagging and grouping of the nodes in an IS-IS domain. The node administrative tags can be used to express and apply locally defined network policies, thereby providing a very useful operational capability. Node administrative tags may be used by either IS-IS its…

RFC79162016-07-01

Operational Management of Loop-Free Alternates

Operational Management of Loop-Free Alternates

Loop-Free Alternates (LFAs), as defined in RFC 5286, constitute an IP Fast Reroute (IP FRR) mechanism enabling traffic protection for IP traffic (and, by extension, MPLS LDP traffic). Following early deployment experiences, this document provides operational feedback on LFAs, highlights some limitations, and proposes a set of refinements to address those limitations. It also proposes required mana…

RFC79152016-06-01

IP/ICMP Translation Algorithm

IP/ICMP Translation Algorithm

This document describes the Stateless IP/ICMP Translation Algorithm (SIIT), which translates between IPv4 and IPv6 packet headers (including ICMP headers). This document obsoletes RFC 6145.

RFC79142016-08-01

The scrypt Password-Based Key Derivation Function

The scrypt Password-Based Key Derivation Function

This document specifies the password-based key derivation function scrypt. The function derives one or more secret keys from a secret string. It is based on memory-hard functions, which offer added protection against attacks using custom hardware. The document also provides an ASN.1 schema.

RFC79132016-06-01

P-Access-Network-Info ABNF Update

P-Access-Network-Info ABNF Update

This document updates RFC 7315, by modifying the extension-access- info part of the P-Access-Network-Info header field Augmented Backus- Naur Form (ABNF), and by adding the following 'access-info' header field parameter values to the list of 'access-info' header field parameter values in the ABNF: 'operator-specific-GI' and 'utran-sai-3gpp'. The values are defined in the ABNF but are not included …

RFC79122016-06-01

Message Authorizing Email Header Field and Its Use for the Draft and Release Procedure

Message Authorizing Email Header Field and Its Use for the Draft and Release Procedure

This document describes a procedure for when a Military Message Handling System (MMHS) message is composed by one user and is only released to the mail transfer system when one or more Authorizing Users authorize release of the message by adding the MMHS-Authorizing-Users header field. The resulting message can be optionally signed by the sender and/or reviewer, allowing recipients to verify both …

RFC79112016-07-01

Advertisement of Multiple Paths in BGP

Advertisement of Multiple Paths in BGP

This document defines a BGP extension that allows the advertisement of multiple paths for the same address prefix without the new paths implicitly replacing any previous ones. The essence of the extension is that each path is identified by a Path Identifier in addition to the address prefix.

RFC79102016-06-01

Interoperability between the Virtual Router Redundancy Protocol and PIM

Interoperability between the Virtual Router Redundancy Protocol and PIM

This document introduces VRRP-aware PIM, a redundancy mechanism for the Protocol Independent Multicast (PIM) to interoperate with the Virtual Router Redundancy Protocol (VRRP). It allows PIM to track VRRP state and to preserve multicast traffic upon failover in a redundant network with virtual routing groups enabled. The mechanism described in this document is based on Cisco IOS software implement…

RFC79092016-06-01

Securing Routing Policy Specification Language (RPSL) Objects with Resource Public Key Infrastructure (RPKI) Signatures

Securing Routing Policy Specification Language (RPSL) Objects with Resource Public Key Infrastructure (RPKI) Signatures

This document describes a method that allows parties to electronically sign Routing Policy Specification Language objects and validate such electronic signatures. This allows relying parties to detect accidental or malicious modifications of such objects. It also allows parties who run Internet Routing Registries or similar databases, but do not yet have authentication (based on Routing Policy Sys…

RFC79082016-06-01

Problem Definition and Classification of BGP Route Leaks

Problem Definition and Classification of BGP Route Leaks

A systemic vulnerability of the Border Gateway Protocol routing system, known as "route leaks", has received significant attention in recent years. Frequent incidents that result in significant disruptions to Internet routing are labeled route leaks, but to date a common definition of the term has been lacking. This document provides a working definition of route leaks while keeping in mind the re…

RFC79062016-06-01

NSA's Cryptographic Message Syntax (CMS) Key Management Attributes

NSA's Cryptographic Message Syntax (CMS) Key Management Attributes

This document defines key management attributes used by the National Security Agency (NSA). The attributes can appear in asymmetric and/or symmetric key packages as well as the Cryptographic Message Syntax (CMS) content types that subsequently envelope the key packages. Key packages described in RFCs 5958 and 6031 are examples of where these attributes can be used.

RFC79052016-06-01

ChaCha20-Poly1305 Cipher Suites for Transport Layer Security (TLS)

ChaCha20-Poly1305 Cipher Suites for Transport Layer Security (TLS)

This document describes the use of the ChaCha stream cipher and Poly1305 authenticator in the Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) protocols. This document updates RFCs 5246 and 6347.

RFC79042016-10-01

A SIP Usage for REsource LOcation And Discovery (RELOAD)

A SIP Usage for REsource LOcation And Discovery (RELOAD)

This document defines a SIP Usage for REsource LOcation And Discovery (RELOAD). The SIP Usage provides the functionality of a SIP proxy or registrar in a fully distributed system and includes a lookup service for Address of Records (AORs) stored in the overlay. It also defines Globally Routable User Agent URIs (GRUUs) that allow the registrations to map an AOR to a specific node reachable through …

RFC79032016-09-01

Windows Image Media Types

Windows Image Media Types

This document registers media types for certain image formats promulgated in Microsoft Windows, namely image/wmf, image/x-wmf, image/emf, image/x-emf, and image/bmp for use with Windows Metafile, Enhanced Metafile, and Windows Bitmap formats. Originally designed for Microsoft Windows 2.0 and 3.0, these image files are intended to be portable between applications and devices, and they may contain b…

RFC79022016-06-01

Registry and Extensions for P-Multicast Service Interface Tunnel Attribute Flags

Registry and Extensions for P-Multicast Service Interface Tunnel Attribute Flags

The BGP-based control procedures for Multicast Virtual Private Networks (MVPNs) make use of a BGP attribute known as the "P-Multicast Service Interface (PMSI) Tunnel" attribute. The attribute contains a one-octet "Flags" field. The purpose of this document is to establish an IANA registry for the assignment of the bits in this field. Since the "Flags" field contains only eight bits, this document …

RFC79012016-06-01

CHAIN Query Requests in DNS

CHAIN Query Requests in DNS

This document defines an EDNS0 extension that can be used by a security-aware validating resolver configured to use a forwarding resolver to send a single query, requesting a complete validation path along with the regular query answer. The reduction in queries potentially lowers the latency and reduces the need to send multiple queries at once. This extension mandates the use of source-IP- verifi…

RFC79002016-06-01

Extranet Multicast in BGP/IP MPLS VPNs

Extranet Multicast in BGP/IP MPLS VPNs

Previous RFCs specify the procedures necessary to allow IP multicast traffic to travel from one site to another within a BGP/MPLS IP VPN (Virtual Private Network). However, it is sometimes desirable to allow multicast traffic whose source is in one VPN to be received by systems that are in another VPN. This is known as a "Multicast VPN (MVPN) extranet". This document updates RFCs 6513, 6514, and 6…

RFC78992016-06-01

Multicast VPN State Damping

Multicast VPN State Damping

This document describes procedures to damp Multicast VPN (MVPN) routing state changes and control the effect of the churn due to the multicast dynamicity in customer sites. The procedures described in this document are applicable to BGP-based multicast VPN and help avoid uncontrolled control-plane load increase in the core routing infrastructure. The new procedures proposed were inspired by BGP un…

RFC78982016-06-01

Domain Subobjects for Resource Reservation Protocol - Traffic Engineering (RSVP-TE)

Domain Subobjects for Resource Reservation Protocol - Traffic Engineering (RSVP-TE)

The Resource Reservation Protocol - Traffic Engineering (RSVP-TE) specification and the Generalized Multiprotocol Label Switching (GMPLS) extensions to RSVP-TE allow abstract nodes and resources to be explicitly included in a path setup. Further, Exclude Route extensions to RSVP-TE allow abstract nodes and resources to be explicitly excluded in a path setup. This document specifies new subobjects …

RFC78972016-06-01

Domain Subobjects for the Path Computation Element Communication Protocol (PCEP)

Domain Subobjects for the Path Computation Element Communication Protocol (PCEP)

The ability to compute shortest constrained Traffic Engineering Label Switched Paths (TE LSPs) in Multiprotocol Label Switching (MPLS) and Generalized MPLS (GMPLS) networks across multiple domains has been identified as a key requirement. In this context, a domain is a collection of network elements within a common sphere of address management or path computational responsibility such as an Interi…

RFC78962016-06-01

Update to the Include Route Object (IRO) Specification in the Path Computation Element Communication Protocol (PCEP)

Update to the Include Route Object (IRO) Specification in the Path Computation Element Communication Protocol (PCEP)

The Path Computation Element Communication Protocol (PCEP) enables communications between a Path Computation Client (PCC) and a PCE, or between two PCEs. RFC 5440 defines the Include Route Object (IRO) to specify network elements to be traversed in the computed path. The specification does not specify if the IRO contains an ordered or unordered list of subobjects. During recent discussions, it was…

RFC78952016-06-01

YANG Module Library

YANG Module Library

This document describes a YANG library that provides information about all the YANG modules used by a network management server (e.g., a Network Configuration Protocol (NETCONF) server). Simple caching mechanisms are provided to allow clients to minimize retrieval of this information.

RFC78942016-06-01

Alternative Challenge Password Attributes for Enrollment over Secure Transport

Alternative Challenge Password Attributes for Enrollment over Secure Transport

This document defines a set of new Certificate Signing Request attributes for use with the Enrollment over Secure Transport (EST) protocol. These attributes provide disambiguation of the existing overloaded uses for the challengePassword attribute defined in "PKCS #9: Selected Object Classes and Attribute Types Version 2.0" (RFC 2985). Uses include the original certificate revocation password, com…

RFC78932016-06-01

Pseudowire Congestion Considerations

Pseudowire Congestion Considerations

Pseudowires (PWs) have become a common mechanism for tunneling traffic and may be found in unmanaged scenarios competing for network resources both with other PWs and with non-PW traffic, such as TCP/IP flows. Thus, it is worthwhile specifying under what conditions such competition is acceptable, i.e., the PW traffic does not significantly harm other traffic or contribute more than it should to co…

RFC78922016-05-01

IANA Allocation Procedures for the GMPLS OTN Signal Type Registry

IANA Allocation Procedures for the GMPLS OTN Signal Type Registry

IANA defined the "OTN Signal Type" subregistry of the "Generalized Multi-Protocol Label Switching (GMPLS) Signaling Parameters" registry in RFC 7139. This document updates the "OTN Signal Type" subregistry to allow registration via Specification Required.

RFC78912016-06-01

Explicit Reverse Path Forwarding (RPF) Vector

Explicit Reverse Path Forwarding (RPF) Vector

The PIM Reverse Path Forwarding (RPF) Vector TLV defined in RFC 5496 can be included in a PIM Join Attribute such that the RPF neighbor is selected based on the unicast reachability of the RPF Vector instead of the source or Rendezvous Point associated with the multicast tree. This document defines a new RPF Vector Attribute type such that an explicit RPF neighbor list can be encoded in the PIM Jo…

RFC78902016-06-01

Concepts and Terminology for Peer-to-Peer SIP (P2PSIP)

Concepts and Terminology for Peer-to-Peer SIP (P2PSIP)

This document defines concepts and terminology for using the Session Initiation Protocol in a peer-to-peer environment where the traditional proxy-registrar and message-routing functions are replaced by a distributed mechanism. These mechanisms may be implemented using a Distributed Hash Table or other distributed data mechanism with similar external properties. This document includes a high-level…

RFC78892016-05-01

The IMAP APPENDLIMIT Extension

The IMAP APPENDLIMIT Extension

This document defines an extension to the IMAP service whereby a server can inform the client about maximum message upload sizes, allowing the client to avoid sending APPEND commands that will fail because the messages are too large.

RFC78882016-05-01

IMAP4 Non-synchronizing Literals

IMAP4 Non-synchronizing Literals

The Internet Message Access Protocol (RFC 3501) contains the "literal" syntactic construct for communicating strings. When sending a literal from client to server, IMAP requires the client to wait for the server to send a command continuation request between sending the octet count and the string data. This document specifies an alternate form of literal that does not require this network round tr…