⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC71962014-05-01

Making Route Flap Damping Usable

Making Route Flap Damping Usable

Route Flap Damping (RFD) was first proposed to reduce BGP churn in routers. Unfortunately, RFD was found to severely penalize sites for being well connected because topological richness amplifies the number of update messages exchanged. Many operators have turned RFD off. Based on experimental measurement, this document recommends adjusting a few RFD algorithmic constants and limits in order to re…

RFC71952014-05-01

Session Description Protocol (SDP) Extension for Setting Audio and Video Media Streams over Circuit-Switched Bearers in the Public Switched Telephone Network (PSTN)

Session Description Protocol (SDP) Extension for Setting Audio and Video Media Streams over Circuit-Switched Bearers in the Public Switched Telephone Network (PSTN)

This memo describes use cases, requirements, and protocol extensions for using the Session Description Protocol (SDP) offer/answer model for establishing audio and video media streams over circuit-switched bearers in the Public Switched Telephone Network (PSTN).

RFC71942014-08-01

Default Port for Internet Relay Chat (IRC) via TLS/SSL

Default Port for Internet Relay Chat (IRC) via TLS/SSL

This document describes the commonly accepted practice of listening on TCP port 6697 for incoming Internet Relay Chat (IRC) connections encrypted via TLS/SSL.

RFC71932014-04-01

The application/cms Media Type

The application/cms Media Type

This document registers the application/cms media type for use with the corresponding CMS (Cryptographic Message Syntax) content types.

RFC71922014-04-01

Algorithms for Cryptographic Message Syntax (CMS) Key Package Receipt and Error Content Types

Algorithms for Cryptographic Message Syntax (CMS) Key Package Receipt and Error Content Types

This document describes the conventions for using several cryptographic algorithms with the Cryptographic Message Syntax (CMS) key package receipt and error content types. Specifically, it includes conventions necessary to implement SignedData, EnvelopedData, EncryptedData, and AuthEnvelopedData.

RFC71912014-04-01

Cryptographic Message Syntax (CMS) Key Package Receipt and Error Content Types

Cryptographic Message Syntax (CMS) Key Package Receipt and Error Content Types

This document defines the syntax for two Cryptographic Message Syntax (CMS) content types: one for key package receipts and another for key package errors. The key package receipt content type is used to confirm receipt of an identified key package or collection of key packages. The key package error content type is used to indicate an error occurred during the processing of a key package. CMS can…

RFC71902014-03-01

Use of Multipath with MPLS and MPLS Transport Profile (MPLS-TP)

Use of Multipath with MPLS and MPLS Transport Profile (MPLS-TP)

Many MPLS implementations have supported multipath techniques, and many MPLS deployments have used multipath techniques, particularly in very high-bandwidth applications, such as provider IP/MPLS core networks. MPLS Transport Profile (MPLS-TP) has strongly discouraged the use of multipath techniques. Some degradation of MPLS-TP Operations, Administration, and Maintenance (OAM) performance cannot b…

RFC71892014-03-01

Virtual Circuit Connectivity Verification (VCCV) Capability Advertisement for MPLS Transport Profile (MPLS-TP)

Virtual Circuit Connectivity Verification (VCCV) Capability Advertisement for MPLS Transport Profile (MPLS-TP)

This document specifies how signaling and selection processes for Pseudowire (PW) Virtual Circuit Connectivity Verification (VCCV) are modified to ensure backward compatibility and allow use of proactive Connectivity Verification (CV), Continuity Check (CC), and Remote Defect Indication (RDI) over MPLS Transport Profile (MPLS-TP) PWs. This document introduces four new CV types and, to accommodate …

RFC71882014-04-01

Optimized Link State Routing Protocol Version 2 (OLSRv2) and MANET Neighborhood Discovery Protocol (NHDP) Extension TLVs

Optimized Link State Routing Protocol Version 2 (OLSRv2) and MANET Neighborhood Discovery Protocol (NHDP) Extension TLVs

This specification describes extensions to definitions of TLVs used by the Optimized Link State Routing Protocol version 2 (OLSRv2) and the MANET Neighborhood Discovery Protocol (NHDP) to increase their abilities to accommodate protocol extensions. This document updates RFC 7181 (OLSRv2) and RFC 6130 (NHDP).

RFC71872014-04-01

Routing Multipoint Relay Optimization for the Optimized Link State Routing Protocol Version 2 (OLSRv2)

Routing Multipoint Relay Optimization for the Optimized Link State Routing Protocol Version 2 (OLSRv2)

This specification updates the Optimized Link State Routing Protocol version 2 (OLSRv2) with an optimization to improve the selection of routing multipoint relays. The optimization retains full interoperability between implementations of OLSRv2 with and without this optimization.

RFC71862014-04-01

Security Threats for the Neighborhood Discovery Protocol (NHDP)

Security Threats for the Neighborhood Discovery Protocol (NHDP)

This document analyzes common security threats of the Neighborhood Discovery Protocol (NHDP) and describes their potential impacts on Mobile Ad Hoc Network (MANET) routing protocols using NHDP. This document is not intended to propose solutions to the threats described.

RFC71852014-04-01

Link Metrics for the Mobile Ad Hoc Network (MANET) Routing Protocol OLSRv2 - Rationale

Link Metrics for the Mobile Ad Hoc Network (MANET) Routing Protocol OLSRv2 - Rationale

The Optimized Link State Routing Protocol version 2 (OLSRv2) includes the ability to assign metrics to links and to use those metrics to allow routing by other than minimum hop count routes. This document provides a historic record of the rationale for, and design considerations behind, how link metrics were included in OLSRv2.

RFC71842014-04-01

Definition of Managed Objects for the Optimized Link State Routing Protocol Version 2

Definition of Managed Objects for the Optimized Link State Routing Protocol Version 2

This document defines the Management Information Base (MIB) module for configuring and managing the Optimized Link State Routing Protocol version 2 (OLSRv2). The OLSRv2-MIB module is structured into configuration information, state information, performance information, and notifications. This additional state and performance information is useful for troubleshooting problems and performance issues…

RFC71832014-04-01

Integrity Protection for the Neighborhood Discovery Protocol (NHDP) and Optimized Link State Routing Protocol Version 2 (OLSRv2)

Integrity Protection for the Neighborhood Discovery Protocol (NHDP) and Optimized Link State Routing Protocol Version 2 (OLSRv2)

This document specifies integrity and replay protection for the Mobile Ad Hoc Network (MANET) Neighborhood Discovery Protocol (NHDP) and the Optimized Link State Routing Protocol version 2 (OLSRv2). This protection is achieved by using an HMAC-SHA-256 Integrity Check Value (ICV) TLV and a Timestamp TLV based on Portable Operating System Interface (POSIX) time. The mechanism in this specification c…

RFC71822014-04-01

Integrity Check Value and Timestamp TLV Definitions for Mobile Ad Hoc Networks (MANETs)

Integrity Check Value and Timestamp TLV Definitions for Mobile Ad Hoc Networks (MANETs)

This document revises, extends, and replaces RFC 6622. It describes general and flexible TLVs for representing cryptographic Integrity Check Values (ICVs) and timestamps, using the generalized Mobile Ad Hoc Network (MANET) packet/message format defined in RFC 5444. It defines two Packet TLVs, two Message TLVs, and two Address Block TLVs for affixing ICVs and timestamps to a packet, a message, and …

RFC71812014-04-01

The Optimized Link State Routing Protocol Version 2

The Optimized Link State Routing Protocol Version 2

This specification describes version 2 of the Optimized Link State Routing Protocol (OLSRv2) for Mobile Ad Hoc Networks (MANETs).

RFC71802014-05-01

Transparent Interconnection of Lots of Links (TRILL): Clarifications, Corrections, and Updates

Transparent Interconnection of Lots of Links (TRILL): Clarifications, Corrections, and Updates

The IETF Transparent Interconnection of Lots of Links (TRILL) protocol provides least-cost pair-wise data forwarding without configuration in multi-hop networks with arbitrary topology and link technology, safe forwarding even during periods of temporary loops, and support for multipathing of both unicast and multicast traffic. TRILL accomplishes this by using Intermediate System to Intermediate S…

RFC71792014-05-01

Transparent Interconnection of Lots of Links (TRILL): Header Extension

Transparent Interconnection of Lots of Links (TRILL): Header Extension

The IETF Transparent Interconnection of Lots of Links (TRILL) base protocol (RFC 6325) specifies minimal hooks to safely support TRILL Header extensions. This document specifies an initial extension providing additional flag bits and specifies some of those bits. It updates RFC 6325.

RFC71782014-05-01

Transparent Interconnection of Lots of Links (TRILL): RBridge Channel Support

Transparent Interconnection of Lots of Links (TRILL): RBridge Channel Support

This document specifies a general channel mechanism for sending messages, such as Bidirectional Forwarding Detection (BFD) messages, between Routing Bridges (RBridges) and between RBridges and end stations in an RBridge campus through extensions to the Transparent Interconnection of Lots of Links (TRILL) protocol.

RFC71772014-05-01

Transparent Interconnection of Lots of Links (TRILL): Adjacency

Transparent Interconnection of Lots of Links (TRILL): Adjacency

The IETF Transparent Interconnection of Lots of Links (TRILL) protocol supports arbitrary link technologies between TRILL switches, including point-to-point links and multi-access Local Area Network (LAN) links that can have multiple TRILL switches and end stations attached. TRILL uses Intermediate System to Intermediate System (IS-IS) routing. This document specifies the establishment, reporting,…

RFC71762014-05-01

Transparent Interconnection of Lots of Links (TRILL) Use of IS-IS

Transparent Interconnection of Lots of Links (TRILL) Use of IS-IS

The IETF Transparent Interconnection of Lots of Links (TRILL) protocol provides optimal pair-wise data frame forwarding without configuration in multi-hop networks with arbitrary topology and link technology; it also provides support for multipathing of both unicast and multicast traffic. This document specifies the data formats and code points for the IS-IS extensions to support TRILL. These data…

RFC71752014-05-01

Transparent Interconnection of Lots of Links (TRILL): Bidirectional Forwarding Detection (BFD) Support

Transparent Interconnection of Lots of Links (TRILL): Bidirectional Forwarding Detection (BFD) Support

This document specifies use of the Bidirectional Forwarding Detection (BFD) protocol in Routing Bridge (RBridge) campuses based on the RBridge Channel extension to the Transparent Interconnection of Lots of Links (TRILL) protocol. BFD is a widely deployed Operations, Administration, and Maintenance (OAM) mechanism in IP and MPLS networks, using UDP and Associated Channel Header (ACH) encapsulation…

RFC71742014-05-01

Transparent Interconnection of Lots of Links (TRILL) Operations, Administration, and Maintenance (OAM) Framework

Transparent Interconnection of Lots of Links (TRILL) Operations, Administration, and Maintenance (OAM) Framework

This document specifies a reference framework for Operations, Administration, and Maintenance (OAM) in Transparent Interconnection of Lots of Links (TRILL) networks. The focus of the document is on the fault and performance management aspects of TRILL OAM.

RFC71732014-05-01

Transparent Interconnection of Lots of Links (TRILL) Transport Using Pseudowires

Transparent Interconnection of Lots of Links (TRILL) Transport Using Pseudowires

This document specifies how to interconnect a pair of Transparent Interconnection of Lots of Links (TRILL) switch ports using pseudowires under existing TRILL and Pseudowire Emulation End-to-End (PWE3) standards.

RFC71722014-05-01

Transparent Interconnection of Lots of Links (TRILL): Fine-Grained Labeling

Transparent Interconnection of Lots of Links (TRILL): Fine-Grained Labeling

The IETF has standardized Transparent Interconnection of Lots of Links (TRILL), a protocol for least-cost transparent frame routing in multi-hop networks with arbitrary topologies and link technologies, using link-state routing and a hop count. The TRILL base protocol standard supports the labeling of TRILL Data packets with up to 4K IDs. However, there are applications that require a larger numbe…

RFC71712014-05-01

PT-EAP: Posture Transport (PT) Protocol for Extensible Authentication Protocol (EAP) Tunnel Methods

PT-EAP: Posture Transport (PT) Protocol for Extensible Authentication Protocol (EAP) Tunnel Methods

This document specifies PT-EAP, a Posture Transport (PT) protocol based on the Extensible Authentication Protocol (EAP) and designed to be used only inside an EAP tunnel method protected by Transport Layer Security (TLS). The document also describes the intended applicability of PT-EAP.

RFC71702014-05-01

Tunnel Extensible Authentication Protocol (TEAP) Version 1

Tunnel Extensible Authentication Protocol (TEAP) Version 1

This document defines the Tunnel Extensible Authentication Protocol (TEAP) version 1. TEAP is a tunnel-based EAP method that enables secure communication between a peer and a server by using the Transport Layer Security (TLS) protocol to establish a mutually authenticated tunnel. Within the tunnel, TLV objects are used to convey authentication-related data between the EAP peer and the EAP server.

RFC71692014-04-01

The NSA (No Secrecy Afforded) Certificate Extension

The NSA (No Secrecy Afforded) Certificate Extension

This document defines the NSA (No Secrecy Afforded) certificate extension appropriate for use in certain PKIX (X.509 Pubic Key Certificates) digital certificates. Historically, clients and servers strived to maintain the privacy of their keys; however, the secrecy of their private keys cannot always be maintained. In certain circumstances, a client or a server might feel that they will be compelle…

RFC71682014-04-01

The Hyper Text Coffee Pot Control Protocol for Tea Efflux Appliances (HTCPCP-TEA)

The Hyper Text Coffee Pot Control Protocol for Tea Efflux Appliances (HTCPCP-TEA)

The Hyper Text Coffee Pot Control Protocol (HTCPCP) specification does not allow for the brewing of tea, in all its variety and complexity. This paper outlines an extension to HTCPCP to allow for pots to provide networked tea-brewing facilities.

RFC71672014-04-01

A Framework for Point-to-Multipoint MPLS in Transport Networks

A Framework for Point-to-Multipoint MPLS in Transport Networks

The Multiprotocol Label Switching Transport Profile (MPLS-TP) is the common set of MPLS protocol functions defined to enable the construction and operation of packet transport networks. The MPLS-TP supports both point-to-point and point-to-multipoint transport paths. This document defines the elements and functions of the MPLS-TP architecture that are applicable specifically to supporting point-to…