⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC93392022-12-01

OSPF Reverse Metric

OSPF Reverse Metric

This document specifies the extensions to OSPF that enable a router to use Link-Local Signaling (LLS) to signal the metric that receiving OSPF neighbor(s) should use for a link to the signaling router. When used on the link to the signaling router, the signaling of this reverse metric (RM) allows a router to influence the amount of traffic flowing towards itself. In certain use cases, this enables…

RFC93382022-12-01

CBOR Object Signing and Encryption (COSE): Countersignatures

CBOR Object Signing and Encryption (COSE): Countersignatures

Concise Binary Object Representation (CBOR) is a data format designed for small code size and small message size. CBOR Object Signing and Encryption (COSE) defines a set of security services for CBOR. This document defines a countersignature algorithm along with the needed header parameters and CBOR tags for COSE. This document updates RFC 9052.

RFC93372022-12-01

Generating Password-Based Keys Using the GOST Algorithms

Generating Password-Based Keys Using the GOST Algorithms

This document specifies how to use "PKCS #5: Password-Based Cryptography Specification Version 2.1" (RFC 8018) to generate a symmetric key from a password in conjunction with the Russian national standard GOST algorithms. PKCS #5 applies a Pseudorandom Function (PRF) -- a cryptographic hash, cipher, or Hash-Based Message Authentication Code (HMAC) -- to the input password along with a salt value a…

RFC93362022-12-01

X.509 Certificate General-Purpose Extended Key Usage (EKU) for Document Signing

X.509 Certificate General-Purpose Extended Key Usage (EKU) for Document Signing

RFC 5280 specifies several extended key purpose identifiers (KeyPurposeIds) for X.509 certificates. This document defines a general-purpose Document-Signing KeyPurposeId for inclusion in the Extended Key Usage (EKU) extension of X.509 public key certificates. Document-Signing applications may require that the EKU extension be present and that a Document-Signing KeyPurposeId be indicated in order f…

RFC93352023-01-01

Completely Encrypting RTP Header Extensions and Contributing Sources

Completely Encrypting RTP Header Extensions and Contributing Sources

While the Secure Real-time Transport Protocol (SRTP) provides confidentiality for the contents of a media packet, a significant amount of metadata is left unprotected, including RTP header extensions and contributing sources (CSRCs). However, this data can be moderately sensitive in many applications. While there have been previous attempts to protect this data, they have had limited deployment, d…

RFC93342023-01-01

Remote ATtestation procedureS (RATS) Architecture

Remote ATtestation procedureS (RATS) Architecture

In network protocol exchanges, it is often useful for one end of a communication to know whether the other end is in an intended operating state. This document provides an architectural overview of the entities involved that make such tests possible through the process of generating, conveying, and evaluating evidentiary Claims. It provides a model that is neutral toward processor architectures, t…

RFC93332023-01-01

Minimal IP Encapsulating Security Payload (ESP)

Minimal IP Encapsulating Security Payload (ESP)

This document describes the minimal properties that an IP Encapsulating Security Payload (ESP) implementation needs to meet to remain interoperable with the standard ESP as defined in RFC 4303. Such a minimal version of ESP is not intended to become a replacement of ESP in RFC 4303. Instead, a minimal implementation is expected to be optimized for constrained environments while remaining interoper…

RFC93322023-01-01

Dual-Queue Coupled Active Queue Management (AQM) for Low Latency, Low Loss, and Scalable Throughput (L4S)

Dual-Queue Coupled Active Queue Management (AQM) for Low Latency, Low Loss, and Scalable Throughput (L4S)

This specification defines a framework for coupling the Active Queue Management (AQM) algorithms in two queues intended for flows with different responses to congestion. This provides a way for the Internet to transition from the scaling problems of standard TCP-Reno-friendly ('Classic') congestion controls to the family of 'Scalable' congestion controls. These are designed for consistently very l…

RFC93312023-01-01

The Explicit Congestion Notification (ECN) Protocol for Low Latency, Low Loss, and Scalable Throughput (L4S)

The Explicit Congestion Notification (ECN) Protocol for Low Latency, Low Loss, and Scalable Throughput (L4S)

This specification defines the protocol to be used for a new network service called Low Latency, Low Loss, and Scalable throughput (L4S). L4S uses an Explicit Congestion Notification (ECN) scheme at the IP layer that is similar to the original (or 'Classic') ECN approach, except as specified within. L4S uses 'Scalable' congestion control, which induces much more frequent control signals from the n…

RFC93302023-01-01

Low Latency, Low Loss, and Scalable Throughput (L4S) Internet Service: Architecture

Low Latency, Low Loss, and Scalable Throughput (L4S) Internet Service: Architecture

This document describes the L4S architecture, which enables Internet applications to achieve low queuing latency, low congestion loss, and scalable throughput control. L4S is based on the insight that the root cause of queuing delay is in the capacity-seeking congestion controllers of senders, not in the queue itself. With the L4S architecture, all Internet applications could (but do not have to) …

RFC93292022-11-01

TCP Encapsulation of Internet Key Exchange Protocol (IKE) and IPsec Packets

TCP Encapsulation of Internet Key Exchange Protocol (IKE) and IPsec Packets

This document describes a method to transport Internet Key Exchange Protocol (IKE) and IPsec packets over a TCP connection for traversing network middleboxes that may block IKE negotiation over UDP. This method, referred to as "TCP encapsulation", involves sending both IKE packets for Security Association (SA) establishment and Encapsulating Security Payload (ESP) packets over a TCP connection. Th…

RFC93282022-12-01

RTP Payload Format for Versatile Video Coding (VVC)

RTP Payload Format for Versatile Video Coding (VVC)

This memo describes an RTP payload format for the Versatile Video Coding (VVC) specification, which was published as both ITU-T Recommendation H.266 and ISO/IEC International Standard 23090-3. VVC was developed by the Joint Video Experts Team (JVET). The RTP payload format allows for packetization of one or more Network Abstraction Layer (NAL) units in each RTP packet payload, as well as fragmenta…

RFC93272022-11-01

Control Messages Protocol for Use with Network Time Protocol Version 4

Control Messages Protocol for Use with Network Time Protocol Version 4

This document describes the structure of the control messages that were historically used with the Network Time Protocol (NTP) before the advent of more modern control and management approaches. These control messages have been used to monitor and control the NTP application running on any IP network attached computer. The information in this document was originally described in Appendix B of RFC …

RFC93262022-11-01

In Situ Operations, Administration, and Maintenance (IOAM) Direct Exporting

In Situ Operations, Administration, and Maintenance (IOAM) Direct Exporting

In situ Operations, Administration, and Maintenance (IOAM) is used for recording and collecting operational and telemetry information. Specifically, IOAM allows telemetry data to be pushed into data packets while they traverse the network. This document introduces a new IOAM option type (denoted IOAM-Option-Type) called the "IOAM Direct Export (DEX) Option-Type". This Option-Type is used as a trig…

RFC93252022-11-01

Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)

Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)

Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) are used to protect data exchanged over a wide range of application protocols and can also form the basis for secure transport protocols. Over the years, the industry has witnessed several serious attacks on TLS and DTLS, including attacks on the most commonly used cipher suites and their modes of operation. This document …

RFC93242022-12-01

Policy Based on the Resource Public Key Infrastructure (RPKI) without Route Refresh

Policy Based on the Resource Public Key Infrastructure (RPKI) without Route Refresh

A BGP speaker performing policy based on the Resource Public Key Infrastructure (RPKI) should not issue route refresh to its neighbors because it has received new RPKI data. This document updates RFC 8481 by describing how to avoid doing so by either keeping a full Adj-RIB-In or saving paths dropped due to ROV (Route Origin Validation) so they may be reevaluated with respect to new RPKI data.

RFC93232022-11-01

A Profile for RPKI Signed Checklists (RSCs)

A Profile for RPKI Signed Checklists (RSCs)

This document defines a Cryptographic Message Syntax (CMS) protected content type for use with the Resource Public Key Infrastructure (RPKI) to carry a general-purpose listing of checksums (a 'checklist'). The objective is to allow for the creation of an attestation, termed an "RPKI Signed Checklist (RSC)", which contains one or more checksums of arbitrary digital objects (files) that are signed w…

RFC93222022-11-01

In Situ Operations, Administration, and Maintenance (IOAM) Loopback and Active Flags

In Situ Operations, Administration, and Maintenance (IOAM) Loopback and Active Flags

In situ Operations, Administration, and Maintenance (IOAM) collects operational and telemetry information in packets while they traverse a path between two points in the network. This document defines two new flags in the IOAM Trace Option headers, specifically the Loopback and Active flags.

RFC93212022-10-01

Signature Validation Token

Signature Validation Token

Electronic signatures have a limited lifespan with respect to the time period that they can be validated and determined to be authentic. The Signature Validation Token (SVT) defined in this specification provides evidence that asserts the validity of an electronic signature. The SVT is provided by a trusted authority, which asserts that a particular signature was successfully validated according t…

RFC93202022-11-01

Deterministic Networking (DetNet) Bounded Latency

Deterministic Networking (DetNet) Bounded Latency

This document presents a timing model for sources, destinations, and Deterministic Networking (DetNet) transit nodes. Using the model, it provides a methodology to compute end-to-end latency and backlog bounds for various queuing methods. The methodology can be used by the management and control planes and by resource reservation algorithms to provide bounded latency and zero congestion loss for t…

RFC93192022-10-01

The Use of maxLength in the Resource Public Key Infrastructure (RPKI)

The Use of maxLength in the Resource Public Key Infrastructure (RPKI)

This document recommends ways to reduce the forged-origin hijack attack surface by prudently limiting the set of IP prefixes that are included in a Route Origin Authorization (ROA). One recommendation is to avoid using the maxLength attribute in ROAs except in some specific cases. The recommendations complement and extend those in RFC 7115. This document also discusses the creation of ROAs for fac…

RFC93182022-10-01

IAB Workshop Report: Measuring Network Quality for End-Users

IAB Workshop Report: Measuring Network Quality for End-Users

The Measuring Network Quality for End-Users workshop was held virtually by the Internet Architecture Board (IAB) on September 14-16, 2021. This report summarizes the workshop, the topics discussed, and some preliminary conclusions drawn at the end of the workshop. Note that this document is a report on the proceedings of the workshop. The views and positions documented in this report are those of …

RFC93172022-10-01

Operational Considerations for Streaming Media

Operational Considerations for Streaming Media

This document provides an overview of operational networking and transport protocol issues that pertain to the quality of experience (QoE) when streaming video and other high-bitrate media over the Internet. This document explains the characteristics of streaming media delivery that have surprised network designers or transport experts who lack specific media expertise, since streaming media highl…

RFC93162022-10-01

Intent Classification

Intent Classification

Intent is an abstract, high-level policy used to operate a network. An intent-based management system includes an interface for users to input requests and an engine to translate the intents into the network configuration and manage their life cycle. This document mostly discusses the concept of network intents, but other types of intents are also considered. Specifically, this document highlights…

RFC93152022-10-01

Intent-Based Networking - Concepts and Definitions

Intent-Based Networking - Concepts and Definitions

Intent and Intent-Based Networking are taking the industry by storm. At the same time, terms related to Intent-Based Networking are often used loosely and inconsistently, in many cases overlapping and confused with other concepts such as "policy." This document clarifies the concept of "intent" and provides an overview of the functionality that is associated with it. The goal is to contribute towa…

RFC93142022-09-01

YANG Data Model for Bidirectional Forwarding Detection (BFD)

YANG Data Model for Bidirectional Forwarding Detection (BFD)

This document defines a YANG data model that can be used to configure and manage Bidirectional Forwarding Detection (BFD). The YANG modules in this document conform to the Network Management Datastore Architecture (NMDA) (RFC 8342). This document updates "YANG Data Model for Bidirectional Forwarding Detection (BFD)" (RFC 9127).

RFC93132022-10-01

Pros and Cons of IPv6 Transition Technologies for IPv4-as-a-Service (IPv4aaS)

Pros and Cons of IPv6 Transition Technologies for IPv4-as-a-Service (IPv4aaS)

Several IPv6 transition technologies have been developed to provide customers with IPv4-as-a-Service (IPv4aaS) for ISPs with an IPv6-only access and/or core network. These technologies have their advantages and disadvantages. Depending on existing topology, skills, strategy, and other preferences, one of these technologies may be the most appropriate solution for a network operator. This document …

RFC93122022-09-01

Manageability of the QUIC Transport Protocol

Manageability of the QUIC Transport Protocol

This document discusses manageability of the QUIC transport protocol and focuses on the implications of QUIC's design and wire image on network operations involving QUIC traffic. It is intended as a "user's manual" for the wire image to provide guidance for network operators and equipment vendors who rely on the use of transport-aware network functions.

RFC93112022-09-01

Running an IETF Hackathon

Running an IETF Hackathon

IETF Hackathons encourage the IETF community to collaborate on running code related to existing and evolving Internet standards. This document provides a set of practices that have been used for running IETF Hackathons. These practices apply to Hackathons in which both in-person and remote participation are possible, with adaptations for Hackathons that are online only.

RFC93102023-01-01

X.509 Certificate Extension for 5G Network Function Types

X.509 Certificate Extension for 5G Network Function Types

This document specifies the certificate extension for including Network Function Types (NFTypes) for the 5G System in X.509 v3 public key certificates as profiled in RFC 5280.