⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC89172020-10-01

The LoST-Validation Straightforward-Naming Authority PoinTeR (S-NAPTR) Application Service Tag

The LoST-Validation Straightforward-Naming Authority PoinTeR (S-NAPTR) Application Service Tag

This document adds the 'LoST-Validation' service tag to the Straightforward-Naming Authority PoinTeR (S-NAPTR) Application Service Tag IANA registry. This tag can appear in a Naming Authority Pointer (NAPTR) Domain Name System (DNS) record to assist clients of the Location-to-Service Translation (LoST) Protocol in identifying LoST servers designated for location validation. This tag and the inform…

RFC89162020-10-01

A YANG Data Model for the Multicast Source Discovery Protocol (MSDP)

A YANG Data Model for the Multicast Source Discovery Protocol (MSDP)

This document defines a YANG data model for the configuration and management of Multicast Source Discovery Protocol (MSDP) protocol operations.

RFC89152020-09-01

Network Time Security for the Network Time Protocol

Network Time Security for the Network Time Protocol

This memo specifies Network Time Security (NTS), a mechanism for using Transport Layer Security (TLS) and Authenticated Encryption with Associated Data (AEAD) to provide cryptographic security for the client-server mode of the Network Time Protocol (NTP). NTS is structured as a suite of two loosely coupled sub-protocols. The first (NTS Key Establishment (NTS-KE)) handles initial authentication and…

RFC89142020-10-01

Extended DNS Errors

Extended DNS Errors

This document defines an extensible method to return additional information about the cause of DNS errors. Though created primarily to extend SERVFAIL to provide additional information about the cause of DNS and DNSSEC failures, the Extended DNS Errors option defined in this document allows all response types to contain extended error information. Extended DNS Error information does not change the…

RFC89132021-11-01

Two-Way Active Measurement Protocol (TWAMP) YANG Data Model

Two-Way Active Measurement Protocol (TWAMP) YANG Data Model

This document specifies a data model for client and server implementations of the Two-Way Active Measurement Protocol (TWAMP). This document defines the TWAMP data model through Unified Modeling Language (UML) class diagrams and formally specifies it using the YANG data modeling language (RFC 7950). The data model is compliant with the Network Management Datastore Architecture (NMDA).

RFC89122021-11-01

Initial Performance Metrics Registry Entries

Initial Performance Metrics Registry Entries

This memo defines the set of initial entries for the IANA Registry of Performance Metrics. The set includes UDP Round-Trip Latency and Loss, Packet Delay Variation, DNS Response Latency and Loss, UDP Poisson One-Way Delay and Loss, UDP Periodic One-Way Delay and Loss, ICMP Round-Trip Latency and Loss, and TCP Round-Trip Delay and Loss.

RFC89112021-11-01

Registry for Performance Metrics

Registry for Performance Metrics

This document defines the format for the IANA Registry of Performance Metrics. This document also gives a set of guidelines for Registered Performance Metric requesters and reviewers.

RFC89102020-09-01

Captive-Portal Identification in DHCP and Router Advertisements (RAs)

Captive-Portal Identification in DHCP and Router Advertisements (RAs)

In many environments offering short-term or temporary Internet access (such as coffee shops), it is common to start new connections in a captive portal mode. This highly restricts what the user can do until the user has satisfied the captive portal conditions. This document describes a DHCPv4 and DHCPv6 option and a Router Advertisement (RA) option to inform clients that they are behind some sort …

RFC89092020-11-01

Registry Data Escrow Specification

Registry Data Escrow Specification

This document specifies the format and contents of data escrow deposits targeted primarily for domain name registries. The specification is designed to be independent of the underlying objects that are being escrowed, and therefore it could also be used for purposes other than domain name registries.

RFC89082020-09-01

Captive Portal API

Captive Portal API

This document describes an HTTP API that allows clients to interact with a Captive Portal system. With this API, clients can discover how to get out of captivity and fetch state about their Captive Portal sessions.

RFC89072020-09-01

The Terminal Access Controller Access-Control System Plus (TACACS+) Protocol

The Terminal Access Controller Access-Control System Plus (TACACS+) Protocol

This document describes the Terminal Access Controller Access-Control System Plus (TACACS+) protocol, which is widely deployed today to provide Device Administration for routers, network access servers, and other networked computing devices via one or more centralized servers.

RFC89062020-09-01

A Common Operational Problem in DNS Servers: Failure to Communicate

A Common Operational Problem in DNS Servers: Failure to Communicate

The DNS is a query/response protocol. Failing to respond to queries, or responding incorrectly, causes both immediate operational problems and long-term problems with protocol development. This document identifies a number of common kinds of queries to which some servers either fail to respond or respond incorrectly. This document also suggests procedures for zone operators to apply to identify an…

RFC89052020-10-01

The 'payto' URI Scheme for Payments

The 'payto' URI Scheme for Payments

This document defines the 'payto' Uniform Resource Identifier (URI) scheme for designating targets for payments. A unified URI scheme for all payment target types allows applications to offer user interactions with URIs that represent payment targets, simplifying the introduction of new payment systems and applications.

RFC89042020-09-01

DNS Whitelist (DNSWL) Email Authentication Method Extension

DNS Whitelist (DNSWL) Email Authentication Method Extension

This document describes an email authentication method compliant with RFC 8601. The method consists of looking up the sender's IP address in a DNS whitelist. This document provides information in case the method is seen in the field, suggests a useful practice, and registers the relevant keywords. This document does not consider blacklists.

RFC89032021-05-01

Use Cases for DDoS Open Threat Signaling

Use Cases for DDoS Open Threat Signaling

The DDoS Open Threat Signaling (DOTS) effort is intended to provide protocols to facilitate interoperability across disparate DDoS Mitigation solutions. This document presents sample use cases that describe the interactions expected between the DOTS components as well as DOTS messaging exchanges. These use cases are meant to identify the interacting DOTS components, how they collaborate, and what …

RFC89022020-09-01

TLS Authentication Using Intelligent Transport System (ITS) Certificates

TLS Authentication Using Intelligent Transport System (ITS) Certificates

The IEEE and ETSI have specified a type of end-entity certificate. This document defines an experimental change to TLS to support IEEE/ETSI certificate types to authenticate TLS entities.

RFC89012020-09-01

Multi-Signer DNSSEC Models

Multi-Signer DNSSEC Models

Many enterprises today employ the service of multiple DNS providers to distribute their authoritative DNS service. Deploying DNSSEC in such an environment may present some challenges, depending on the configuration and feature set in use. In particular, when each DNS provider independently signs zone data with their own keys, additional key-management mechanisms are necessary. This document presen…

RFC89002020-09-01

IP Fragmentation Considered Fragile

IP Fragmentation Considered Fragile

This document describes IP fragmentation and explains how it introduces fragility to Internet communication. This document also proposes alternatives to IP fragmentation and provides recommendations for developers and network operators.

RFC88992020-09-01

Packetization Layer Path MTU Discovery for Datagram Transports

Packetization Layer Path MTU Discovery for Datagram Transports

This document specifies Datagram Packetization Layer Path MTU Discovery (DPLPMTUD). This is a robust method for Path MTU Discovery (PMTUD) for datagram Packetization Layers (PLs). It allows a PL, or a datagram application that uses a PL, to discover whether a network path can support the current size of datagram. This can be used to detect and reduce the message size when a sender encounters a pac…

RFC88982020-09-01

Third-Party Token-Based Authentication and Authorization for Session Initiation Protocol (SIP)

Third-Party Token-Based Authentication and Authorization for Session Initiation Protocol (SIP)

This document defines the "Bearer" authentication scheme for the Session Initiation Protocol (SIP) and a mechanism by which user authentication and SIP registration authorization is delegated to a third party, using the OAuth 2.0 framework and OpenID Connect Core 1.0. This document updates RFC 3261 to provide guidance on how a SIP User Agent Client (UAC) responds to a SIP 401/407 response that con…

RFC88972020-09-01

Requirements for Resource Public Key Infrastructure (RPKI) Relying Parties

Requirements for Resource Public Key Infrastructure (RPKI) Relying Parties

This document provides a single reference point for requirements for Relying Party (RP) software for use in the Resource Public Key Infrastructure (RPKI). It cites requirements that appear in several RPKI RFCs, making it easier for implementers to become aware of these requirements. Over time, this RFC will be updated to reflect changes to the requirements and guidance specified in the RFCs discus…

RFC88962020-11-01

Application-Layer Traffic Optimization (ALTO) Cost Calendar

Application-Layer Traffic Optimization (ALTO) Cost Calendar

This document is an extension to the base Application-Layer Traffic Optimization (ALTO) protocol. It extends the ALTO cost information service so that applications decide not only 'where' to connect but also 'when'. This is useful for applications that need to perform bulk data transfer and would like to schedule these transfers during an off-peak hour, for example. This extension introduces the A…

RFC88952020-11-01

Application-Layer Traffic Optimization (ALTO) Incremental Updates Using Server-Sent Events (SSE)

Application-Layer Traffic Optimization (ALTO) Incremental Updates Using Server-Sent Events (SSE)

The Application-Layer Traffic Optimization (ALTO) protocol (RFC 7285) provides network-related information, called network information resources, to client applications so that clients can make informed decisions in utilizing network resources. This document presents a mechanism to allow an ALTO server to push updates to ALTO clients to achieve two benefits: (1) updates can be incremental, in that…

RFC88942020-09-01

Simple Certificate Enrolment Protocol

Simple Certificate Enrolment Protocol

This document specifies the Simple Certificate Enrolment Protocol (SCEP), a PKI protocol that leverages existing technology by using Cryptographic Message Syntax (CMS, formerly known as PKCS #7) and PKCS #10 over HTTP. SCEP is the evolution of the enrolment protocol sponsored by Cisco Systems, which enjoys wide support in both client and server implementations, as well as being relied upon by nume…

RFC88932020-09-01

Resource Public Key Infrastructure (RPKI) Origin Validation for BGP Export

Resource Public Key Infrastructure (RPKI) Origin Validation for BGP Export

A BGP speaker may perform Resource Public Key Infrastructure (RPKI) origin validation not only on routes received from BGP neighbors and routes that are redistributed from other routing protocols, but also on routes it sends to BGP neighbors. For egress policy, it is important that the classification use the 'effective origin AS' of the processed route, which may specifically be altered by the com…

RFC88922020-08-01

Guidelines and Registration Procedures for Interface Types and Tunnel Types

Guidelines and Registration Procedures for Interface Types and Tunnel Types

This document provides guidelines and procedures for those who are defining, registering, or evaluating definitions of new interface types ("ifType" values) and tunnel types. The original definition of the IANA interface type registry predated the use of IANA Considerations sections and YANG modules, so some confusion arose over time. Tunnel types were added later, with the same requirements and a…

RFC88912020-09-01

GOST R 34.12-2015: Block Cipher "Magma"

GOST R 34.12-2015: Block Cipher "Magma"

In addition to a new cipher with a block length of n=128 bits (referred to as "Kuznyechik" and described in RFC 7801), Russian Federal standard GOST R 34.12-2015 includes an updated version of the block cipher with a block length of n=64 bits and key length of k=256 bits, which is also referred to as "Magma". The algorithm is an updated version of an older block cipher with a block length of n=64 …

RFC88902020-08-01

Интернет предназначен для конечных пользователей

The Internet is for End Users

Формулирует позицию IAB: при конфликте интересов развитие Интернета должно отдавать приоритет интересам людей — конечных пользователей. Документ предлагает учитывать косвенные общественные последствия, приватность, безопасность, доступность и свободу действий пользователя.

RFC88892020-08-01

Multipoint Alternate-Marking Method for Passive and Hybrid Performance Monitoring

Multipoint Alternate-Marking Method for Passive and Hybrid Performance Monitoring

The Alternate-Marking method, as presented in RFC 8321, can only be applied to point-to-point flows, because it assumes that all the packets of the flow measured on one node are measured again by a single second node. This document generalizes and expands this methodology to measure any kind of unicast flow whose packets can follow several different paths in the network -- in wider terms, a multip…

RFC88882021-01-01

RTP Control Protocol (RTCP) Feedback for Congestion Control

RTP Control Protocol (RTCP) Feedback for Congestion Control

An effective RTP congestion control algorithm requires more fine-grained feedback on packet loss, timing, and Explicit Congestion Notification (ECN) marks than is provided by the standard RTP Control Protocol (RTCP) Sender Report (SR) and Receiver Report (RR) packets. This document describes an RTCP feedback message intended to enable congestion control for interactive real-time traffic using RTP.…