⌕ Поиск по атласу

IETF · RFC

Опубликованные RFC, связи обновления и замены, официальные статусы и русские переводы.

Реестр · 9 842 документов

RFC77072016-03-01

Network Reconnaissance in IPv6 Networks

Network Reconnaissance in IPv6 Networks

IPv6 offers a much larger address space than that of its IPv4 counterpart. An IPv6 subnet of size /64 can (in theory) accommodate approximately 1.844 * 10^19 hosts, thus resulting in a much lower host density (#hosts/#addresses) than is typical in IPv4 networks, where a site typically has 65,000 or fewer unique addresses. As a result, it is widely assumed that it would take a tremendous effort to …

RFC77062015-11-01

Decreasing Access Time to Root Servers by Running One on Loopback

Decreasing Access Time to Root Servers by Running One on Loopback

Some DNS recursive resolvers have longer-than-desired round-trip times to the closest DNS root server. Some DNS recursive resolver operators want to prevent snooping of requests sent to DNS root servers by third parties. Such resolvers can greatly decrease the round-trip time and prevent observation of requests by running a copy of the full root zone on a loopback address (such as 127.0.0.1). This…

RFC77052015-11-01

Autonomous System Migration Mechanisms and Their Effects on the BGP AS_PATH Attribute

Autonomous System Migration Mechanisms and Their Effects on the BGP AS_PATH Attribute

This document discusses some existing commonly used BGP mechanisms for Autonomous System Number (ASN) migration that are not formally part of the BGP4 protocol specification. It is necessary to document these de facto standards to ensure that they are properly supported in future BGP protocol work.

RFC77042015-11-01

An IETF with Much Diversity and Professional Conduct

An IETF with Much Diversity and Professional Conduct

The process of producing today's Internet technologies through a culture of open participation and diverse collaboration has proved strikingly efficient and effective, and it is distinctive among standards organizations. During the early years of the IETF and its antecedent, participation was almost entirely composed of a small group of well-funded, American, white, male technicians, demonstrating…

RFC77032015-11-01

Experience with Testing of Mapping of Address and Port Using Translation (MAP-T)

Experience with Testing of Mapping of Address and Port Using Translation (MAP-T)

This document describes the testing result of a network utilizing a Mapping of Address and Port using Translation (MAP-T) double translation solution; it provides an overview of user applications' behavior with a shared IPv4 address. The MAP-T software is from CERNET Center and the test environment is on the NIC.br network with real and virtualized machines.

RFC77022015-12-01

Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Groupchat

Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Groupchat

This document defines a bidirectional protocol mapping for the exchange of instant messages in the context of a multi-party chat session among users of the Session Initiation Protocol (SIP) and users of the Extensible Messaging and Presence Protocol (XMPP). Specifically, this document defines a mapping between the SIP-based Message Session Relay Protocol (MSRP) and the XMPP Multi-User Chat (MUC) e…

RFC77012015-12-01

Multi-party Chat Using the Message Session Relay Protocol (MSRP)

Multi-party Chat Using the Message Session Relay Protocol (MSRP)

The Message Session Relay Protocol (MSRP) defines a mechanism for sending instant messages (IMs) within a peer-to-peer session, negotiated using the Session Initiation Protocol (SIP) and the Session Description Protocol (SDP). This document defines the necessary tools for establishing multi-party chat sessions, or chat rooms, using MSRP.

RFC77002015-12-01

Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames

Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames

This document describes methods for handling Unicode strings representing memorable, human-friendly names (called "nicknames", "display names", or "petnames") for people, devices, accounts, websites, and other entities.

RFC76992015-11-01

Generalized Labels for the Flexi-Grid in Lambda Switch Capable (LSC) Label Switching Routers

Generalized Labels for the Flexi-Grid in Lambda Switch Capable (LSC) Label Switching Routers

GMPLS supports the description of optical switching by identifying entries in fixed lists of switchable wavelengths (called grids) through the encoding of lambda labels. Work within the ITU-T Study Group 15 has defined a finer-granularity grid, and the facility to flexibly select different widths of spectrum from the grid. This document defines a new GMPLS lambda label format to support this flexi…

RFC76982015-11-01

Framework and Requirements for GMPLS-Based Control of Flexi-Grid Dense Wavelength Division Multiplexing (DWDM) Networks

Framework and Requirements for GMPLS-Based Control of Flexi-Grid Dense Wavelength Division Multiplexing (DWDM) Networks

To allow efficient allocation of optical spectral bandwidth for systems that have high bit-rates, the International Telecommunication Union Telecommunication Standardization Sector (ITU-T) has extended its Recommendations G.694.1 and G.872 to include a new Dense Wavelength Division Multiplexing (DWDM) grid by defining a set of nominal central frequencies, channel spacings, and the concept of the "…

RFC76972016-01-01

MPLS Transport Profile (MPLS-TP) Operations, Administration, and Maintenance (OAM) Identifiers Management Information Base (MIB)

MPLS Transport Profile (MPLS-TP) Operations, Administration, and Maintenance (OAM) Identifiers Management Information Base (MIB)

This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in the Internet community. In particular, it describes managed objects to configure the Operations, Administration, and Maintenance (OAM) identifiers for Multiprotocol Label Switching (MPLS) and the MPLS-based Transport Profile (TP).

RFC76962015-11-01

Guidelines for Cryptographic Algorithm Agility and Selecting Mandatory-to-Implement Algorithms

Guidelines for Cryptographic Algorithm Agility and Selecting Mandatory-to-Implement Algorithms

Many IETF protocols use cryptographic algorithms to provide confidentiality, integrity, authentication, or digital signature. Communicating peers must support a common set of cryptographic algorithms for these mechanisms to work properly. This memo provides guidelines to ensure that protocols have the ability to migrate from one mandatory-to-implement algorithm suite to another over time.

RFC76952015-11-01

Distributed Prefix Assignment Algorithm

Distributed Prefix Assignment Algorithm

This document specifies a distributed algorithm for dividing a set of prefixes in a manner that allows for automatic assignment of sub-prefixes that are unique and non-overlapping. Used in conjunction with a protocol that provides flooding of information among a set of participating nodes, prefix configuration within a network may be automated.

RFC76942015-11-01

Hypertext Transfer Protocol (HTTP) Client-Initiated Content-Encoding

Hypertext Transfer Protocol (HTTP) Client-Initiated Content-Encoding

In HTTP, content codings allow for payload encodings such as for compression or integrity checks. In particular, the "gzip" content coding is widely used for payload data sent in response messages. Content codings can be used in request messages as well; however, discoverability is not on par with response messages. This document extends the HTTP "Accept-Encoding" header field for use in responses…

RFC76932015-11-01

The BLAKE2 Cryptographic Hash and Message Authentication Code (MAC)

The BLAKE2 Cryptographic Hash and Message Authentication Code (MAC)

This document describes the cryptographic hash function BLAKE2 and makes the algorithm specification and C source code conveniently available to the Internet community. BLAKE2 comes in two main flavors: BLAKE2b is optimized for 64-bit platforms and BLAKE2s for smaller architectures. BLAKE2 can be directly keyed, making it functionally equivalent to a Message Authentication Code (MAC).

RFC76922015-12-01

Compression Extensions for WebSocket

Compression Extensions for WebSocket

This document defines a framework for creating WebSocket extensions that add compression functionality to the WebSocket Protocol. An extension based on this framework compresses the payload data portion of WebSocket data messages on a per-message basis using parameters negotiated during the opening handshake. This framework provides a general method for applying a compression algorithm to the cont…

RFC76912015-11-01

Updating the Term Dates of IETF Administrative Oversight Committee (IAOC) Members

Updating the Term Dates of IETF Administrative Oversight Committee (IAOC) Members

BCP 101 defines the start and end dates for the terms of IETF Administrative Oversight Committee (IAOC) members; these terms have proven to be impractical. This memo updates BCP 101 to direct the IAOC to establish more practical start and end dates for terms of IAOC members.

RFC76902016-01-01

Close Encounters of the ICMP Type 2 Kind (Near Misses with ICMPv6 Packet Too Big (PTB))

Close Encounters of the ICMP Type 2 Kind (Near Misses with ICMPv6 Packet Too Big (PTB))

This document calls attention to the problem of delivering ICMPv6 type 2 "Packet Too Big" (PTB) messages to the intended destination (typically the server) in ECMP load-balanced or anycast network architectures. It discusses operational mitigations that can be employed to address this class of failures.

RFC76892015-11-01

Signaling Extensions for Wavelength Switched Optical Networks

Signaling Extensions for Wavelength Switched Optical Networks

This document provides extensions to Generalized Multiprotocol Label Switching (GMPLS) signaling for control of Wavelength Switched Optical Networks (WSONs). Such extensions are applicable in WSONs under a number of conditions including: (a) when optional processing, such as regeneration, must be configured to occur at specific nodes along a path, (b) where equipment must be configured to accept a…

RFC76882015-11-01

GMPLS OSPF Enhancement for Signal and Network Element Compatibility for Wavelength Switched Optical Networks

GMPLS OSPF Enhancement for Signal and Network Element Compatibility for Wavelength Switched Optical Networks

This document provides Generalized Multiprotocol Label Switching (GMPLS) Open Shortest Path First (OSPF) routing enhancements to support signal compatibility constraints associated with Wavelength Switched Optical Network (WSON) elements. These routing enhancements are applicable in common optical or hybrid electro-optical networks where not all the optical signals in the network are compatible wi…

RFC76872015-12-01

Report from the Strengthening the Internet (STRINT) Workshop

Report from the Strengthening the Internet (STRINT) Workshop

The Strengthening the Internet (STRINT) workshop assembled one hundred participants in London for two days in early 2014 to discuss how the technical community, and in particular the IETF and the W3C, should react to Pervasive Monitoring and more generally how to strengthen the Internet in the face of such attacks. The discussions covered issues of terminology, the role of user interfaces, classes…

RFC76862015-10-01

The ".onion" Special-Use Domain Name

The ".onion" Special-Use Domain Name

This document registers the ".onion" Special-Use Domain Name.

RFC76852015-10-01

A Transport Layer Security (TLS) ClientHello Padding Extension

A Transport Layer Security (TLS) ClientHello Padding Extension

This memo describes a Transport Layer Security (TLS) extension that can be used to pad ClientHello messages to a desired size.

RFC76842015-11-01

OSPFv2 Prefix/Link Attribute Advertisement

OSPFv2 Prefix/Link Attribute Advertisement

OSPFv2 requires functional extension beyond what can readily be done with the fixed-format Link State Advertisements (LSAs) as described in RFC 2328. This document defines OSPFv2 Opaque LSAs based on Type-Length-Value (TLV) tuples that can be used to associate additional attributes with prefixes or links. Depending on the application, these prefixes and links may or may not be advertised in the fi…

RFC76832015-10-01

Diameter Overload Indication Conveyance

Diameter Overload Indication Conveyance

This specification defines a base solution for Diameter overload control, referred to as Diameter Overload Indication Conveyance (DOIC).

RFC76822015-12-01

Considerations for Internet Routing Registries (IRRs) and Routing Policy Configuration

Considerations for Internet Routing Registries (IRRs) and Routing Policy Configuration

The purpose of this document is to catalog issues that influenced the efficacy of Internet Routing Registries (IRRs) for inter-domain routing policy specification and application in the global routing system over the past two decades. Additionally, it provides a discussion regarding which of these issues are still problematic in practice, and which are simply artifacts that are no longer applicabl…

RFC76812015-10-01

Email Exchange of Secondary School Transcripts

Email Exchange of Secondary School Transcripts

A common format simplifies exchange of secondary school academic transcripts via electronic mail. Existing standards are applied to prevent unauthorized alteration of transcript content and to deliver transcripts directly and securely from each student to his or her chosen recipients. By eliminating third-party intervention and surveillance, the defined protocol better protects student privacy and…

RFC76802016-01-01

A One-Way Loss Metric for IP Performance Metrics (IPPM)

A One-Way Loss Metric for IP Performance Metrics (IPPM)

This memo defines a metric for one-way loss of packets across Internet paths. It builds on notions introduced and discussed in the IP Performance Metrics (IPPM) Framework document, RFC 2330; the reader is assumed to be familiar with that document. This memo makes RFC 2680 obsolete.

RFC76792016-01-01

A One-Way Delay Metric for IP Performance Metrics (IPPM)

A One-Way Delay Metric for IP Performance Metrics (IPPM)

This memo defines a metric for one-way delay of packets across Internet paths. It builds on notions introduced and discussed in the IP Performance Metrics (IPPM) Framework document, RFC 2330; the reader is assumed to be familiar with that document. This memo makes RFC 2679 obsolete.

RFC76782015-10-01

Attribute-Value Pairs for Provisioning Customer Equipment Supporting IPv4-Over-IPv6 Transitional Solutions

Attribute-Value Pairs for Provisioning Customer Equipment Supporting IPv4-Over-IPv6 Transitional Solutions

During the transition from IPv4 to IPv6, customer equipment may have to support one of the various transition methods that have been defined for carrying IPv4 packets over IPv6. This document enumerates the information that needs to be provisioned on a customer edge router to support a list of transition techniques based on tunneling IPv4 in IPv6, with a view to defining reusable components for a …