О документе
Network Working Group D. Eastlake
Request for Comments: 2606 A. Panitz
BCP: 32 Июнь 1999
Категория: Лучшая современная практика
Зарезервированные DNS-имена верхнего уровняСтатус данного меморандума
Этот документ устанавливает Лучшую современную практику Интернета для
интернет-сообщества и запрашивает обсуждение и предложения по
улучшениям. Распространение данного меморандума не ограничено.Уведомление об авторских правах
Copyright (C) The Internet Society (1999). All Rights Reserved.Аннотация
Чтобы снизить вероятность конфликтов и путаницы, несколько доменных
имён верхнего уровня зарезервированы для использования при частном
тестировании, в качестве примеров в документации и тому подобного.
Кроме того, документированы несколько доменных имён второго уровня,
зарезервированных для использования в качестве примеров.1. Введение
Глобальная система доменных имён Интернета документирована в [RFC 1034,
1035, 1591] и многочисленных дополнительных Request for Comments. Она
определяет дерево имён, начинающееся с корня, ".", непосредственно под
которым находятся доменные имена верхнего уровня, такие как ".com" и
".us". Ниже доменных имён верхнего уровня обычно располагаются
дополнительные уровни имён.2. TLD для тестирования и примеров в документации
Существует потребность в именах доменов верхнего уровня (TLD), которые
могут использоваться для создания имён, применимых без опасения
конфликтов с текущими или будущими фактическими именами TLD в глобальной
DNS для частного тестирования существующего кода, связанного с DNS,
примеров в документации, экспериментов, связанных с DNS, недопустимых
DNS-имён или иных сходных целей.
Например, без руководящих указаний узел может настроить несколько
локальных дополнительных неиспользуемых доменов верхнего уровня для
тестирования локального кода и конфигурации DNS. Позднее эти TLD могут
начать фактически использоваться в глобальном Интернете. В результате
локальные попытки обратиться к реальным данным в этих зонах могут быть
сорваны локальными тестовыми версиями. Либо может быть написан тестовый
или примерный код, обращающийся к используемому TLD, в расчёте на то,
что тестовый код будет выполняться только в ограниченной тестовой сети
или пример никогда фактически не будет выполнен. Позднее тестовый код
может выйти за пределы тестовой среды либо пример может быть
действительно реализован в коде и запущен в Интернете. В зависимости от
характера теста или примера, возможно, лучше, чтобы он ссылался на TLD,
постоянно зарезервированный для таких целей.
Для безопасного удовлетворения этих потребностей резервируются четыре
доменных имени, перечисленные и описанные ниже.
.test
.example
.invalid
.localhost
".test" рекомендуется для использования при тестировании текущего
или нового кода, связанного с DNS.
".example" рекомендуется для использования в документации или в
качестве примеров.
".invalid" предназначен для использования при формировании доменных
имён в режиме онлайн, которые гарантированно являются недопустимыми и
чья недопустимость очевидна с первого взгляда.
TLD ".localhost" традиционно статически определяется в реализациях
DNS хостов как имеющий запись A, указывающую на IP-адрес обратной
петли, и зарезервирован для такого использования. Любое другое
использование конфликтовало бы с широко развёрнутым кодом, который
предполагает такое использование.3. Зарезервированные примерные доменные имена второго уровня
Internet Assigned Numbers Authority (IANA) также в настоящее время
имеет следующие зарезервированные доменные имена второго уровня,
которые могут использоваться в качестве примеров.
example.com
example.net
example.org4. Соображения IANA
IANA согласилась с четырьмя резервированиями доменных имён верхнего
уровня, установленными в этом документе, и будет резервировать их для
указанных целей.5. Соображения безопасности
Путаница и конфликты могут быть вызваны использованием текущего или
будущего доменного имени верхнего уровня при экспериментировании или
тестировании, в качестве примера в документации, для обозначения
недопустимых имён либо в качестве синонима адреса обратной петли.
Тестовое и экспериментальное программное обеспечение может выйти за
пределы тестовой среды и в итоге выполняться в глобальной действующей
DNS. Даже примеры, используемые «только» в документации, могут в итоге
быть реализованы в коде и выпущены либо вызвать конфликты вследствие
последующего реального использования и возможного приобретения прав
интеллектуальной собственности на такие «примерные» имена.
Резервирование нескольких доменных имён верхнего уровня для этих целей
сведёт к минимуму такую путаницу и конфликты.Ссылки
[RFC 1034] Mockapetris, P., "Domain names - concepts and facilities",
STD 13, RFC 1034, November 1987.
[RFC 1035] Mockapetris, P., "Domain names - implementation and
specification", STD 13, RFC 1035, November 1987.
[RFC 1591] Postel, J., "Domain Name System Structure and Delegation",
RFC 1591, March 1994.Адреса авторов
Donald E. Eastlake 3rd
IBM
65 Shindegan Hill Road, RR #1
Carmel, NY 10512
Phone: +1 914-276-1668(h)
+1 914-784-7913(w)
FAX: +1 914-784-3833(3)
EMail: dee3@us.ibm.com
Aliza R. Panitz
500 Stamford Dr. No. 310
Newark, DE 19711 USA
Phone: +1 302-738-1554
EMail: buglady@fuschia.netПолное заявление об авторских правах
Copyright (C) The Internet Society (1999). All Rights Reserved.
Этот документ и его переводы могут копироваться и предоставляться
другим лицам, а производные работы, которые комментируют или иным
образом поясняют его либо содействуют его реализации, могут
подготавливаться, копироваться, публиковаться и распространяться,
полностью или частично, без каких-либо ограничений при условии, что
приведённое выше уведомление об авторских правах и этот абзац включены
во все такие копии и производные работы. Однако сам этот документ не
может быть каким-либо образом изменён, например путём удаления
уведомления об авторских правах или ссылок на Internet Society либо
другие интернет-организации, за исключением изменений, необходимых для
разработки стандартов Интернета, в каковом случае должны соблюдаться
процедуры в отношении авторских прав, установленные процессом разработки
интернет-стандартов, либо изменений, требуемых для перевода его на языки
помимо английского.
Ограниченные разрешения, предоставленные выше, являются бессрочными и
не будут отозваны Internet Society, её правопреемниками или лицами,
которым она передала права.
Этот документ и содержащаяся в нём информация предоставляются на условиях
«КАК ЕСТЬ», И THE INTERNET SOCIETY И INTERNET ENGINEERING TASK FORCE
ОТКАЗЫВАЮТСЯ ОТ ВСЕХ ГАРАНТИЙ, ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ, ВКЛЮЧАЯ, СРЕДИ
ПРОЧЕГО, ЛЮБУЮ ГАРАНТИЮ ТОГО, ЧТО ИСПОЛЬЗОВАНИЕ СОДЕРЖАЩЕЙСЯ ЗДЕСЬ
ИНФОРМАЦИИ НЕ НАРУШИТ КАКИХ-ЛИБО ПРАВ, ЛИБО ЛЮБЫЕ ПОДРАЗУМЕВАЕМЫЕ
ГАРАНТИИ КОММЕРЧЕСКОЙ ПРИГОДНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ ОПРЕДЕЛЁННОЙ ЦЕЛИ.Благодарность
Финансирование функции RFC Editor в настоящее время обеспечивается
Internet Society.