Рабочая группа сети L. Daigle, ред.
Запрос комментариев: 4052 Internet Architecture Board
BCP: 102 апрель 2005 г.
Категория: Лучшая современная практика
Процессы IAB по управлению отношениями взаимодействия IETF
Статус этого меморандума
Этот документ определяет Лучшую современную практику Интернета для
интернет-сообщества и запрашивает обсуждение и предложения по
улучшениям. Распространение этого меморандума не ограничено.
Уведомление об авторских правах
Авторское право (C) The Internet Society (2005).
Аннотация
В этом документе рассматриваются процедуры, используемые IAB для
установления и поддержания отношений взаимодействия между IETF и другими
Организациями по разработке стандартов (SDO), консорциумами и отраслевыми
форумами. В этом документе также рассматриваются назначение и
обязанности менеджеров и представителей IETF по взаимодействию, а также
ожидания IAB в отношении организаций, с которыми устанавливаются отношения
взаимодействия.
1. Отношения взаимодействия и персонал
IETF как организации необходимо участвовать в прямой коммуникации или
совместных начинаниях с различными другими формальными организациями.
Например, IETF является одной из нескольких Организаций по разработке
стандартов, или SDO, и все SDO, включая IETF, всё чаще считают необходимым
обмениваться информацией и координировать свою деятельность, связанную с
технологиями Интернета. Это полезно для предотвращения дублирования усилий
и управления взаимодействиями между их группами. В случаях, когда взаимные
усилия по обмену информацией и координации деятельности формализованы,
такие отношения обычно называются «отношениями взаимодействия».
В таких случаях лицо из IETF назначается для управления определёнными
отношениями взаимодействия; в другой организации это лицо обычно называют
«менеджером IETF по взаимодействию». Когда ожидается, что отношения
взаимодействия будут охватывать сложный или широкий круг деятельности,
для выполнения некоторых частей коммуникаций могут назначаться
дополнительные лица, координируемые менеджером по взаимодействию. Нередко
другая организация аналогично назначает собственного менеджера по
взаимодействию с IETF.
Этот документ в основном касается:
o установления и поддержания отношений взаимодействия, а также
o назначения и обязанностей менеджеров и представителей IETF по
взаимодействию.
Управление менеджерами других организаций по взаимодействию с IETF,
как в контексте отношений взаимодействия, так и вне его, выходит за
рамки данного документа.
IETF поручила Internet Architecture Board управлять отношениями
взаимодействия. В соответствии со своим уставом [2] IAB выступает
представителем интересов IETF и Internet Society в технических отношениях
взаимодействия с другими организациями, занимающимися стандартами и иными
техническими и организационными вопросами, относящимися к всемирному
Интернету. Отношения взаимодействия поддерживаются настолько неформальными,
насколько возможно, и должны иметь доказуемую ценность для технического
мандата IETF. Отдельные участники IETF назначаются IAB менеджерами или
представителями по взаимодействию с другими организациями.
В целом отношения взаимодействия наиболее ценны, когда имеются области
технической разработки, представляющие взаимный интерес. В большинстве
случаев SDO предпочли бы использовать существующую работу, выполненную
другими организациями, а не воспроизводить её самостоятельно (и хотели бы,
чтобы то же происходило в отношении их собственной работы). Установление
отношений взаимодействия может обеспечить основу для постоянных коммуникаций,
позволяющих
o предотвращать непреднамеренное дублирование усилий, не препятствуя
ни одной из организаций следовать собственному мандату;
o предоставлять авторитетную информацию о зависимостях работы одной
организации от работы другой.
2. Аспекты взаимодействия и управления взаимодействием
2.1. Отношения взаимодействия
Отношения взаимодействия устанавливаются, когда, по мнению другой
организации, IAB и участников IETF, выполняющих работу, это взаимно
приемлемо и необходимо для некоторой конкретной цели. Для этого нет
установленного процесса или формы; участники IETF и равноправная
организация обращаются к IAB и после обсуждения достигают соглашения о
формировании таких отношений. В некоторых случаях предполагаемые область
действия и руководящие принципы сотрудничества документируются специально
(например, см. [3], [4] и [5]).
При установлении отношений IAB ожидает взаимного обмена мнениями и
обсуждения наилучшего подхода к выполнению новых задач по стандартизации.
Любые возникающие для IETF рабочие задачи будут выполняться в соответствии
с обычными процедурами IETF, определёнными в [1]. Равноправная организация
часто имеет организационную структуру и процедуры, отличающиеся от IETF,
что потребует от обеих организаций определённой гибкости для адаптации.
IAB ожидает, что каждая организация будет использовать отношения
осмотрительно, предоставляя время для выполнения процессов, которые она
запрашивает у другой организации, и не будет предъявлять неразумных
требований.
2.2. Менеджер по взаимодействию
Как описано выше, большая часть работы по темам, представляющим взаимный
интерес, будет выполняться обычным образом в рамках IETF и равноправной
организации. Поэтому большинство коммуникаций будет носить неформальный
характер (например, обсуждения в Рабочей группе (WG) или списке рассылки).
Важная функция менеджера по взаимодействию состоит в обеспечении того,
чтобы коммуникация поддерживалась, была продуктивной и своевременной. Он
или она может использовать любой применимый деловой подход — от частных до
публичных коммуникаций — и привлекать другие стороны по мере необходимости.
Если
сообщение от равноправной организации адресовано неподходящей стороне,
например отправлено в WG без копии Area Director (AD) или отправлено не в
ту WG, менеджер по взаимодействию поможет перенаправить сообщение либо
иным образом дополнить коммуникацию.
Менеджерам IETF по взаимодействию СЛЕДУЕТ (SHOULD) также обмениваться
информацией и координировать действия с другими менеджерами по
взаимодействию там, где соответствующие виды технической деятельности
пересекаются.
Поскольку IAB в конечном итоге отвечает за отношения взаимодействия,
любой, у кого возникает проблема с такими отношениями (будь то участник
IETF или лицо из равноправной организации), должен сначала обратиться к
назначенному IAB менеджеру по взаимодействию, а если это не приводит к
удовлетворительному результату — к самому IAB.
2.3. Представители по взаимодействию
Менеджер по взаимодействию является, в частности, представителем IETF
с целью управления отношениями взаимодействия. Для тех же отношений может
возникнуть необходимость определить других представителей. Например, если
область взаимной работы обширна, может быть уместно назначить нескольких
лиц представителями по взаимодействию с различными частями другой
организации. Либо может быть уместно назначить представителя по
взаимодействию для участия в конкретном заседании.
Эти другие представители по взаимодействию выбираются IAB и работают
совместно (и в тесной коммуникации) с менеджером по взаимодействию. В
некоторых случаях это также может потребовать обмена информацией и
координации с другими менеджерами или представителями по взаимодействию
там, где соответствующие виды технической деятельности пересекаются.
Конкретные обязанности представителя по взаимодействию будут определены
при назначении.
2.4. Коммуникации по взаимодействию
Коммуникации между организациями используют разнообразные формальные и
неформальные каналы. Заявленное предпочтение IETF, которая в значительной
степени является неформальной организацией, заключается в использовании
неформальных каналов, поскольку исторически они хорошо работали для
ускорения решения вопросов. Однако в некоторых случаях более формальная
коммуникация уместна либо как дополнение к неформальному каналу, либо вместо
него. В случае формальных коммуникаций установленные процедуры многих
организаций используют форму, известную как «заявление о взаимодействии».
Процедуры отправки, управления заявлениями о взаимодействии и ответа на них
рассматриваются в [6].
3. Краткое изложение обязанностей менеджера IETF по взаимодействию
Хотя требования, безусловно, будут различаться в зависимости от характера
равноправной организации и типа выполняемой совместной работы, общие
ожидания в отношении менеджера по взаимодействию, назначенного IAB,
заключаются в следующем:
o Посещать соответствующие заседания равноправной организации по мере
необходимости и сообщать соответствующей организации IETF о любых
существенных обновлениях.
o Передавать равноправной организации любые сообщения от IETF, когда это
специально предписано. В целом эти коммуникации «представляют IETF», и
поэтому при их подготовке должны проявляться должная осмотрительность
и консенсус.
o Готовить периодические обновления. Адресат этих обновлений (например,
IAB, AD, WG) обычно определяется при назначении.
o Контролировать доставку заявлений о взаимодействии, адресованных IETF,
обеспечивая их поступление к надлежащему адресату внутри IETF, а также
обеспечивать подготовку и своевременную отправку соответствующих ответов
от IETF.
o Работать с другой организацией, чтобы обеспечить надлежащее направление
заявлений IETF о взаимодействии и своевременный ответ на них.
o Обмениваться информацией и координировать действия с другими менеджерами
и представителями IETF по взаимодействию там, где соответствующие виды
технической деятельности пересекаются.
4. Утверждение и передача заявлений о взаимодействии
Важно, чтобы предлагаемые заявления IETF о взаимодействии проходили
надлежащую проверку руководством и чтобы те, кто пишет такие заявления и
утверждает, что говорит от имени IETF, действительно представляли взгляды
IETF.
Все исходящие заявления о взаимодействии будут копироваться в IETF
Secretariat с использованием процедур, определённых в [6] или документах,
заменяющих его.
Для заявления о взаимодействии, подготовленного от имени WG IETF,
председатель(и) WG должен подготовить заявление на основе надлежащих
обсуждений в WG, чтобы обеспечить консенсус рабочей группы по представленной
позиции или позициям. Председатель(и) должен подготовить заявление о
взаимодействии либо согласиться с его отправкой и должен уведомить AD о том,
что заявление о взаимодействии было отправлено, направив копию сообщения
соответствующим AD.
Для заявления о взаимодействии, подготовленного от имени области IETF,
AD должен подготовить заявление о взаимодействии либо согласиться с его
отправкой. Если заявление о взаимодействии не отправлено AD, их согласие
должно быть получено заранее и подтверждено направлением копии сообщения AD.
Для заявления о взаимодействии, подготовленного от имени IETF в целом,
председатель IETF должен подготовить заявление о взаимодействии либо
согласиться с его отправкой. Если заявление о взаимодействии не отправлено
председателем IETF, его или её согласие должно быть получено заранее и
подтверждено направлением копии сообщения председателю IETF.
Для заявления о взаимодействии, подготовленного IAB, председатель IAB
должен подготовить заявление о взаимодействии либо согласиться с его
отправкой. Если заявление о взаимодействии не отправлено председателем
IAB, его или её согласие должно быть получено заранее и подтверждено
направлением копии сообщения председателю IAB.
В случаях, когда предварительное согласие не было получено, как изложено
выше, и назначенный орган (AD, председатель IETF или председатель IAB)
фактически не согласен с сообщением, назначенный орган будет работать с
менеджером по взаимодействию для принятия надлежащих последующих мер,
включая выпуск пересмотренного заявления о взаимодействии, если необходимо.
Очевидно, что этой ситуации лучше избегать, обеспечивая надлежащее согласие
до отправки сообщения о взаимодействии.
5. Вопросы безопасности
Эти процедуры не создают угрозы безопасности Интернета.
6. Благодарности
Этот документ был разработан в рамках обсуждения управления [6],
и авторы того документа внесли значительный вклад в разработку
настоящего документа. Кроме того, эта версия документа была улучшена
по сравнению с предыдущей несколькими предложениями Stephen J.
Trowbridge, Peter Saint-Andre, Michael Patton, Bert Wijnen, Fred
Baker, Scott Bradner, Scott Brim, Avri Doria, Allison Mankin, Thomas
Narten, Russ Housley и Dan Romasanu.
Членами IAB на момент утверждения этого документа были:
Bernard Aboba
Harald Alvestrand (председатель IETF)
Rob Austein
Leslie Daigle (председатель IAB)
Patrik Faltstrom
Sally Floyd
Jun-ichiro Itojun Hagino
Mark Handley
Bob Hinden
Geoff Huston (исполнительный директор IAB)
Eric Rescorla
Pete Resnick
Jonathan Rosenberg
7. Ссылки
7.1. Нормативные ссылки
[1] Bradner, S., "The Internet Standards Process -- Revision 3", BCP
09, RFC 2026, October 1996.
[2] Internet Architecture Board and B. Carpenter, "Charter of the
Internet Architecture Board (IAB)", BCP 39, RFC 2850, May 2000.
7.2. Информационные ссылки
[3] Rosenbrock, K., Sanmugam, R., Bradner, S., and J. Klensin,
"3GPP-IETF Standardization Collaboration", RFC 3113, June 2001.
[4] Bradner, S., Calhoun, P., Cuschieri, H., Dennett, S., Flynn, G.,
Lipford, M., and M. McPheters, "3GPP2-IETF Standardization
Collaboration", RFC 3131, June 2001.
[5] Fishman, G. and S. Bradner, "Internet Engineering Task Force and
International Telecommunication Union - Telecommunications
Standardization Sector Collaboration Guidelines", RFC 3356,
August 2002.
[6] Trowbridge, S., Bradner, S., and F. Baker, "Procedure for
Handling Liaison Statements Between Standards Bodies",
June 2004.
Адреса авторов
Leslie Daigle
Редактор
Internet Architecture Board
IAB
EMail: iab@iab.org
Полное заявление об авторских правах
Copyright (C) The Internet Society (2005).
На этот документ распространяются права, лицензии и ограничения,
содержащиеся в BCP 78, и, за исключением предусмотренного там,
авторы сохраняют все свои права.
Этот документ и содержащаяся в нём информация предоставляются на
условиях «КАК ЕСТЬ», И УЧАСТНИК, ОРГАНИЗАЦИЯ, КОТОРУЮ ОН/ОНА
ПРЕДСТАВЛЯЕТ ИЛИ КОТОРОЙ СПОНСИРУЕТСЯ (ЕСЛИ ТАКОВАЯ ИМЕЕТСЯ),
INTERNET SOCIETY И INTERNET ENGINEERING TASK FORCE ОТКАЗЫВАЮТСЯ ОТ
ВСЕХ ГАРАНТИЙ, ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ, ВКЛЮЧАЯ, ПОМИМО ПРОЧЕГО,
ЛЮБУЮ ГАРАНТИЮ ТОГО, ЧТО ИСПОЛЬЗОВАНИЕ СОДЕРЖАЩЕЙСЯ ЗДЕСЬ
ИНФОРМАЦИИ НЕ НАРУШИТ КАКИХ-ЛИБО ПРАВ, И ЛЮБЫЕ ПОДРАЗУМЕВАЕМЫЕ
ГАРАНТИИ ТОВАРНОЙ ПРИГОДНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ ОПРЕДЕЛЁННОЙ ЦЕЛИ.
Интеллектуальная собственность
IETF не занимает позиции относительно действительности или объёма
каких-либо прав интеллектуальной собственности либо иных прав,
которые могут заявляться как относящиеся к реализации или
использованию технологии, описанной в этом документе, или
относительно того, может ли лицензия по таким правам быть доступна
или не быть доступна; также она не заявляет, что предприняла
какие-либо независимые усилия по выявлению любых таких прав.
Информацию о процедурах, касающихся прав в документах RFC, можно
найти в BCP 78 и BCP 79.
Копии раскрытий IPR, сделанных Секретариату IETF, и любые заверения
о лицензиях, которые будут предоставлены, либо результат попытки
получить общую лицензию или разрешение на использование таких
имущественных прав разработчиками или пользователями данной
спецификации можно получить из онлайнового репозитория IPR IETF по
адресу http://www.ietf.org/ipr.
IETF предлагает любой заинтересованной стороне довести до её
сведения любые авторские права, патенты, заявки на патенты или иные
имущественные права, которые могут охватывать технологию, которая
может потребоваться для реализации этого стандарта. Просьба
направлять эту информацию в IETF по адресу ietf-
ipr@ietf.org.
Благодарность
Финансирование функции RFC Editor в настоящее время обеспечивается
Internet Society.